Excel: Stunden zusammenzählen - wie?

honeybee
Goto Top
Hallo,

ich erstelle gerade eine Excel-Tabelle für die Arbeitszeiterfassung.
Die Wochenenden sind arbeitsfrei, ebenso die Feiertage im April 2022 (ist ein Beispiel).

Nun möchte ich die Stunden zusammenzählen, aber wenn ich die SUMME-Funktion nehme, sieht das Ergebnis null aus.
Die Zellen sind bereits mit "hh:ss" formatiert.

Wie kann man die Stunden zusammenzählen?

screenshot

Content-Key: 2374874547

Url: https://administrator.de/contentid/2374874547

Ausgedruckt am: 29.06.2022 um 20:06 Uhr

Mitglied: MirkoKR
Lösung MirkoKR 01.04.2022 aktualisiert um 21:19:48 Uhr
Goto Top
Hallo

Goggl hilft ;- )


Gesucht nach:

excel stundenzettel formel


Viel Spaß ;-) face-wink
Mitglied: NixVerstehen
Lösung NixVerstehen 01.04.2022 um 21:22:10 Uhr
Goto Top
Zitat von @honeybee:

Hallo,
Die Zellen sind bereits mit "hh:ss" formatiert.

Bis du dir mit hh:ss sicher? Ich denke, das soll hh:mm lauten.
Versuch mal

Dann sollte es gehen.

Gruß NV
Mitglied: honeybee
honeybee 01.04.2022 um 21:24:06 Uhr
Goto Top
Danke, das kenne ich schon.

Bloß wenn an den Samstagen und Sonntagen sowie Feiertagen keine Null steht (weil arbeitsfrei), dann berechnet Excel falsch. Sonst müsste ich dort, wo die Felder leer sind, auch die Nullen hinzufügen.

Geht das nicht irgendwie besser?
Mitglied: MirkoKR
MirkoKR 01.04.2022 um 21:33:14 Uhr
Goto Top
wenn(a1="";0;[sonst formel])
Mitglied: MirkoKR
MirkoKR 01.04.2022 um 21:42:43 Uhr
Goto Top
Mit

SUMMEWENN()

dürfteste auch zum Ergebnis kommen..
Mitglied: Franz-Josef-II
Franz-Josef-II 02.04.2022 aktualisiert um 09:28:15 Uhr
Goto Top
Guten Morgen

.... und was ist, wenn Du die Zeilen mit den Wochenenden ganz einfach nicht einträgst? Also komplett löscht?
Werden ja eh nicht gebraucht. Solltest Du ausnahmsweise doch am Samstag, Sonn- oder Feiertag was arbeiten, dann einfach einfügen.
Mitglied: Penny.Cilin
Lösung Penny.Cilin 02.04.2022 um 10:38:17 Uhr
Goto Top
Hallo @honeybee,

auch wenn ich LibreOffice verwende, vielleicht helfen Dir folgende Denkansätze:

Ich verwende folgende Formeln, um die Arbeitszeiten zu berechnen:
  • Tagesarbeitszeit:
=WENN(ISTLEER(D2);"";REST(D2-C2;1))
  • Tagesarbeitszeit als Industriezeit:
=WENN(ISTLEER(D2);"";STUNDE(H2)+(MINUTE(H2)/60))
  • Differenz (Plus / Minus) Zeiten
=WENN(ISTLEER(D2);"";K2-J2)
  • Monatsarbeitszeit
=WENN(ISTLEER(M1:M32);"";SUMME(M2:M32))

  • Formatierung der Stunden:
[HH]:MM;[ROT]-[HH]:MM

D.h. wenn Minusstunden gearbeitet wird, dann werden diese in Rot angezeigt.


Gruss Penny.
Mitglied: erikro
erikro 02.04.2022 um 16:17:22 Uhr
Goto Top
Moin,

Zitat von @honeybee:
Bloß wenn an den Samstagen und Sonntagen sowie Feiertagen keine Null steht (weil arbeitsfrei), dann berechnet Excel falsch. Sonst müsste ich dort, wo die Felder leer sind, auch die Nullen hinzufügen.

Nein, tut es nicht. Die Summenformel ignoriert alle Zellen, in denen keine Zahl steht und das Ergebnis ist korrekt. Wenn es nicht korrekt dargestellt wird, dann liegt es am Zeitformat. Wie ein Kollege schon sagte, ist das richtige Format

Wenn ich mir die Tabelle aber so angucke, fällt mir auf, dass die Zeiten linksbündig stehen. Ist das vielleicht nicht das richtige Format angebracht?

Liebe Grüße

Erik