lunes92
Goto Top

Herstellung einer VPN Verbindung von FritzBox 7590 AX über Wireguard zu GL.Inet GL-MX 3000

Moin Community,

ich habe anhand der Anleitung unter dem Forumsbeitrag versucht die Konfiguration erstellen, leider ohne Erfolg. Ich würde gerne wissen wo ich was eingeben muss.

Hardware:
Server: FritzBox 7590 AX
Client: GL-MT-3000 (GL.Inet)


Fritzbox IPv4-Adresse:
ip-adresse

GL-MT-3000 IP (Default)
192.168.8.1


1) Wenn ich den die Wireguard Verbindung auf der FritzBox per "Netzwerke koppeln oder spezielle Verbindung herstelle" herstellen möchte, welche IP Adresse trage ich dort ein?

Sind diese Werte in dem Fall korrekt?
Entferntes Netzwerk: 192.168.1
Submaske: 255.255.255.0


Ich habe als Konfig folgendes genommen:

[Interface]
PrivateKey = XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
Address = 192.168.8.1/24
DNS = 192.168.178.1


[Peer]
PublicKey = XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
PresharedKey = XXXXXXXXXXXXXXXXXXXXXXXXXXX
AllowedIPs = 192.168.178.0/24, 0.0.0.0/0
Endpoint = XXXXXXXXXXX.myfritz.net:52165
PersistentKeepalive = 25

Mit der Konfig konnte ich aber keine Verbindung aufbauen. Muss ich irgendwo die IPv4-Adresse verwenden anstatt 192.168.178.0? Habe ich was vergessen zu aktivieren?


Beste Grüße

Content-Key: 9119715114

Url: https://administrator.de/contentid/9119715114

Printed on: May 21, 2024 at 19:05 o'clock

Member: aqui
aqui Apr 10, 2024 updated at 13:59:37 (UTC)
Goto Top
welche IP Adresse trage ich dort ein?
Das beschreibt dir doch das Tutorial:
Fritzbox VPN Wireguard Verbindung zu Beryl Client
Natürlich nur wenn du es denn auch wirklich gelesen hast. 🤔
Da fragt dann auch nix nach einer IP?! Welche auch wenn die Fritzbox die fertige Client Konfig automatisch ausgibt.
Ich habe als Konfig folgendes genommen:
Wenn das die Konfig ist die dir deine Fritzbox für den Client Router ausgespuckt hat zum Download ist das OK.
Muss ich irgendwo die IPv4-Adresse verwenden anstatt 192.168.178.0?
Ähem...Gegenfrage: Ist denn 192.168.178.0 keine IPv4 Adresse?? 🤔
Mit der Konfig konnte ich aber keine Verbindung aufbauen.
Scheint wohl bei GL.inet der Normalfall zu sein.
Du hast ja dazu dann ganz sicher auch den wichtigen Hinweis am Ende des Tutorials gelesen den diese verwarzten GL.inet Clients wohl zwingend im Setup erwarten damit es überhaupt funktioniert:
Fritzbox VPN Wireguard Verbindung zu Beryl Client

Mit anderen Worten der GL.inet Client erzwingt scheinbar den Redirect Mode damit es überhaupt funktioniert!
Mit einem Mikrotik wär das nicht passiert... face-wink
Member: Lunes92
Lunes92 Apr 10, 2024 updated at 14:50:04 (UTC)
Goto Top
Okay ich habe es zu schnell überflogen.

Das bedeutet ich konfiguriere meine Fritzbox wie folgt:
Entferntes Netzwerk: 192.168.8.0
Submaske: 255.255.255.0

Wenn du die LAN-IP-Adresse nicht über die Web-Oberfläche finden kannst, kannst du alternativ auf einem mit dem GL.Inet-Gerät verbundenen Gerät die IP-Adresse über die Befehlszeile ermitteln. Öffne dazu die Befehlszeile (z. B. Terminal unter macOS/Linux oder Eingabeaufforderung unter Windows) und gib den Befehl ipconfig (unter Windows. Suche nach dem Eintrag, der mit 192.168. beginnt, um die LAN-IP-Adresse deines GL.Inet-Geräts zu identifizieren.

und passe die Konfig folgendermaßen an:

[Interface]
PrivateKey = XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
Address = 192.168.8.1/24
DNS = 192.168.178.1


[Peer]
PublicKey = XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
PresharedKey = XXXXXXXXXXXXXXXXXXXXXXXXXXX
AllowedIPs = 0.0.0.0/0
Endpoint = XXXXXXXXXXX.myfritz.net:52165
PersistentKeepalive = 25

Ich probiere es gleich mal aus, ob es funktioniert.

In der Thematik bin ich noch ein 100%tiger Newbie :D Aber Mikrotik schaue ich mir auch einmal an.
Member: aqui
aqui Apr 11, 2024 updated at 09:57:45 (UTC)
Goto Top
Das bedeutet ich konfiguriere meine Fritzbox wie folgt:
Sieht gut aus!
Aber Mikrotik schaue ich mir auch einmal an.
Mit 25 Euronen bist du dabei! face-wink
In der Thematik bin ich noch ein 100%tiger Newbie
Dann hilft, wie immer, das genaue Lesen und Verstehen des Tutorials. face-wink
Member: Lunes92
Lunes92 Apr 11, 2024 at 16:33:10 (UTC)
Goto Top
Was würde passieren wenn ich anstatt des Standard-Gateway 192.168.8.1 die IP4v-Adresse nehme?

Danke dir auf jeden Fall für die Hilfe!
Member: Lunes92
Lunes92 Apr 11, 2024 at 16:35:08 (UTC)
Goto Top
Das zeigt mir die Fritzbox in den Wireguard Einstellungen an. Ist es korrekt? Obwohl ich 192.168.8.1 als entferntes Netzwerk angegeben habe?
screenshot
Member: Lunes92
Lunes92 Apr 11, 2024 at 16:35:59 (UTC)
Goto Top
Meine Konfig sieht nun so aus:

[Interface]
PrivateKey = XXX
Address = 192.168.8.1/24
DNS = 192.168.178.1


[Peer]
PublicKey = XXX
PresharedKey = iXXXX
AllowedIPs = 0.0.0.0/0
Endpoint = XXXX:55968
PersistentKeepalive = 25
Member: aqui
aqui Apr 11, 2024 updated at 17:00:55 (UTC)
Goto Top
Ist es korrekt? Obwohl ich 192.168.8.1 als entferntes Netzwerk angegeben habe?
Jein!
Netzwerke gibt man bekanntlich immer an indem alle Hostbits auf 0 gesetzt sind! Solche einfachen Basics weiss man aber auch als Laie! 🧐
Mit der "192.168.8.1" hast du aber fälschlicherweise eine Hostadresse eingegeben statt einer Netzwerkadresse wozu dich die Fritzbox ja eigentlich explizit aufgefordert hatte.
Die .1 Ist eine Endgeräte Adresse und keine Netzwerk Adresse wie man unschwer sehen kann. face-sad
Die FB hat vermutlich etwas KI drin die sie solche grundlegenden Fauxpas' von Usern die ihre Menü Kommentare nicht oder nicht richtig lesen korrigieren lässt! 😉
Der Rest ist richtig...
Member: Lunes92
Lunes92 Apr 11, 2024 at 17:13:37 (UTC)
Goto Top
Okay nun bekomme ich diese Fehlermeldung:

Thu Apr 11 19:10:40 2024 daemon.notice netifd: Interface 'wgclient' is setting up now
Thu Apr 11 19:12:27 2024 user.notice wireguard-debug: USER=root ifname=wgclient ACTION=REKEY-GIVEUP SHLVL=1 HOME=/ HOTPLUG_TYPE=wireguard LOGNAME=root DEVICENAME= TERM=linux SUBSYSTEM=wireguard PATH=/usr/sbin:/usr/bin:/sbin:/bin PWD=/
Thu Apr 11 19:12:27 2024 daemon.notice netifd: Interface 'wgclient' is now down
Thu Apr 11 19:12:27 2024 daemon.notice netifd: Interface 'wgclient' is setting up now
Thu Apr 11 19:12:27 2024 user.notice firewall: Reloading firewall due to ifdown of wgclient ()

Ich werde mir noch ein Buch zulegen ;) Schaden solls ja nicht
Member: aqui
aqui Apr 12, 2024 at 09:46:27 (UTC)
Goto Top
Okay nun bekomme ich diese Fehlermeldung:
WO bekommst du die?? Zudem ist sie nichtssagend und besagt nur das der WG Daemon neu geladen wird. Aus welchem Grund ist unklar.
Hast du den GL.inet auf die aktuellste Firmware upgedatet??

Welche (unabgewandelte) Konfig Datei gibt dir die Fritzbox denn bei
Entferntes Netzwerk: 192.168.8.0
Submaske: 255.255.255.0

zum Download aus?
Member: Lunes92
Lunes92 Apr 12, 2024 at 14:04:57 (UTC)
Goto Top
Moin,

das ist der Logfile des Beryl Ax wenn ich den Tunnel mit der config aktiviere.

Das wäre diese hier:

Interface]
PrivateKey = XXX
Address = 192.168.8.1/24
DNS = fritz.box


[Peer]
PublicKey = XXX
PresharedKey = iXXXX
AllowedIPs = 192.168.178.1/24
Endpoint = XXXX:55968
PersistentKeepalive = 25
Member: aqui
aqui Apr 12, 2024 updated at 15:21:34 (UTC)
Goto Top
Eben mal alles auf einer 7490 mit einem GL.inet Mango getestet....
Lokales LAN FB: 192.168.188.0. /24
Lokales LAN GL: 192.168.8.0. /24

Exportierte Fritzbox Konfig:
[Interface]
PrivateKey = yP1+qF5s97nW2FpYP6f8KNpWS0isl7MR7543QjgkR2o=
Address = 192.168.8.1/24
DNS = 192.168.188.1

[Peer]
PublicKey = l+5XJduWNFhodldxhZM3TtFQLKu+0o3ZI8jhfFeq4Ss=
PresharedKey = iE+RSfzjcrHD8winLFDyKoye/3OLX+X+nbJh4+UvwV0=
AllowedIPs = 192.168.188.0/24
Endpoint = xyz.myfritz.net:51298
PersistentKeepalive = 25 

Wireguard Client in der FB aufgemacht und o.a. Konfig manuell rein cut and pasted
Verbindungen gecheckt:

glfb

Fazit: Works as designed!! Und....eine Anpassung auf 0.0.0.0/0 bei den AllowedIPs muss man de facto NICHT machen. Geht auch so einwandfrei!
Member: aqui
aqui Apr 18, 2024 at 10:54:08 (UTC)
Goto Top
Wenn es das denn war bitte deinen Thread dann als erledigt schliessen!
How can I mark a post as solved?