isteffen
Goto Top

Hyper-V Host kein Internet bei "Gemeinsames Verwenden."

Hallo Forum,

ich habe folgendes System:

1) Windows 10 - 64-Bit
2) Hyper-V installiert
3) Einen physischen Netzwerkadapter inklusive fest eingetragenen IPv4-Parametern

Ich muss auf diesem PC eine kleine VM laufen lassen. Sobald ich im Hyper-V Manager einen Switch erstelle und den Haken bei "Gemeinsames Verwenden dieses Netzwerkadapters für das Verwaltungsbetriebssystem zulassen" setze und speichere, habe ich kein Internet mehr auf meinem Host.

In der Systemsteuerung sehe ich den neu angelegten Switch, und sogar meine IPv4-Parameter sind übernommen. Kennt ihr das Problem? Gibt es dafür eine Lösung?

Gruß
SM

Content-Key: 3485397375

Url: https://administrator.de/contentid/3485397375

Printed on: March 1, 2024 at 00:03 o'clock

Member: CH3COOH
Solution CH3COOH Oct 30, 2023 at 12:09:13 (UTC)
Goto Top
Hallo SM,
nimm die feste IP vom Adapter runter. Danach legst du den Switch an, nun hast du einen neuen Adapter (wo auch der Name vom Switch drauf steht). Diesem Adapter gibst du jetzt deine feste IP.
Gruß
Member: iSteffen
iSteffen Oct 30, 2023 at 12:13:41 (UTC)
Goto Top
Problem ist das ich kein DHCP habe und selbst nur per TeamViewer drauf bin. Ist das aber die Lösung? Dann würde ich versuchen den Kunden blind das zu erklären :D
Member: CH3COOH
CH3COOH Oct 30, 2023 at 12:17:12 (UTC)
Goto Top
Das ist der weg der bei uns funktioniert. Theoretisch ließe sich das ganze vorhaben ja auch per Powershell realisieren und über zum Beispiel ne Aufgabe oder nen Skript mit kurzem Sleep ausführen.
Gruß
Member: iSteffen
iSteffen Oct 30, 2023 at 22:33:39 (UTC)
Goto Top
Das war wirklich die Lösung.

Wie könnte den so ein Skript aussehen?
Member: CH3COOH
CH3COOH Oct 31, 2023 updated at 16:03:48 (UTC)
Goto Top
Hallo,
ach da gibt es so ein paar Kommandos....

https://learn.microsoft.com/en-us/windows-server/virtualization/hyper-v/ ...

https://learn.microsoft.com/en-us/powershell/module/nettcpip/set-netipad ...

Fertig gibt es sowas nicht face-wink
Edit: Vielleicht alternativ mal über einen Server mit Out of Band Management nachdenken, iLO oder ähnliches... ist bei den kleinen Schwierig, aber schon sehr hilfreich.

Gruß