Hyper-VM kann Internet nicht über IPv6 erreichen

kpieper
Goto Top
Es geht um einen Server bei Hetzner. Als Host nutze ich einen Hyper-V Server 2016 (den ohne GUI). Bisher laufen darauf 3 VMs, jede hat eine eigene IPv4 Adresse.
Bei einem neuen Server, der nur intern genutzt wird, möchte ich ausschließlich IPv6 benutzen.

Ich habe auf dem Host folgendes ausgeführt:


Der Host erreicht Adressen im Internet z.B. mit


In zwei VMs (Windows Server 2016 Standard mit GUI) habe ich IPv6 aktiviert und jeweils eine andere Adresse aus dem Block eingetragen. Außerdem fe80::1 als Standardgateway. Jede VM kann die jeweils andere und den Host direkt über die IPv6 Adressen anpingen. Der Host erreicht die VMs ebenfalls.

Aber ich kann keine Adressen im Internet anpingen:

Content-Key: 3237664578

Url: https://administrator.de/contentid/3237664578

Ausgedruckt am: 15.08.2022 um 18:08 Uhr

Mitglied: aqui
aqui 02.07.2022 um 15:37:26 Uhr
Goto Top
Die lokale Firewall dieser beiden VMs erlaubt eingehende ICMPv6 Echo-Reply Pakete?
Da DNS ja klappt sieht es sehr nach einem Fehler in der lokalen Firewall bei den v6 Settings aus.
Welche ICMPv6 Pakete für v6 zwingend über die FW passieren müssen kannst du z.B. HIER im Kapitel 3.2, Seite 5 nachlesen.
Mitglied: kpieper
Lösung kpieper 02.07.2022 um 15:53:39 Uhr
Goto Top
Es war kein Problem mit der Firewall, sondern die Konfiguration war falsch.

Es funktioniert jetzt.

Auf dem Host (vorher die alte Konfiguration löschen):

In den VMs die IP Adressen aus dem zugeteilten Block und als Gateway die zweite IPv6 Adresse aus dem zugeteilten Block eintragen. Dadurch gehen die Pakete von den VMs über den virtuellen Switch und den Adapter letztendlich an fe80::1 - so wie es bei Hetzner vorgesehen ist.

Im Prinzip steht es hier: Hetzner - Windows Server Subnetz - IPv6

Da steht auch noch etwas zu den Routen. Bei mir war das aber nicht mehr erforderlich.

Was mich nur noch irritiert: Auf dem Host haben sowohl der Adapter als auch der virtuelle Switch IPv6 Adressen. Ich dachte bisher, dass der Adapter keine haben dürfte, wenn man einen virtuellen Switch einsetzt.
Mitglied: aqui
aqui 02.07.2022 aktualisiert um 16:02:32 Uhr
Goto Top
Es funktioniert jetzt.
Glückwunsch ! 👏
Der vSwitch sollte eigentlich niemals eine IP Adresse haben, es sei denn er ist managebar. Bei VmWare hat der vSwitch keinerlei IP, wie es auch sein sollte, denn der macht ja rein nur L2 Forwarding.
Müsste ggf. ein Hyper-V Spezl beantworten...

Wenns das denn war bitte deinen Thread dann auch als erledigt markieren!