badger
Goto Top

IE geschützter Modus: Foxit Reader

Hallo Leute,

ich bin gerade dabei, Foxit Reader als neues PDF-Standardprogramm einzurichten.

Habe dabei nur ein "Problem":
Ich will, dass auch der IE PDF's mit Foxit öffnet.
Habe dazu Foxit auch entsprechend konfiguriert.

Allerdings bekommen die User beim öffnen von PDFs die Warnung "Eine Webseite möchte Webinhalte mithilfe dieses Programms auf dem Computer öffnen.":
fehler

Kann man das "Zulassen" irgendwie per GPO odgl. verteilen?

Habe bis jetzt leider in Inet nichts passendes dazu gefunden.
Auch liefert regShot keine brauchbaren Werte.

Besten Dank für eure Tipps!

Patrick

Content-Key: 339393

Url: https://administrator.de/contentid/339393

Printed on: February 25, 2024 at 06:02 o'clock

Member: absurt77
absurt77 May 31, 2017 at 08:20:51 (UTC)
Goto Top
Hallo Patrick,

es gibt mehrere Wege, habe aber auf meiner Lieblingsseite etwas gefunden, was dir sicxherlich weiterhilft!

http://www.borncity.com/blog/2010/11/26/windows-sicherheit-blockt-setup ...

Grüße
Joerg
Member: Badger
Badger May 31, 2017 at 09:27:29 (UTC)
Goto Top
Hallo Joerg,

danke dir für den Link.
Soweit ich das verstanden habe, ist der einzige Weg generell die Funktion "Anwendungen und unsichere Dateien starten" zu aktivieren.

Aber das ist auch nicht ganz mein Ding. Würde gerne diese Warnung nur für Foxit "ausblenden".
Dazu gibt es wohl keine Möglichkeit?!

Grüße
Patrick
Mitglied: 114685
114685 May 31, 2017 updated at 12:38:09 (UTC)
Goto Top
Hi,

möglicherweise kannst du das in den Internetoptionen in der Sicherheitszone für das lokale Intranet konfigurieren:
Sieh dir mal die Einstellmöglichkeiten unter
ActiveX Steuerelemente und Plugins
an. Da gibt es die Option bei einigen Elementen, sie vom Administrator (wohl über die Gruppenrichtlinien zu finden)
genehmigen zu lassen.

Dann gibt es in der Registry noch einen Key für eine Policy:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Low Rights\ElevationPolicy\{AC155DD0-14EE-4F26-86AA-F974045CFE55}

Vergleiche dort mal vorher und nachher, vielleicht spielt der eine Rolle.

Wenn du dir den Foxit Reader über den Internet Explorer geladen hast, hängt da an der Installationsdatei noch kein kleiner Stream von 32 Byte dran, den du vorher entfernen musst, sonst kommt da auch noch eine Bestätigungsabfrage.
Stream entfernen geht z. B. über Umkopieren NTFS > FAT > NTFS oder
mit AltenateStreamView von nirsoft.

Versuch macht kluch.

Gruß
Member: absurt77
absurt77 May 31, 2017 updated at 12:31:57 (UTC)
Goto Top
Hi,
hast du mal einen alternativen Browser versucht, Chrome, vielleicht umgehtst du hierbei diese IE Sperre.

IE: Vertrauenswürdeige Seiten und Zonen einrichten und Testen. Diese können dann in der GPO nachgebaut werden.
  • mit FILE:// kann man Pfade und Freigaben als Sichere Zone anlegen
  • Computerkonfiguration/Administrative Vorlagen/Windows Komponenten/Internet Explorer/Internetsystemsteuerung/Sicherheitsseite den Punkt Liste der Site zu Zonenzuweisungen
Member: Badger
Badger Jun 06, 2017 at 13:15:45 (UTC)
Goto Top
Danke für eure Antworten.

Ich habe diesbezüglich nun ein paar Tests gemacht.
Im Intranet kommt beim Öffnen von PDFs keine Fehlermeldung - In der Zone Internet schon.

Dies hängt aber nicht mehr der Einstellung "ActiveX Steuerelemente und Plugins" zusammen (die korrekt konfiguriert wäre) sondern mit "Geschützen Modus aktivieren".

Sobald ich diese Einstellung deaktiviere, kommt auch die Meldung nicht mehr.

Nachdem diese Einstellung ja prinzipiell Sinn hat, will ich diese auch nicht deaktivieren.

Die Frage die ich mir stelle: Warum funktioniert es mit Acrobat mit aktivieren geschützen Modus und mit Foxit nicht?

Grüße
Patrick
Mitglied: 114685
114685 Jun 06, 2017 updated at 14:50:46 (UTC)
Goto Top
Hi,

auch in der Zone Internet funktioniert bei mir der Foxit im Geschützten Modus. Ich habe den ganz normal mit seinen Standard-Einstellungen installiert (ohne den extra zu installierenden Kram), lediglich bei den Plugins habe ich aufgeräumt und auch den Service, der installiert wird, auf Deaktiviert gesetzt, weil ich den Reader ausschließlich zum Lesen von PDF nutze. Nur das Browser.fpi -Plugin ist vorhanden und aktiv, der Rest der fpi-Dateien ist gelöscht.

Sieh mal bei den Einstellungen unter Trust Manager nach, welche Einstellungen dort getätigt wurden. Ich habe nur Javascript Aktionen aktivieren und Sicheren Lesemodus angehakt und sonst nichts, und der Foxit läuft im Nur-Lese-Modus.
Edit:
Hab da gerade noch was im Trust Manager entdeckt: Sieh mal nach, was da unter
Internetseiten ... außerhalb des Webbrowsers bei dir eingestellt ist.


Die Frage zum Acrobat kann ich dir leider nicht beantworten, der ist bei mir schon seit ~ 10 Jahren eine NoGo-Applikation. face-wink

Gruß
Member: Badger
Badger Jun 13, 2017 at 10:23:49 (UTC)
Goto Top
Hallo und sorry für die späte Antwort.

Ich habe nochmal alle Einstellungen im Foxit kontrolliert. Da ist alles so wie bei dir.
Bzw. habe ich mich auch mit Internetseiten ... außerhalb des Webbrowsers gespielt. Hilft leider alles nichts face-sad

Ich tue mich aktuell ziemlich schwer einzugrenzen, ob das eine Foxit-Einstellung ist oder eine IE-Einstellung.

Setzt du deine IE-Einstellungen manuell oder per GPO?
Falls per GPO: Könntest du mir einen Export zukommen lassen? Dann kann ich die Einstellungen vergleichen und finde so vlt. den Fehler.

Grüße
Patrick
Mitglied: 114685
114685 Jun 13, 2017 at 10:58:41 (UTC)
Goto Top
Hi,

die Einstellungen setzte ich manuell bzw. ich habe sie von der Installationsroutine übernommen.

Du könntest dir eine Sicherung erstellen von
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones
und im IE die Einstellungen auf den Standard zurücksetzen lassen (Internetoptionen > Erweitert > unterer Button)

Vielleicht kannst du so den Fehler eingrenzen. Ob sich das mit euren GPO-Einstellungen verträgt, kann ich dir aber nicht sagen. face-smile

Den vorherigen Zustand müsstest du mit dem Import der vorher gespeicherten Registry-Einstellungen wiederherstellen können.

No risk no fun.

Gruß
Member: Badger
Badger Jun 13, 2017 at 11:25:59 (UTC)
Goto Top
So:
die besagte GPO deaktiviert, IE auf Default zurückgesetzt, Foxit auf Default UND: das gleiche Problem face-sad

Irgendwie zum verzweifeln...
Mitglied: 114685
114685 Jun 13, 2017 updated at 11:34:17 (UTC)
Goto Top
Hi,

wenn du möchtest, schick mir mal per PN deine Einstellungen aus ... \Zones\0
und \Zones\3

0 Ist lokal und 3 ist Internet.

Gruß
Member: Badger
Badger Jun 13, 2017, updated at Jun 19, 2017 at 07:52:09 (UTC)
Goto Top
Du hast Post face-smile

Habe nun zum Testen auch eine Webseite mit einem PDF zur Site "Intranet" hinzugefügt und dort die Sicherheitsstufe auf "Niedrig" gesetzt.
Selbes Spiel...
Die einzige Möglichkeit bisher diese Warnung zu "deaktivieren" ist das abschalten des geschützten Modus.
Member: Badger
Badger Jun 26, 2017 at 06:57:35 (UTC)
Goto Top
Ich habe nun direkt von Foxit die Antwort erhalten, dass das Foxit IE plugin nur mit abgeschalteten "geschützten Modus" funktioniert.
Ist das wirklich bei euch auch so?

Grüße
Patrick
Member: Badger
Badger Jul 04, 2017 at 12:57:04 (UTC)
Goto Top
So:
nachdem ich nun einen Testrechner aufgesetzt habe konnte ich mittels regshot den Fehler finden.
Der Grund für die Fehlermeldung war, dass der Regkey "HKCU\SOFTWARE\Microsoft\Internet Explorer\Low Rights\ElevationPolicy" (aus welchen Gründen auch immer) nicht gesetzt war.

Mittels dieser amdx files konnte ich das Problem aber nun beheben.

Besten Dank für eure Hilfe!

Patrick