Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Installation PHP auf dem IIS 6

Mitglied: mark78

mark78 (Level 1) - Jetzt verbinden

19.07.2006, aktualisiert 09.08.2006, 3827 Aufrufe, 5 Kommentare

hallo zusammmen

ich bin dran PHP 5 auf unserem IIS 6 zu installieren! Auf der Defaultwebseite funktioniert es auch wunderbar. Jetzt haben wir aber im IIS natürlich einige andrere Seiten, also zusätzliche Webpages!
Bei denen funktioniert das PHP nicht.

Weiss jemand was ich evt. noch anpassen muss im php.ini oder so dass es auch auf allen anderen seiten funktioniert, oder vielleicht muss ich ja auch noch eine anpassung auf den weiteren Webpages im IIS vornehmen!

Besten Dank für Eure Hilfe!

Mark78
Mitglied: HenningD
08.08.2006 um 18:27 Uhr
Hallo,
ich habe genau das gleiche Problem. Hat mittlerweile jemand eine Lösung dafür?

Für die Default Seite funktioniert alles, für neu angelegte Seiten bekomme ich immer eine 404 Fehlerseite.

Für Hilfe wäre ich sehr dankbar!
Bitte warten ..
Mitglied: mark78
09.08.2006 um 09:44 Uhr
Hallo

Leider hat sich das problem bei mir auch noch nicht gelöst!
Habe auch das ganze nochmals durchgeführt wie es in der anleitung steht aber es kommt irgendwie nicht zum laufen!

Falls ich was neues weiss lass ich es dich wissen.
Bitte schreibe auch wenn du was neues weisst!

Gruss
Mark78
Bitte warten ..
Mitglied: HenningD
09.08.2006 um 15:07 Uhr
Hallo

Bei mir waren es 2 "Fehler". Prüf mal bei allen Webseiten nach, ob die php Erweiterung auch die gleichen Einstellungen hat wie die Default WEbseite. Bei der Default Webseite war bei mir phpisapi.dll angegeben, die neu erstellen Webseiten bezogen sich allerdings auf die php-cgi.exe. Warum auch immer.

Ausserdem musst du in der php.ini das doc_root auskommentieren. Danach hat bei mir alles einwandfrei funktioniert. PHP läuft nun auf allen eingerichteten Webseiten ohne Probleme.
Bitte warten ..
Mitglied: mark78
09.08.2006 um 18:00 Uhr
yessssssss....

das mit dem auskommentieren von der doc_root variable hat bei mir voll geholfen.

hast du dann dein wwwroot Verzeichnis auch nicht auf dem C: Laufwerk?
Ich habe es drum auf dem Laufwerk D: und ich könnte mir noch vorstellen dass das zu dem problem geführt hat. Ja nun habe ich einfach kein wert in doc_root un es funktioniert.

Gruss
Mark78
Bitte warten ..
Mitglied: HenningD
09.08.2006 um 18:53 Uhr
Also ich hab mein webroot noch auf C:

Ich denke PHP kommt einfach nicht mit den virtuellen Webseiten klar, wenn doc_root gesetzt ist und die Webseite die mit PHP laufen soll eine Ebene tiefer liegt.

Naja..zumindest funktioniert es nun, und das ist ja die Hauptsache!
Bitte warten ..
Ähnliche Inhalte
Informationsdienste
PHP-IIS 8 Websitefehler
Frage von BlacckyInformationsdienste2 Kommentare

Hallo liebe Forum Nutzer, Und zwar wollte ich Cloud/Mail(Website)/Forum Server jemanden zur Verfügung stellen. Für Tests habe ich die ...

Hosting & Housing
HTTPS auf IIS 6 deaktivieren
Frage von kochi09Hosting & Housing3 Kommentare

Hallo zusammen, ich suche nach einer Lösung für folgendes Problem: ich habe eine Website auf einem alten IIS6 die ...

Datenbanken
Probleme mit IIS PHP SQL auf SBS2011
Frage von ITS2015Datenbanken8 Kommentare

Hallo, Erst einmal zum Server: Dell PowerEdge 610 2 x QC Xeon 32GB RAM RAID10 ( 6x 600GB SAS ...

CMS

PHP - WordPress auf Apache schneller als auf IIS?

Frage von Rene1976CMS13 Kommentare

Hallo Gemeinde, wir haben einen Win 2008 R2 RootServer mit Plesk 12.5. Dort laufen auch ASPX Websites drauf. Jetzt ...

Neue Wissensbeiträge
Humor (lol)
Administrator.de Perlen
Tipp von DerWindowsFreak2 vor 2 TagenHumor (lol)3 Kommentare

Hallo, Heute beim stöbern auf dieser Seite bin auf folgenden Thread aus dem Jahre 2006 gestossen: Was meint ihr? ...

Erkennung und -Abwehr
OpenSSH-Backdoor Malware erkennen
Tipp von Frank vor 3 TagenErkennung und -Abwehr

Sicherheitsforscher von Eset haben 21 Malware-Familien untersucht. Die Malware soll Hintertüren via OpenSSH bereitstellen, so dass Angreifer Fernzugriff auf ...

iOS
WatchChat für Whatsapp
Tipp von Criemo vor 6 TageniOS5 Kommentare

Ziemlich coole App für WhatsApp User in Verbindung mit der Apple Watch. Gibts für iOS sowohl als auch für ...

iOS
IOS hat nen Cursor!
Tipp von Criemo vor 7 TageniOS5 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Heiß diskutierte Inhalte
Grafikkarten & Monitore
PCIe 1.0 Grafikkarte für 3840x2160
Frage von Windows10GegnerGrafikkarten & Monitore30 Kommentare

Hallo, mein Vater hat einen neuen Monitor gekauft, welcher eine native Auflösung von 3840*2160 hat. Diese muss jetzt auch ...

Windows Server
Dienstnamen und oder Deutsche und Englische Beschreibung in services.msc gleichzeitig anzeigen
gelöst Frage von vafk18Windows Server23 Kommentare

Guten Morgen, die Suche nach Diensten in services.msc gestaltet sich immer wieder schwierig, weil mir je nach Aufgabe die ...

Windows 10
Windows Enterprise 1809 Eval nicht bootbar
Frage von Sunny89Windows 1022 Kommentare

Hallo zusammen, bevor ich mich jetzt noch stundenlang rumärger wollte ich euch fragen, ob Ihr die gleichen Probleme habt ...

JavaScript
Javascript: WebSql
gelöst Frage von internet2107JavaScript13 Kommentare

Guten Morgen zusammen, zunächst einmal einen schönen dritten Advent. Ich habe ein Problem mit Javascript und WebSQL. Bisher habe ...