Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst IPv6 Routing ohne Funktion

Mitglied: clSchak

clSchak (Level 3) - Jetzt verbinden

16.10.2019, aktualisiert 21:16 Uhr, 220 Aufrufe, 5 Kommentare

Hiho

wir haben seit Anfang der Woche das Problem, das der gesamte IPv6 Traffic nicht mehr geroutet wird. Die VE's sind aus den einzelnen VLANs erreichbar, der Router selbst kann auch fröhlch alle Geräte in den unterschiedlichen VLANs anpingen, wenn man aber von einem Endpunkt (Client, Server usw.) versucht ein IPv6 Adresse in einem anderen VLAN zu erreichen kommt das ganz bis zum Router und läuft dann ins Nirvana.

Wir arbeiten aktuell und zu Testzwecken ausschließlich mit statischen IP Adressen, aus dem Grund Advertised der Router auch seine Settings nicht, funktionierte auch alles anstandslos bis Anfang dieser Woche :< , es wurde am Routing nichts umgestellt, auch eine doppelte Adressvergabe kann ausgeschlossen werden. In den Logs steht auch nichts was darauf hinweist, dass das Routing "aus" ist, die Router hatten auch keinen Reboot oder vergleichbares. Ich kann mir da aktuell keinen Reim drauf machen

Gerät ist ein 4er Stack ICX7750 mit dem L3 RouterImage

Anbei die Auszüge aus der Config:

Basis Config:
01.
errdisable recovery cause all
02.
errdisable recovery interval 10
03.
aaa authentication login default local
04.
jumbo
05.
default-vlan-id 777
06.
enable skip-page-display
07.
enable super-user-password .....
08.
enable aaa console
09.
hostname GeräteName
10.
ip dns server-address ServerIP ServerIP
11.
ip forward-protocol udp 4
12.
ip forward-protocol udp echo
13.
ip route 0.0.0.0/0 NextHopIP
14.
!
15.
ipv6 dns server-address (IPv6Präfix):1::2 (IPv6Präfix):1::50
16.
ipv6 unicast-routing
17.
ipv6 route ::/0 (IPv6Präfix):1::12
18.
ipv6 route (IPv6Präfix):200::/64 (IPv6Präfix):1::58
19.
!
20.
qos-tos map dscp-priority 46 to 6
21.
logging host ServerIP  udp-port 10514
22.
logging facility syslog
23.
logging buffered 1000
24.
username admin password .....
25.
snmp-server community ..... ro
26.
snmp-server community ..... rw
27.
!
28.
!
29.
clock timezone gmt GMT+01
30.
!
31.
!
32.
ntp
33.
 server ServerIP
34.
 server ServerIP
35.
!
36.
!
37.
hitless-failover enable
38.
!
39.
router ospf
40.
 area 0.0.0.0
41.
 auto-cost reference-bandwidth 4294967
42.
!
43.
!
44.
!
45.
!
46.
!
47.
!
48.
!
49.
ipv6 router ospf
50.
 area 0.0.0.0
51.
 auto-cost reference-bandwidth 4294967
52.
!
Router Interfaces
01.
interface ve 1
02.
 ip address IP-Adresse 255.255.255.0
03.
 ip address IP-Adresse 255.255.252.0
04.
 ip directed-broadcast
05.
 ip helper-address 1 IP-Adresse
06.
 ip ospf area 0.0.0.0
07.
 ipv6 address (IPv6Präfix):1::30/64
08.
 ipv6 enable
09.
 ipv6 ospf area 0.0.0.0
10.
 ipv6 ospf active
11.
 ipv6 nd suppress-ra
12.
!
13.
interface ve 12
14.
 ip address IP-Adresse 255.255.255.0
15.

16.
 ip ospf area 0.0.0.0
17.
!
18.
interface ve 15
19.
 ip address IP-Adresse 255.255.255.0
20.
!
21.
interface ve 50
22.
 ip address IP-Adresse 255.255.255.0
23.
 ip ospf area 0.0.0.0
24.
 ipv6 address (IPv6Präfix):50::30/64
25.
 ipv6 enable
26.
 ipv6 ospf area 0.0.0.0
27.
 ipv6 ospf active
28.
 ipv6 nd suppress-ra
29.
!
Vielleicht hat ja noch wer ein Idee woran es liegen kann

FW Version: 08.0.30gT203

Add: Lustig ist allerdings, das ich aus jedem VLAN die RouterInterfaces anpingen von jedem anderen VLAN ...


Gruß
@clSchak
Mitglied: aqui
LÖSUNG 16.10.2019, aktualisiert um 22:48 Uhr
Deine Firmware ist recht alt und auch schon lange nicht mehr die recommended Version.
Du solltest als Allererstes den Stack auf die recommended Version 8.0.7f (aktuell latest) updaten und das Verhalten nochmal checken.
Ein kurzer Check mit der 8.0.7f auf einem 7250 zeigte hier absolut fehlerloses Verhalten im v6 Routing mit statischen IPs auf den Endgeräten. Innerhalb des Switches. Test aktuell nur mit einem Switch. Ein OSPFv3 Test Umfeld dauert etwas kann ich aber testen.
<OT> Hat das einen Grund warum du der OSPF Reference Bandwith so einen komischen Wert gibst und nicht schlicht und einfach 100000 ?? Dann hätte ein 100Gig Interface die Cost 1 und bis 100G kann der OSPF Prozess dann alles fehlerlos identifizieren ?! </OT>
Bitte warten ..
Mitglied: clSchak
16.10.2019, aktualisiert um 23:28 Uhr
01.
ssh@NAME(config-ospf6-router)#auto-cost reference-bandwidth
02.
  DECIMAL   <1-4294967>  in Mbits per second
darum, ist der maximale Wert der lt. CLI gesetzt werden kann.

Updaten wird da schon komplizierter, das Gerät ist der Primäre Router :> ich kann den nicht mal eben rebooten ohne vorher einige andere Dienst neuzustarten, außerdem _suckt_ die neue PVID Funktion ... .

Btw. wir haben ohnehin nur eine Area und vor Uhrzeiten OSPF als Protokoll gewählt und sind dann dabei geblieben. Ich habe auch schon das ganze IPv6 Routing auf RIP umgestellt, der gleich Effekt, wir haben keine ACL's oder vergleichbares auf dem Router laufen was evtl. einen Sideeffekt haben könnte. Das IPv4 Routing funktioniert auf den Interfaces anstandslos, nur das IPv6 eben nicht :|.

Evtl. morgen mal einen Call bei Ruckus aufmachen.

PS: 8.0.9d ist die aktuellste Version bzw. 8.0.80d
Bitte warten ..
Mitglied: aqui
17.10.2019, aktualisiert um 10:15 Uhr
Btw. wir haben ohnehin nur eine Area und vor Uhrzeiten OSPF als Protokoll gewählt und sind dann dabei geblieben.
Was ja per se nicht falsch ist und man generell so machen kann !
auf RIP umgestellt, der gleich Effekt
Igitt...RIP, nee lieber OSPF. Aber das das nichts ändert ist mehr oder weniger nachvollziehbar, denn die Routing Protokolle distribuieren ja einzig nur die Routen. Vermutlich liegt dein Kinken im IPv6 Forwarding selber. Deine Routing Tabelle (sh ip rou) zeigt dir sicher alles sauber an, oder ?
8.0.9d ist die aktuellste Version bzw. 8.0.80d
Ja, aber nicht die "Recommended" !! Ich habe teils böse Erfahrungen gemacht mit den brandneuen Images. OK nur in Nischenkonfigs (NAC Umfeld) aber das hat Tage gekostet rauszubekommen wo der Fehler lag. Letztlich ein Bug der im Recommended nicht drin war. Seitdem bleibe ich dabei, gehe aber immer auf den höchsten Minor Patch Level in dem Release Train. Wenn man zwingend brandneu nehmen muss wegen irgendwelcher Features, sollte hinten mindestens ein "c" sein.
Ich flash die 8.3er mal ins Secondary und teste das damit nochmal... Mal sehen ob man das reproduzieren kann auf anderen Modellen. Ggf. ist das nur ein Hänger und verschwindet nach einem Reboot. Wenn du aber rebootest kannst du auch gleich auf die aktuelle Recommended gehen !
Vielleicht mal ein kleines Warungsfenster heute nach Feierabend einschieben ?! Ins Secondary Flash kannst du sie ja schon mal vorab kopieren. Reboot dauert ja nur 2-3 Minuten...
Bitte warten ..
Mitglied: clSchak
17.10.2019, aktualisiert um 10:41 Uhr
Hi aqui

ja die Routen werden korrekt im OSPF auf den VE Interfaces angezeigt

Lustiges Verhalten:

InterVLAN Routing -> geht nicht, also ich kann z.B. keine Adresse von VLAN1 in VLAN50 pingen

Routing ins Internet: ping -6 auf die Google: funktioniert von allen VLANs ôÔ

.... das zum Verhalten, ich habe testweise auch das RouterAdvertisment wieder eingeschaltet allerdings ohne Erfolg.

Was ich jetzt gemacht habe auf den VE's: IPv6 Adresse gelöscht und direkt neu gesetzt -> alles funktioniert wieder :| - das habe ich gestern Abend nicht probiert, da ja aktuell die gesamte IPv6 Geschichte static ist.

Aber ich kann das Verhalten nicht nachvollziehen warum das nicht funktioniert hat, sieht mir doch sehr nach einen Bug aus - werde wohl updaten müssen.

Mal sehen wann sich ein Zeitfenster findet, da wir 24/7 Betrieb habe und das halt "Core" ist, ist da ein wenig Abstimmung notwendig aber nicht unmöglich.
Bitte warten ..
Mitglied: aqui
17.10.2019 um 13:09 Uhr
werde wohl updaten müssen.
Besser ist das in jedem Falle. Wenn du das verlässlich laufen haben willst ist das ein Muss...weisst du selber.
Wie gesagt Reboot dauert ja nur 2-3 Minuten.
Beim nächsten TAC Case hauen die dir das so oder so um die Ohren, denn die 3er ist vermutlich nicht mehr supportet auf der Plattform.
Übrigens...
Auch mit der 8.0.3 latest liess sich das hier auf dem 7250 nicht reproduzieren. Ist wie bei dir, wenn man es neu konfiguriert rennt es.
Vermutlich ist das irgendwie ein temporärer Hänger in der FIB oder CAM Table oder Buffer Overflow oder was auch immer in der Firmware.
Bitte warten ..
Ähnliche Inhalte
Router & Routing
PfSense IPv6 Routing
Frage von fundave3Router & Routing17 Kommentare

Hallo zusammen, ich gehe mal davon aus, wenn das Wort IPv6 Fällt , ist der Beitrag schon entfernt. :) ...

Netzwerkgrundlagen
IPv6 Inter-VLAN Routing
gelöst Frage von clSchakNetzwerkgrundlagen14 Kommentare

Hi ich befasse mich gerade mit der Implementierung von IPv6 was bisher (in einem VLAN) korrekt funktioniert inkl. DNS ...

Netzwerke
Routing-Frage IPv6 und IPv4
gelöst Frage von 135624Netzwerke7 Kommentare

Hallo, ich habe eine Frage zum Thema IPv6. Ich habe das mit dem Subnetting ungefähr begriffen nur eines ist ...

Router & Routing
IPv6 Routing mit Pfsense als VM
gelöst Frage von DaniRouter & Routing14 Kommentare

Guten Abend liebe Netzwerkler, ich sehe gerade vor lauter Bäumen den Wald nicht Ich habe mir bei einem Webhoster ...

Neue Wissensbeiträge
MikroTik RouterOS

Dynamische VLAN Zuweisung für WLAN (u. LAN) Clients mit Mikrotik

Anleitung von aqui vor 3 TagenMikroTik RouterOS

1. Allgemeine Einleitung: Das folgende Tutorial gibt einen Überblick über die dynamische VLAN Zuweisung von WLAN und LAN Clients ...

Humor (lol)
Würde man Frauen in IT-Klassen einteilen
Information von Henere vor 6 TagenHumor (lol)19 Kommentare

wollen, gäbe es folgende Varianten: Die Internet-Frau: Man muss bezahlen, um sich Zugang zu ihr zu verschaffen. Die Server-Frau: ...

Sicherheits-Tools

TrendMicro WorryFree Business Security 10.0 SP1 - neuer Patch 2179 (Korrekturupdate) verfügbar!

Tipp von VGem-e vor 6 TagenSicherheits-Tools

Servus, grad eben entdeckt, nachdem Patch 2178 zurückgezogen wurde: Gruß

Administrator.de Feedback
Entwicklertagebuch: Tracking und Werbung
Information von admtech vor 10 TagenAdministrator.de Feedback3 Kommentare

Hallo Administrator User, wir haben unser Tracking auf das Matomo Tool umgestellt. Damit hosten wir die Webanalyse ab sofort ...

Heiß diskutierte Inhalte
Ubuntu
Linux Ubuntu VNC IP
Frage von 141835Ubuntu58 Kommentare

Wie finde ich bei Linux Ubuntu die IP-Adresse vom VNC Server heraus???

Windows Server
Domaincontroller Windows Server 2003 durch 2016 ersetzen
Frage von MilordWindows Server18 Kommentare

Hallo zusammen, eventuell kann einer von euch weiterhelfen. Ich stecke aktuell etwas fest und komme nicht richtig weiter. Folgende ...

Batch & Shell
Wiederkehrende Ausgabe in .csv ausblenden
Frage von chkdskBatch & Shell15 Kommentare

Guten Tag zusammen, ich habe folgendes Powershell Skript geschrieben, welches mit alle AD Gruppen inkl NTFS Berechtigungen eines gewünschten ...

Hyper-V
Hyper-V-Host rebootet - einige wenige Gäste haben danach Ping-Zeiten von über 400ms!
Frage von DerWoWussteHyper-V15 Kommentare

Moin an alle Hyper-V Admins! Hat jemand außer mir schon einmal Folgendes erlebt? Hyper-V auf Server 2019. Server startet ...