vofoad
Goto Top

Join hostname greater 15 characters

Hallo zusammen,

bei uns im Netzwerk und der windows AD existierte ein Sambafileserver mit einem langen hostname server-experimental. Dieser lief aber noch unter Debian9, also wollte ich ihn unter Debian11 neu aufziehen. Beim join in die AD stolper ich jetzt aber über den langen hostname. Die Recherche im Netz ergeben sowas wie Hostname größer 15 Chars ist in Windows nicht möglich - dem widerspricht aber der alte Server. Alle Versuche mit Parametern für net ads join sind fehlgeschlagen. Welche Möglichkeit gibt es noch? Spontan würde mir nur noch ein join mit kurzem Namen und dann umbenennen einfallen?!? Aber ist sowas möglich?

Content-Key: 1976885514

Url: https://administrator.de/contentid/1976885514

Printed on: February 24, 2024 at 16:02 o'clock

Member: Th0mKa
Th0mKa Feb 22, 2022 at 09:31:44 (UTC)
Goto Top
Moin,

Kannst du deinen Text bitte mal lesbar machen damit man weiß wo dein Problem ist?

/Thomas
Member: vofoAD
vofoAD Feb 22, 2022 at 10:01:30 (UTC)
Goto Top
okee ... Anführungszeichen, bzw. Sonderzeichen werden nicht dargestellt ... dann eben so
Member: vofoAD
vofoAD Feb 22, 2022 at 10:16:17 (UTC)
Goto Top
wir werden jetzt den pragmatischen Weg einschlagen und den neuen Server kurz server-exp nennen. Dennoch wäre spannend zu wissen wie es vorher möglich war einen 19 Chars langen Namen in die AD zu bekommen.
Member: Th0mKa
Th0mKa Feb 22, 2022 at 11:58:31 (UTC)
Goto Top
Zitat von @vofoAD:

wir werden jetzt den pragmatischen Weg einschlagen und den neuen Server kurz server-exp nennen. Dennoch wäre spannend zu wissen wie es vorher möglich war einen 19 Chars langen Namen in die AD zu bekommen.

Computernamen größer 15 Zeichen gehen schon länger, das war ja nur eine Beschränkung des NetBios Protokolls.
Kein NetBios = Kein Problem
Member: vofoAD
vofoAD Feb 22, 2022 at 12:51:51 (UTC)
Goto Top
aber obwohl in der smb.conf disable netbios = yes gesetzt war konnte der Server mit dem langen hostname nicht durch den Befehl net ads join in die AD integriert werden. Es gab immer die Fehlermeldung, das der Name zu lang ist. Müsste man dazu dann den nmbd.service komplett deaktivieren?
Member: Th0mKa
Th0mKa Feb 22, 2022 at 13:10:26 (UTC)
Goto Top
Zitat von @vofoAD:

aber obwohl in der smb.conf disable netbios = yes gesetzt war konnte der Server mit dem langen hostname nicht durch den Befehl net ads join in die AD integriert werden. Es gab immer die Fehlermeldung, das der Name zu lang ist. Müsste man dazu dann den nmbd.service komplett deaktivieren?

Hab keine große Ahnung von Samba, in Windows funktioniert das einfach so.
Mitglied: 1915348599
1915348599 Feb 22, 2022 updated at 15:50:42 (UTC)
Goto Top
Den eigentlichen Hostnamen des Servers musst du nicht ändern nur den NETBIOS Namen auf 15 Zeichen in der smb.conf verkürzen und Diensttneustart reicht i.d.R. .
[global]
netbios name = shortname