mitschy71
Goto Top

Kein DNS Zugriff von Fritz LAN in das MikroTik VLAN

Hallo zusammen,

ich habe folgendes Thema, ich konnte meinen MikroTik hAP ax² nach der Anleitung hier im Forum einrichten, ich dachte auch das alles wunderbar funktioniert.

Habe auch das Script für die DNS Auflösung aktiviert und kann von Geräten die im VLAN des Mikrotik hängen schön die Geräte im Fritz Netzwerk per DNS erreichen. Beispiel: ping pc1.fritz.box.
Ich dachte, wenn das funktioniert, müssen ja auch die Geräte, hier habe ich eine Domäne vlan10.local eingerichtet, im vlan10 erreichbar sein und habe WIN11PC1.vlan10.local angepingt, das funktioniert leider nicht, über die IP kann ich ihn anpingen.
Kann mir jemand einen Tipp geben, was ich evtl. vergessen oder übersehen haben könnte?

Ich hoffe die Informationen sind erstmal ausreichend. Vielen Dank für die Hilfe!

Content-Key: 9104947620

Url: https://administrator.de/contentid/9104947620

Printed on: February 23, 2024 at 07:02 o'clock

Member: PC-Helfer
PC-Helfer Sep 13, 2023 at 16:16:28 (UTC)
Goto Top
Hi,

nach welcher Anleitung hast du den Mikrotik eingerichtet?

SG
Member: em-pie
em-pie Sep 13, 2023 at 16:19:11 (UTC)
Goto Top
Moin,

Der DNS der Fritte kann mit der Domain vlan10.Local nichts anfangen. Die weiß nicht, wohin die die Anfragen weiterleiten soll.

Der musste den Mikrotik für die Domain vlan10.Local als Forwarding Server eingetragen haben. Ob das mit der Fritte aber geht, habe ich gerade nicht im Kopf
Member: Mitschy71
Mitschy71 Sep 13, 2023 updated at 16:39:06 (UTC)
Goto Top
Hallo,
danke schonmal für eure Antworten.
@PC-Helfer
Ich habe den MikroTik nach dieser Anleitung eingerichtet: MikroTik VLAN Konfiguration ab RouterOS Version 6.41.

@em-pie Genau das vermute ich auch, aber hab leider auch keine Ahnung ob und wie das evtl. bei der Fritzbox geht.
Member: Pjordorf
Pjordorf Sep 13, 2023 at 16:54:09 (UTC)
Goto Top
Hallo,

Zitat von @Mitschy71:
Genau das vermute ich auch, aber hab leider auch keine Ahnung ob und wie das evtl. bei der Fritzbox geht.
Eine Fritte kann kein vLAN und kann auch nur ein Gastnetz neben ihr Netz, kann auch nicht routen zu anderen Netzen, selbst für ihr eigenes Gastnetz ist eine FritzBox Taub. Works as designed.

Gruß,
Peter
Member: LordGurke
LordGurke Sep 13, 2023 at 18:49:06 (UTC)
Goto Top
Der obligatorische Hinweis: ".local" ist eine spezielle TLD, die für mDNS reserviert ist und somit erstmal nur innerhalb des selben VLAN funktioniert.
Benutze eine andere TLD für normales DNS.
Member: em-pie
em-pie Sep 13, 2023 at 19:33:00 (UTC)
Goto Top
Zitat von @Pjordorf:

Hallo,

Zitat von @Mitschy71:
Genau das vermute ich auch, aber hab leider auch keine Ahnung ob und wie das evtl. bei der Fritzbox geht.
Eine Fritte kann kein vLAN und kann auch nur ein Gastnetz neben ihr Netz, kann auch nicht routen zu anderen Netzen, selbst für ihr eigenes Gastnetz ist eine FritzBox Taub. Works as designed.

Die Fritte muss auch kein VLAN können, wenn der Mikrotik selbst ein Bein im Netz der Fritte hat… Rest geht ja über stat. Routen….

Wenn der hAP ein DNS Forwarding kann, sollte der ggf. Für alle Netze DNS (und ggf. DHCP) spielen - auch für das Netz der Fritte…
Member: aqui
aqui Sep 14, 2023 updated at 07:38:55 (UTC)
Goto Top
hier habe ich eine Domäne vlan10.local eingerichtet
.local ist keine intelligente Idee und eher ein NoGo in lokalen Netzen zumindestens wenn man sie bewusst in statischen DNS Settings verwendet:
Hinweise zur Verwendung der Domäne .local in DNS und mDNS
Member: Mitschy71
Mitschy71 Sep 14, 2023 at 09:42:57 (UTC)
Goto Top
Zitat von @LordGurke:

Der obligatorische Hinweis: ".local" ist eine spezielle TLD, die für mDNS reserviert ist und somit erstmal nur innerhalb des selben VLAN funktioniert.
Benutze eine andere TLD für normales DNS.

Vielen Dank, werde ich ändern!
Member: Mitschy71
Mitschy71 Sep 14, 2023 at 09:46:17 (UTC)
Goto Top
Zitat von @em-pie:

Zitat von @Pjordorf:

Hallo,

Zitat von @Mitschy71:
Genau das vermute ich auch, aber hab leider auch keine Ahnung ob und wie das evtl. bei der Fritzbox geht.
Eine Fritte kann kein vLAN und kann auch nur ein Gastnetz neben ihr Netz, kann auch nicht routen zu anderen Netzen, selbst für ihr eigenes Gastnetz ist eine FritzBox Taub. Works as designed.

Die Fritte muss auch kein VLAN können, wenn der Mikrotik selbst ein Bein im Netz der Fritte hat… Rest geht ja über stat. Routen….

Wenn der hAP ein DNS Forwarding kann, sollte der ggf. Für alle Netze DNS (und ggf. DHCP) spielen - auch für das Netz der Fritte…

Wenn ich das richtig verstehe, soll ich den DHCP und DNS-Server auf dem MikroTik-Gerät einrichten, damit alles funktioniert?
Member: aqui
aqui Sep 14, 2023 updated at 09:59:37 (UTC)
Goto Top
Laut deinen Ausführungen von oben hast du das doch schon alles gemacht? Wozu also die Frage? 🤔
Guckst du HIER!
Member: Mitschy71
Mitschy71 Sep 14, 2023 at 13:28:58 (UTC)
Goto Top
Zitat von @aqui:

Laut deinen Ausführungen von oben hast du das doch schon alles gemacht? Wozu also die Frage? 🤔
Guckst du HIER!

Möglicherweise habe ich mich missverständlich ausgedrückt, aber ich habe den Mikrotik-Router gemäß der Anleitung eingerichtet. Allerdings scheint das Szenario in der Abbildung vor dem MikroTik-Router mit den Client-Geräten im Fritz-Netzwerk nicht vorzuliegen. Auf der FritzBox läuft ein DHCP-Server und DNS-Client, der den Geräten IP-Adressen und Namen zuweist. Daher meine Frage.
2023-09-14 15_17_56-window
Member: aqui
aqui Sep 15, 2023 updated at 06:58:35 (UTC)
Goto Top
Allerdings scheint das Szenario in der Abbildung vor dem MikroTik-Router mit den Client-Geräten im Fritz-Netzwerk nicht vorzuliegen.
Bahnhof?, Ägypten?
Scheint?? Ja was denn nun... Liegt es vor oder nicht und ist es mit NAT oder ohne konfiguriert??
In einem Administrator Forum sollte man solche grundlegenden Dinge schon genau wissen um zielgerichtet helfen zu können. Kristallkugeln hilft nicht wirklich... face-sad
Ob im Koppelnetz zur Fritzbox noch Clients sind oder nicht ist doch für eine korrekte DNS Auflösung völlig unerheblich!
Member: aqui
aqui Oct 24, 2023 at 14:15:07 (UTC)
Goto Top
Wenn es das war bitte nicht vergessen deinen Thread hier als erledigt zu markieren!