kefhvdi
Goto Top

Lokale Links (laufwerklinks) öffnen Firefox

Guten Tag,

Firefox öffnet folgende Links einer Intranetseite nicht.

file:///X:/Ordner1/Ordner2/Datei.pdf

Im IE geht es problemlos. Habe diverse Einstellungen bereits ausprobiert. Leider ohne Erfolg.
Es handelt sich hierbei um Firefox 53.0 32bit.

Edit:

Lösung:

in der pref.js von Firefox folgendes eintragen:

user_pref("capability.policy.policynames", "localfilelinks");
user_pref("capability.policy.localfilelinks.sites", "http://DeineWebseite");
user_pref("capability.policy.localfilelinks.checkloaduri.enabled", "allAccess");

Content-Key: 336029

Url: https://administrator.de/contentid/336029

Printed on: June 23, 2024 at 14:06 o'clock

Member: Pedant
Pedant May 17, 2017 at 11:54:32 (UTC)
Goto Top
Hallo KEFHVDI,

ein Intranetseite ist etwas anderes, Du meinst eine lokale Datei.
Intranet heißt im Groben Dienste im eigenen Netzwerk zu betreiben, die auf Internet-Technologien basieren, wie zB. einen Webserver.
Eine Intranetseite könnte beispielsweise diese Adresse haben:
http://meinlokalerserver oder http://meinlokalerserver.ich.local
Aber das nur nebenbei.

Zur Sache:
Bei meinem Firefox funktioniert das auch ohne Deine Einstellungen:
Lokaler Ordner: file:/c:/
Netzwerk-Ordner: file:
/meinrechner/c$/
Netzwerk-Ordner: file:
///127.0.0.1/c$/

Ich habe zwar auch Einstellungen geändert, aber die sollten/müssten den Browser nur davon abhalten sich aus meinen Adressleisten-Eingaben irgendwelche URLs zu basteln oder gar eine Suche damit zu starten, statt einfach die eingegebene Adresse zu öffnen.
Das Firefox ein fehlendes "http://" ergänzt finde ich gut, alles andere geht zu weit.

Wenn ich "meinrechner" eingebe, dann will ich die Startseite meines lokalen Webservers sehen, also
http://meinrechner und nicht auf
http://www.meinrechner.com gehen und auch nicht nach
"meinrechner" suchen lassen.

Nur zur Vollständigkeit hier meine Änderungen:
user_pref("browser.fixup.alternate.enabled", false);
user_pref("keyword.enabled", false);
user_pref("browser.urlbar.trimURLs", false);
user_pref("browser.urlbar.formatting.enabled", false);
Unter der Annahme, dass meine Änderungen nichts mit Deinem Problem zu tun haben, also keine alternative Lösung darstellen, frage ich mich warum das Problem bei Dir bestand und bei mir nicht.
(Meine Firefox ist im Moment 53.0.2 (64-Bit), aber bei den Versionen vorher war das bei mir auch schon so.)

Gruß Frank