evolutio
Goto Top

Mikrotik RB5009UG+S+IN und Mikrotik cAP ax

Servus Leute,

ich bin komplett neu im Mikrotik Thema und habe mich die letzten Tage intensiver mit dem RouterBoard 5009UG+S+IN und dem cAP ax beschäftigt.

Mein Setup ist aktuell folgendes:
  • Glasfaser mit einem Glasfaser Modem 2 per Netzwerk-Kabel in meine Wohnung (Glasfaser ging nicht)
  • Glasfaser Modem 2 per Netzwerkkabel in ether1 verbunden
  • per Netzwerkkabel über die Ports 2-8 liegen die Räume am Router an

soweit funktioniert alles.

Meine Basiskonfiguration sieht wie folgt aus:
  • ether1 zu wan umbenannt
  • VLAN mit der ID 7 auf dem Interface wan mit dem Namen vlan7-telekom erstellt
  • PPPoE-Client auf dem Interface vlan7-telekom mit meinen Zugangsdaten konfiguriert
  • eine Adress List (192.168.10.1/24) auf dem Interface ether2 erstellt
  • DHCP-Server auf dem Interface ether2 erstellt, sodass automatisch 192.168.10.x auf dem Interface ether2 verteilt werden
  • in der Firewall eine NAT-Rule mit der action masquerade und der Chain srcnat erstellt

Somit komme ich in der Basiskonfiguration mit einer Verbindung von ether2 ins Internet.

Jetzt habe ich auf dem Interface ether4 auch einen Adress List (192.168.4.1/24) mit einem DHCP-Server erstellt, sodass alle Geräte auf dem Interface ether4 eine IP zugewiesen bekommen.

Dann habe ich bei Capsman auf Manage gedrückt und das soweit eingerichtet. Dann den cAP ax auf ether4 eingesteckt und den Reset-Knopf (wie hier beschrieben) in den CapsMode verstezt.

Darauf erscheint in der Log-Ansicht folgendes:
  • ether4 link down
  • ether4 link up
  • ether4 link down
  • ether4 link up
  • ether4 link down
  • ether4 link up

und das war's. Dasselbe habe ich auch mit einer einfachen Konfiguration unter Capsman versucht, sodass die Konfiguration eigl. auf den cAP ax angewendet werden sollte, was allerdings nicht der Fall ist.

Stecke ich den cAP ax dann an meinen LAN-Port und konfiguriere mir die manuelle IP 192.168.4.50 komme ich per WinBox auf die IP 192.168.4.2 auf den cAP ax. Jetzt weiß ich nicht, wie ich die automatische Konfiguration über mein RB5009 vornehmen kann, sodass die Interfaces wifi1 und wifi2 in meinem Router angezeigt werden.

Ich hatte mir schon Cap AX meldet sich nicht an Capsman an durchgelesen, da ich so ziemlich das selbe Problem habe, allerdings habe ich als AP nur den cAP ax.

Ich hoffe, dass ihr mir folgen könnte und ggf. weiter helfen könnt.

Der Router ist auf Version 7.11 und der cAP ax auf Version 7.8

Der Export der aktuellen Konfig (inkl. Capsman versuch):
/interface ethernet
set [ find default-name=ether1 ] name=wan
/interface vlan
add interface=wan name=vlan7-telekom vlan-id=7
/interface pppoe-client
add add-default-route=yes disabled=no interface=vlan7-telekom name=\
    pppoe-out-telekom user=@t-online.de
/interface wifiwave2 configuration
add channel.band=2ghz-ax country=Germany disabled=no name=ap-2.4ghz \
    security.authentication-types=wpa2-psk,wpa3-psk ssid=Gummibaerenbande
add channel.band=5ghz-n country=Germany disabled=no name=ap-5ghz \
    security.authentication-types=wpa2-psk,wpa3-psk ssid=Gummibaerenbande
/ip pool
add name=dhcp_pool0 ranges=192.168.10.2-192.168.10.254
add name=dhcp_pool1 ranges=192.168.4.2-192.168.4.254
add name=dhcp_pool2 ranges=192.168.4.2-192.168.4.254
/ip dhcp-server
add address-pool=dhcp_pool0 interface=ether2 name=dhcp1
add address-pool=dhcp_pool2 interface=ether4 name=dhcp2
/interface wifiwave2 cap
set certificate=CAPsMAN-789A1802D0EC discovery-interfaces=all enabled=yes
/ip address
add address=192.168.10.1/24 interface=ether2 network=192.168.10.0
add address=192.168.4.1/24 interface=ether4 network=192.168.4.0
/ip dhcp-server network
add address=192.168.4.0/24 dns-server=1.1.1.1,8.8.8.8 gateway=192.168.4.1
add address=192.168.10.0/24 dns-server=1.1.1.1,8.8.8.8 gateway=192.168.10.1
/ip dns
set servers=1.1.1.1,8.8.8.8
/ip firewall nat
add action=masquerade chain=srcnat
/system note
set show-at-login=no

Liebe Grüße,
Evolutio

Content-Key: 8157487776

Url: https://administrator.de/contentid/8157487776

Printed on: February 23, 2024 at 07:02 o'clock

Member: aqui
aqui Aug 16, 2023 at 08:37:24 (UTC)
Goto Top
Die Capsman Einstellung einmal nach diesem Setup versucht?
Member: Evolutio
Evolutio Aug 16, 2023 updated at 09:58:22 (UTC)
Goto Top
Hallo @aqui, danke für deine Nachricht - auf den Artikel war ich auch gestoßen.
Das Problem ist, dass der cAP ax nur Wifiwave2 kann und somit ältere Artikel nicht mehr komplett funktionieren, oder ich was falsch gemacht habe.

Auf jeden Fall habe ich jetzt folgendes gemacht:
- 7.11 auf dem RB5009 und dem cAP ax installiert
- Wifiwave2 Package auf dem RB5009 und cAP ax installiert

jetzt konnte ich über Capsman den AP einrichten.

Hilfreich war auch folgender Thread: Mikrotik Wifiwave2 - CAPsMan VLan Zuordnung

Aktuell hänge ich an dem Problem, dass bei mir cap-wifi1 das 2.4GHz konfigurierte ist
und cap-wifi2 das 5GHz konfigurierte. Beide haben die selbe SSID. Allerdings verbinden sich die Geräte nur auf das 2.4GHz Netzwerk.

meine Konfig:
/interface bridge
add name=bridge vlan-filtering=yes
/interface ethernet
set [ find default-name=ether1 ] name=wan
/interface vlan
add interface=wan name=vlan7-telekom vlan-id=7
add disabled=yes interface=bridge name=vlan40 vlan-id=40
/interface pppoe-client
add add-default-route=yes disabled=no interface=vlan7-telekom name=\
    pppoe-out-telekom user=XYZ@t-online.de
/interface wifiwave2 channel
add band=2ghz-g disabled=no name=ch_24 skip-dfs-channels=all
add band=5ghz-n disabled=no name=ch_5
/interface wifiwave2 datapath
add bridge=bridge name=vlan20 vlan-id=20
/interface wifiwave2 security
add authentication-types=wpa2-psk,wpa3-psk disabled=no name=ap_security
/interface wifiwave2 configuration
add channel=ch_24 channel.band=2ghz-ax .skip-dfs-channels=all country=Germany \
    disabled=no mode=ap name=ap-2.4ghz security=ap_security \
    security.authentication-types=wpa2-psk,wpa3-psk ssid=Gummibaerenbande
add channel=ch_5 channel.band=5ghz-ax .skip-dfs-channels=all country=Germany \
    disabled=no mode=ap name=ap-5ghz security=ap_security \
    security.authentication-types=wpa2-psk,wpa3-psk ssid=Gummibaerenbande
/ip pool
add name=dhcp_pool0 ranges=192.168.10.2-192.168.10.254
add name=dhcp_pool3 ranges=192.168.1.2-192.168.1.254
add name=dhcp_pool5 ranges=192.168.4.2-192.168.4.254
/ip dhcp-server
add address-pool=dhcp_pool3 interface=ether2 name=dhcp1
add address-pool=dhcp_pool5 interface=ether4 lease-time=10m name=dhcp2
/interface wifiwave2 capsman
set ca-certificate=auto enabled=yes package-path="" require-peer-certificate=\  
    no upgrade-policy=none
/interface wifiwave2 provisioning
add action=create-dynamic-enabled comment="2.4 GHz" disabled=no \  
    master-configuration=ap-2.4ghz supported-bands=2ghz-ax
add action=create-dynamic-enabled comment="5 GHz" disabled=no \  
    master-configuration=ap-5ghz supported-bands=5ghz-n
/ip address
add address=192.168.1.1/24 interface=ether2 network=192.168.1.0
add address=192.168.4.1/24 interface=ether4 network=192.168.4.0
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=1.1.1.1,8.8.8.8 gateway=192.168.1.1
add address=192.168.4.0/24 gateway=192.168.4.1
/ip dns
set servers=1.1.1.1,8.8.8.8
/ip firewall nat
add action=masquerade chain=srcnat
/system clock
set time-zone-name=Europe/Berlin
/system note
set show-at-login=no
/system ntp client
set enabled=yes
/system ntp client servers
add address=de.pool.ntp.org
/tool graphing interface
add
Member: aqui
aqui Aug 16, 2023 at 10:08:15 (UTC)
Goto Top
dass bei mir cap-wifi1 das 2.4GHz konfigurierte ist und cap-wifi2 das 5GHz konfigurierte.
Das ist aber schon seit Jahrzehnten so das 1 immer 2,4 Ghz ist und 2 ist 5 Ghz. Wo ist denn da ein Problem? 🤔 Jedes Band hat eben sein WLAN Interface, das ist bei allen anderen Herstellern auf der Welt auch so.
Allerdings verbinde sich die Geräte...
Kann es sein das du vergessen hast das 5 Ghz Interface mit in die Bridge aufzunehmen?? Guckst du auch hier!

Sehenswert ist auch dieser YouTube Beitrag zu dem Thema um die üblichen Setup Fehler zu vermeiden!
https://m.youtube.com/watch?v=JRbAqie1_AM
Member: Evolutio
Evolutio Aug 16, 2023 updated at 13:30:45 (UTC)
Goto Top
dass bei mir cap-wifi1 das 2.4GHz konfigurierte ist und cap-wifi2 das 5GHz konfigurierte.
Das ist aber schon seit Jahrzehnten so das 1 immer 2,4 Ghz ist und 2 ist 5 Ghz. Wo ist denn da ein Problem? 🤔 Jedes Band hat eben sein WLAN Interface, das ist bei allen anderen Herstellern auf der Welt auch so.
Ich weiß, dass das bei jedem Hersteller so der Fall ist! Dann habe ich mich falsch ausgedrückt. :D
Die Konfiguration ist ja richtig, nur die Geräte die sich dahin verbinden sollen, verbinden sich nicht richtig.

Allerdings verbinde sich die Geräte...
Kann es sein das du vergessen hast das 5 Ghz Interface mit in die Bridge aufzunehmen?? Guckst du auch hier!

Sehenswert ist auch dieser YouTube Beitrag zu dem Thema um die üblichen Setup Fehler zu vermeiden!
https://m.youtube.com/watch?v=JRbAqie1_AM
Ich habe jetzt nochmal eine etwas andere Konfiguration gemacht, sodass cap-wifi1 die 5GHz Konfiguration lädt und cap-wifi2 dementsprechend die 2.4GHz. Jetzt verbinden sich die Geräte in das 5GHz Netzwerk. Nur vermute ich dann, dass sich die Geräte die nur 2.4GHz können nicht in das Netzwerk einwählen.

Ist wohl nur mein Handy, was meint sich auf 2.4 GHz verbinden zu müssen. Das MacBook Pro verbindet sich auf 5GHz und das SteamDeck auch. Kurios!

Danke für die beiden Links, das Video werde ich mir nachher mal anschauen!

EDIT:
Nachdem ich mir das jetzt einige Zeit mit einigen verbundenen Geräten angeschaut habe, Switchen die immer mal wieder zwischen 2.4GHz und 5GHz. So ganz verstanden habe ich immer noch nicht warum.

EDIT2:

Den ersten Link habe ich mir mal angeschaut, ich habe diverse Konfigurationsmöglichkeiten gar nicht mehr. Z.b. VLAN-MODE, kann nur die VLAN-ID finden. Auch hat man mit Wifiwave2 nicht mehr die Möglichkeit virtuelle AP's zu erstellen, wenn ich das richtig verstehe. Auch finde ich bei Tante Google nicht wirklich was. Auch hier https://help.mikrotik.com/docs/display/ROS/WifiWave2 ist nicht wirklich was zu finden.
Member: aqui
aqui Aug 17, 2023 at 12:58:09 (UTC)
Goto Top
Ich habe jetzt nochmal eine etwas andere Konfiguration gemacht
Eigentlich völlig unsinnig, denn WAS sollte der Sinn davon sein?
Du musst schlicht und einfache beide WLAN Interfaces nur an die Bridge binden. Nicht mehr und nicht weniger!
Wenn du mit VLANs arbeitest bindest du die beiden WLANs an das entsprechende (gleiche) VLAN.
Da o.a. Tutorial zeigt dir das doch ganz genau!
Ein Dual Radio Ap macht in der Regel immer ein sog. Band Steering. Nach einem Probe Request den der Client sendet verzögert der AP den Probe Reply des 2,4 Ghz Radios so das bei Dual Radio Clients immer bevorzugt ins störungsärmere und performantere 5 Ghz Band verbunden wird. Simple Standardlogik bei Dualradio WLANs. 😉
mit WiFi2 nicht mehr die Möglichkeit...
Sorry aber das ist Unsinn. Das würde ja bedeuten das man keinerlei MSSID Option mehr hat im Setup. Das ist ein Hauptfeature der APs und stimmt so nicht.
Das MT Tutorial zeigt dir ja im Kapitel WLAN wie es statisch gemacht wird und das Capsman Tutorial wie es grundlegend mit CapsMan rennt. Wichtig ist hier immer den Datapath auch local conection zu setzen das die WLAN AP Daten nicht zentral zum Controller getunnelt werden!
Member: Evolutio
Evolutio Aug 18, 2023 at 08:44:23 (UTC)
Goto Top
Eigentlich völlig unsinnig, denn WAS sollte der Sinn davon sein?
Der Sinn davon sollte gar keiner sein, war eher ein Versuch um zu schauen ob das was ändern könnte.
Hat es aber, Spoiler, nicht.

Sorry aber das ist Unsinn. Das würde ja bedeuten das man keinerlei MSSID Option mehr hat im Setup. Das ist ein Hauptfeature der APs und stimmt so nicht.
Da gebe ich dir recht im nachhinein. Es ist nur alles etwas anders mit der Wifiwave2 Konfiguration als in den von dir verlinkten Beiträgen und Videos die ich mir angeschaut habe. Aber wie in dem anderen Thread (Mikrotik Wifiwave2 - CAPsMan VLan Zuordnung) auch von mir geschrieben, habe ich das Problem dort lösen können.

Wichtig ist hier immer den Datapath auch local conection zu setzen das die WLAN AP Daten nicht zentral zum Controller getunnelt werden!
Könntest du dazu noch eine Erklärung liefern, warum man den Datapath auf "local Connection" setzen sollte, damit die Daten nicht zum Controller getunnelt werden?
Member: aqui
aqui Aug 18, 2023 updated at 09:15:41 (UTC)
Goto Top
Ohne local Forwarding würde sich der gesamte WLAN Traffic aller APs in den Tunnel zwängen müssen um dann am Controller zentral auf die Switch Infrastruktur ausgekoppelt zu werden.
Das so ein Konzept nicht besonders skalierbar ist versteht auch ein Laie. Man muss dann also über kurz oder lang mit massiven Performane Einschränkungen leben besonders wenn man mehr als 2 APs betreibt. Damit führt man modernere WLAN Verfahren wie .ac oder .ax ad absurdum weil man im Nachhinein wieder deren Bandbreite begrenzt.
Tunneling bedeutet zudem auch immer eine CPU basierte Paket Encapsulation und Decapsulation...auch nicht skalierbar in Bezug auf Performance.
Solche Tunnelkonzepte sind daher tiefstes WLAN Neandertal und eine local Termination Konfig ist deshalb immer Pflicht wenn man ein performantes WLAN mit modernen Verfahren sinnvoll skalierbar betreiben will.
Sagt einem aber eigentlich auch schon der gesunde IT Verstand... 😉
Member: Evolutio
Evolutio Aug 18, 2023 updated at 10:01:11 (UTC)
Goto Top
Das so ein Konzept nicht besonders skalierbar ist versteht auch ein Laie.
Sagt einem aber eigentlich auch schon der gesunde IT Verstand
Mit Deiner Erklärung, versteht das tatsächlich ein Laie. Es gibt da draußen bestimmt Leute die nicht täglich mit diesen Begriffen umgehen und sich dennoch in das Thema einlesen möchten und ggf. auf diesen Thread stoßen und sich genau diese Frage stellen, warum ich dich gebeten habe das zu erklären und dahingehend auch kein, sagen wir es in deinen Worten, "gesunden IT Verstand" haben und sich fragen, was Du damit meintest.

Aber dennoch danke für deine Erklärung.
Member: aqui
aqui Sep 11, 2023 at 10:11:59 (UTC)
Goto Top
Wenn es das denn nun war bitte deinen Thread hier dann auch als erledigt schliessen!