hajo2006
Goto Top

NAS Laufwerk nicht auslesbar

Moin,

ich habe da ein kleines Problem. Für meine NAS ASUSTOR 202 TE habe ich mir 2 neue HDD
gekauft. diese haben eine Kapazität von jeweils 8TB. Nun habe ich es geschafft das eine der
HDD die 3TB in Slot 1 und die andere nun mit einer 8TB bestückt ist.

Die NAS 2 3TB HDD waren jeweils als einzene HDD in der NAS eingebunden. Nun habe ich die
in Slot 2 befindliche 3TB HDD durch eine 8TB HDD ersetzt. was nach anfänglichen Problemen
auch geklappt hat. Allerdings kann ich die 3 TB HDD nicht mehr auslesen. Selbst wenn ich sie
wieder ins NAS einsetze komme ich nicht an die Daten ran.

Nun meine Frage an Euch, gibt es noch eine Möglichkeit an die Daten heranzukommen mit
normalen Boardmitteln oder heißt es die Daten sind weg. Bei den Daten handelt es sich um
Serien die ich aufgenommen habe aus dem TV.

Würde mich freuen wenn ihr mir vielleicht helfen könntet. Denn es war schon eine menge an
Arbeit die Folgen aufzunehmen und dann die Werbung abzuschneiden und neu zusammen zu
setzen.

Beste Grüße
Hajo

Content-Key: 33030749414

Url: https://administrator.de/contentid/33030749414

Printed on: February 27, 2024 at 23:02 o'clock

Member: michi1983
michi1983 Feb 13, 2024 at 09:34:51 (UTC)
Goto Top
Hallo,

da es sich nur um Serien handelt, stufe ich die Daten mal nicht als wichtig ein.
Ich würde ein Live Linux von einem USB Stick booten und dann die Platte über einen Adapter anstecken und schauen ob ich die Daten dann auslesen kann.

Gruß
Member: Hajo2006
Hajo2006 Feb 13, 2024 at 10:30:29 (UTC)
Goto Top
Hallo michi1983,

das mit dem Livesystem hatte ich schon getestet. Leider erkennt er nur eine kleine HDD und dann 2 weitere
Partitionen die nichts enthalten sollen.
Scheint also so das es wohl heißt alle Folgen neu aufnehmen.

Beste Grüße
Member: abramakabra
Solution abramakabra Feb 13, 2024 updated at 11:14:41 (UTC)
Goto Top
Das ist oft normal bei solchen NAS Platten, die werden meist entweder mit LVM oder mdadm eingerichtet.
Ein Scan mit mdadm --assemble --scan liest die md devices dann ein sofern alle nötigen Member auf der Disk vorhanden sind.

Die Ausgaben der Befehle
fdisk -l
lsblk
mdadm --detail --scan
pvs
vgs
lvs
sollte Klarheit verschaffen.

Sollten die Platten mit LUKS verschlüsselt worden sein, hilft cryptsetup weiter
cryptsetup luksOpen /dev/[whatever] mydevice
mit anschließender Eingabe des Passwortes und mounten erledigt danach ein
mkdir -p /mnt/mytarget
mount /dev/mapper/mydevice /mnt/mytarget
sofern das Device vorher erfolgreich geöffnet werden konnte.
Member: Lochkartenstanzer
Lochkartenstanzer Feb 13, 2024 at 10:59:09 (UTC)
Goto Top
Zitat von @Hajo2006:

Hallo michi1983,

das mit dem Livesystem hatte ich schon getestet. Leider erkennt er nur eine kleine HDD und dann 2 weitere
Partitionen die nichts enthalten sollen.
Scheint also so das es wohl heißt alle Folgen neu aufnehmen.

Beste Grüße

Sicher? Schon Mal genauer geschst, was da für Filesysteme drauf sind?

lks
Member: Hajo2006
Hajo2006 Feb 13, 2024 at 11:05:49 (UTC)
Goto Top
Hallo Lochkartenstanzer,

welches Filesystemdrauf ist kann ich Dir erst sagen wenn ich wieder zu Hause bin. Dann schaue ich dort
mal nach und schreib es hier.

Hi abramakabra,

danke für deinen Tip. Das werde ich wenn ich zu Hause bin mal testen.
Member: Lochkartenstanzer
Lochkartenstanzer Feb 13, 2024 at 11:09:53 (UTC)
Goto Top
Zitat von @Hajo2006:

Hallo Lochkartenstanzer,

welches Filesystemdrauf ist kann ich Dir erst sagen wenn ich wieder zu Hause bin. Dann schaue ich dort
mal nach und schreib es hier.

Hi abramakabra,

danke für deinen Tip. Das werde ich wenn ich zu Hause bin mal testen.

Moin,

Als erstes mal mit fdisk -l schauen, welche Partitionstypen da sind und wie groß die Partitionen sind. eventuell sind das raidmembers oder logival volumes, die nciht automatisch eingebunden werden.

lks
Member: Starmanager
Starmanager Feb 13, 2024 at 12:11:04 (UTC)
Goto Top
Hier gibt es auch Tools zum schauen ob noch was da ist.

http://runtime.org/
Member: Hajo2006
Hajo2006 Feb 14, 2024 at 17:55:22 (UTC)
Goto Top
Zitat von @abramakabra:

Das ist oft normal bei solchen NAS Platten, die werden meist entweder mit LVM oder mdadm eingerichtet.
Ein Scan mit mdadm --assemble --scan liest die md devices dann ein sofern alle nötigen Member auf der Disk vorhanden sind.

Die Ausgaben der Befehle
fdisk -l
lsblk
mdadm --scan --detail
pvs
vgs
lvs
sollte Klarheit verschaffen.

Sollten die Platten mit LUKS verschlüsselt worden sein, hilft cryptsetup weiter
cryptsetup luksOpen /dev/[whatever] mydevice
mit anschließender Eingabe des Passwortes und mounten erledigt danach ein
mkdir -p /mnt/mytarget
mount /dev/mapper/mydevice /mnt/mytarget
sofern das Device vorher erfolgreich geöffnet werden konnte.

Leider bekomme ich folge Anzeige wenn ich den Befehl:

sudo mdadm --scan --detail

nutze.

sdc 8:32 0 2,7T 0 disk
├─sdc1 8:33 0 255M 0 part
├─sdc2 8:34 0 2G 0 part
│ └─md0 9:0 0 2G 0 raid1
├─sdc3 8:35 0 2G 0 part
│ └─md126 9:126 0 2G 0 raid1
└─sdc4 8:36 0 2,7T 0 part
└─md2 9:2 0 2,7T 0 raid1
sr0 11:0 1 2K 0 rom
hajo@hajo-System-Product-Name:~$ sudo mdadm --scan --detail
mdadm: --scan does not set the mode, and so cannot be the first option.
Member: abramakabra
abramakabra Feb 14, 2024 updated at 18:13:35 (UTC)
Goto Top
Sorry war ein "Dreher"
sudo mdadm --detail --scan
Member: Hajo2006
Hajo2006 Feb 15, 2024 at 07:00:05 (UTC)
Goto Top
Moin abramakabra,

werde das nochmal heute wenn ich wieder zu Hause bin testen. Doch ich konnte gestern
auch schon Daten sehen und habe dann diese von den NAS HDD auf eine zusätzlich im
Linux befindliche HDD verschoben. Sah sehr danach aus das ich wieder zugriff auf meine
verloren geglaubten Daten bekommen habe.

Heute morgen hatte ich leider nicht die Zeit zu schauen ob alles auf der linux HDD ist. Doch
eins merke ich, das ich mit Linux eher an meine Daten komme als mit den Windows eigenen
Tool face-smile.
Member: Hajo2006
Hajo2006 Feb 16, 2024 at 06:55:30 (UTC)
Goto Top
Hat alles super geklappt, Daten sind wieder hergestellt.

Besten Dank an abramakabra
Member: abramakabra
abramakabra Feb 16, 2024 at 07:03:01 (UTC)
Goto Top
👌🍾