Nicht freigegebener Speicher wird nicht angezeigt (UEFI Problem?)

tim589
Goto Top
Hallo zusammen.

Ich habe folgendes Szenario:
Für eine schnelle Installation von PCs habe ich in einer VM Windows 10 (UEFI Installation) vorbereitet mit einer 50GB Platte. Nach allen Updates und Änderungen und Sysprep mache ich ein Clonezilla Image.

Nachdem ich das Image auf den PC gespielt habe will ich den Speicher erweitern, da ja normal jeder PC mehr als 50GB Speicher hat. Vor UEFI wurde im Windows der nicht zugewiesene Speicher angezeigt und man konnte mit diskpart zb. ganz einfach die Festplatte auf die volle Größe erweitern.

Seit dem UEFI Image geht das nicht mehr. Der nicht zugewiesene Speicher wird im Windows nicht angezeigt. Sowohl mit Secureboot, als auch ohne Secureboot. Ich habe auch nochmal ein aktuelles ISO von Microsoft heruntergeladen, da ich dachte, dass hier evtl. ein Problem war, aber ohne Erfolg.

Aktuell gibt es nur die Möglichkeit mit gparted den Speicher zu erweitern.

Warum ist das so? Hat hierzu jmd eine Idee?

Vielen Dank für eure Hilfe.

LG Timo

Content-Key: 397363

Url: https://administrator.de/contentid/397363

Ausgedruckt am: 01.07.2022 um 12:07 Uhr

Mitglied: Bem0815
Bem0815 07.01.2019 um 08:36:18 Uhr
Goto Top
Moin,

wird der freie Speicherplatz nur unter Diskpart nicht angezeigt oder auch in der Windows Datenträgerverwaltung?
Gibt es physikalisch hinter der C: Partition noch z.B. eine OEM Partition oder ähnliches die eine Vergrößerung verhindert?
Mitglied: TIM589
TIM589 07.01.2019 um 12:04:05 Uhr
Goto Top
Vielen Dank für deine Antwort.

Leider habe ich das alles schon geprüft. Unter Diskpart wird die Festplatte auch nur mit den 50GB angezeigt unter der Windows Datenträgerverwaltung genauso. Da gibt es nur die System-reservierte Partition und C:

Also ich muss wirklich mit gparted booten, erst dort habe ich eine Möglichkeit die Platte zu erweitern, weil ich bisher unter Windows nichts gefunden habe, dass der nicht zugewiesene Speicherplatz überhaupt angezeigt wird.
Mitglied: TIM589
TIM589 07.01.2019 um 16:24:10 Uhr
Goto Top
Ich habe einwas gefunden, wo zumindest die Volumengröße per Abfrage richtig angezeigt wird. Allerdings funktioniert hier leider der extend Befehl noch nicht.

Evtl. Kennt sich hier jemand aus:


Hier noch der Check, dass wirklich SizeMax > SizeMin wäre und der erste Befehl erfolgreich war:
Mitglied: 137846
137846 07.01.2019 aktualisiert um 16:56:20 Uhr
Goto Top
Nach allen Updates und Änderungen und Sysprep mache ich ein Clonezilla Image.
Dann hast du das Image entweder mit den falschen Optionen zurück gespielt.
https://clonezilla.org/clonezilla-live/doc/11_lite_server/advanced/09-ad ...
Ich kann hier ohne Probleme auch eine Disk im GPT-Format und UEFI-Mode nach Restore eines Images resizen.

Gruß A.

oder .... s. folgenden Kommentar
Mitglied: 137846
137846 07.01.2019 aktualisiert um 16:57:44 Uhr
Goto Top
Zu beachten ist auch das wenn du die Bootfiles auf die selbe Partition wie Windows selbst spielst und davon bootest kannst du diese Partition im laufenden Betrieb nicht erweitern, weil Windows das aus Sicherheitsgründen verhindert!
S. http://www.tomshardware.co.uk/answers/id-1767935/full-hdd-capacity-clon ...

Also dein Partition-Layout posten!
Mitglied: TIM589
TIM589 08.01.2019 aktualisiert um 07:31:50 Uhr
Goto Top
Vielen Dank dir. Also an einer Clonezillaoption glaube ich kaum dass es liegt. Hier nehme ich einfach nur den Basic Mode (also keinen expert) und dann hat man ja eh keine Einstellungsmöglichkeiten.
Aktivierst du noch exptert Optionen?

Und die Installation ist ganz normal von einem Windows ISO erzeugt, also hier wurde keine Hand angelegt, somit sollte das eigentlich passen.
Partitionslayout ist wie folgt:

partitionslayout

Wobei ich bei deinem Link nur herauslese, dass Clonezilla den blauen Bereich kopiert und Akronis noch einen resize macht. Allerdings in dem Fall aus dem Link ist der Schwarze Bereich ja dann in der Datenträgerverwaltung sichtbar, was bei mir nicht der Fall ist. Das ist auch erst seitdem ich ein UEFI Image erstellt habe. Davor konnte man ganz einfach in der Datenträgerverwaltung oder mit diskpart erweitern, aber da wird ja nichts angezeigt. Das einzige wo was angezeigt wird, dass noch nicht zugewiesener Speicher da ist, ist Powershell.
Mitglied: 137846
137846 08.01.2019 aktualisiert um 08:20:06 Uhr
Goto Top
sollte das eigentlich passen. Partitionslayout ist wie folgt:
Das Layout ist nicht Standard! Außerdem fehlt da die im Standard vorhandene MSR
Also an einer Clonezillaoption glaube ich kaum dass es liegt.
Wenn das Part. Layout stimmen würde dann schon, denn sonst würde es ja gehen, hier getestet.
Mitglied: TIM589
TIM589 08.01.2019 um 08:35:07 Uhr
Goto Top
Wie sollte das Layout aussehen? Ich habe nämlich die aktuelle ISO von Win10 heruntergeladen und unter virtualbox installiert mit den EFI Optionen in der VM. Mit diesem Layout wurde das System installiert^^
Mitglied: 137846
137846 08.01.2019 aktualisiert um 09:28:54 Uhr
Goto Top
https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/co ...

Den Link von mir weiter oben hast du überhaupt gelesen ?? Partitionen direkt in Clonezilla angepasst hätte schon gereicht... Ansonsten Partition um 100MB schrinken und dann extenden. Das nächste mal einfach supportete Clone-Methoden benutzen, Bordmittel hätten btw. auch gereicht..
Mitglied: TIM589
TIM589 08.01.2019 um 09:43:41 Uhr
Goto Top
Aah sorry. Das hilft weiter, ich probiere da mal rum.

Wobei ja die Standardpartitionierung von Microsoft ganz schön unvorteilhaft ist oder...
System-MSR-Windows-Recovery

Mit dem Recovery hinter Windows kann man die C Partition ja gar nicht erweitern, die muss ja ganz rechts sein, dass das überhaupt ohne weiteres geht.

Also ich probier das mal und melde mich wieder. Vielen Dank dir!
Mitglied: TIM589
TIM589 08.01.2019 um 10:01:08 Uhr
Goto Top
Das lustige ist ja. Ich habe eben nochmal mim Media Creation Tool die aktuelle Iso herunter geladen und diesmal im Vmware Workstation Pro (Version 15) installiert. Einfach um zu sehen, ob die Partitionierung anders ist.

Aber hier habe ich exakt die gleiche Partitionierung wie oben im Bild :D
Mitglied: 137846
Lösung 137846 08.01.2019 aktualisiert um 12:12:30 Uhr
Goto Top
Also habe das hier mal nachgestellt (Clonezilla base UEFI Media). Es liegt an Clonezilla, wie schon vermutet. Wenn du das Dateisystem nicht schon in Clonezilla hast erweitern lassen kommt es zu diesem Verhalten.
Was unter Windows hilft das du es trotzdem erweitern kannst ist die Partition in Diskpart um einen kleinen Teil zu shrinken und es dann zu erweitern:
Du machst also in Diskpart folgendes:
Fertig.

Hier erfolgreich getestet:

screenshot

screenshot

screenshot
Mitglied: TIM589
TIM589 08.01.2019 um 13:49:53 Uhr
Goto Top
Bester Mann :) face-smile Habe es eben auch getestet. Die Vorgehensweise funktioniert wunderbar!

Vielen vielen vielen Dank dir :) face-smile
Mitglied: Bem0815
Bem0815 08.01.2019 um 15:11:45 Uhr
Goto Top
Wenn Clonezilla die Probleme verursacht und du nicht jedes mal diesen Workaround nehmen möchtest könntest du auch ein paar Euro in eine Acronis True Image Lizenz stecken. Die kostet ja auch nicht die Welt.

Ich hab das immer damit gemacht statt mit Clonezilla. Da gibt es das Problem nicht.

Mit dem Programm dann einfach einen Bootstick erstellen und diesen booten.
Damit dann den PC mit deinem Master Image extern sichern und auf dein Zielsystem als Backup Wiederherstellen.

Hab das auch mal mit PXE gemacht und dann ein Image in relativ kurzer Zeit auf 30 Rechner geschoben.
Hat vielleicht insgesamt etwa nur 1 - 1,5 Stunden gedauert. Am meisten Zeit hat mich dabei das Kabel umstecken gekostet.
Hatte alle 30 Rechner am LAN, hab dann auf dem ersten das Backup gestartet und Maus, Tastatur und Monitor auf den zweiten umgesteckt, wieder gestartet usw.
Mitglied: TIM589
TIM589 09.01.2019 um 10:46:27 Uhr
Goto Top
Jap Akronis macht selbst ein Resize :) face-smile Damit gehts ganz sicher.

In dem Image ist eh eine Installationsroutine per Skript eingebunden und Clonezilla wollten wir beibehalten. Aber trotzdem Danke.