Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Probleme mit Windows 2003 Server (Media Server und FTP)

Mitglied: 9218
Hallo,

ich muss mich gerade mit meinem ersten Windows 2003 Webserver vertraut
machen. Momentan leider noch absolut Newbiemäßig. Debian ist mein eigentliches
Feld. Unser Unternehmen benötigt jedoch einen Streamserver für .wmv Dateien. Daher
diese Entscheidung.


Meine Probleme: Ich habe nun erstmal nach und nach alle Dienste installiert. U.a.
den Media Server, IIS 6.0, etc. Auch eine Domain habe ich schon eingerichtet.
Neues Verzeichnis unter C:\Inetpub\wwwroot\ erstellt, dann mit IIS die Domain
angelegt.

Jetzt sehe ich jedoch nichts von einer FTP-Möglichkeit? FTP Zugang ist nämlich zwingend
notwendig für den Upload der Video-Inhalte. Und da suche ich jetzt nach einer Möglichkeit
einen FTP-Zugang für das Web anzulegen. Welche Möglichkeiten / Anleitungen gibt es dazu?

Das nächste Problem ist der Media Server. Wir wollen die Inhalte alle direkt unter der Domain
ablegen. Also in diesem Fall unter C:\Inetpub\wwwroot\domain.de\wmv_files
Jetzt gibt es ja die Sache mit den Publishingpoints. Da ist schon einer eingetragen mit:
<standard> on-demand. Das sollte ja auch so richtig sein, ist ja on-demand. Jedoch
war das Verzeichnis auf C:\WMPub\wmroot gestellt. Das habe ich geändert auf das
o.g. Verzeichnis in denen die Files liegen sollen.

Welche Einstellungen sind da noch nötig? Ich habe dann eine Playlist erstellt (.wsx)
und einen Testfile eingegeben. Diese wsx-Datei habe ich stream.wsx genannt und unter
C:\Inetpub\wwwroot\domain.de abgelegt.

Rufe ich nun: http://www.domain.de/stream.wsx auf, bietet mir der Browser die wsx-Datei
zum Download an. In dieser ist ja der gesamte Pfad zum File, etc. verzeichnet, das kann ja
so also nicht korrekt sein? Rufe ich mms://www.domain.de/stream.wsx wird der File gestreamt,
dass funktioniert.

Was gibt es im Bezug auf den Media Server noch zu beachten? Eventuell hilfreiche deutsche
Tutorials, etc.? Ich würde mich sehr über Antworten freuen.

Content-Key: 6475

Url: https://administrator.de/contentid/6475

Ausgedruckt am: 27.09.2021 um 15:09 Uhr

Mitglied: moenni
moenni 03.02.2005 um 20:25:16 Uhr
Goto Top
Zum FTP Problem:
Der IIs installiert ftp nicht von Haus aus mit, sondern dieser Dienst muss extra nachinstalliert werden.
Mitglied: 9218
9218 03.02.2005 um 20:51:27 Uhr
Goto Top
Wenn ich mal finden würde WO ich das nachinstallieren kann...
Ich habe mir schon einen Wolf gesucht und nichts gefunden. Im
IIS ist es nicht drin, das steht fest.

Wenn ich Dienste hinzufügen möchte, steht da auch nichts von FTP.
Wo ist das also zu finden?
Mitglied: moenni
moenni 04.02.2005 um 09:53:03 Uhr
Goto Top
Systemsteuerung - Software - Windowskomponenten - IIS.... - FTP...
Mitglied: 9218
9218 04.02.2005 um 16:14:56 Uhr
Goto Top
Danke, habe ich jetzt gefunden und ist auch installiert, jedoch hapert es noch
an der Konfiguration, ich bekomme einfach keinen Connect per Ws_ftp. Folgendes
habe ich gemacht, bzw. möchte ich machen:

- Neue ftp Seite
- Verzeichnis C:\Inetpub\wwwroot\domain.de soll per ftp erreichbar sein
- Hier wurde nun ein User IUSR_SERVERNAME und ein Passwort angelegt

Jetzt versuche ich einen Connect auf die IP mit dem Usernamen und dem Passwort.
Ws_ftp gibt jedoch nur: 530 User IUSER_SERVERNAME cannot log in.
!Login failure, so quitting.

Gibt es eventuell ein Tutorial zum einrichten des FTP-Zugangs?
Mitglied: moenni
moenni 04.02.2005 um 18:56:07 Uhr
Goto Top
Ich habe bei mir die Einstellung "anonyme Verbindung zulassen" nicht aktiviert. Stattdessen habe für den FTP Zugang spezielle Benutzer angelegt, und die dann in den FTP-Ordnern unter Sicherheit Zugriffsrechte erteilt.
Diese Ordner sind von der Vererbung ausgeschlossen.
Für alle vorhergehenden Ordner hat "jeder" Leserechte. Diese sind aber über FTP nicht erreichbar.

Im IExplorer passives FTP abwählen und Ordneransicht für FTP anwählen.
Den FTP kannst Du im LAN unter ftp://<ServerName> erreichen.

Jezt sollte ein Anmeldebildschirm erscheinen.

Vom Inernet aus gehts genauso. Anstatt <Server Name> IP oder Domänennamen eingeben.
Heiß diskutierte Beiträge
info
Bundeswehr lässt Retro Funkgeräte für 600 Millionen Euro produzierenhacktorVor 1 TagInformationHardware11 Kommentare

Dachte zuerst das ist ein verspäteter Aprilscherz Die saufen da offensichtlich zu viel Club-Cola au banan. ...

question
Neue Verschlüsselung TLS 1.3eberhartIIVor 1 TagFrageDrucker und Scanner16 Kommentare

Hallo, es geht um eine Verschlüsselung, die die Telekom seit 02. September 2021 einsetzt. Ab diesem Datum müssen die E-Mails mit dem Schlüssel TLS 1.3 ...

question
Hyper-V 2016 shutdown VM bei niedrigem Akkustand der USV gelöst keine-ahnungVor 1 TagFrageWindows Server3 Kommentare

Moin at all, mir hat es heute meine 15 Jahre alte APC Smart-UPS zerschossen - steht ihr zu, wie ich meine. Habe so ein Ding ...

question
In der Suche nach einem IPsec Lan-to-Lan Travel RouterJohanspbVor 1 TagFrageRouter & Routing4 Kommentare

Hallo zusammen, zuhause habe ich einen FritzBox 7590, auf welchem ich VPN-Server eingerichtet habe. Die Aufgabe ist folgendes: Ich reise gern und übernachte oft in ...

question
Partition reparieren, oder löschen ?Hermann73Vor 21 StundenFrageWindows 107 Kommentare

Vielleicht ist das für manche eine dumme Frage. Kann man eine defekte Partition löschen? Ich habe das Problem, dass ich auf die Partition "E" durch ...

question
Keine Internet mit IPv6 in den VLANs (FritzBox auf SG350)derBenVor 1 TagFrageRouter & Routing5 Kommentare

Hallo zusammen, ich brauch bitte eure Hilfe im Bezug auf VLAN und IPv6. Problem: Keine Internetverbindung mit IPv6 in den VLAN´s Netzwerkaufbau: Internet (VodafoneCable + ...

general
Frage an die IT-Administratoren in UnternehmenFuchor2020Vor 1 StundeAllgemeinOff Topic7 Kommentare

Hallo Leute, freue mich hier im Forum dabei sein zu dürfen. Da ich noch relativ neu in der IT Branche bin, befasse ich mich aktuell ...

question
Hyper-V Reset - Löschen aller alten und defekten VMs gelöst menkusaVor 18 StundenFrageHyper-V3 Kommentare

Hallo Leute, nachdem ich ein bestehendes RAID50 leider nicht mehr erweitern konnte, habe ich dieses gelöscht und ein neues RAID5 erstellt was leichter mit Zusatzplatten ...