jmzbeki
Goto Top

Proxmox bridge vmbr0 funktioniert nicht

Hallo,


ich möchte eigtl. mehrere VM´s mit interner ip anlegen und durch portforward von der server ip von aussen zugriff drauf haben.
Habe eine zweite bridge vmbr2 eingerichtet so wie hier > https://raymii.org/s/tutorials/Proxmox_VE_One_Public_IP.html beschrieben, aber nix funktioniert.
Wenn ich eine vm mit venet erstelle und eine meiner ips angebe dann läuft alles reibungslos. ich habe aber nur zwei ip und brauche aber 8 VM´s.

Was übersehe ich evtl.?

network interface settings
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet manual

auto eth1
iface eth1 inet manual

auto vmbr0
iface vmbr0 inet static
address xxx.xxx.xxx.80
netmask 255.255.255.0
gateway xxx.xxx.xxx.1
broadcast xxx.xxx.xxx.255
bridge_ports eth0
bridge_stp off
bridge_fd 0
network xxx.xxx.xxx.0
pointopoint xxx.xxx.xxx.1

auto vmbr2
iface vmbr2 inet static
address 10.21.21.254
netmask 255.255.255.0
bridge_ports eth1
bridge_stp off
bridge_fd 0
post-up echo 1 > /proc/sys/net/ipv4/ip_forward
post-up iptables -t nat -A POSTROUTING -s '10.21.21.0/24' -o vmbr0 -j MASQUERADE
post-down iptables -t nat -D POSTROUTING -s '10.21.21.0/24' -o vmbr0 -j MASQUERADE
post-up iptables -t nat -A PREROUTING -i vmbr0 -p tcp --dport 2222 -j DNAT --to 10.21.21.5:22
post-down iptables -t nat -D PREROUTING -i vmbr0 -p tcp --dport 2222 -j DNAT --to 10.21.21.5:22

Content-Key: 273939

Url: https://administrator.de/contentid/273939

Printed on: April 22, 2024 at 06:04 o'clock