Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

RPC-Dienst funktioniert vermutlich nicht

Mitglied: Nicolaas

Nicolaas (Level 1) - Jetzt verbinden

04.07.2017 um 14:20 Uhr, 1714 Aufrufe, 21 Kommentare, 1 Danke

Hallo zusammen,

ich betreibe Privat ein Netzwerk mit einem DC + Hyper-V für WSUS (S1) und einem Hyper-V-Host (S2).
Seid Sonntag funktioniert mein BackUp mit Veeam (Veeam Backup & Replication) nicht mehr.
Heute wollte ich mal überprüfen was das Problem ist

Dabei ist mir aufgefallen, das in der Hyper-V Console nicht mehr auf den jeweils anderen Server zugreifen kann.
Auch im Server Manager (S1) können alle Server nicht mehr aktualisiert werden.

Könnt Ihr mir kurz einige Tipps geben. Wo der Fehler sein könnte.

Gruß,
Nicolaas
Mitglied: SlainteMhath
04.07.2017 um 14:25 Uhr
Moin,

Fehlermeldung im Veeam? Was steht am Host/in der VM im Eventlog? Notfalls die ganze Anlage mal durchbooten.

lg,
Slainte
Bitte warten ..
Mitglied: Nicolaas
04.07.2017 um 14:33 Uhr
Hallo Slainte,

Veeam:
Failed to call RPC function 'StartAgent': Ein Socketvorgang konnte nicht ausgeführt werden, da dem System Pufferspeicher fehlte oder eine Warteschlange voll war. Cannot connect to socket.

Eventlog:
DCOM konnte mit keinem der konfigurierten Protokolle mit dem Computer "S1.ad.burleigh.de" kommunizieren; angefordert von PID d18 (C:\Windows\system32\mmc.exe).

Leider sagt mir dern Fehler aus dem Eventlog nichts

LG Nicolaas
Bitte warten ..
Mitglied: 114685
04.07.2017 um 14:42 Uhr
Hi,

normalerweise hat jeder Eintrag auch Informationen zur Event-ID (EreignisID). Wenn man im unteren Feld auf Details > XML-Ansicht geht, bekommst du sehr viel Informationen, von denen du einiges mehr erfährst.

Die kann man sogar in die Zwischenablage packen.

Gruß
Bitte warten ..
Mitglied: Nicolaas
04.07.2017 um 14:46 Uhr
Hi,

meinst du etwa das hier:

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event;>"
- <System>
<Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
<EventID Qualifiers="0">10028</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8080000000000000</Keywords>
<TimeCreated SystemTime="2017-07-04T12:21:38.826168300Z" />
<EventRecordID>198405</EventRecordID>
<Correlation />
<Execution ProcessID="932" ThreadID="72688" />
<Channel>System</Channel>
<Computer>S2.ad.domain.de</Computer>
<Security UserID="S-1-5-21-4267654618-2133829342-1311147331-500" />
</System>
- <EventData>
<Data Name="param1">S1.ad.domain.de</Data>
<Data Name="param2">d18</Data>
<Data Name="param3">C:\Windows\system32\mmc.exe</Data>

Gruß
Nicolaas
Bitte warten ..
Mitglied: 114685
04.07.2017, aktualisiert um 14:56 Uhr
meinst du etwa das hier

Genau das.

Und dann suchst du über eventid.net nach dem Source DCOM und der EventID 10028, was dir dort als mögliche Ursache angeboten wird.

Gruß
Bitte warten ..
Mitglied: Pjordorf
04.07.2017 um 14:58 Uhr
Hallo,

Zitat von Nicolaas:
ich betreibe Privat ein Netzwerk mit einem DC + Hyper-V für WSUS (S1) und einem Hyper-V-Host (S2).
Hmmm, was ist denn wie aufgebaut? Einen DC mit Hyper-V und dort als VM einen Server 20XX fpr WSUS (S1) und dann noch einen Hyper-V auf ein anderes Blech - dein Hyper-V Host (S2) ?!? Oder ists alles nur ein Blech mit nur des hyper-V und alles andere sind VMs mit deinen DC, WSUS, und Host?
Was hat dein Blech an CPUs, RAM, Platten, RAID Kontroller, LAN Karten usw?
Was haben deine VMs zugewiesen an CPUs, RAM usw.

Was sagen deine Logs und welche Event IDs?

Gruß,
Peter
Bitte warten ..
Mitglied: Nicolaas
04.07.2017 um 15:17 Uhr
HAllo Peter,

der Server Nr. 1 ist ein DC (Win2012 R2) + DNS, DHCP, WDS, Veeam und Hyper-V
Auf dem Hyper-V läuft nur eine VM (Win2012 R2 WSUS)

Server 2 ist ein HP ProLiant DL380 Gen7 der nur Hyper-V-Host ist. (auch W2012 R2)
Auf dem Laufen mehrere VMs mit z.B. Exchange, RDG, etc. und einem weiteren DC

Ich stelle mir gerade die Frage auf welchem Server der Fehler im EventLog stehen müsste.

Ich denke der Fehler müsste im DC1(S1) stehen, weil ich dort alle anderen Server auch nicht erreichbar sind.
Ist meine vermutung richtig?

Eimal durch Booten möchte ich den Hyper-V-Host (S2) nicht, weil dort auch die Sophos läuft.

Falls der Server nicht mehr richtig booten würde komme ich nicht mehr per remote drauf.

Gruß Nicolaas
Bitte warten ..
Mitglied: Paccolino
04.07.2017 um 20:17 Uhr
Hi Nicolaas,

ich hab genau das gleiche Problem und dreh mich seit ein paar Wochen damit im Kreis.

Struktur:

1 HyperV Host, auch VEEAM (Windows 2016 Std Server)
4 virtuelle Server im HyperV (DC/EXCHSRV/E-Mail Archive/TS)

Auf dem HyperV Host, läuft außer dem Backup nichts unternehmenskritisches.

Was ich bisher rausgefunden hab:

Wenn ich den HyperV Host neu starte, läuft alles ohne Probleme, .. nach ca. 20-36h ist dann wieder Ende.
- Ich komme über den Browser nicht mehr auf alle Seiten
- VEEAM knn keine Backups mehr durchführen, weil die Konsole den Server nicht findet
- im HyperV Manager kann ich die nicht mehr auf die Konsolenansicht der virtuellen Gastsysteme
- selbst interne Appliance auf die ich via Browser HTTP zugreifen möchte geht nichts mehr..!

Die Fehlermeldung springt mir bei verschiedenen Systemen immer wieder entgegen:
"ein Socketvorgang konnte nicht ausgeführt werden, da dem System Pufferspeicher fehlte oder eine Warteschlange voll ..."
Fehler bei der Anforderung zum Zuordnen einer kurzlebigen Portnummer aus dem globalen TCP-Portanschluss, da alle diese Ports derzeit verwendet werden.


Ich habe durch Dr. Google schon von Anfang an folgenden Workarround gefunden:
Link SupportForum Microsoft

Diesen Weg aber noch nicht ausprobiert, bisher alles Netzwerkseitige überprüft und aktualisiert, d.h. Treiber, Virtual Switch aufgelöst, neu erstellt usw.. und immer wieder nach 1 bis 1/2 Tagen geht nix mehr....

Ich wurschtel nicht gerne einfach so in der Registrierung rum, die HighPorts könnten schon Auslöser des Problems sein, was zumindest diese seltsame Tatsache erklärt dass einige Zugriffe absolut nicht gehen, andere schon. . .. (egal ob intern oder extern)

Was mich jetzt ein bissl irritiert ist, dass Du auch VEEAM einsetzt - denn mir wäre es lieber die Ursache zu finden, als irgend eine Lösung bei der ich nicht genau abschätzen kann was das in Zukunft genau bedeutet.

Neustarten hat also bisher eher eine "heilende Wirkung" allerdings hält dies nicht lange an.

besten Gruß - chriz
Bitte warten ..
Mitglied: 114685
04.07.2017, aktualisiert um 22:21 Uhr
Hi,

versuch mal, ob du mit TCPView von Microsoft-Sysinternals rausbekommen kannst, welches Programm oder welcher Dienst die TCP/UDP-Port belegt, evtl. kannst du damit einige schließen bzw. Sockets freigeben. Das kannst du online holen und auch starten: https://live.sysinternals.com/tcpview.exe

Gruß

Edit: Der Tipp gilt natürlich auch für den TO @Nicolaas
Bitte warten ..
Mitglied: Paccolino
04.07.2017 um 22:19 Uhr
Hey huganotter,

bombe, danke für den Tipp!
Werde ich checken sobald der Fehler wieder auftritt, im Moment sehe ich natürlich viele Anwendungen und Dienste - noch funktioniert aber alles bestens.. (Weil ich heute Abend das System neu gestartet hab...

gruß chriz
Bitte warten ..
Mitglied: Nicolaas
05.07.2017 um 08:43 Uhr
Hi,

Vielen Dank schon mal für den Tipp :D

auf welchem Server sollte ich dann das Prüfen? Auf beiden?
Ich bekomme leider die EXE gerade nicht auf den Hyper-V-Host (S2), weil dieser nicht mal mehr eine Verbindung mit dem InternetExplorer aufbauen möchte.

Netzwerkfreigabe will er auch nicht mehr

Also vermutlich neustarten Exe kopieren und warten bis der Fehler wieder da ist. Richtig?

Gruß
Nicolaas
Bitte warten ..
Mitglied: geocast
05.07.2017 um 09:36 Uhr
Habt ihr zufällig iSCSI Ziele bei euch? Bzw welche die nicht mehr vorhanden sind, aber der Client versucht sich immer noch damit zu verbinden? Ist zurzeit ein Fehler von einem Update, habe mich auch Totgesucht und endlich darauf gestoßen.
Bitte warten ..
Mitglied: Paccolino
05.07.2017 um 09:47 Uhr
Auf diesem Server nicht - nur ein eingebundenes Netzwerklaufwerk der E-Mail Archivierungslösung (MSFT Virtual Disk)
Allerdings ist der von Dir angesprochene Fehler interessant, hast Du da nähere Infos? (hab mehrere Server mit ISCSI Anbindung laufen)

lg
Bitte warten ..
Mitglied: geocast
05.07.2017 um 10:02 Uhr
Hier ein Link dazu iSCSI Fehler

Ich war davon betroffen. Trifft eben zu, wenn die iSCSI Ziele die ganze Zeit auf Reconnect stehen. Konnte mich nach einer Weile nicht mehr per RDP Anmelden etc.
Bitte warten ..
Mitglied: 114685
05.07.2017 um 10:38 Uhr
Hi,

Zitat von Nicolaas:
auf welchem Server sollte ich dann das Prüfen? Auf beiden?

Ich würde mal mit dem anfangen, von dem du die XML aus dem Eventlog kopiert hast,

Gruß
Bitte warten ..
Mitglied: Paccolino
05.07.2017 um 11:08 Uhr
Ich denke auch dass NUR der Host das Problem hat. . . .
DC auf Host ist halt auch eher suboptimal - der wirkliche Vorteil einer Virtualisierung geht dabei irgendwie flöten
Bitte warten ..
Mitglied: Nicolaas
05.07.2017 um 14:01 Uhr
Nach einem Server neustart funktioniert der der Hyper-V-Host (S2) wieder.
mal sehen

Ich habe das letzte Update in verdacht, weil 2 Tage nach dem Updates die Probleme gekommen sind.
Bitte warten ..
Mitglied: Paccolino
06.07.2017 um 08:30 Uhr
Schönen guten Morgen,

nun ist es wieder soweit, der Server steckt wieder in diesem Problem fest, mit TCPView kann ich die Verbindungen sehen,
vom Status her sind sie aber meiner Meinung nach alle "ok"

Entweder LISTENING, ETABLISHED oder ab und an mal SYN_SEND

Mir fällt ansonsten nichts auffälliges auf, außer dass es 119 Endpoints sind mit der Option "Show unconnected Endpoints" - nehme ich hier den Haken weg sind es nur noch 15.

Kann es sein, dass die Ports nach und nach nicht mehr freigegeben werden?

Bin hier wirklich ratlos. . .

viele Grüße, c
Bitte warten ..
Mitglied: 114685
06.07.2017, aktualisiert um 12:10 Uhr
Hi,
Zitat von Paccolino:
Mir fällt ansonsten nichts auffälliges auf, außer dass es 119 Endpoints sind mit der Option "Show unconnected Endpoints" - nehme ich hier den Haken weg sind es nur noch 15.

119 sollten problemlos verkraftbar sein, ich hatte auf meinem Desktop-System schon über 250 zusammen mit den unconneted

Kann es sein, dass die Ports nach und nach nicht mehr freigegeben werden?

Kann sein, das kann ich aber nicht beurteilen, da ich nur ein Desktopsystem bediene. Normalerweise verschwinden die aber wieder, wenn der in der Registry konfigurierte Timeout abgelaufen ist. Ich hätte da einen Link zu den Einstellungen zur Hand, du könntest ja mal vergleichen:
https://msdn.microsoft.com/en-us/library/ms884977.aspx
Sorry, hatte den falschen Link erwischt, hier der richtige:
https://msdn.microsoft.com/en-us/library/dn167252.aspx

Bei den LISTENING Connections sind aber hier nur SYSTEM oder Systemdienste, die angezeigt werden, das dürfte normal sein. Achte mal auf die Local- und Remote-Address, die sollte 0 bzw localhost sein, und die verwendeten Ports sollten auch der Standardverwendung entsprechen.

Hier noch was zu den Sockets und dem dafür benötigten Speicher,
dort liegt ja wohl der Fehler lt. Fehlermeldung:
https://stackoverflow.com/questions/22025623/how-many-tcp-sockets-can-i- ...

Vielleicht findet noch hat noch jemand einen Lösungsvorschlag zur Hand, ich muss hier passen.

Gruß
Bitte warten ..
Mitglied: Paccolino
06.07.2017, aktualisiert um 18:47 Uhr
Ich glaube Du hast recht @geocast..! Zumindest war auf dem Server was, was eigentlich nicht sein durfte - ein Fragment von einer ISCSI Anbindung!, bin gespannt - nur noch zwei mal schlafen - wenn es dann noch läuft hast damit voll ins schwarze getroffen!

lg
Bitte warten ..
Mitglied: Paccolino
10.07.2017 um 23:05 Uhr
Yep, das wars..! Besten Dank @geocast für den Tipp - mein Problem hat sich damit gelöst...
Bitte warten ..
Ähnliche Inhalte
Windows Server
RPC Server ändern
Frage von DerNeueITlerWindows Server2 Kommentare

Hallo Community, ich habe folgende Problem. mir ist am Wochenende ein Server gestorben was ansich nicht weiter schlimm ist, ...

Windows Server

Problem mit Software auf Server, vermutlich Datenausführungsverhinderung

Frage von KabelkeberWindows Server8 Kommentare

Hallo! Folgendes Problem: Software für einen Werkstatt-Testerlt. Hersteller kompatibel für alle (!) Windows-OS ab Windows 7. Was macht diese ...

Windows 10

Windows 10 und Spionage (vermutlich blöde Frage)

gelöst Frage von stervaWindows 1010 Kommentare

Hallo zusammen, besteht bei Windows 10 Home an sich die Gefahr, dass mir der Inhalt meiner Platte bzw. einzelne ...

Windows 10

WakeOnLAN Ruhezustand RPC-Server

Frage von LeonPro12Windows 106 Kommentare

Hallo, Ich möchte gerne meinen Win10 Pro NAS Server per WakeOnLAN in den Ruhezustand versetzen können. Nur dabei kommt ...

Neue Wissensbeiträge
Windows Update
Sicherheitsupdate für SQL Server 2014 SP3
Information von sabines vor 5 StundenWindows Update

Für den SQL Server 2014 existiert ein Sicherheitsupdate. Laut KB Artikel wird es als CU3 angezeigt: Server 2014 SP3 ...

Backup

Veeam Agent für MS Windows - neue Version verfügbar (bedingt jedoch offenbar .NET Framework 4.6)

Information von VGem-e vor 1 TagBackup

Moin Kollegen, einer unserer Server zeigte grad an, dass für o.g. Software ein Update verfügbar ist. Ob ein evtl. ...

Python

Sie meinen es ja nur gut - Microsoft hilft python-Entwicklern auf unnachahmliche Weise

Information von DerWoWusste vor 2 TagenPython2 Kommentare

Stellt Euch vor, Ihr nutzt python unter Windows 10 und skriptet damit regelmäßig Dinge. Nach dem Update auf Windows ...

Sicherheits-Tools

TrendMicro Worry-Free Business Security 10.0 SP1 steht in Englisch bereit mit Unterstützung für Windows 10 1903 (May Update)

Information von VGem-e vor 3 TagenSicherheits-Tools1 Kommentar

Moin Kollegen, Dann kommt wohl demnächst auch die deutschsprachige/europäische Version zur Auslieferung. Gruß VGem-e

Heiß diskutierte Inhalte
Windows Server
Windows Server 2016 einrichten
Frage von borjiaWindows Server34 Kommentare

Ich würde gerne einen Server einrichten, erstmal nur mit DNS und AD. Habe mich die letzten Wochen durch diverse ...

Google Android
Anbieter für Diensthandys
Frage von Pat.batGoogle Android24 Kommentare

Hallo zusammen, ich bin seit einiger Zeit zuständig für die Diensthandys bei uns in der Behörde. Eine Management Software ...

Exchange Server
Vorgehen um von Tobit auf Exchange zu wechseln
Frage von Martin1987Exchange Server17 Kommentare

Guten Abend Ich habe den Auftrag erhalten, unser Mail von David zu Outlook zu wechseln. Wie muss ich da ...

Microsoft Office
Office 365 eMail via Website verschicken
Frage von BiBeSoMicrosoft Office16 Kommentare

Hallo, kann man im Office 365 eMails anlegen welche zum versenden (smtp) für die Website funktionieren ? Muss man ...