Scheduled Task mit Powershell erstellen Parameter: "Run wether user."

keiosid
Goto Top
Hallo,
leider bin ich auf dem Powershellkuchen nicht die hellste Leuchte, aber vielleicht kann mir geholfen werden.

Ich muss einige Scheduled Tasks anlegen.
Da nun auf GMSA Accounts umgestellt wurde, habe ich ein Template für die Erstellung der Tasks erhalten.
Funktioniert soweit auch.
Nur ein Prameter passt nicht

Es ist immer "Run only when user is logged on" angehakt.
Damit der task aber auch ach einem Reboot läuft, brauche ich
"Run whether user is logged on or not".

wie kann ich das bei der Erstellung des Tasks mit geben?

Hier mal mein Scritpt (sensible daten sind ersetzt)


Ich habe mich schon durch die Beschreibung von Microsoft gewühlt, aber nicht den passenden Parameter gefunden.

Vielen dank im voraus.

Gruß
Keios

Content-Key: 1759660401

Url: https://administrator.de/contentid/1759660401

Ausgedruckt am: 18.05.2022 um 09:05 Uhr

Mitglied: colinardo
colinardo 25.01.2022 aktualisiert um 11:39:45 Uhr
Goto Top
Servus Keios,
bei GMSAs musst du in New-ScheduledTaskPrincipal den -LogonType auf Password setzen damit der Task auf "Unabhängig von der Benutzeranmeldung ..." gesetzt wird
Denn im Hintergrund besitzt der GMSA ja ein Passwort nur wird das eben von Windows verwaltet. "Serviceaccount" wäre hier in der Tat mit GMSAs das naheliegendste, gilt aber nur für SYSTEM & Co. aber naja ...

Grüße Uwe
Mitglied: KeiosID
KeiosID 25.01.2022 um 12:51:56 Uhr
Goto Top
Hallo colinardo,

muss ich dann noch einen Platzhalter für das Passwort setzen?
wenn ja, wie.
Ich erhalte beim ändern auf Password fogende Fehlermeldung;
obwohl ich den GMSA schon in die lokale Admingruppe reingepackt habe.

Es ihandelt sich hier um einen frisch aufgesetzten Win2022 Server.

danke
Gruß
EMu
Mitglied: colinardo
Lösung colinardo 25.01.2022 aktualisiert um 14:14:13 Uhr
Goto Top
Zitat von @KeiosID:
muss ich dann noch einen Platzhalter für das Passwort setzen?
Nein ist nicht nötig.
Klappt hier problemlos ohne Angabe. Mit welchen Settings wurde der GMSA angelegt, mit -PrincipalsAllowedToRetrieveManagedPasswort und dort die entsprechenden Computer-Gruppen angegeben? Und wurde der Account auch auf der entsprechenden Maschine installiert?

screenshot

screenshot
Mitglied: KeiosID
KeiosID 25.01.2022 um 15:01:34 Uhr
Goto Top
Danke Uwe,
du hast mich auf die richtige Lösung gebracht.
Ich musste den Server noch in die entsprechende Computergruppe für den GMSA Account stzen. Nachdem es synchronisiert war, geht es nun.
Damit lag das Problem wohl anders als ursprünglich vermutet
Gruß
Emu
Mitglied: colinardo
colinardo 25.01.2022 um 15:06:38 Uhr
Goto Top
👍
Grüße Uwe