Nach Serverausfall RAID1 auf neue Maschine umziehen - Wie RAID-Treiber nachträglich einbinden?

Mitglied: Dysan86

Dysan86 (Level 1) - Jetzt verbinden

25.11.2011 um 09:54 Uhr, 10334 Aufrufe, 7 Kommentare

Azubi in Nöten! Bisher war Adminstrator.de mehr Ausbildung, als mein "Ausbilder" zu bieten hat. Danke euch :) face-smile

Hallo,

ich hab hier ein HP ProLiant ML110 Server (Datenblatt: http://h20195.www2.hp.com/v2/GetPDF.aspx/4AA2-9842DEE.pdf), auf dem ein RAID1 lief. Leider ist das Mainboard defekt und die Maschine startet gar nicht mehr.
Eine neue Maschine habe ich bereits hier stehen, es ist ein FS TX100 S2 (Datenblatt: https://sp.ts.fujitsu.com/dmsp/docs/ds-py-tx100-s1.pdf).

Ich habe bereits ein Backup vom "alten" RAID1 gemacht und dieses auf das neue RAID1 geclont. Leider bzw. logischerweise startet der Windows Server 2003 Standard nicht, da die RAID-Treiber vom LSI Embedded MegaRaid (Onboard)
wohl fehlen - es kommen zwei Balken von Startscreen, dann startet er neu. Gibt es da eine Möglichkeit diese nachträglich zu installieren? Bzw. habe ich von Anfang an etwas nicht korrekt gemacht?

Kollege meinte, ich sollte einen RAID-Controller einbauen, Windows zum laufen bekommen und dann würde das Windows den Onboard-Controller erkennen und ich könnte ihn einfach installieren. Ich möchte ihn, indem ich euch jetzt befrage, nicht
in Frage stellen, aber der Server soll heute fertig werden und zum rumbasteln habe ich demnach nicht viel Zeit.

Danke im voraus.
Mitglied: goscho
25.11.2011 um 13:50 Uhr
Hallo "Azubi in Nöten"
womit hast du das Backup des Servers gemacht?

Ich möchte dich nicht gleich entmutigen ;-) face-wink
Aber wenn das keine Sicherungssoftware wie z.B. Symantec System Recovery (früher BESR) oder Acronis Backup & Recovery (früher True Image) mit Universal Restore war, dann wird dein Unterfangen sehr schwierig.

Wenn du den Server baugleich organisieren kannst, sind deine Chancen am größten. :-) face-smile
Bitte warten ..
Mitglied: Quebert
25.11.2011 um 14:30 Uhr
Hallo,

ich hatte schon mal einen ähnlichen Fall. Bin dann mit meinem Backup von Fujitsu auf HP umgezogen.

Brenn dir am besten den passenden Raid-Treiber auf eine CD. Dann bootest du mit der Server Install - CD. Du kommst an den Punkt, wo du eine bestehende Installation reparieren kannst - führe diesen Schritt aus, dann wird das Setup deine HDDs und somit das Windows nicht finden (da kein Treiber) und du kannst von einer CD den passenden Treiber in das Setup laden. Eventuell musst du auch von einem externen USB-Floppy Laufwerk den Treiber nachladen, ich bin mir nicht ganz sicher.

Jetzt musst du nur noch das Setup fertigstellen und hast danach ein bootfähiges System.


Achja, ich hatte bei meinem "Problem" nur ein "NTBackup" zur Hand.


Greez

Quebert
Bitte warten ..
Mitglied: Dysan86
25.11.2011 um 14:42 Uhr
Hab einfach mit Norton Ghost eine der Festplatten aus dem RAID1 auf das neue geklont. Warum könnte das Probleme geben?

Aber ich hab jetzt eventuell schon die Lösung:
Hab ein Clone auf eine IDE-Platte gemacht und dann mit einem PCI-E IDE-Controller das Ding im abgesicherten Modus hochgefahren, Raid-Treiber installiert. Bin grad dabei, von der IDE wieder auf das RAID1 zu clonen.
Müsste theoretisch ja klappen.

Baugleichen Server gibt es leider nicht, und ich habe 5 Sata-Controller ausprobiert, aber da fehlten natürlich auch die Treiber. Nervend, aber mit IDE klappt es wohl. Langsam, aber es klappt! War schon kurz davor es per USB-Adapter zu probieren.
Ich kann Microsoft nur empfehlen in der Liste, wenn man vor dem Start F8 drückt, auch einen Punkt zum Treiber einspielen, einzubauen.

Melde mich noch, ob wirklich geklappt hat.
Bitte warten ..
Mitglied: Dysan86
25.11.2011 um 14:47 Uhr
Brenn dir am besten den passenden Raid-Treiber auf eine CD. Dann bootest du mit der Server Install - CD. Du kommst an den Punkt,
wo du eine bestehende Installation reparieren kannst - führe diesen Schritt aus, dann wird das Setup deine HDDs und somit das
Windows nicht finden (da kein Treiber) und du kannst von einer CD den passenden Treiber in das Setup laden. Eventuell musst du
auch von einem externen USB-Floppy Laufwerk den Treiber nachladen, ich bin mir nicht ganz sicher.

Danke, das würde ich als nächstes tun, wenn es jetzt nicht klappt. Nur der Treiber ist zu groß, für eine Floppy, danke FS. (Treiber: http://support.ts.fujitsu.com/Download/Showdescription.asp?SoftwareGUID ... FS sagt noch:
Creating a driver floppy for Windows 2003 x86:
Please do not copy the megasr2k.sys file to that floppy.
This is due to the limited FDD memory (1.44 MB).

Hatte deshalb schon ne Anleitung rausgesucht, mit der man einen USB-Stick als Floppy emulieren kann. (http://www.pctipp.ch/praxishilfe/kummerkasten/hardware/32765/bootfaehig ...) Man kann ja nie wissen. BTW: Wie mache ich hier vernüftige Links? Die Formatierungshilfe springt mit bei nur mit leerem Fenster auf.
Bitte warten ..
Mitglied: Quebert
25.11.2011 um 14:58 Uhr
Hallo,

ja ist ein wenig kompliziert mit USB-Sticks als Floppy-Ersatz, solange das OS WS2k3 ist. Probier einfach mal. Brenn dir auf jeden Fall die CD, du kannst dann während der Treiberauswahl die Setup-CD entfernen, das sagt dir dann alles das Setup.

Greez

Quebert
Bitte warten ..
Mitglied: Dysan86
25.11.2011 um 15:14 Uhr
ja ist ein wenig kompliziert mit USB-Sticks als Floppy-Ersatz, solange das OS WS2k3 ist. Probier einfach mal. Brenn dir auf jeden
Fall die CD, du kannst dann während der Treiberauswahl die Setup-CD entfernen, das sagt dir dann alles das Setup.

Oh, ok! Wenn man da Z drückt kommt sonst immer nur A: zur Auswahl, deshalb die Geschichte mit dem USB-Stick als Floppy.
Bitte warten ..
Mitglied: Quebert
25.11.2011 um 15:23 Uhr
Das kann sein, ist schon ne Weile her als ich das gemacht habe. Einfach mal ausprobieren, sonst kannst du ja probieren, die Treiber von 2 Floppys zu laden?

Greez
Bitte warten ..
Heiß diskutierte Inhalte
Exchange Server
0-day Exploit Chain für Exchange Server - Patches verfügbar
kgbornVor 1 TagInformationExchange Server6 Kommentare

Zur Info: Microsoft warnt vor einer Exploit-Chain, bei der vier 0-day-Schwachstellen für gezielte Angriffe auf Exchange per Outlook Web App kombiniert werden (eine chines. ...

Netzwerkgrundlagen
DS-Lite Verständnisfrage Wireguard
gelöst fnbaluVor 1 TagFrageNetzwerkgrundlagen23 Kommentare

Hallo zusammen, bisher läuft bei mir alles klassisch. pfSense mit DDNS und ich verbinde mich mit OpenVPN in das Heimnetz und erspare mir so ...

HTML
Ich brauche dringend Hilfe !
gelöst JulianpustVor 11 StundenFrageHTML16 Kommentare

Hallo erstmal, ich habe großen Mist gebaut in der Firma wo ich gerade mal 2 Tage arbeite. Was ist passiert: Ich sollte von Gmail ...

Windows 10
Windows 10 schickt lokale Anfragen an das Gateway - was tun?
gelöst runthegaunzVor 1 TagFrageWindows 1015 Kommentare

Hallo! Ich bin vor ein paar Tagen wieder von Linux auf Windows umgestiegen. Ich hab die Windows 10 Version 20H2 installiert, wurde von Windows ...

Switche und Hubs
23 Cisco Switch einrichten - Wie am einfachsten?
gelöst Freak-On-SiliconVor 1 TagFrageSwitche und Hubs18 Kommentare

Hallo; Ich habe hier 4stk Cisco SX350X-24 9Stk Cisco SG350X-48P 10Stk Cisco SG350X-48 Diese werden aufgeteilt auf 9 Racks, und ersetzen alte HP Switches. ...

Exchange Server
Aktuelle Exchange Sicherheitslücke
jojo0411Vor 1 TagAllgemeinExchange Server11 Kommentare

Hallo Leute, Momentan gibt es da wieder einmal ein schönes neues Thema. Sehe ich das richtig das ich mit Exchange 2016 und CU 19 ...

Netzwerke
Smarthome Heimnetzwerk absichern
hell.wienVor 1 TagFrageNetzwerke12 Kommentare

Hallo. Ich mach mir gerade gedanken wie ich meine neue Wohnung sicher mache Überischthalber zur Hardware: Vorhanden: Modem APU4D4 Cisco SG250X-24P Mikrotik cAP ac ...

Windows Server
Windows Firewall: Alle öffentliche IPs sperren bis auf eine
SabSchapVor 1 TagFrageWindows Server7 Kommentare

Hallo, wir haben einen Windows 2019 Server. Wir nutzen diesen als Webserver. Nun haben wir die Webadresse www.test.de und möchten diese für alle öffentlichen ...