Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst TELNET SMTP-Mailversand Problem mit AUTH LOGIN

Mitglied: CLU

CLU (Level 1) - Jetzt verbinden

03.02.2006, aktualisiert 08.02.2006, 32332 Aufrufe, 6 Kommentare

Ich versuche mit TELNET ein Mail zu senden, aber ich scheitere bei AUTH LOGIN!

Hallo,

mir muß mal jemand auf die Sprünge helfen:
Ich versuche mit TELNET ein Mail zu senden, aber ich scheitere bei AUTH LOGIN!

Beispiel:
User: erika.mustermann@web.de
Password: 12345

TELNET SMTP.web.de 25
Verbindungsaufbau klappt!

HELO klappt auch
EHLO klappt auch

AUTH LOGIN klappt nicht! Ich übergebe jeweils einzeln und nach BASE64 verschlüsselt meinen Benutzer und Passwort.
Ich bekomme aber immer nur "incorrect user or password"!

was mache ich falsch?
Mitglied: filippg
03.02.2006 um 19:36 Uhr
Hallo,

vielleicht erwartet ja der Server einfach keine Base64-Encodierung? Die zulässigen Codierungen sollte er idealerweise als Antwort auf EHLO senden.
Ansonsten ist deine Fehlerbeschreibung etwas unspezifisch, sende doch mal ein Sitzungsprotokoll.

Filipp
Bitte warten ..
Mitglied: CLU
08.02.2006 um 12:07 Uhr
Hier das Sitzungsprotokoll:

221 2.0.0 {mp012} GMX Mailservices
220 {mp020} GMX Mailservices ESMTP
EHLO erika.mustermann@gmx.de
250-{mp020} GMX Mailservices
250-8BITMIME
250-ENHANCEDSTATUSCODES
250-AUTH=LOGIN CRAM-MD5 PLAIN
250-AUTH CRAM-MD5 LOGIN PLAIN
250 STARTTLS
AUTH login
334 VXNlcm5hbWU6
***=
334 UGFzc3dvcmQ6
MTIZNDU=
535 5.7.0 {mp020} Incorrect username or password
Bitte warten ..
Mitglied: filippg
08.02.2006 um 13:55 Uhr
Hallo,

also bei mir funktioniert das einwandfrei:

220 {mp030} GMX Mailservices ESMTP
EHLO xxxxxxxx
250-{mp030} GMX Mailservices
250-8BITMIME
250-ENHANCEDSTATUSCODES
250-AUTH=LOGIN CRAM-MD5 PLAIN
250-AUTH CRAM-MD5 LOGIN PLAIN
250 STARTTLS
AUTH LOGIN
334 VXNlcm5hbWU6
xxxxxxxx
334 UGFzc3dvcmQ6
xxxxxxxx
235 2.7.0 {mp030} Go ahead

Ich gehe mal davon aus, dass du Nutzer und Passwort vor dem Posten extra geändert hast, aber vielleicht solltest du das einfach nochmal testen. Ich habe das Tool unter http://www.patshaping.de/projekte/kleinkram/base64.php genommen.
Daneben kann man bei GMX unter E-Mail -> Optionen -> Sicherheit noch Einstellungen zur SMTP-Sicherheit machen, aber auth-login sollte immer funktionieren.

Filipp


Edit: Was mir gerade aufgefallen ist: Originalposting bezog sich auf Web.de, jetzt ist von GMX die Rede, was ist es denn nun? Übrigens: Web.de lässt dich, wenn du kein Club-Mitglied bist nur alle 15min deine eMails abrufen. Das führt auch häufig zu Fehlern, allerdings gibt Web.de afaik wenigstens eine entsprechende Fehlermeldung (und nicht einfach login incorrect).
Bitte warten ..
Mitglied: CLU
08.02.2006 um 14:24 Uhr
Hallo,

bei mir klappt es leider immer noch nicht.
Per Web-Front-End kann ich problemlos Mails verschicken.

Frage zu AUTH LOGIN:
Welche der folgenden "identischen" User muß ich nach BASE64 verschlüsseln und dann bei AUTH LOGIN übergeben:

erika.mustermann@gmx.de ?
erika.mustermann ?
GMX-Kundennummer?

Sorry für die Verwirrung mit GMX.DE und WEB.DE: Ich brauche eine Lösung für GMX.DE! WEB.DE habe ich zum vergleichen genutzt.

Gruss CLU
Bitte warten ..
Mitglied: filippg
08.02.2006 um 14:54 Uhr
Hallo,

ja, das hätte ich noch erwähnen sollen: ich habe die komplette eMail-Adresse genommen (mit @gmx.???), gmx selber schreibt allerdings was von Kundennummer.

Filipp
Bitte warten ..
Mitglied: CLU
08.02.2006 um 15:28 Uhr
Hallo,

also ich habe das Ganze nochmal aus einer DOS-Box gemacht:
Dort klappt AUTH LOGON !
Ich habe das vorher immer mit einem Tool namens SMTP-Explorer gemacht.
Wo da der Unterschied liegt, weiß ich leider nicht.
Vielleicht "klatscht" der bei der Übergabe der verschlüsselten Eingaben noch ein Enter mehr rein oder so. EGAL!

In der guten alten DOS-Box lauft alles!
Und das reicht mir auch!
Dann tippe ich halt auf command-line weiter...

Vielen Dank an Filipp für die freundliche technische Unterstützung und die Hinweise.

Gruss CLU
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Automatischer Login per Telnet
Frage von 121851Batch & Shell6 Kommentare

Hallo zusammen, ich habe folgendes Problem. Erstmal bin ich nicht so fit was Programmieren angeht. Gibt es eine möglichkeit ...

iOS
IOS SMTP-Mailversand nicht möglich
gelöst Frage von saschagiOS3 Kommentare

Hallo zusammen, ich habe ein Problem mit dem Mailversand auf einem IPhone 5 (9.2) und iPad gleichermaßen. Die Mailadresse ...

Debian
Zarafa smtp-auth via CRAM-MD5
Frage von zwirniDebian1 Kommentar

Hallo zusammen, nach tagelangen Kopfzerbrechen möchte ich mich nun an die Admin Kollegen wenden. Mein Mailservers läuft auf Debian ...

Hardware

Adaptec ASR8805E smtp Mailversand externer Mailserver

Frage von derBadnerHardware8 Kommentare

Hallo, ich habe zur Zeit folgendes Problem: Ein Kunde hat einen Server erhalten der einen Adaptec ASR8805E Raidcontroller hat. ...

Neue Wissensbeiträge
Internet

Kommentar: Bundesregierung erwägt Ausschluss von Huawei im 5G-Netz - Unsere Presse wird immer sensationsgieriger

Information von Frank vor 1 TagInternet5 Kommentare

Hier mal wieder ein schönes Beispiel für fehlgeleiteten Journalismus und Politik zugleich. Da werden aus Gerüchten plötzlich Fakten, da ...

Windows 10

Netzwerk-Bug in allen Windows 10-Versionen durch Januar 2019-Updates

Information von kgborn vor 2 TagenWindows 101 Kommentar

Nur ein kurzer Hinweis für Admins, die Windows 10-Clients im Portfolio haben. Mit den Updates vom 8. Januar 2019 ...

Windows 10

Windows 10 V1809: Rollout ist gestartet - kommt per Windows Update

Information von kgborn vor 2 TagenWindows 102 Kommentare

Eine kurze Information für die Admins, die Windows 10 im Programm haben. Microsoft hat die letzte Baustelle (die Inkompatibilität ...

Sicherheit

Heise Beitrag Passwort-Sammlung mit 773 Millionen Online-Konten im Netz aufgetaucht

Information von Penny.Cilin vor 2 TagenSicherheit6 Kommentare

Auf Heise Online ist folgender Beitrag veröffentlicht worden: Heise Beitrag passwörter geleakt Ich bin mir jetzt nicht ganz sicher, ...

Heiß diskutierte Inhalte
TK-Netze & Geräte
TAPI auf einem Win2016Server installieren und einrichten
Frage von wstabelTK-Netze & Geräte32 Kommentare

Hallo liebe Admins, ich habe folgende Situation: 1 Windows Server 2016 Standard als DC 1 SNOM 710 IP-Telefon 1 ...

Batch & Shell
Mit findstr batch doppelte zeilen einer txt löschen
Frage von Burningx2Batch & Shell26 Kommentare

Hi Vor einer weile habe ich im netzt einen windows shell befehl gefunden mit welchem man über die konsole ...

Windows 10
Robocopy Quelle und Ziel vertauscht Daten gelöscht ?
Frage von eastclintwoodWindows 1021 Kommentare

Hallo, ich wollte Daten von einer extrernen Festplatte (USB) auf eine interne Platte per robocopy sichern. Leider habe ich ...

Microsoft
Übertragung von MS Volumenlizenzen
Frage von SherlockineMicrosoft20 Kommentare

Ich bin Angestellte in einer kleinen 10-köpfigen IT-Firma, die Netzwerklösungen, Telefonielösungen und Ähnliches anbietet. Im Sommer hatten wir einen ...