Ubuntu Apache immer wieder nicht erreichbar

Mitglied: da-chiller

da-chiller (Level 1) - Jetzt verbinden

13.09.2011, aktualisiert 15:19 Uhr, 8407 Aufrufe, 9 Kommentare

Hallo zusammen,

ich hoffe ich finde hier Hilfe zu meinem Problem bezüglich meines Webservers und dessen Konfiguration.
Ich habe mich jetzt schon eine Weile mit der Materie auseinander gesetzt und komme dennoch nicht hinter das Problem.
Grundsätzliche Kenntnisse zu Netzwerken, Servern, Diensten, Ubuntu, usw. sind vorhanden

Danke im Vorraus

Ich habe folgende Situation:

Es hängt eine Kabel-FritzBox mit einer festen IP von KabelBW vor dem internen Netzwerk, über welches ein WLAN-Accesspoint und ein vSphere-Host angeschlossen sind.
Auf dem VM-Host laufen zwei Server und eine Testmaschine mit WinXP. Die beiden Server sind ein ClearOS 5 SBS und, um den es eigentlich geht, ein Ubuntu Server 11.04.

Der Ubuntu Server soll als Webserver dienen und ist mit Apache, PHP, MySQL nach dieser Anleitung konfiguriert.
http://www.howtoforge.com/installing-apache2-with-php5-and-mysql-suppor ...

Die Ports in der FritzBox sind entsprechend konfiguriert und das Ganze funktioniert auch gut.

Das Problem:
Immer wieder ist die Joomla-Seite die darauf läuft nicht erreichbar. Von intern über die IP des Servers überhaupt kein Thema. Aber über die Domain, die richtig aufgelöst wird, funktioniert der Aufruf der Seite immer wieder nicht. Auch das neustarten des virtuellen Servers bringt keine Besserung.
Ich kann den letzten Snapshot, bei dem alles lief, wiederherstellen und dann geht es wieder. Aber irgendwann - im Zeitraum von Stunden oder Tagen ist die Seite dann wieder nicht erreichbar.
Ein weiteres Phänomen ist, dass die Seite über mein Handy manchmal funktioniert, aber zur gleichen Zeit von einem Rechner bei uns im Büro hinter einem Squid-Proxy wieder nicht erreichbar ist.

Das macht mich total fertig - zumal da recht bald eine kommerzielle Seite drauf laufen soll...

Ist denn Grundsätzlich lighttpd die bessere Wahl?

Hier noch die Config von hosts
und interfaces
Was wäre denn noch Sinnvoll?
Mitglied: Orlean
13.09.2011 um 12:04 Uhr
hiho,

Was sagen denn die Logfiles?
Was sagen ping und tracert, wenn deine Webseite nicht erreichbar ist? (Sowohl Domain Name als auch IP bzw. extern/intern)? Bzw. kommst du von deinem Server dann nach extern?
Irgendwelche Config Dateien angepasst, oder alles noch "Standard"?
Wie sind deine VirtualHosts konfiguriert?

Gruß Orlean

PS: Ich weiß ja nicht, was auf dem Webauftritt genau laufen soll bzw. wofür ihr einen eigenen Server dafür benötigt, aber je nach eigenem Kenntnisstand wäre es nicht eventuell besser/einfacher das ganze auf externen Webspace auszulagern?
Bitte warten ..
Mitglied: da-chiller
13.09.2011 um 13:19 Uhr
Hi,

/apache2/error.log
bei den meisten handelt es sich um das fehlende favicon, fehlende Seiten (falsche Adresse), oder Angriffsversuche...

Aber der Aufruf, wenn die Seite erreichbar ist, scheint auch immer zu funktionieren - dafür bekom ich auch Logs in der Analyse (Piwik).
In Augenblick ist sie nur übers Handy erreichbar!

Kann es sein das die Anzahl der Zugreifenden Probleme macht? Ist die FritzBox kacke?

Die Pings werden beantwortet, die Route endet bei der FB!

Den Apache hatte ich soweit in Ruhe gelassen.

Als Virtual Host ist die Joomla-Seite in 000-default konfiguriert.


Rein theoretisch wäre das ausweichen auf einen Provider wahrscheinlich die einfachere Lösung. Allerdings soll in die Seite eine Hotelbuchungskomponente eingebaut werden, die auf einer eigenen Datenbank läuft. Diese soll bei uns auf dem Server laufen. Ich gehe einfach davon aus, dass es für uns komfortabler ist die Seite bei uns zu hosten. Zumal es technisch kein Problem geben dürfte und wir an Infrastruktur alles notwendige im Haus haben. - Von der Tatsache, dass es Spaß macht, wenns dann gut funktioniert und man selbst noch was dabei gelernt hat, ganz abgesehen. Ich hoffe Du verstehst das ^^

Danke für die schnelle Antwort

Gruß da-chiller


EDIT: Kurz nach absenden dieser Anwort, konnte ich die Seite von einem Rechner ohne Proxy aufrufen - trracert & ping: keine Veränderung
Bitte warten ..
Mitglied: da-chiller
13.09.2011 um 14:05 Uhr
Kurzer Nachtrag:

Ist das ein Problem?
Bei 9. (Zeile 13) und wenn ja, wie löse ich das?


Errorlog vom apache nach reboot:
der fatal error müsste ja ein Joomla-Problem sein...???

Vielen Dank
Bitte warten ..
Mitglied: Orlean
13.09.2011 um 15:14 Uhr
Ideallerweiße sollte dort natürlich keine Zeitüberschreitung vorhanden sein, und generell könnte ich mir auch vorstellen, das hier das Problem liegt. Hier könnte man z. B. einmal gegentesten, wenn die Seite denn normal erreichbar ist, wie dann ein tracert aus sieht.

Als ganz einfache "Behelfslösung", würde mir jetzt auf anhieb ein Routerneustart einfallen, glaube zwar nicht, das damit Abhilfe geschaffen ist.

Der Fehler im Errorlog müsste von Joomla kommen, bisher aber noch nicht wirklich mit Joomla gearbeitet.
Bitte warten ..
Mitglied: da-chiller
13.09.2011 um 15:20 Uhr
Zitat von @Orlean:
Ideallerweiße sollte dort natürlich keine Zeitüberschreitung vorhanden sein, und generell könnte ich mir auch
vorstellen, das hier das Problem liegt. Hier könnte man z. B. einmal gegentesten, wenn die Seite denn normal erreichbar ist,
wie dann ein tracert aus sieht.
Das sieht leider auch nicht anders aus - auch von verschiedenen Stationen aus!


Als ganz einfache "Behelfslösung", würde mir jetzt auf anhieb ein Routerneustart einfallen, glaube zwar nicht,
das damit Abhilfe geschaffen ist.
Das hat leider bisher auch keinen Erfolg gebracht!

Aber danke nochmal
Bitte warten ..
Mitglied: tonabnehmer
13.09.2011 um 15:56 Uhr
Zitat von @Orlean:
Ideallerweiße sollte dort natürlich keine Zeitüberschreitung vorhanden sein, und generell könnte ich mir auch
vorstellen, das hier das Problem liegt. Hier könnte man z. B. einmal gegentesten, wenn die Seite denn normal erreichbar ist,
wie dann ein tracert aus sieht.

Das ist m. E. falsch. Bei Traceroute ist entscheidend, dass der letzte Hop also das Ziel erreicht wird. Ob irgendwo auf dem Weg ein Hop nicht auf Ping antwortet ist völlig normal.

Ich würde mal den ganzen Joomla Kram beiseite packen und gucken ob die normale "It Works!" Seite erreichbar ist bzw. Telnet auf die IP Port 80 machen. Der Eintrag des öffentlichen Namens in der /etc/host ist mir auch etwas suspekt. Kann es auch sein, dass Du aus dem internen Netz über die öffentliche IP auf den Apachen im internen Netz zugreifst?
Bitte warten ..
Mitglied: da-chiller
13.09.2011 um 16:12 Uhr
Ich würde mal den ganzen Joomla Kram beiseite packen und gucken ob die normale "It Works!" Seite erreichbar ist
bzw. Telnet auf die IP Port 80 machen. Der Eintrag des öffentlichen Namens in der /etc/host ist mir auch etwas suspekt. Kann
es auch sein, dass Du aus dem internen Netz über die öffentliche IP auf den Apachen im internen Netz zugreifst?

Du meinst, ob das funktioniert?
Es ist so: Der Ubuntu-Server hat die Adresse 192.168.10.200 für intern und .2.24 für extern - also zum Router hin.
Ich kann von meinen internen Rechnern problemlos und jederzeit über beide IPs die Seite aufrufen.
Oder habe ich Dich grade falsch verstanden?

Sollte ich mal die interne Nic abschalten? Wird nur für SSH usw. benötigt. Im Zweifel komm ich immer noch über den vSphere-Client auf dessen Konsole...
Bitte warten ..
Mitglied: tonabnehmer
13.09.2011 um 16:24 Uhr
Meine Vorschläge: Die VM bekommt nur eine NIC für extern, also IP .2.24. In der /etc/hosts lässt Du den Eintrag mit dem öffentlichen Hostnamen weg. Der braucht nur localhost 127.0.0.1 und webserver .2.24. Im Router leitest Du die verwendeten Ports z. B. 80 und 443 an die .2.24 weiter. Von intern erreichst Du den Apachen und auch SSH etc. über die .2.24. Aus dem Internet erreichst Du den Apachen über www.domain.de -> öffentliche IP Adresse. Erst dann würde ich Joomla aufsetzen.
Bitte warten ..
Mitglied: da-chiller
14.09.2011 um 13:36 Uhr
Zitat von @tonabnehmer:
Meine Vorschläge: Die VM bekommt nur eine NIC für extern, also IP .2.24. In der /etc/hosts lässt Du den Eintrag mit
dem öffentlichen Hostnamen weg. Der braucht nur localhost 127.0.0.1 und webserver .2.24. Im Router leitest Du die verwendeten
Ports z. B. 80 und 443 an die .2.24 weiter. Von intern erreichst Du den Apachen und auch SSH etc. über die .2.24. Aus dem
Internet erreichst Du den Apachen über www.domain.de -> öffentliche IP Adresse. Erst dann würde ich Joomla
aufsetzen.

Hallo tonabnehmer,

hmm, das scheint jetzt zunächst mal geholfen zu haben. Mal sehen wie lange ;)

Vielen Dank für die schnelle Hilfe!!!
Bitte warten ..
Heiß diskutierte Inhalte
LAN, WAN, Wireless
Mikrotik CAP AC als Wlan Bridge
theoberlinVor 1 TagFrageLAN, WAN, Wireless28 Kommentare

Hallo zusammen, ich habe mal wieder ein kleines Problem. Folge Idee: 5Ghz Modul des CAP AC wird als Client in ein WLAN eingebunden(Station). 2.4 ...

Windows 10
PDF automatisch auf zwei Drucker aufteilen
hannes.pVor 1 TagFrageWindows 109 Kommentare

Hallo zusammen, ich suche verzweifelt nach einer Möglichkeit, ein von einer Web-Anwendung generiertes PDF automatisch auf zwei Drucker drucken zu lassen. Das PDF Dokument ...

Microsoft
Erwerb von M365 Lizenzen, Partner Autorisierung für Azure AD - Globaler Administrator wirklich nötig?
NidavellirVor 1 TagFrageMicrosoft4 Kommentare

Hi zusammen, bitte entschuldigt den etwas sperrigen Titel, aber ein knapperer wollte mir nicht einfallen. :D Wir wollen bei einem Systemhaus M365 Lizenzen (Business ...

Windows 10
Sperrbildschirm nach 5 min
ZeppelinVor 1 TagFrageWindows 1012 Kommentare

Hallo zusammen, ich wende mich mit meinem anliegen an euch weil ich mit meinen Möglichkeiten am Ende bin. Wenn innerhalb von 5 min. keine ...

Speicherkarten
Welchen USB Stick für Bootstick?
gelöst dlnkrgVor 1 TagFrageSpeicherkarten6 Kommentare

Hallo, Ich bin auf der Suche nach USB - Sticks, auf denen ich Linux Ubuntu installieren kann und praktisch als Festplatte für das Betriebssystem ...

Off Topic
BKA und der Bundestrojaner
brammerVor 1 TagInformationOff Topic3 Kommentare

Hallo, habe kurz überlegt ob das unter Off Topic allgemein oder Off Topic LOL gehört brammer

Sicherheit
Emails als Nur Text
Jessica98Vor 1 TagFrageSicherheit4 Kommentare

Hallo zusammen, macht es Sinn E-Mails als nur Text einzustellen, um sich vor schädlichen HTML-Code zu schützen? Meines Erachtens wird ein Benutzer diese Email ...

Windows Netzwerk
Sporadisch kein Netz auf mehreren Win10-Maschinen
SolarflareVor 14 StundenFrageWindows Netzwerk6 Kommentare

Hallo, ich habe seit Monaten einen eigenartigen Effekt in unserem Windows-Netz. Windows-Domäne mit ca. 100 Maschinen, alle Clients aktuelles Windows 10. Die Maschinen hängen ...