Windows 10 Professional Neuinstallation auf vorinstallierten 10 Home funktioniert nicht

Mitglied: Thunder2008

Thunder2008 (Level 1) - Jetzt verbinden

20.12.2015 um 19:35 Uhr, 2748 Aufrufe, 21 Kommentare

Hallo zusammen,

wir haben vorinstallierte Desktop Rechner mit Windows 10 Home. Diese sollen in eine Domain eingebunden werden, daher soll ordnungsgemäß eine saubere Windows 10 professional x64 blanco installiert werden. Nach Umstellen der Bootreihenfolge funktioniert die Installation einschließlich Formatierung der Festplatten einwandfrei. Es kommt keine Microsoft Key Abfrage (dieser wird scheinbar automatisch aus dem Bios gezogen). Und hier ist auch das Problem. trotz der eingelegten Windows Professional CD wird letztendlich nur die Windows Home Edition freigeschaltet.
Über die Systemeigenschaften lässt sich der Key ebenfalls nicht ändern. Nach mehrfacher Suche im Internet habe ich über "PC Einstellungen" auch den Link in den Shop gefunden. Dort wird der Key aber ebenfalls nicht angenommen, da es sich um OEM Versionen handelt.

Die Crux ist nun, wir haben die Rechner mit Home und die zusätzlichen Professional Versionen welche aber nicht angenommen werden. Ich würde mich sehr über Antworten und Hilfestellungen freuen.

Viele Grüße
Thunder2008
Mitglied: Kuemmel
20.12.2015 um 19:47 Uhr
Moin,
was passiert wenn du den Product-Key in Windows Home änderst? Wandelt es sich dann in eine Pro um?

Gruß
Kümmel
Bitte warten ..
Mitglied: Lochkartenstanzer
20.12.2015, aktualisiert um 20:01 Uhr
Moin,

Probier mal das. Das funktioniert unter Windows X genauso.

lks
Bitte warten ..
Mitglied: Kuemmel
20.12.2015 um 20:10 Uhr
Moin LKS,
ich glaube das Problem des TEs ist, dass Win10 sich den Key automatisch aus dem BIOS zieht (Home-Edition) und dann die Versionsauswahl übersprungen wird, sodass er kein Pro wählen kann.
Bitte warten ..
Mitglied: Lochkartenstanzer
20.12.2015 um 20:12 Uhr
Zitat von @Kuemmel:

Moin LKS,
ich glaube das Problem des TEs ist, dass Win10 sich den Key automatisch aus dem BIOS zieht (Home-Edition) und dann die Versionsauswahl übersprungen wird, sodass er kein Pro wählen kann.

Und genau dieses Problem läßt sich mit der ei.cfg aus dem obigen LInk beheben!

Mit der obigen ei.cfg bekomtm man beide Varianten home + Pro zu Installation angeboten statt die Version zu nehmen, die aufgrund des Lizenzkeys im BIOS bestimmt wird.

lks
Bitte warten ..
Mitglied: Kuemmel
20.12.2015, aktualisiert um 20:15 Uhr
Hatte das so neulich auch mal bei einer Lenovo-Consumer-Kiste getestet, hat leider unter Win10 nicht funktioniert! :-( face-sad Kann aber sein das es bei manchen Modellen dennoch funktioniert. Warten wir mal ab! :-) face-smile
Bitte warten ..
Mitglied: Nemo-G
20.12.2015 um 20:19 Uhr
Ein ähnlicher Fall ist bei Deskmodder beschrieben.
Wenn der Lösungsvorschlag zutrifft, so ist eine Datei .\sources\EI.CFG in das zu modifizierende Installationsmedium einzufügen:

Eine zum Erfolg führende Variante könnte ein anderer Eintrag unter [Channel] sein:

Viel Erfolg!
Gruß, Nemo-G
Bitte warten ..
Mitglied: kontext
21.12.2015 um 09:27 Uhr
Hallo @Thunder2008,

du hast ja schon ein paar brauchbare Tipps bekommen die funktionieren sollten. :-) face-smile
Hatte das Problem in der Vergangenheit auch (zum Glück nur bei einem Gerät) und konnte mit der Änderung der ei.cfg das Windows 10 Pro über das mitgelieferte Windows 10 Home "drüberbügeln".

Ansonsten - eine andere Quick und Dirty Variante, welche man testen könnt:
HDD ausbauen und Windows 10 Pro in einem anderen Gerät installieren.
Am besten einen "alten" Testrechner oder ähnliches verwenden - damit das Setup keinen falschen KEY zieht.
Anschließend Key eingeben und die Installation starten.
Platte ins Zielsystem einbauen und Installation fertigstellen und sich "hoffentlich" freuen. :-) face-smile

Gruß
@kontext
Bitte warten ..
Mitglied: Thunder2008
21.12.2015 um 13:54 Uhr
Hallo zusammen,
vielen Dank für die zahlreichen Lösungsansätze und Vorschläge. Die ei.cfg habe ich ebenfalls in das Bootmedium integriert. Entsprechend angepasst, da es sich um Windows OEM Versionen handelt.
Entweder bootet das System aber garnicht erst von der CD und wenn doch rödelt es einige Minuten. Es schaut dann so aus, als ob das Setup in regulärer Version startet. Dann kommt jedoch ein Smiley und die Fehlermeldung "Es ist ein problem aufgetreten und der PC muss neu gestartet werden". In diesem Fall mit dem Fehlercode "Inaccessible_Boot_Device". Auch schonmal "memory_management".

Von dem Hersteller Asus bekommt dazu leider ebenso nur einen Verweis auf die einschlägigen Websites. Der Support scheint nicht qualifiziert genug zu sagen wie das Secure Boot ausgeschaltet werden kann bzw. wie man verhindert, dass der Key gepusht wird.

VG
Thunder
Bitte warten ..
Mitglied: Lochkartenstanzer
21.12.2015, aktualisiert um 14:00 Uhr
Zitat von @Thunder2008:

Dann kommt jedoch ein Smiley und die Fehlermeldung "Es ist ein problem aufgetreten und der PC muss neu gestartet werden". In diesem Fall mit dem Fehlercode "Inaccessible_Boot_Device". Auch schonmal "memory_management".

Das scheinen dann aber eher hardware-Probleme zu sein.

Du solltest Dir direkt das ISO von MS herunterladen und daraus einen Stick mit der passenden ei.cfg machen, denn Du weißt nicht, welche Schweinereien die ganzen OEM-Hersteller anstellen (das geht von einfacher Werbemalware bis hin zu Trojanern und Backdoors!).

lks
Bitte warten ..
Mitglied: Thunder2008
21.12.2015 um 14:22 Uhr
Das scheint insbesondere an der Bios Funktion zu liegen. Safeboot lässt sich in diesem Fall nicht ausschalten etc. Für das erstellte Image haben wir eine aktuelle Windows 10 Professional x64 CD verwendet und lediglich die ei.cfg hinzugefügt wie mir hier detailliert beschrieben wurde. An dem Image dürfte es also nicht liegen.
Bitte warten ..
Mitglied: Nemo-G
21.12.2015 um 14:30 Uhr
Zitat von @Lochkartenstanzer:

... Das scheinen dann aber eher hardware-Probleme zu sein.

Du solltest Dir direkt das ISO von MS herunterladen und daraus einen Stick mit der passenden ei.cfg machen, denn Du weißt nicht, welche Schweinereien die ganzen OEM-Hersteller anstellen (das geht von einfacher Werbemalware bis hin zu Trojanern und Backdoors!).

lks
Das sehe ich ebenso.
Wovon hast Du gebootet? DVD zu schnell gebrannt?
Auch dem Original von MS kann ich nur zuraten. Ist allerdings in jedem Fall nur Build 10586.0 von Ende Oktober und aktuell ist 10586.36.

Ein Tipp: Wenn Du etliche Rechner aufsetzen musst/willst, lohnt es zeitlich auf jeden Fall, vorher den letzten kumulativen Patch und auch den für den FlashPlayer im IE zu integrieren. Vgl. meinen aktuellen Post bei Win-Lite.

@lks: Wie war das doch gleich mit dem Überloch in Spalte 81?

Gruß, Nemo-G
Bitte warten ..
Mitglied: Nemo-G
21.12.2015, aktualisiert um 15:25 Uhr
Hallo Thunder2008,
Du hast schneller geantwortet als ich meine Antwort um 14:30h abschicken konnte.

Es bleiben:
- DVD i.O.?
- Andererseits kann ich mir nicht vorstellen, dass heutzutage noch "inaccessible boot device" kommt. Zu Zeiten von XP gab's das gerne mal, insbesondere mit dem Aufkommen von S-ATA.

Gruß, Nemo-G
Bitte warten ..
Mitglied: Thunder2008
21.12.2015 um 15:38 Uhr
Danke für eure Antworten. Im aktuellsten MS build dasselbe. Ich konnte es mir auch nicht vorstellen. Ist aber leider so. drei unabhängige DVDs voneinander funktionieren nicht einschließlich zu testzwecken einer Original MS Windows 7 (ohne ei.cfg). Ich kann mir nur vorstellen, dass es daran liegt dass ich nicht von dem UEFI-DVDRAM boote sondern von dem Standardlaufwerk ohne UEFI. Leider gibt asus hierzu bisher keine Infos raus und den 1st Lvl Support am Telefon kann man scheinbar in die Tonne treten, es sei denn man hat Fragen dazu wie rum das Stromkabel eingesteckt wird.
Insbesondere zu der Frage ob und wie man Safeboot ausstellt und verhindern kann dass der Key gepusht wird können die leider keine Antwort geben. Der Mailsupport hat sich bisher nicht zurück gemeldet, da ich hier noch die Hoffnung habe, dass wir eine gute Antwort von dem 2nd Lvl bekommen.

Generell stimme ich euch zu. Es kann eigentlich nur an einer Kleinigkeit liegen ... bei IBM / Lenovo Notebooks gab es mal ähnliche Probleme. Da haben wir den SATA Channel auf Compatible für den Zeitraum der OS Installation gestellt und es klappte. Aber eine solche Funktion finde ich bei den Clients hier leider nicht.
VG
Bitte warten ..
Mitglied: Nemo-G
21.12.2015 um 16:08 Uhr
Zitat von @Thunder2008:

... Da haben wir den SATA Channel auf Compatible für den Zeitraum der OS Installation gestellt und es klappte. Aber eine solche Funktion finde ich bei den Clients hier leider nicht.
VG
Das wäre aber auch nicht der Hit, wenn Du S-ATA-Controller im kompatiblen Modus betreibst. Späteres Umstellen auf AHCI ist auch nur mit Klimmzügen möglich.

Brauchst Du denn für Deine Maschinen einen speziellen Treiber für den SATA-Controller, den selbst Win10 nicht kennt oder aber ist der dort falsch implementiert, wie man es von nVidia-Grafikkarten gehört hat?
Wenn ja: Dann hilft auch nur eine Integration ins Installationsmedium mit DISM, NTLite oder auch Win Toolkit.

Gruß, Nemo-G
Bitte warten ..
Mitglied: Thunder2008
21.12.2015 um 16:43 Uhr
Hmm k.A. gute Frage. Einen client haben wir jetzt auf Pro geupgradet bekommen. Jedoch nur über den Shop und als Basis wie gehabt mit der Home Version.
Die OEM Keys werden im Shop nicht angenommen, genau so wenig wie über Computer-Produkuct Key ändern. Nach wie vor hängt es scheinbar am Safeboot.

Wenn man CSM ausschaltet, kann man aus irgendeinem Grund nicht mehr vom DVDRAM booten sondern bekommt nur noch eine abgespeckte Boot-Auswahl angezeigt.
Asus Support hat sich dazu bisher noch nicht geäußert, da ich generell nach wie vor von einer überschaubaren Einstellung ausgehe.
Bitte warten ..
Mitglied: AndreBoine
21.12.2015 um 17:08 Uhr
Den Windows Produkt Keys im BIOS neu eintragen geht nicht?
Bitte warten ..
Mitglied: Thunder2008
21.12.2015 um 18:05 Uhr
Nein leider nicht. Und wenn man die vorhandenen Keys manuell raus löscht, sind diese nach einem Neustart wieder drin.
VG
Bitte warten ..
Mitglied: Nemo-G
21.12.2015 um 20:09 Uhr
Zitat von @Thunder2008:

Nein leider nicht. Und wenn man die vorhandenen Keys manuell raus löscht, sind diese nach einem Neustart wieder drin.
VG
Hast Du nach dem Löschen versucht, _offline_ mit eingestellter ei.cfg zu installieren?

Gruß, Nemo-G
Bitte warten ..
Mitglied: HRusch
22.12.2015 um 11:36 Uhr
Moin,

eine Möglichkeit wäre es das Home nach der Installation über das "Windows Anytime Update" zu einem Pro zu machen.

Schöne Grüße
Bitte warten ..
Mitglied: AndreBoine
06.01.2016 um 17:45 Uhr
Laut einem Fachkollegen von mir gibts dazu i.d.R. Herstellereigene Tools mit denen der Windows10-ProduktKey im BIOS geflasht werden kann.

Bei manchen Rechnern ist das offensichtlich nötig. Ohne Key-Flash keine neue Windows-Installation.

Empfehlung: an den Hersteller wenden und das Flash-Tool abfordern.
Bitte warten ..
Mitglied: killtec
08.01.2016 um 08:05 Uhr
Hi,
du glaubst doch wohl nicht, dass der Hersteller so ein Tool raus rückt....

Gruß
Bitte warten ..
Heiß diskutierte Inhalte
LAN, WAN, Wireless
Starlink im Unternehmen?
0xFFFFVor 13 StundenFrageLAN, WAN, Wireless36 Kommentare

Guten Morgen Admins, leider leiden wir darunter, dass wir uns hier in DE noch in einem Entwicklungsland was die Internetanbindung angeht, sehr. Nun kam ...

Microsoft
Datenkrake - Browser
DennisWeberVor 1 TagErfahrungsberichtMicrosoft10 Kommentare

Hallo zusammen, ich empfehle euch mal definitiv in "Temp" Verzeichnis eures Browsers zu schauen. Es war für mich erschreckend, wie viele wichtige Dokumente und ...

Off Topic
Klimaanlage im Serverraum
gelöst imebroVor 10 StundenFrageOff Topic19 Kommentare

Hallo, wir haben einen kleinen Serverraum (viell. 5 - 6 m²), in dem ein Serverschrank steht. Der Raum hat kein Fenster!!! Darin befinden sich ...

Netzwerkmanagement
Sicherheitsrisiken Synology DS Admin Konto
RitchtoolsVor 1 TagFrageNetzwerkmanagement6 Kommentare

Hallo Zusammen, ich habe die Pflege von einem Firmen NAS übernommen (Synology) es sind mehrere Rechner im Netzwerk die auf Daten zugreifen. Leider hat ...

Windows 10
Windows 10 hängt bei Neustart immer bei "Bitte warten" über Stunden
gelöst Odde23Vor 11 StundenFrageWindows 1023 Kommentare

Ich habe seit längerem, um genau zu sein seit gut einem Jahr, da wurde der Rechner gekauft, das Problem, dass der Rechner bei einem ...

Windows 10
Windows 10 System Recovery Ordner fast 60 GB - Wie löschen?
Looser27Vor 1 TagFrageWindows 106 Kommentare

Guten Morgen, bei einem unserer Clients funktioniert scheinbar das automatische Aufräumen nach Updates / Upgrades nicht. Wie kann ich dem Kollegen auf die Schnelle ...

Windows 10
Windows 10 verliert die Druckertreiber
KMP1988Vor 1 TagFrageWindows 1010 Kommentare

Servus zusammen, wir haben bei einem Kunden folgende Konstellation: - Server2019 (AD, DNS, DHCP) - Server2019 (Print-Server-Rolle) - W10-Clients Die Drucker werden übers Logon-Scirpt ...

DNS
Opendns.com - Kosten?
cordialVor 1 TagFrageDNS2 Kommentare

Moin, Ich möchte gerne den OpenDNS Dienst mal verstehen. Hab da schon länger einen Account mit Filterung. Die "Free" Edition bei OpenDNS ist doch ...