Windows Server 2003 SP2 - Event ID 55 - NTFS Dateisystemstruktur beschädigt.

Mitglied: Born4IT

Born4IT (Level 1) - Jetzt verbinden

17.10.2011 um 11:36 Uhr, 5680 Aufrufe, 14 Kommentare

Hallo werte Administratorengemeinde,

ich habe leider seit anfang letzter Woche folgendes Problem auf einem unserer Windows Server 2003 SP2.

Kurz zu den Systemdaten:

Intel Xeon 3,06 GHz
Windows Server 2003 SP2 aktueller Patchstand

ICP GDT8124RZ Hardware Raid
6 x 33,6 Gig Ultra 320 SCSI (3 x Raid 1)
4 x 147 Gig Ultra 320 SCSI (2 x Raid 1)

Laut Controller sind alle Platten in einem guten Zustand.
Jedoch habe ich auf der Partition D (liegt zusammen mit der Systempartition auf einem 147er Verbund) vermehrt NTFS-Fehler.
Einige Dateien lassen sich weder öffnen, noch löschen. Erst durch einen CHKDSK /F /D werden bei der Behebung einiger Indexfehler im Dateisystem betroffene Dateien entfernt, nicht repariert.

Ich habe auch schon den Beitrag von Olli325 "Event-ID 55 NTFS-Fehler" gelesen und den besagten MicrosoftPatch eingespielt.

Leider trat der Fehler dennoch erneut auf, was mich grad etwas ratlos macht. Ich hoffe ihr habt noch ein paar hilfreiche Tips.

Danke im Voraus

3e133c4ad438d420c0a4c5324005d2a6 - Klicke auf das Bild, um es zu vergrößern
Mitglied: SlainteMhath
17.10.2011 um 11:40 Uhr
Moin,

was mir dazu spontan einfällt:

- Ist der Schreibcache am RAID Controller aktiviert? Wenn Ja -> Abschalten
- Lass' mal (am Wochenende) einen memtest laufen.

lg,
Slainte
Bitte warten ..
Mitglied: Curb47
17.10.2011 um 11:49 Uhr
Hallo Born4IT,

bei Möglichkeit hol dir doch mal ein SysLog - Tool.

z.B. http://technet.microsoft.com/de-de/sysinternals/bb896645

und schau dir nach dem Bootvorgang (Bootlog aktivieren unter Optionen) bei welchem Verzeichnis er beschädigt angibt, vielleicht kannst du dieses entfernen und evtl. neu anlegen.

Lg

Curb
Bitte warten ..
Mitglied: Pjordorf
17.10.2011 um 11:59 Uhr
Hallo,

Zitat von @Born4IT:
Jedoch habe ich auf der Partition D (liegt zusammen mit der Systempartition auf einem 147er Verbund) vermehrt NTFS-Fehler.
Könnte nicht doch dein NTFS etwas abbekommen haben? Offline gehen. Parition Sichern (Image erstellen), Formatieren. Sicherung zurück (Image). Was sagt dann dein NTFS?

Ich habe auch schon den Beitrag von Olli325 "Event-ID 55 NTFS-Fehler" gelesen und den besagten MicrosoftPatch eingespielt.
Dann wirkt sich aber nur aus falls du eine Clustergröße kleiner 4096 Bytes bei der Erstellung gewählt hast. Hast du das?

Gruß,
Peter
Bitte warten ..
Mitglied: Born4IT
17.10.2011 um 12:02 Uhr
Hallo Slainte, hallo Curb,

Der Schreibcache ist deaktiviert.
Werde aber dennoch die Variante mit dem Memtest mal in Betracht ziehen.

Danke für den Tip mit dem Syslog, Curb.
Werde ich auch einmal durchführen und schauen was er mir sagt.

Gruß, Marco
Bitte warten ..
Mitglied: Born4IT
17.10.2011 um 12:11 Uhr
Hallo Peter,

Ich hatte gehofft das es das gute alte CHKDSK hinbiegen würde. Aber es besteht natürlich auch die Variante mit dem Defekt des NTFS.
Die Partition wurde damals mit einer Clustergröße von 4096 Bytes erstellt, ich war jedoch der Hoffnung das der Fehler damit dennoch behoben sein könnte (gibt mehrere solcher Aussgen in anderen Foren).
Ansonsten werde ich um eine Neuformatierung der Partition wohl nicht herum kommen.

Gruß, Marco
Bitte warten ..
Mitglied: Born4IT
18.10.2011 um 11:13 Uhr
Guten Morgen zusammen,

also meine Nachtschicht war leider nicht so erfolgreich. Folgendes hab ich durchgeführt:

- Dateiindizes per CHKDSK /F korriert
- Daten der betroffenen Partition wurden gesichert (Image)
- Partition neu formatiert (kein quickformat)
- Gesicherten Daten (Image) wieder zurück gespielt.

Nach dem erfolgreichen Start sah das Ereignisprotokoll erstmal ganz gut aus. Jedoch haben sich heute Morgen um 1 Uhr dann doch wieder NTFS-Fehler eingeschlichen. Meine Vermutung ist, das zu dem zeitpunkt das NTBackup auf die betroffenen Dateibereiche zugegriffen hat. Werde die Tage mal sowohl einen memtest machen, wie auch einen bootlogger mitlaufen lassen, in der Hoffnung das sich daraus Antworten ergeben.
Die hoffnung ist ehr gering das es sich scheinbar auf abgegrenzte Bereiche des NTFS zu beziehen scheint.

Hat sonst noch jemand eine Idee wie ich dem Hasen das Fell über die Ohren ziehen kann? Bin für jeden Rat dankbar.

Gruß, Marco
Bitte warten ..
Mitglied: SlainteMhath
18.10.2011 um 11:23 Uhr
- Daten der betroffenen Partition wurden gesichert (Image)
Aehm... bei defektem NTFS hätte sich ein File-Level-Backup angeboten (robocopy o.Ä.) mit einem Image spielst du dann das kaputte NTFS wieder drauf...
Bitte warten ..
Mitglied: Born4IT
18.10.2011 um 11:29 Uhr
Deine Aussage mal traurigerweise Sinn.

Also das ganze nochmal *g*. Nimmt Robocopy Standartmäig alle Berechtigungen mit oder muss ich diverse Freigabe- und NTFS-Berechtigungen neu setzen?

Danke
Bitte warten ..
Mitglied: SlainteMhath
18.10.2011 um 11:39 Uhr
Berechtigungen werden mit dem Switch /COPYALL mitgenommen. Freigaben musst du neu setzen.
Bitte warten ..
Mitglied: Born4IT
20.10.2011 um 13:32 Uhr
Hallo zusammen,

Hier schonmal ein kurzes Feedback zur aktuellen Lage:

- Files per robocopy auf eine Freigabe gesichert (robocopy "%source%" "%destination%" /E /B /COPYALL /R:1 /W:1 /LOG:robolog.txt /TEE)
- Bestehende Freigaben zwecks späterer Wiederherstellung notiert (ShareEnum aus der Sysinternals Suite hatte leider nicht alle User der Freigaben angezeigt)
- Partition Formatiert
- Files per Robocopy an den vorherigen Speicherort zurück kopiert

Erfreulicherweise konnte ich feststellen, dass W3K3 sich die Freigaben gemerkt hatte und sie nach dem kopiervorgang auf dem Ursprünglichen Speicherort auf die Ordner gesetzt hat.
Das System läuft jetzt wieder seit ca. 0:30 Uhr und bisher (13:30 Uhr) sind keine erneuten ID55-Fehler im Ereignisprotokoll geloggt.

Gruß, Marco
Bitte warten ..
Mitglied: goscho
20.10.2011 um 14:18 Uhr
Zitat von @Born4IT:
Hallo zusammen,
Hi Marco
Erfreulicherweise konnte ich feststellen, dass W3K3 sich die Freigaben gemerkt hatte und sie nach dem kopiervorgang auf dem
Ursprünglichen Speicherort auf die Ordner gesetzt hat.
Das System läuft jetzt wieder seit ca. 0:30 Uhr und bisher (13:30 Uhr) sind keine erneuten ID55-Fehler im Ereignisprotokoll
geloggt.
Jetzt noch die folgende Nacht mit der Sicherung durch NT-Backup abwarten und dann könnte dein Problem hoffentlich behoben sein.
Bitte warten ..
Mitglied: Born4IT
20.10.2011 um 15:14 Uhr
Hi Goscho,

Ich hoffe das es genau so läuft. Ich halte euch natürlich auf dem Laufenden und werde den Beitrag bei Erfolg als gelöst kennzeichnen.

gruß, Marco
Bitte warten ..
Mitglied: Born4IT
21.10.2011 um 07:52 Uhr
Guten morgen alle zusammen,

Gute Nachrichten von meiner Seite. NTBackup ist die Nacht gelaufen, das Dateisystem hat gehalten und ist noch konsistent.
Danke an alle die mich unterstützt haben. Wenn einer von euch im Umkreis von Zwickau wohnt kurze PM, wir suchen ne Bar und ich lass nen Bierchen springen *g*

Gruß und schönes Wochenende,

Marco
Bitte warten ..
Mitglied: SlainteMhath
21.10.2011 um 08:47 Uhr
Moin,

Freud mich das es wieder funktioniert :) face-smile

kurze PM, wir suchen ne Bar und ich lass nen Bierchen springen
*name notier* :) face-smile

lg,
Slainte
Bitte warten ..
Heiß diskutierte Inhalte
HTML
Ich brauche dringend Hilfe !
gelöst JulianpustVor 1 TagFrageHTML17 Kommentare

Hallo erstmal, ich habe großen Mist gebaut in der Firma wo ich gerade mal 2 Tage arbeite. Was ist passiert: Ich sollte von Gmail ...

Windows 10
Windows 10 schickt lokale Anfragen an das Gateway - was tun?
gelöst runthegaunzVor 1 TagFrageWindows 1015 Kommentare

Hallo! Ich bin vor ein paar Tagen wieder von Linux auf Windows umgestiegen. Ich hab die Windows 10 Version 20H2 installiert, wurde von Windows ...

Switche und Hubs
23 Cisco Switch einrichten - Wie am einfachsten?
gelöst Freak-On-SiliconVor 1 TagFrageSwitche und Hubs18 Kommentare

Hallo; Ich habe hier 4stk Cisco SX350X-24 9Stk Cisco SG350X-48P 10Stk Cisco SG350X-48 Diese werden aufgeteilt auf 9 Racks, und ersetzen alte HP Switches. ...

Exchange Server
Aktuelle Exchange Sicherheitslücke
jojo0411Vor 1 TagAllgemeinExchange Server11 Kommentare

Hallo Leute, Momentan gibt es da wieder einmal ein schönes neues Thema. Sehe ich das richtig das ich mit Exchange 2016 und CU 19 ...

Windows Server
Windows Firewall: Alle öffentliche IPs sperren bis auf eine
SabSchapVor 1 TagFrageWindows Server7 Kommentare

Hallo, wir haben einen Windows 2019 Server. Wir nutzen diesen als Webserver. Nun haben wir die Webadresse www.test.de und möchten diese für alle öffentlichen ...

Windows Server
Server-Internetverbindung kurz trennen und wieder aktivieren
gelöst imebroVor 1 TagFrageWindows Server11 Kommentare

Hallo, wir haben im Moment fast täglich immer wieder Ausfälle unserer Internetverbindung. Unser Provider sagt, dass er kein Problem feststellen kann. Aber wenn vom ...

LAN, WAN, Wireless
8 Geräte - verteilen oder auf einen Switch?
DoKi468Vor 18 StundenFrageLAN, WAN, Wireless10 Kommentare

Hallo liebe Admins, eine kurze Frage: Ich habe hier eine FB 6190 Cable stehen sowie einen noch unmonitored switch mit 8 Anschlüssen. Momentan sieht ...

Netzwerke
Smarthome Heimnetzwerk absichern
hell.wienVor 1 TagFrageNetzwerke12 Kommentare

Hallo. Ich mach mir gerade gedanken wie ich meine neue Wohnung sicher mache Überischthalber zur Hardware: Vorhanden: Modem APU4D4 Cisco SG250X-24P Mikrotik cAP ac ...