antenope
Goto Top

ESET Installationsprobleme mit Windows 10 - Lösung inside

Hallo zusammen,
viele Jahre habe ich jetzt hier Beiträge gelesen und Lösungen gesucht. Ich denke es ist nun an der Zeit auch etwas beizutragen.


Viele von euch werden ebenfalls so wie ich ESET im Einsatz haben. Seit dem Mai Update habe ich aber erhebliche Installationsprobleme gehabt bis ich nach der absoluten Verzweiflung auf die recht simple Lösung gestoßen bin.


Fehlerbild:
  • Die ESET-Proudkte installieren sich zwar, haben aber schon beim Setup Probleme (z.B. Dienst kann nicht gestartet werden)
  • Der Erstscan braucht ewig und kann nicht abgebrochen werden
  • Die GUI reagiert nicht mehr bzw. zeigt nichts mehr an
  • Ein Neustart legt den Rechner komplett lahm (Explorer, ESET, nichts reagiert mehr)
  • Echtzeitschutz aktiviert sich nicht

Ursache:
  • Das Problem tritt auf wenn das Mai-Update VOR ESET installiert wird
  • ESET kann den Defender nicht korrekt deaktivieren und sich nicht korrekt im Sicherheitscenter einbetten / wird von diesem nicht erkannt
  • Defender + ESET sind dann aktiv und "kämpfen" gegeneinander (beste Lösung = komplette Neuinstallation)

Lösungen:
  • Ganz simpel, ESET vor dem Mai-Update installieren und erst dann Updaten. Das Update zerstört keine bestehende Installation.
  • Manuell folgende Registry-Schlüssel setzten
"HKLM\SYSTEM\CurrentControlSet\Services\SecurityHealthService" --> "Start" (als D_WORD) und dem Wert "4" = Startmodus manuell
"HKLM\SOFTWARE\Policies\Microsoft\Windows Defender" --> "DisableAntiSpyware" (als D_WORD) und dem Wert "1" = Deaktiviert Windows Defender

Ich bevorzuge die erste Lösung, da man bei den Reg-Schlüsseln nicht sicher sein kann was diese ggf. später für Auswirkungen haben könnten (Stichwort Funktionsupdates).


Naja vielleicht erspare ich ja dem einen oder anderen damit viel Zeit ;)

p.s. solltet ihr die ERA-VM im Einsatz haben, macht ein Produktupdate und erstellt stets neue Installationsmodule beim Einrichten neuer Rechner. Ist die ERA-Version alt, läd dieser nur die alten Installationsmodule!

Content-Key: 342142

Url: https://administrator.de/contentid/342142

Printed on: April 21, 2024 at 02:04 o'clock

Member: mathu
mathu Jul 03, 2017 at 06:14:46 (UTC)
Goto Top
Ist vielleicht ESET in dem Fall nicht ganz aktuell, bzw. angepasst an das Mai Update? Vielleicht hat der Hersteller mittlerweile schon eine neue Version, die das Phänomen behebt? face-smile
Member: anteNope
anteNope Jul 03, 2017 updated at 07:20:05 (UTC)
Goto Top
So sieht es aus ;)

Angefangen hatte das mit 3 Notebooks und NOD32 Antivirus. Auf einem zerstörte die Installation nachhaltig das System. Der ESET Support meinte nur "nein uns ist das nicht bekannt", worauf hin ich das als Einzelfall abtat, aber dennoch ein ausführliches Support-Ticket erstellt hatte.

Ein paar Tage drauf hatte ich dann ebenfalls massive Probleme mit der Endpoint-Antivirus in Verbindung mit ERA. Üblicher Weise erstelle ich ein neues Installations-Modul, dass dieses aber dann immer noch alt ist, so lange der ERA nicht aktualisiert wurde, kann ja keiner Wissen (ein Hinweis wäre nett). Der Installationsfehler trat dann aber auch mit der ganz aktuellen Version auf (2. Neuinstallation). Dem Support sei das immer noch nicht bekannt ... Bis ich mich erinnerte, dass es ein Update mit Bezug auf den Defender gab, dauerte es etwas und dann lag die Lösung auf der Hand.

Also neues Support Ticket, diesmal noch ausführlicher. Zig Tage drauf kam dann die Antwort "das Problem sei bekannt" mit der Aussage die Entwicklung arbeite daran, terminlich aber nicht fix ... ... DAS wäre mal einen Newsletter wert ;)

Wie dem auch sei, ich habe bisher noch keine weitere Rückmeldung auf die Tickets, also gehe ich davon aus, dass das noch nicht behoben ist ;)
Naja jedenfalls habe ich nicht den Drang danach das auszutesten und wollte euch das ebenfalls ersparen ;)
Member: transocean
transocean Jul 03, 2017 at 17:52:25 (UTC)
Goto Top
Moin,

ich habe gerade Eset Endpoint Antivirus Version 6.5.2107.1 auf einem frischem Windows 10 Enterprise installiert und hatte keinerlei Probleme.

Gruß

Uwe
Member: anteNope
anteNope Jul 03, 2017 updated at 20:32:20 (UTC)
Goto Top
Die Frage ist, ob du es vor der Installation von ESET auf den aktuellsten Stand gebracht hast. Und ist bei der Enterprise überhaupt der Defender enthalten / aktiv?

Aber wenn das nun wieder geht, um so besser =)
Member: anteNope
anteNope Jul 04, 2017 at 09:31:02 (UTC)
Goto Top
Moin,

die "Endpoint Antivirus Version 6.5.2107.1" ist die aktuelle Version. Bei der steht im Changelog der Bugfix zum Problem. Dennoch bitte dran denken bei der Erstellung der Installationsmodule vorher den ERA bzw. die Appliance zu aktualisieren =)

Bei der NOD32 z.B. fehlt der Bugfix aber noch.