Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Mitglied: colinardo

colinardo (Level 5) - Jetzt verbinden

22.11.2017, aktualisiert 02.02.2018, 3695 Aufrufe, 10 Kommentare, 13 Danke


Einleitung

Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal auf SSL umstellen wollte (Sollte ja heute Pflichtprogramm sein). Nötig dafür ist natürlich ein gültiges Zertifikat so dass bei den Usern keine Warnungen aufpoppen. Da ein kostenpflichtiges Zertifikat nicht in Frage kam, dachte ich mir, lösen wir es mit Let's Encrypt Zertifikaten. Problem: Mikrotik bietet keine Möglichkeit solche Zertifikate automatisiert zu erneuern und alle 3 Monate manuell erneuern geht ja gar nicht . Also dachte ich mir, ran an ans Werk und nachrüsten. Natürlich kann man das Generieren der Zertifikate auch auf andere Systeme auslagern(Cloud/Azure/AWS/Raspi) und nur die Zertifikate am Mikrotik downloaden lassen, aber hier ging es vornehmlich darum, das Ganze ohne weitere zusätzlich Strom fressenden Systeme gänzlich allein auf dem Router zu realisieren.

In den nachfolgenden Punkten erläutere ich euch die notwendigen Schritte um ein Let's Encrypt Zertifikat abzurufen und in den Speicher des Mikrotik zu importieren um es anschließend in den Hotspot einzubinden. Grundsätzlich ist der Ablauf folgender:
  • Anlegen einer METARouter-Instanz
  • Anpassen der Instanz mit den nötigen Tools
  • Erzeugen von SSH-Keys für den automatisierten Login auf den Webspace und dem Mikrotik (Zur Verifizierung bei Let's Encrypt wird der Webspace der Domain für welche das Zertifikat erzeugt werden soll temporär per SSHFS eingebunden.)
  • Einfügen eines Skripts zur Erneuerung des Zertifikats
  • Skript in den Autostart der Instanz einfügen, so dass es beim Booten automatisch gestartet wird
  • Skript kopiert erzeugtes Zertifikat und privaten Schlüssel per SCP zurück in den Speicher des Mikrotik.
  • Ein Mikrotik-Skript startet dann das ganze und lässt sich via Scheduler z.B. alle 60 Tage für die Verlängerung des Zertifikats ausführen

In diesem Beispiel erneuere ich das Hotspot-Zertifikat. Das Mikrotik-Script kann natürlich jeder auf seine Bedürfnisse anpassen, wenn z.B. das Zertifikat für eine andere Komponente auf dem Mikrotik verwendet werden soll.

1. Hinweise

Da die Anleitung das Feature MetaROUTER des Mikrotik verwendet kommen folgende Geräte in Frage
https://wiki.mikrotik.com/wiki/Manual:Metarouter
Currently MetaRouter can be used on

RB400, RB700 series except models with SPI flash, RB900 series except models with SPI flash, RB2011 boards
Listed PPC boards: RB1000, RB1100, RB1100AH and RB800.
Euer Mikrotik sollte genügend freien RAM (für die METARouter Instanz ca. 16-32MB) und NAND-Speicher haben.
Als Spielwiese kam ein RB951G-2HnD mit 128MB RAM und 128MB Speicher zum Einsatz.
Die Instanz begnügt sich normalerweise mit sehr wenig RAM (ca. 10MB), bei Bedarf lässt sich sich auch noch weiter abspecken, aber das lass ich euch .

2. Meta-ROUTER Image herunterladen und installieren

  • Für die MIPS Architektur dieses OpenWRT Image herunterladen (Für andere Architekturen müsst Ihr euch ein eigenes Image bauen):
  • http://download.bmsoft.de/mikrotik/12.09/metarouter/mr-mips/openwrt-mr- ...
  • Das Archiv so wie es ist in den Speicher des Mikrotik kopieren (Drag n' Drop in die Winbox / SFTP / FTP)
  • Nun erstellen wir einen neuen Meta-ROUTER mit dem Image (Bitte das Häkchen bei enable raus nehmen, da wir vor dem Start der VM erst noch ein Netzwerkinterface hinzufügen müssen)

screenshot - Klicke auf das Bild, um es zu vergrößern

Alternativ als Shell-Befehl:
/metarouter import-image file-name=openwrt-mr-mips-rootfs.tar.gz memory-size=32 enabled=no


  • Jetzt benötigen wir ein Netzwerk-Interface für die Instanz

Folgende Einstellungen vornehmen:

Virtual-Machine: <Bitte aus dem Dropdown auswählen>
Type: Dynamic
Dynamic-MAC-Address: <wird vom Mikrotik generiert, kann bei Bedarf geändert werden>
Bridge-Interface: <Das Bridge-Interface wählen welchem dieses Interface dynamisch hinzugefügt wird>
VM MAC-Address: <wird vom Mikrotik generiert, kann bei Bedarf geändert werden>


screenshot - Klicke auf das Bild, um es zu vergrößern

Alternativ als Shell-Befehl:
/metarouter interface add virtual-machine=[/metarouter find] dynamic-bridge=<BRIDGE INTERFACE> type=dynamic


Damit ist die Instanz zum ersten Start bereit.

3. Anpassen der Meta-ROUTER Instanz


Los geht's. Starten der Instanz:

screenshot - Klicke auf das Bild, um es zu vergrößern

Alternativ als Shell-Befehl:
/metarouter enable MR1
/metarouter console MR1

Die Instanz startet nach dem Aktivieren automatisch und wird euch in der Spalte "Status" als "running" signalisiert.
Die Konsole des Meta-ROUTER erreicht ihr nun über das Kontextmenü > "Console", oder über den oben gezeigten Shell-Befehl. Drückt darin einmal ENTER um die Shell zu aktivieren.

screenshot - Klicke auf das Bild, um es zu vergrößern

Als erstes solltet ihr euch nun davon überzeugen das die Netzwerkkarte der Instanz Netzzugang hat (Wenn ihr eine statische IP bevorzugt, könnt ihr das in der Datei /etc/config/network nachholen).
Dazu ein ifconfig eintippen, ein route sollte das Default Gateway listen und ein Ping an eine Internetadresse sollte erfolgreich sein.

screenshot - Klicke auf das Bild, um es zu vergrößern

Nun fehlen uns noch einige Tools und Einstellungen. Ich habe der kürze halber der nötigen Befehle hier im Kasten zusammengefasst und jeweils kommentiert
# disable firewall and dropbear ssh agent
/etc/init.d/firewall stop && /etc/init.d/firewall disable
/etc/init.d/dropbear stop && /etc/init.d/dropbear disable
# load current package list
opkg update
# remove dropbear ssh client (we use openssh client instead)
opkg remove dropbear
# install needed packages
opkg install wget openssh-client openssl-util sshfs openssh-keygen
# make wget globally ignore certificates
echo "check_certificate = off" >>~/.wgetrc
# download acme.sh and install(ignore warning about missing 'socat', it's not needed.
wget -O - https://get.acme.sh | sh
In meinem Beispiel hat ist der Webspace per SSH/SCP erreichbar welchen wir nun in ein Verzeichnis in der Instanz mounten wollen. Damit das in der Zukunft natürlich automatisch ohne Passworteingabe passiert erzeugt ihr euch ein Keypair, gängige Praxis die ich euch sicherlich nicht nochmal detailliert vorbeten muss, oder .
Kurzfassung:
ssh-keygen -t rsa
eingeben und alle Eingaben mit Enter bestätigen (kein Passwort für den Schlüssel vergeben!).
Den Inhalt des PublicKeys (/root/.ssh/id_rsa.pub) solltet ihr nun auf dem Webspace in die Datei ~/.ssh/authorized_keys kopieren. Abschließend testet ihr den Zugang zum Webspace mit
01.
ssh user12345@sftp.mywebspace.de
Ein Login sollte dann ohne Passwortabfrage erfolgen.

Das gleiche brauchen wir für den Transfer der nach generierten Zertifikate auf den Mikrotik. Für diese Aufgabe erzeugt man besten einen extra User am Mikrotik dem man dann den generierten Public-Key importiert. Anleitung dazu siehe:
https://jcutrer.com/howto/networking/mikrotik/routeros-ssh-publickeyauth ...
(ACHTUNG: Damit ihr euch nicht vom Mikrotik ausperrt wenn Ihr den Private-Key nicht aus dem Meta-ROUTER gesichert habt, achtet darauf das ihr den Key nicht dem admin zuweist denn sonst kommt ihr ohne Key-Auth nicht mehr auf den Mikrotik) -Anmerkung der Redaktion:-> Oh, ja ist mir selbst auch schon passiert , hatte die Keys aber gesichert und brauchte somit kein Backup zurückspielen.

Jetzt erstellen wir das Skript welches das Zertifikat bei Let's Encrypt abruft und auf den Mikrotik transferiert.
Dazu eine leere Datei erstellen mit
vi /root/generate_certificate
Nun i drücken und folgendes Skript einfügen:
Dabei gibt es diese Variablen die es an eure Umgebung anzupassen gilt:

DOMAIN = <COMMON-NAME des Zertifikats das erzeugt werden soll>
WEBROOT = <Das lokale Verzeichnis in welchem wir den Webspace temporär mounten (Dient zur Verifikation von Let's Encrypt)>
WEBSPACE = <Benutzerkennung und Host eures Webspace>
MIKROTIKSSHHOST = <Benutzerkennung und Host/IP unter der der Mikrotik per SSH seinen Speicher zur Verfügung stellt>
MAXWAITINET = <Zeit in Sekunden wie lange das Skript max. auf eine Internetverbindung wartet.>


01.
#!/bin/sh
02.
# BEGIN VARS
03.
DOMAIN=hotspot.domain.de
04.
WEBROOT=/root/webroot
05.
WEBSPACE=u123456@data.host:/
06.
MIKROTIKSSHHOST=script@10.10.1.1:/
07.
MAXWAITINET=120
08.
# END VARS
09.

10.
# check Internet-Connection
11.
TRIES=0
12.
while ! ping -c 1 google.de >/dev/null 2>&1 ;do   
13.
	if [ $TRIES -ge $MAXWAITINET ] ;then
14.
	    logger "ERROR, NO INTERNET!"
15.
            echo "ERROR, NO INTERNET!"
16.
	    exit
17.
    fi
18.
    TRIES=$(($TRIES + 1))
19.
    sleep 1
20.
done
21.

22.
logger "### START generating certificates ###"
23.
# create webroot mount directory
24.
mkdir "$WEBROOT" 2>/dev/null
25.
# unmount if already mountet
26.
umount "$WEBROOT" 2>/dev/null
27.
# mount  webspace root to local directory
28.
sshfs "$WEBSPACE" "$WEBROOT" -o allow_root
29.
# renew certificate
30.
/root/.acme.sh/acme.sh --issue --webroot "$WEBROOT" -d $DOMAIN --force --log --log-level 2
31.
if [ $? -ne 0 ] ;then
32.
  logger "Error generating certificates with Let's Encrypt, please check '/root/.acme.sh/acme.sh.log'"
33.
  exit 1
34.
fi
35.
# scp certificate and key to Mikrotik
36.
scp /root/.acme.sh/${DOMAIN}/${DOMAIN}.cer /root/.acme.sh/${DOMAIN}/${DOMAIN}.key $MIKROTIKSSHHOST
37.
# unmount webspace
38.
umount "$WEBROOT"
39.
logger "### END generating certificates ###"
Nun drückt in VIM ESC und abschließen schreibt :wq! zum Speichern des Skripts.
Jetzt noch ausführbar machen mit
chmod +x /root/generate_certificate
Das Mounten des Webspace (sshfs) solltet ihr vorher erst mal manuell testen, genauso wie das Verbinden mit dem Mikrotik-Speicher (via ssh oder scp). Das muss nun alles ohne Passworteingabe funktionieren, wenn nicht müsst ihr das erst beheben bevor ihr hier weiter macht.

Damit das Skript beim Booten der Meta-ROUTER Instanz automatisch startet fügen wir in die Datei /etc/rc.local vor dem exit 0 noch folgende Zeile ein:
/root/generate_certificate
Sollte nun soweit alles geklappt haben könnt Ihr des Skript das erste mal testen und es mit einem
/root/generate_certificate
starten. Hat alles geklappt findet Ihr die Zertifikate einmal in der Instanz selbst unter /root/.acme.sh/<COMMON-NAME>, und im Root des Mikrotik -Speichers abgelegt. Erst wenn das erfolgreich war fahrt ihr weiter mit der Anleitung fort.

4. Mikrotik-Skript zum installieren der Zertifikate anlegen

Jetzt verlassen wir die Instanz des Meta-ROUTER erst mal mit exit (Fenster könnt ihr dann schließen), und arbeiten weiter in Winbox.
Das nächste Mikrotik-Skript erledigt nun nachstehende Aufgaben
  • Starten des Meta-Routers
  • Importieren der Zertifikate in den Zertifikate-Speicher des Mikrotik
  • Aktualisieren Hotspot-Profils
  • Stoppen des Meta-Routers (Ein Dauerlaufen ist hier ja nicht nötig).
Das Skript hat folgende Variablen die angepasst werden müssen:

COMMONNAME = <Common-Name eures Zertifikats>
HOTSPOTPROFILE = <Der Name des zu aktualisierenden Hotspot-Profils>
METAROUTERNAME = <Name eures Meta-ROUTERS>
MAXWAIT = <Maximale Zeit in Sekunden die das Skript auf die neu erzeugten Zertifikate wartet>

01.
# BEGIN VARS
02.
:local COMMONNAME "hotspot.domain.de"
03.
:local HOTSPOTPROFILE "hotspot_gast"
04.
:local METAROUTERNAME "MR1"
05.
:local MAXWAIT 300
06.
# END VARS
07.

08.
:local TRIES 0
09.
:local ERROR false
10.
# start metarouter instance
11.
/metarouter enable $METAROUTERNAME
12.
# wait until certificates are generated and transfered from metarouter instance
13.
:while ((([:len [/file find name="$COMMONNAME.cer"]] + [:len [/file find name="$COMMONNAME.key"]]) < 2) && !$ERROR) do={
14.
	if ($TRIES <= $MAXWAIT) do={
15.
                    :set TRIES ($TRIES+1)	
16.
                    :delay 1
17.
	} else={
18.
                    /log error message="Error renewing certificate, certificate was not generated in time! Please check METARouter logs."
19.
	            :set ERROR true
20.
	}
21.
}
22.
if (!$ERROR) do={
23.
	/certificate
24.
	# remove old certificates
25.
	remove [find where common-name="$COMMONNAME"]
26.
	# import new certificate
27.
	import file-name="$COMMONNAME.cer" passphrase=""
28.
	import file-name="$COMMONNAME.key" passphrase=""
29.
	# update hotspot profile ssl certificate
30.
	/ip hotspot profile set "$HOTSPOTPROFILE" ssl-certificate=[/certificate find where common-name="$COMMONNAME"]
31.
	# remove certificate files
32.
	/file remove "$COMMONNAME.cer"
33.
	/file remove "$COMMONNAME.key"
34.
}
35.
# Stop metarouter instance
36.
/metarouter disable "$METAROUTERNAME"
Das Skript legt ihr unter /system scripts ab und speichert es:

screenshot - Klicke auf das Bild, um es zu vergrößern

Automatisch gestartet werden kann es dann wie gewohnt mit dem Scheduler (z.B. alle 60 Tage):

screenshot - Klicke auf das Bild, um es zu vergrößern

5. Schlusswort

Bei der Verifikation des Let's Encrypt Zertfikats seit ihr natürlich frei das auf DNS-Verify etc. umzustellen. Das hier war ein einfaches Beispiel bei dem der Kunden seinen Webspace und die Domain bei 1und1 hatte und da bot es sich an den Webspace per SSHFS einzubinden.
Man sieht, mit Meta-ROUTERN lässt sich eine Menge realisieren die ein Mikrotik von selbst nicht anbietet. Auch ganz nützlich z.B. ist eine Asterisk Instanz, macht z.B. eine Fritz!box dann gänzlich überflüssig beim "kleinen Kunden" .

Noch ein wichtiger Hinweis wenn ihr fleißig Zertifikate im Test erstellt und erneuert: Achtet auf die Limits von Let's Encrypt, z.B. maximal 5 Zertfikate von ein und der selben Domain pro Woche (sliding Window). Hier einzusehen:
Rate Limits - Let's Encrypt - Free SSL/TLS Certificates
Also nicht übertreiben, sonst gibt euch das Skript einen Fehler ala 429 too many requests aus .

Hoffe die Anleitung ist dem ein oder anderen von Nutzen .

Wie immer gilt: Nutzung auf eigene Gefahr.

Nun viel Spaß beim Basteln an eurem eigenen Projekt.

Grüße @colinardo

Falls euch der Beitrag gefällt, könnt ich euch auch gerne jederzeit mit einer kleinen Spende erkenntlich zeigen, wenn euch danach ist.
Mitglied: Frank
22.11.2017 um 19:37 Uhr
Klasse, danke für die Anleitung

Gruß
Frank
Bitte warten ..
Mitglied: colinardo
22.11.2017, aktualisiert um 19:42 Uhr
Gerne, nur das Apostroph bei Let's Encrypt bekomme ich leider nicht in den Titel, aber wat solls .
Bitte warten ..
Mitglied: 134464
22.11.2017 um 19:47 Uhr
Geil . Kann ich echt gut gebrauchen!
Das gibt wieder massig Stoff für kühle Wintertage .

Gruß @Specht
Bitte warten ..
Mitglied: Vision2015
22.11.2017 um 19:55 Uhr
Super...

Danke für deine Mühe...

Frank
Bitte warten ..
Mitglied: aqui
23.11.2017 um 09:38 Uhr
Klasse Tutorial !
Nun fehlt nur noch eine Version für das pfSense Captive Portal
Bitte warten ..
Mitglied: colinardo
23.11.2017, aktualisiert um 10:45 Uhr
Zitat von aqui:
Klasse Tutorial !
Hi @aqui, freut mich das es gefällt .
> Nun fehlt nur noch eine Version für das pfSense Captive Portal
Zur pfSense: Das platzsparende ACME-Package das ich auch in obiger Anleitung als einfaches *.sh Skript verwende gibt es bereits als fertiges Package für die pfSense (2.3.2-p1 and later):
Siehe: https://doc.pfsense.org/index.php/ACME_package

Grüße Uwe
Bitte warten ..
Mitglied: aqui
23.11.2017 um 10:59 Uhr
Stimmt, du hast Recht ! Das muss ich gleich mal testen
Bitte warten ..
Mitglied: Penny.Cilin
23.11.2017 um 11:13 Uhr
Moin und Danke @colinardo

das ist Klasse. Einen schönen Tag noch allesamt.

Gruss Penny
Bitte warten ..
Mitglied: horstvogel
05.12.2017 um 13:30 Uhr
Hallo,
das ACME Package nutze ich schon eine ganze Zeit. Die Erneuerung des Zertifikates funktioniert. Leider habe ich das immer noch keine Lösung gefunden, wie ich die automatische Import in den Squid Reverse Proxy. Vielleicht könnt Ihr mir einen Hinweis geben.
Danke!

https://www.administrator.de/forum/pfsense-acme-packages-refresh-crl-squ ...
Bitte warten ..
Mitglied: colinardo
05.12.2017, aktualisiert um 16:44 Uhr
@horstvogel : Siehe meinen Kommentar dazu in deinem Thread.

Grüße Uwe
Bitte warten ..
Ähnliche Inhalte
Verschlüsselung & Zertifikate
Auf Lets Encrypt wechseln
Erfahrungsbericht von wiesi200Verschlüsselung & Zertifikate3 Kommentare

Hallo, nach dem Theater was aktuell bei StartCom herrscht welches ich aktuell als Zertifikats Anbieter nutzte hab ich mich ...

Router & Routing
Lets Encrypt kommt auf die FritzBox
Information von 134464Router & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Verschlüsselung & Zertifikate

Lets Encrypt stellt nun auch Wildcard-Zertifikate aus

Information von em-pieVerschlüsselung & Zertifikate

Für alle, die sich mit der Thematik "Zertifikate" etwas mehr beschäftigen und dabei Let's Encrypt in Betracht ziehen respektive ...

Sicherheit

MikroTik-Router patchen, Schwachstelle wird ausgenutzt

Information von kgbornSicherheit

Am 23. April 2018 wurde von Mikrotik ein Security Advisory herausgegeben, welches auf eine Schwachstelle im RouterOS hinwies. Mikrotik ...

Neue Wissensbeiträge
Internet

Kommentar: Bundesregierung erwägt Ausschluss von Huawei im 5G-Netz - Unsere Presse wird immer sensationsgieriger

Information von Frank vor 1 TagInternet4 Kommentare

Hier mal wieder ein schönes Beispiel für fehlgeleiteten Journalismus und Politik zugleich. Da werden aus Gerüchten plötzlich Fakten, da ...

Windows 10

Netzwerk-Bug in allen Windows 10-Versionen durch Januar 2019-Updates

Information von kgborn vor 1 TagWindows 101 Kommentar

Nur ein kurzer Hinweis für Admins, die Windows 10-Clients im Portfolio haben. Mit den Updates vom 8. Januar 2019 ...

Windows 10

Windows 10 V1809: Rollout ist gestartet - kommt per Windows Update

Information von kgborn vor 1 TagWindows 102 Kommentare

Eine kurze Information für die Admins, die Windows 10 im Programm haben. Microsoft hat die letzte Baustelle (die Inkompatibilität ...

Sicherheit

Heise Beitrag Passwort-Sammlung mit 773 Millionen Online-Konten im Netz aufgetaucht

Information von Penny.Cilin vor 2 TagenSicherheit6 Kommentare

Auf Heise Online ist folgender Beitrag veröffentlicht worden: Heise Beitrag passwörter geleakt Ich bin mir jetzt nicht ganz sicher, ...

Heiß diskutierte Inhalte
Batch & Shell
Mit findstr batch doppelte zeilen einer txt löschen
Frage von Burningx2Batch & Shell24 Kommentare

Hi Vor einer weile habe ich im netzt einen windows shell befehl gefunden mit welchem man über die konsole ...

Verschlüsselung & Zertifikate
Netzwerkfreigabe Verschlüsselung
Frage von grill-itVerschlüsselung & Zertifikate20 Kommentare

Moin zusammen, sicher nutzen hier die ein oder anderen ein Produkt zur Verschlüsselung von Netzwerkfreigaben/-laufwerken auf denen hochsensible Daten ...

Debian
OpenSSH Login mit Public Key schlägt fehl, mit Passwort funktioniert
gelöst Frage von DKowalkeDebian19 Kommentare

Hallo zusammen, ich hatte hier schon nach einer Anleitung für einen SFTP Server mit Linux gefragt, habe dort auch ...

Microsoft
Übertragung von MS Volumenlizenzen
Frage von SherlockineMicrosoft18 Kommentare

Ich bin Angestellte in einer kleinen 10-köpfigen IT-Firma, die Netzwerklösungen, Telefonielösungen und Ähnliches anbietet. Im Sommer hatten wir einen ...