Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Active Directory umziehen innerhalb Windows Server 2003

Mitglied: 2Leasy
Hallo,

ich habe den Auftrag bekommen einen alten Windows 2003 Server, durch einen neuen (Hardware) zu ersetzen und
alle Daten und Einstellungen dabei zu übernehmen.

Ich muss dazu sagen, dass ich in dem Bereich Serversysteme nur mit gesundem Halbwissen gesegnet bin, die Organisation für die ich dies mache sich jedoch einen "richtigen" Profi-Admin nicht leisten kann.

Nun gut, ich habe im Prinzip auch alles auf den neuen Rechner übertragen können, dabei bin ich wie folgt vorgegangen (zum Nachvollziehen, evtl. is da schon ein Fehler):

- Neuen Rechner in das Netzwerk eingehängt
- Einzeln die Funktionen übertragen (DNS, DHCP, Div. Einstellungen)
- Installation von Active Directory
- Einfügen als Zusätzlicher Domain Controller
- Replizieren der AD Daten auf den neuen DC

So, hiermit dachte ich, das meine Arbeit getan sei, doch als ich den alten Server abschaltete funktionierte das Anmelden der Clients im Netz nicht mehr....Ich hab den Server dann wieder reaktiviert und dort nacheinander alle Funktionen abgeschaltet (und immer wieder getestet), bis letztlich nur noch das AD über war. Alle Funktionen ausser das AD scheinen also sauber und autark auf dem neuen Server zu laufen.

Ich habe mich dann mal schlau gelesen und herausgefunden, das noch einige zusätzliche Arbeiten nötig sind um das AD auf einen neuen DC zu übertragen.

- 5 FSMO Rollen übertragen ---> Habe ich gemacht und "netdom query fsmo" zeigt alle 5 Rollen bei dem neuen Server
- Globaler Katalog ---> ist eingetragen bei dem neuen Server

Trotzdem will es einfach nicht funktionieren....


Ich habe daher DCDiag laufen lassen und dies ergab etliche Fehlermeldungen, die ich allerdings nicht richtig deuten kann (will die gesamte Auswertung erstmal nicht posten, zu viele pers. Daten drin). Zusammenfassend scheint es noch irgendwo Verbindungen zum alten Server zu geben, die das System daran hindern den neuen DC als einzigen und autarken anzusehen. Vor allem folgende Passage in der Auswertung wundert mich: (SPP ist die zu übernehmende Domäne, DCDiag lief auf dem neuen Server, der alte ist deaktiviert)


DC discovery test. . . . . . . . . : Failed
[FATAL] Cannot find DC in domain 'SPP'. [ERROR_NO_SUCH_DOMAIN]


DC list test . . . . . . . . . . . : Failed
'SPP': Cannot find DC to get DC list from [test skipped].


Trust relationship test. . . . . . : Skipped


Kerberos test. . . . . . . . . . . : Skipped
'SPP': Cannot find DC to get DC list from [test skipped].


LDAP test. . . . . . . . . . . . . : Failed
Cannot find DC to run LDAP tests on. The error occurred was: Die angegebene
Domõne ist nicht vorhanden, oder es konnte keine Verbindung hergestellt werden.


Da ich langsam wirklich nicht mehr weiß, wo ich den Fehler noch zu suchen habe und einfach mein Fachwissen hier auch an seine Grenzen stößt (eigentlich bin ich schon lange drüber, aber man liest sich so durch), brauch ich mal professionelle Hilfe

Vielen Dank schonmal für eure Bemühungen und ich hoffe die Informationen sind ausreichend, wenn nicht, sagt mir,
was ihr noch wissen müsst

Gruß
2Leasy

Content-Key: 66528

Url: https://administrator.de/contentid/66528

Ausgedruckt am: 28.09.2021 um 06:09 Uhr

Mitglied: Karo
Karo 18.08.2007 um 16:50:11 Uhr
Goto Top
Hi,

was ich nicht verstehe:

- Installation von Active Directory

Wieso? Du installierst den neuen server und hängst ihn in die vorhandene Domain als Member. Dann machst Du DCPromo in die schon vorhandene Struktur. DNS einrichten (Den neuen auch als primären setzen, auch darauf achten das die DNS Server sich selbst als primären in der Netzwerkverwaltung haben. Und das per 127.0.0.1), GC setzen, WARTEN(!), FSMO Rollen übertragen. Und Du solltest WARTEN. Die Replikation aller Sachen kann unter Umständen recht dauern.

Zu guter letzt musst Du beim alten ein DCPROMO zwecks demote machen, damit er sauber aus dem AD als DC entfernt wird.

Karo
Mitglied: 2Leasy
2Leasy 18.08.2007 um 17:03:52 Uhr
Goto Top
Hallo Karo,

danke erstmal für die schnelle Antwort....

Nun, es kann ja sein, das ich bei einigen Aktionen, die ich durchgeführt habe, etwas vorschnell gewesen bin (ich hatte ja das mit dem Halbwissen erwähnt).

Beispielsweise DNS: Ich hab da ausser der Nutzung des Assistenten und der Anpassung von Daten, die ich im alten Server gesehen habe nichts weiter gemacht....Vielleicht war das ja falsch, ich weiß es nicht. Oder ich hab was vergessen oder übersehen?

Ich habe jetzt in den letzten Stunden soviel gefummelt und gemacht, das ich selbst nicht mehr genau weiß, was hier Stand ist...Ich versuche jetzt mal einen Zustand herzustellen, das beide als primäre DC in der Domäne eingetragen sind und alle 5 FSMO Rollen beim neuen Server liegen...

Das mit dem DNS muss ich mir allerdings genau anschauen....da kenn ich mich auch so überhaupt nicht aus

Gruß
2Leasy
Mitglied: Karo
Karo 19.08.2007 um 17:23:29 Uhr
Goto Top
Hi Ya,

ich hoffe Du hast ein Backup vor Deinen Eingriffen. Ansonsten rate ich Dir jemanden hinzuzuziehen, der sich mit dr Materie besser auskennt. Nicht umsonst bilden sich viele, mich eingeschlossen, über Jahre weiter, zertifizieren sich etc etc. Bitte nicht falsch verstehen, aber kannst Du Deinen Vorgesetzten die hundertprozentige Aussage geben, daß das AD auch in einem Jahr noch problemlos läuft? Ich fände das grob fahrlässig und Du solltest Dir genau überlegen, ob Du Deinen Job in Gefahr bringen willst. Wenn Deine Firma nicht mehr arbeiten kann .... <grübelgrübel>

Bye

Karo
Mitglied: 2Leasy
2Leasy 20.08.2007 um 07:39:58 Uhr
Goto Top
Guten Morgen,

Na ja....bzgl. des Hinzuziehens habe ich ja diesen Post hier im Forum aufgemacht in der Hoffnung, das es nur ein oder zwei Kniffe waren/sind, die ich übersehen habe...Scheinbar ist dem aber nicht so.

Was das System hier angeht...Nun, zum einen ist es keine Firma und zum anderen sind sie auf das Teil nicht zwingend angewiesen...Nur steht der Server hier halt schon 2 Jahre und das jetzt alles zurückzubauen, nur weil ich das nicht "auf die Reihe bekomme", das will ich irgendwie nicht hinnehmen (und die Leute, die sich hier an die Vorzüge eines solchen Systems gewöhnt haben auch nicht :-) face-smile )

Natürlich hat ein Admin, mit zig Zertifikaten und Jahrelanger Erfahrung mehr drauf als ich, aber den könnte hier auch keiner bezahlen (ich weiß, was das so kostet), wobei ich nicht sagen will, dass so ein Wissen das Geld nicht wert ist....im Gegenteil


So, zurück zum eigentlichen Thema:

Ich habe es geschafft, das AD auf dem neuen Server wieder zu entfernen und habe es neu installiert, so wie Du es beschrieben hast...derzeit scheint die Replikation zu laufen, ich warte das gerade mal ab und schau mal, ob das dann einwandfrei klappt

Gruß
2Leasy
Mitglied: Karo
Karo 20.08.2007 um 08:15:10 Uhr
Goto Top
Moin,

wenn läuft freu ich mich natürlich mit Dir :-) face-smile

Das mit dem hinzuziehen meinte ich natürlich vorort. Es gibt auch Fachkräfte, die man für ein paar Stunden anmieten kann. Das lohnt sich nicht nur in Hinblick auf die laufende Umgebung, sondern dass man dabei auch was lernen kann.

Klar das es für Dein Ego klasse ist wenn es läuft :-) face-smile Wenn es nicht so schlimm ist, wenn das Teil wegbricht, dann kannst Du natürlich experimentieren. Ob das die anderen Leute ebenfalls so sehen steht allerdings auf einem anderen Blatt. ;-) face-wink

Schön wenn ich Dir helfen konnte :-) face-smile

bye

Karo
Heiß diskutierte Beiträge
info
Bundeswehr lässt Retro Funkgeräte für 600 Millionen Euro produzierenhacktorVor 1 TagInformationHardware13 Kommentare

Dachte zuerst das ist ein verspäteter Aprilscherz Die saufen da offensichtlich zu viel Club-Cola au banan. ...

question
Neue Verschlüsselung TLS 1.3eberhartIIVor 1 TagFrageDrucker und Scanner17 Kommentare

Hallo, es geht um eine Verschlüsselung, die die Telekom seit 02. September 2021 einsetzt. Ab diesem Datum müssen die E-Mails mit dem Schlüssel TLS 1.3 ...

question
Zentrales Nutzermanagement Windows ServerDeltaDragonVor 1 TagFrageWindows Server6 Kommentare

Hallo zusammen, Ich suche hier heute Euren Rat zum Thema Nutzermanagement auf einem Windows-V-Server Kenntnisse Ich bin zwar seit zehn Jahren Softwareentwickler (Java), habe jedoch ...

general
Frage an die IT-Administratoren in UnternehmenFuchor2020Vor 17 StundenAllgemeinOff Topic12 Kommentare

Hallo Leute, freue mich hier im Forum dabei sein zu dürfen. Da ich noch relativ neu in der IT Branche bin, befasse ich mich aktuell ...

question
Partition reparieren, oder löschen ?Hermann73Vor 1 TagFrageWindows 107 Kommentare

Vielleicht ist das für manche eine dumme Frage. Kann man eine defekte Partition löschen? Ich habe das Problem, dass ich auf die Partition "E" durch ...

question
BIOS-Passwort beim Neustart umgehenFreeBSDVor 13 StundenFrageEntwicklung11 Kommentare

Hallo zusammen, ich bin gerade auf der Suche nach einer Lösung für folgendes Problem und zwar haben wir in der Firma mehrere Notebooks im Einsatz ...

question
Keine Internet mit IPv6 in den VLANs (FritzBox auf SG350) gelöst derBenVor 1 TagFrageRouter & Routing9 Kommentare

Hallo zusammen, ich brauch bitte eure Hilfe im Bezug auf VLAN und IPv6. Problem: Keine Internetverbindung mit IPv6 in den VLAN´s Netzwerkaufbau: Internet (VodafoneCable + ...

question
Merkwürdige Meldung im iPhone Safari BrowsermartenkVor 14 StundenFrageiOS8 Kommentare

Hallo Gemeinschaft ich bekomme seit kurzem dieses Bild in Safari: Was bedeutet es? ...