hokaido
Goto Top

Adguard Home DNS in Fritzbox eintragen

Hallo,

ich habe mir auf einem Raspberry Pi Adguard installiert, Pi eingerichtet, abgesichert und Adguard eingerichtet. Passt alles.

Wo in der Fritzbox trage ich jetzt die IP des PI als lokaler DNS Server ein? Es gibt 3 Möglichkeiten, ich habe gegoogelt, manchmal es werden anscheinend alle 3 Möglichkeiten genommen. Welche ist die beste, und vor allem, wo sind die Unterschiede?

Möglichkeit 1: Internet => Zugangsdaten => DNS Server für IP4 und IP6
dns1


Möglichkeit 2: Internet => Zugangsdaten => DNS over TLS (DoT)
dns2

Möglichkeit 3: Heimnetz => Netzwerk => Netzwerkeinstellungen => IP-Adressen für IP4 und IP6
dns3

Und was trage ich generell für eine IPv6 ein?

Kann hier jemand helfen?

Danke

Content-Key: 13123657342

Url: https://administrator.de/contentid/13123657342

Printed on: March 3, 2024 at 16:03 o'clock

Member: aqui
aqui Dec 10, 2023 updated at 16:38:02 (UTC)
Goto Top
Kann hier jemand helfen?
Das sollte in einem Administrator Forum nicht die Frage sein...! face-wink

Möglichkeit 1 wäre halbwegs richtig ist aber letztlich auch falsch wenn dir die Client bezogenen Adguard Statistiken wichtig sind?!

Die Fritzbox leitet bei Option 1 dann alle eingehenden DNS Requests der Clients an deinen Adguard weiter.
Allerdings hat diese Setup Variante, wie oben schon angemerkt, einen großen Nachteil:
Deine Clients haben alle weiterhin die Fritzbox als DNS Server eingestellt diesen DNS bekommen sie von der Fritzbox per DHCP automatisch.
Damit gehen dann DNS Anfragen immer erst über die FB die sie dann an den Adguard weiterleitet.
In den Statistiken tauchen dann keine Endgeräte mehr auf sondern nur noch die FB und du kannst somit nicht mehr sehen welcher Client WAS macht und wieviel von dort gefiltert wird. Damit beraubst du dich eines wichtigen Analysetools. face-sad
Aus dem Grund ist diese Setup Variante kontraproduktiv.

Du kannst hier also wieder den Haken setzen "Vom Internet zugewiesenen DNS benutzen" oder du aktiviertst die Möglichkeit 2 über die DoT Server
Bei 2 nutzt die FB direkt diese dort angegeben DoT Server und würde auch den Adguard umgehen. Die DoT oder DoH Server gibst du ja im Adguard als Ziel DNS Server ein!

Du musst also dafür sorgen das deine Clients alle direkt die Adguard IP als DNS Server bekommen und nicht mehr die Fritzbox!
Das stellst du in den Settings des DHCP Servers auf der Fritzbox ein!
Dort gibst du dann als DNS Server IP die IP deines Adguard ein. Fertisch!

Ob das geklappt hat kannst du bei Winblows Clients mit dem Kommando ipconfig -all ansehen. Dort sollte dir dann als DNS Server nicht mehr die FB sondern die Adguard IP angezeigt werden und dann siehst du auch wieder alle Client spezifischen Statistiken im Adguard Dashboard! 😉
Member: hokaido
hokaido Dec 10, 2023 at 21:28:09 (UTC)
Goto Top
Danke. Das hilft mir weiter
Ich brauche Option 2face-smile
Member: hokaido
hokaido Dec 10, 2023 updated at 23:30:39 (UTC)
Goto Top
Ich hab die IP4 eingetragen, aber irgendwie geht das ganze an Adguard vorbei. Anfragen werden nicht gefiltert. Seiten wie Spiegel oder GMX sind nach wie vor voll von Werbung. Im Adguard Dashboard werden auch keine Filterungen angezeigt.

Kann es sein, dass die Clients das ganze über IP6 umgehen?
Wenn ja, der Pi hat 3 IP6 Adressen in der Fritzbox stehen, welche ist die richtige und wo in der Fritzbox eintragen?
Member: Althalus
Althalus Dec 11, 2023 at 07:51:45 (UTC)
Goto Top
Moin hokaido,
die IPv6 welche du von der Fritte brauchst fängt mit "fd00" an.
ABER evtl. hilft dir auch dieser Link? Benutze seit letzter Woche Donnerstag auch AdGuard zu Hause über nen Raspi. Läuft soweit gut, vor allem bei Geräten die keine AdBlocker haben können.
Member: hokaido
hokaido Dec 11, 2023 at 08:11:21 (UTC)
Goto Top
@Althalus:
Danke. Den Artiekl kannte ich.

Ich fass nochmal kurz zusammen, was ich gemacht habe.
In der Fritzbox Heimnetz => Netzwerk => Netzwerkeinstellungen => IP-Adressen für IP4 und IP6
Die IP4 des PI und die mit fd00 beginnende IP6 des PI eingetragen sowieUnique Local Addresses (ULA) immer zuweisen => aktiviert

Unter Internet => Zugangsdaten=> DNS Server
Jeweils bei IP4 und IP6: Vom Internetanbieter zugewiesene DNSv4-Server verwenden (empfohlen) => aktiviert

DNS over TLS (DoT) => deaktiviert, denn das macht ja zukünftig Adguard

Frage zu den Clients:
Bisher stehen die immer bei Gateway auf "Adresse der Fritzbox" sowie bei DNS Server auf "automatisch" oder auf "Adresse der Fritzbox".

Ändere ich das jetzt auch auf jedem Gerät oder passt das und die FB gbt die Einstellungen weiter?
Member: Althalus
Althalus Dec 11, 2023 at 08:19:58 (UTC)
Goto Top
Hast du sowohl die Fritte als auch den Raspi einmal neu gestartet? Bei mir hatte das zum Erfolg geführt.
Ansonsten habe ich kaum was an den Einstellungen geändert, wobei ich im internen Netz die IPv6 komplett deaktiviert habe.
Member: hokaido
hokaido Dec 11, 2023 at 08:22:27 (UTC)
Goto Top
Ja neugestartet
Member: elix2k
elix2k Dec 11, 2023 at 08:25:16 (UTC)
Goto Top
Du musst ADGuards IP-Adresse in den DHCP-Einstellungen der Fritz!Box eintragen. Anschließend die Netzwerkverbindung auf den Clients neu aufbauen. Auf Windows-Geräten reicht ein ipconfig /release und ipconfig /renew.

Auf einigen Android Geräten ist mir aufgefallen, dass der Chrome Browser seinen eigenen DNS verwendet und somit nichts geblockt wird.
Member: hokaido
hokaido Dec 11, 2023 at 08:38:17 (UTC)
Goto Top
Siehe oben, dass hab ich ja gemacht
Member: aqui
aqui Dec 11, 2023 at 08:59:51 (UTC)
Goto Top
Ich brauche Option 2
Nein falsch! Beide von dir genannten Optionen sind ja falsch! face-sad
Wie Kollege @elix2k schon gesagt hat muss du die IP Adresse des Adguard im DHCP Server der Fritzbox als DNS Server eintragen. Steht oben leider nicht das du das gemacht hast.
Danach musst du deine Clients einmal vom LAN oder WLAN trennen und neu verbinden, das die sich logischerweise neue IP Adressen per DHCP ziehen und damit dann auch den neuen DNS Server (Adguard).
Dann gibst du einmal ipconfig -all ein in der Eingabeaufforderung und überprüfst ob dann der neue DNS Server (Adguard) auch am Client angekommen ist! face-wink
Member: Althalus
Althalus Dec 11, 2023 at 09:02:54 (UTC)
Goto Top
Da ich aktuell auf Arbeit bin kann ich erst heute Abend sagen wo ich was eingestellt habe in der Fritte. Jedoch bin ich da nach der Anleitung gegangen. Hatte jedoch eine andere Anleitung als die gepostete genommen.
Nämlich folgende kleine Youtubeserie.
Bei mir selbst klappt es alles Problemlos ansonsten.
Member: aqui
aqui Dec 11, 2023 updated at 09:47:47 (UTC)
Goto Top
Findet auch ein Laie auf Anhieb!! face-wink

Netzwerk --> Netzwerkeinstellungen --> Weitere Einstellungen --> IP Adressen --> IPv4 Einstellungen

fbdhcp

Wenn man mit Dual Stack fährt dann zusätzlich auch noch für IPv6:

fbdhcp6
Member: hokaido
hokaido Dec 11, 2023 at 09:46:25 (UTC)
Goto Top
@aqui:
Für IP4 hab ich das doch gemacht.

Bei IP6 widersprecht ihr Euch aber:
Zum einen wird hier gesagt, die IP6 die mit "fd00" beginnt, Du nimmst aber die andereface-smile
Member: aqui
aqui Dec 11, 2023 updated at 09:49:43 (UTC)
Goto Top
https://de.wikipedia.org/wiki/IPv6#Unique_Local_Unicast
Lesen und verstehen...! face-wink

Was sagt ein ipconfig -all bei dir NACH der Änderung?!
Member: hokaido
hokaido Dec 12, 2023 at 23:08:39 (UTC)
Goto Top
Danke. Ich kann mich frühestens am Wochenende wieder damit beschäftigen undmelde mich dann
Member: aqui
aqui Dec 13, 2023 at 09:38:39 (UTC)
Goto Top
Wir sind gespannt... face-wink
Member: hokaido
hokaido Dec 17, 2023 updated at 23:07:19 (UTC)
Goto Top
So das klappt jetzt soweit.
Aber: Ich musste auf den Clients den IP4 DNS manuell ändern. Hatte ich vorher extra gefragt, ob das notwednig ist, egal.

Und:
Kann ich irgendwo - seid es in der FB oder in den Clients - einen Fallback DNS eintragen, falls der Pi nicht verfügbar ist?
Wenn ich in Windows an erster Stelle den Adguard als DNS und an 2. Stelle die IP der FB eintrage, sollte es doch funktionieren, oder?
Member: elix2k
elix2k Dec 18, 2023 at 06:46:05 (UTC)
Goto Top
Zitat von @hokaido:

So das klappt jetzt soweit.
Aber: Ich musste auf den Clients den IP4 DNS manuell ändern. Hatte ich vorher extra gefragt, ob das notwednig ist, egal.

Man muss den DSN auf den Clients nicht eintragen, wenn du DHCP benutzt. Bei statischen IP-Adressen ist das ja klar...


Und:
Kann ich irgendwo - seid es in der FB oder in den Clients - einen Fallback DNS eintragen, falls der Pi nicht verfügbar ist?
Wenn ich in Windows an erster Stelle den Adguard als DNS und an 2. Stelle die IP der FB eintrage, sollte es doch funktionieren, oder?
Jupp, das ist richtig.
Member: aqui
aqui Dec 18, 2023 updated at 08:36:18 (UTC)
Goto Top
Ich musste auf den Clients den IP4 DNS manuell ändern.
Das ist natürlich völliger Quatsch.
Kollege @elix2k hat es oben schon gesagt: Wenn man den DNS Server entsprechend im DHCP einträgt wird der auch dynamisch an die Clients weitergegeben. Kann man ja auch selber immer mit ipconfig -all sehen und überprüfen. Auf einer 7490er FB mit aktueller 7.5er Firmware rennt das hier erwartungsgemäß fehlerfrei wie in Millionen anderer Fritzboxen auch!
Zeigt also das es irgendwo noch einen PEKAC Fehler beim TO gibt. face-sad
Member: aqui
aqui Dec 30, 2023 at 11:44:21 (UTC)
Goto Top
Wenn es das denn nun war bitte deinen Thread dann auch als erledigt markieren!
Wie kann ich einen Beitrag auf "gelöst" oder "erledigt" setzen?