yakazaa
Goto Top

C-Sharp Application unter BartPE

Hallo zusammen,

um unseren Kunden die Image-Wiederherstellung zu erleichtern haben unsere Entwickler eine C-Sharp Application entwickelt.
Diese soll nun unter Bart PE laufen.

Es geht zuersteinmal um eine Testdatei, welche im Prinzip nichts weiter tut als ein Hallo Welt + Statusbalken anzuzeigen.

Wenn ich diese Datei vom BartPE aus öffne,
kriege ich den folgenden Fehler:

The application failed to initialize properly (0xc0000135). Click on OK to terminate the application.
Siehe hier:
ed3c33b005aafaf72608e0d5be1b999a-app_test

Unser Verdacht zeigt auf das fehlende .net Framework in dieser Umgebung.
Gibt es da euch bekannte Möglichkeiten soetwas zu implementieren ?!

Vielen Dank,
wie immer im Voraus !

Dominik

Content-Key: 114728

Url: https://administrator.de/contentid/114728

Printed on: April 18, 2024 at 01:04 o'clock

Member: pulse
pulse Apr 27, 2009 at 10:01:28 (UTC)
Goto Top
das problem hast du ja nun schon erkannt... und mit etwas googlen wär dir schon geholfen

Suchwörter: BartPE .net

http://www.pebuilder.de/downloads.php?cat=6
Member: yakazaa
yakazaa Apr 27, 2009 at 10:18:22 (UTC)
Goto Top
Jaja, haut nur immer drauf .. ;)

Alles klaro, hatte es schon gefudnen, nur vergessen hier den Thread zu stoppen...
Danke trozdem !
Member: Shaker1978
Shaker1978 Apr 27, 2009 at 10:19:33 (UTC)
Goto Top
Habe die .cab Datei aus dem link noch nicht ausprobiert, aber ist es vielleicht auch möglich über slipstreaming zu erreichen, das .NET FW schon ins Windows zu bekommen, so wie man auch Upates direkt slipstreamen kann? Ich habe z.B. ein Part-PE aus einem SP3-slipstreamed Windows erzeugt. Vielleicht geht das auch mit der .NET Installations-exe...