Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWünsch Dir wasWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Cisco Switch Port Trunk

Mitglied: Finchen961988

Finchen961988 (Level 2) - Jetzt verbinden

28.02.2019 um 18:23 Uhr, 3008 Aufrufe, 8 Kommentare

Hallo liebes Forum,

ich habe oder ich bin aus Zufall über ein Cisco 3750G 24POrt gestolpert und habe mir ein kleines Projekt aufgebaut, denn Learning-by Doing ist immer gut!

Naja ich habe als Firewall eine Sophos und habe mehrere VLANS mit der Sophos eingerichtet, jetzt habe ich UBiquiti Switche hier hängen und die zu programmieren ist ja echt einfach!
Ich möchte aber jetzt die UBiquti ausbauen und den Cisco einsetzen, die VLANS habe ich schon im Cisco bekannt gemacht und auch den Ports per Putty zugewiesen, per switport Access vlan!

Aber ich verstehe eines nicht, ich habe eine QNAP NAS mit 4x1GB und in der NAS habe ich diese im virtuellen Switch verbunden, beim Ubiquti habe ich das Trunking aktiviert und das klappt das gut, so meine frage ist und ich verstehe nicht die Anleitungen wie muss ich dieses Trunk/LCAP in der Switch einrichten?

Nehmen wir GigabitPOrt 3 und 4
was für ein Befehl muss ich da eingeben damit das klappt?

Könntet Ihr mich da helfen bitte?
Mitglied: aqui
LÖSUNG 28.02.2019, aktualisiert um 18:46 Uhr
denn Learning-by Doing ist immer gut!
So ist es !
beim Ubiquti habe ich das Trunking aktiviert
Da herrscht etwas Verwirrung im richtigen Sprach Gebrauch der Funktionen:
Trunk Cisco = Tagged Uplink
LACP Link Aggregation (Cisco) = Etherchannel oder Port Channel
Trunk (Rest der Netzwerk Welt) = Link Aggregation mit LACP
Du siehst, es ist etwas verwirrend und man verwendet besser das Wort "Trunk" nicht sondern "LAG" oder "LACP LAG" um da eindeutig zu sein.

Vermutlich willst du eine Link Aggregation machen, richtig ? Sprich 2 der QNAP Ports auf einen LACP Port-Channel (Trunk) beim Cisco Catalysten bündeln (Port 3 u. 4)
Dann bist du hier richtig:
https://administrator.de/wissen/netzwerk-management-server-raspberry-pi- ...
Dort findest du auch die für dich passende Konfig für deinen Catalysten mit IOS !

Nehmen wir GigabitPOrt 3 und 4
Das sähe dann bei dir bei einem untagged Endgeräte Port so aus:
!
interface Port-channel1
description LACP LAG auf QNAP-NAS
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/3
description LAG Member 1 QNAP-NAS
switchport mode access
channel-group 1 mode active
spanning-tree portfast
!
interface GigabitEtherne/4
description LAG Member 2 QNAP-NAS
switchport mode access
channel-group 1 mode active
spanning-tree portfast
!

Ein show port-channel 1 zeigt dir dann ob du alles richtig gemacht hast (Status muss "up/up" sein !)
Ein show lacp neig zeigt dir den negotiateten LACP Nachbarn, sprich dein QNAP NAS.

Bei einem Tagged Port für mehrere VLANs sähe es dann so aus:
!
interface Port-channel1
description LACP LAG auf QNAP-NAS
switchport mode trunk
switchport trunk allowed vlan all
spanning-tree portfast
!
interface GigabitEthernet0/3
description LAG Member 1 QNAP-NAS
switchport mode trunk
switchport trunk allowed vlan all
channel-group 1 mode active
spanning-tree portfast
!
interface GigabitEtherne/4
description LAG Member 2 QNAP-NAS
switchport mode trunk
switchport trunk allowed vlan all
channel-group 1 mode active
spanning-tree portfast
!
Bitte warten ..
Mitglied: Finchen961988
28.02.2019 um 18:53 Uhr
Vielen Dank ich werde es mal am Samstag probieren und berichten, werde es heute nicht mehr schaffenund morgen gucken wir mal.

Vielen Dank
Bitte warten ..
Mitglied: Finchen961988
28.02.2019 um 18:54 Uhr
Und ja ich wollte eine link aggregation machen
Bitte warten ..
Mitglied: Finchen961988
05.03.2019 um 19:31 Uhr
Hallo,

habe mich nu dran gesetzt, aber ich verstehe nicht, wo das herkommt:

"interface Port-channel1 "

Wie muss ich die Anlegen und kann ich die Nummer freiwählen?
Und wie funktionert das mit dem Beschriften?
Bitte warten ..
Mitglied: aqui
LÖSUNG 05.03.2019, aktualisiert um 20:36 Uhr
aber ich verstehe nicht, wo das herkommt:
Wenn du die physischen Ports (z.B. GigabitEthernet0/3) mit dem Kommando channel-group 1 mode active als Member eines Port Channels (Cisco Sprech für LACP LAG) konfiguriert hast, dann legt er automatisch ein virtuelles Port Channel Interface an.
Die Indexnummer bei channel-group 1 mode active bestimmt immer auch den dazu korrespondierenden Port Channel Interface Index.
Z.B. wenn du auf dem Switch einen 2ten Port Channel einrichtest mit channel-group 2 mode active korrespondiert das dann zu einem interface Port-channel2
Guckst du auch hier:
http://www.nwlab.net/tutorials/link-aggregation/
Und wie funktionert das mit dem Beschriften?
Das ist das Interface Kommando description !
Z.B.:
!
switch# conf t
switch(config)# int gig 0/3
switch(config-if)# description LAG Member 1 QNAP-NAS
switch(config-if)# <ctrl z>
switch#wr
!

Fertisch !
Bitte warten ..
Mitglied: Finchen961988
05.03.2019 um 21:08 Uhr
also, als Befehl so:

switch# conf t
switch(config)# channel-group 33 mode active
switch(config)# strg +z

switch# conf t
switch(conf)# int channel-group 33
switch(conf-if)# description LAG QNAP
switch(conf-if)# switch port mode trunk
switch(conf-if)# switch port trunk allowed vlan 20 (angelegt als Server VLAN )
Muss das spanning-tree?

Dann müsste ich die beiden Ports dazu bauen, befehe suche ich mir dann noch,
fehlt noch was?

33 <- es gibt zwar kein 1,2,11,22 oder so aber 33 finde ich gerade gut
Bitte warten ..
Mitglied: aqui
06.03.2019, aktualisiert 08.10.2019
also, als Befehl so:
Nein !
Bitte lies dir doch die obige Thread Antwort mal wirklich durch und lese das Cisco Handbuch !!
Angenommen deine beiden physischen Ports auf dem Switch die du bündeln willst sind die Ports 3 und 4 und der LAG soll als Endgeräte Port im VLAN 20 liegen.
Den STP Befehl kannst du auch weglassen, der ist NICHT zwingend erforderlich !
Dann sieht das so aus:
!
switch# conf t
switch(config)#: interface GigabitEthernet0/3
switch(config-if)#: description LAG Member 1 QNAP-NAS
switch(config-if)#: switchport mode access
switch(config-if)#: switchport access vlan 20
switch(config-if)#: channel-group 33 mode active
switch(config-if)#: quit
switch(config)#: interface GigabitEthernet0/4
switch(config-if)#: description LAG Member 2 QNAP-NAS
switch(config-if)#: switchport mode access
switch(config-if)#: switchport access vlan 20
switch(config-if)#: channel-group 33 mode active
switch(config-if)#: quit
switch(config)#: interface PortChannel 33
switch(config-if)#: description LAG zum QNAP NAS
switch(config-if)#: switchport mode access
switch(config-if)#: switchport access vlan 20
switch(config-if)#: <ctrl z>
switch#: wr

Fertisch !
Kontrolliere nochmal mit einem show run die Konfig das alle 3 Ports (4 und 4 sowie der PortChannel 33) die o.a. Konfig haben. Im Zweifel hier posten sollte es wider Erwarten nicht gehen.
Ein show port-channel 33 zeigt dir dann ob der Port Channel (LAG) zum QNAP aktiv und funktional ist !!
Ebenso ein show int po 33 oder auch ein show lacp neigh

Grundlagen wie immer dazu auch hier:
https://administrator.de/wissen/netzwerk-management-server-raspberry-pi- ...
und auch
https://administrator.de/wissen/mikrotik-vlan-konfiguration-routeros-ver ...
Bitte warten ..
Mitglied: aqui
LÖSUNG 08.10.2019 um 17:16 Uhr
Wenn es das jetzt war bitte dann auch
https://administrator.de/faq/32
nicht vergessen !
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless

Sniffen mit Wireshark auf Cisco Trunk Port

Frage von edvmaedchenfuerallesLAN, WAN, Wireless2 Kommentare

Hallo. Noob-Frage: Wenn ich den Traffic eines Trunk-Ports auf einem Cisco Switch (3850) mittels Wireshark mitsniffe, welchen Traffic sehe ...

Switche und Hubs

Cisco Switch Port Up-Down

gelöst Frage von newit1Switche und Hubs3 Kommentare

Hallo, ich habe den Cisco SG500X-48 Switch. Gibt es eine Möglichkeit zu sehen, wann ein bestimmter Port UP und ...

Switche und Hubs

Trunk Switch überprüfen

Frage von cableguy009Switche und Hubs5 Kommentare

Hallo, ich habe zwei Switche, die ich über einen Trunk verbinden möchte. 1. Switch Dlink DGS 1210, 24 Port ...

LAN, WAN, Wireless

Cisco Trunk Ports

Frage von 134311LAN, WAN, Wireless1 Kommentar

Guten Abend zusammen, habe eine verstäntis Farge zu einem Cisco Catalyst 2960. Wenn ich den Befehl "sh int trunk" ...

Neue Wissensbeiträge
Monitoring

Unabhängiger Ansatz - IoT (frei von Cloud- oder Appzwang) - Hier mit Schaltsteckdosen

Anleitung von beidermachtvongreyscull vor 16 StundenMonitoring

Tach Kollegen, ich erzähle Euch mal von meiner Ausgangslage und den/m Problem(chen) Ich benutze ein NAS zur Lagerung meiner ...

Microsoft
Microsoft Advanced Threat Protection for Linux
Information von Dani vor 2 TagenMicrosoft

Microsoft Defender Advanced Threat Protection (MD ATP) support for Linux with kernel version 3.10.0-327 or later, including the following ...

Humor (lol)
! ! Today ist SysAdmin-Day ! !
Information von VGem-e vor 4 TagenHumor (lol)5 Kommentare

Moin, "Happy Birthday" an alle Systemadministratoren, Mausschubser, System-/EDV-Betreuer, SysOps etc!! Siehe auch. Edit (Video hinzugefügt): Gruß VGem-e

Exchange Server
Basic Authentication and Exchange Online
Information von Dani vor 6 TagenExchange Server

Today we are pleased to announce some new changes to Modern Authentication controls in the Microsoft 365 Admin Center, ...

Heiß diskutierte Inhalte
Google Android
Smartphone - Internes Radio auf Bluetooth Lautsprecher abspielen
Frage von emeriksGoogle Android22 Kommentare

Hi, vielleicht kann ja einer von Euch auch sowas beantworten. Ich habe hier ein Samsung Smartphone - S10 Lite. ...

Windows Server
DCPromo bleibt bei Migration Server 2008R2 auf 2016 hängen
gelöst Frage von Leo-leWindows Server20 Kommentare

Hallo Forum, wir sind gerade dabei, unsere beiden DCs auf Server 2016 zu migrieren. Aktuell hängt der zusätzlich ins ...

Ausbildung
Wie wird man zum Systemadministrator?
gelöst Frage von DavidHergAusbildung19 Kommentare

Guten Abend zusammen, Ich hatte hier schon ein paar Fragen gestellt, und mir wurde super weiter geholfen! Ich mache ...

Windows Server
Denselben Port auf verschiedenen Netzwerkkarten nutzen
gelöst Frage von entchenbrotWindows Server17 Kommentare

Hi wir haben einen Server PC mit verschiedenen Netzwerkkarten als Art Gaming-Server und würden gerne ein Spiel in zwei ...

Weniger Werbung?
Administrator Magazin
07 | 2020 In der Juli-Ausgabe beleuchtet das IT-Administrator Magazin den Themenschwerpunkt "Monitoring & Support". Darin zeigt die Redaktion unter anderem, wie Sie die Leistung von Terminalservern im Blick behalten und welche Neuerungen das Ticketsystem OTRS 8 mitbringt. Auch die Überwachung von USV-Anlagen darf nicht fehlen. In ...