elix2k
Goto Top

CISCO Switche und Profinet

Hallo zusammen,

seit dem wir einige Siemens SPS in unsere Cisco Netzwer-Umgebung eingebunden haben, kommt es wöchentlich zu Ausfällen.
Die Uplink-Ports der Switche wechseln den Status zu "errdisabled" und in den Logs ekennt man keinen Grund dafür.

Wir setzen die Catalyst 2960X Serie als Access-Switche ein.
Die Port-Konfigurations sieht so aus:

interface GigabitEthernet1/0/2
description "SPS Port"
switchport access vlan 106
switchport mode access
switchport voice vlan dot1p
spanning-tree portfast edge

MIt den billigen D-Link Switchen gab es nie Probleme.

Muss man auf was Besonderes in einer Cisco-Umgebung achten, oder sind die Switche grundsätzlich nicht Profinet fähig?

Vielen Dank im Voraus!

Content-Key: 431539

Url: https://administrator.de/contentid/431539

Printed on: March 3, 2024 at 02:03 o'clock

Member: aqui
aqui Mar 22, 2019 updated at 16:21:24 (UTC)
Goto Top
...kommt es wöchentlich zu Ausfällen. Die Uplink-Ports der Switche wechseln den Status zu "errdisabled"
Das ist ein klassisches Verhalten wenn es noch andere nicht Cisco IOS Switches im Netzwerk gibt !!
Der Grund ist wie eigentlich jeder Netzwerker weiss, das inkompatible Spanning Tree !!
Cisco nutzt ein Per VLAN Spanning Tree Verfahren, hat also einen dedizierten Spanning Tree Prozess pro VLAN.
Dazu kommt noch das dieses Cisco PVSTP proprietäre Mac Adressen für die Spanning Tree BPDU Pakete nutzt.
Das ganze heisst dann PVSTP+ und ist mit den meisten (Billig) Switches wie die oben von dir zitierten D-Links vollkommen inkomatibel.
Schlimmer noch....
Solche einfachen Single Span Switches haben ja nur einen einzigen globalen (R)STP Prozess über alle VLANs und fluten die gesamten VLANs der Cisco mit dem gleichen STP BPDU Paketen, die diese dann wieder flutet. So kommt es zu STP Mismatches die unkontrolliert je nach Root- und Backup Root Switch Konfig Ports in den Error Disable Mode bringen. Error Disable wendet der Cisco zum Eigenschutz an damit es nicht zu Loops und damit einhergehenden Floodings und Broadcast Stürmen im Netz kommt die es in den Orkus reissen.
DAS ist das Besondere auf was man zwingend in einem Netzwerk mit Cisco Catalyst IOS Switches achten muss wenn dort noch andere Netzwerk Hardware zum Einsatz kommt.
Catalyst Switches lassen sich NICHT in einem Single Span Verfahren betreiben !
Wenn sie in heterogenen Netzen arbeiten muss man immer MSTP als STP Protokoll verwenden was meist alle anderen Switches auch können.
Siehe zu dem Thema auch hier:
Spanning-Tree Modus-Migration (PVST nach MST bei Cisco)

Reine Single Spann Switches sind nicht kompatibel mit Cisco Catalysten und lassen sich in Bezug auf Spanning Tree nicht zusammen mit diesen betreiben.
Die einzige Option bei solchen Switches ist dann STP komplett zu deaktivieren und die BPDUs dann zu fluten sollten sie kein MSTP supporten.
Nicht toll und mit Gefahren behaftet aber die einzige Option wenn man die Switches nicht tauschen will, was langfristig letztlich besser wäre.

2ter Fehler oben:
Was hat das switchport voice vlan dot1p dort auf einem SPS Port zu suchen ???
Du machst ja vermutlich KEIN Voice mit einer SPS Maschine, oder ?
Also weg mit diesem sinnlosen und auch gefährlichen Kommando von solchen Ports die keine Telefonie oder Voice Ports sind !
Das hat nur was auf Ports zu suchen an denen Telefone angeschlossen sind.
So sollte eine saubere Endgeräte Port Konfig für den SPS aussehen:
interface GigabitEthernet1/0/2
description SPS-Port
switchport access vlan 106
switchport mode access
switchport nonegotiate
spanning-tree portfast
!

Nicht mehr und nicht weniger...
Siehe deine Switchkonfigs auf diese 2 Punkte durch. Korrigiere sie und dann kommt es auch nie mehr zu solchen Ausfällen.
Member: brammer
brammer Mar 22, 2019 at 20:39:33 (UTC)
Goto Top
Hallo,

Was hat das switchport voice vlan dot1p dort auf
einem SPS Port zu suchen ???
Du machst ja vermutlich KEIN Voice mit einer SPS
Maschine, oder ?

Es geht wohl weniger um Voice in diesem Vlan...
Eher darum das Siemens hier nicht RFC konform arbeitet... in der Kommunikation mit der S7 kommt es vor das zu kleine Pakete gesendet werden. Die werden eigentlich verworfen und der Counter für runts geht hoch...
Mit dem voice vlan Eintrag werden zu kleine Pakete nicht mehr verworfen.
Allerdings würde ich den Eintrag ändern auf

switchport voice vlan 106

Brammer
Member: canlot
canlot Mar 23, 2019 at 10:21:04 (UTC)
Goto Top
Zitat von @aqui:

...kommt es wöchentlich zu Ausfällen. Die Uplink-Ports der Switche wechseln den Status zu "errdisabled"
Das ist ein klassisches Verhalten wenn es noch andere nicht Cisco IOS Switches im Netzwerk gibt !!
Der Grund ist wie eigentlich jeder Netzwerker weiss, das inkompatible Spanning Tree !!
Cisco nutzt ein Per VLAN Spanning Tree Verfahren, hat also einen dedizierten Spanning Tree Prozess pro VLAN.
Dazu kommt noch das dieses Cisco PVSTP proprietäre Mac Adressen für die Spanning Tree BPDU Pakete nutzt.
Das ganze heisst dann PVSTP+ und ist mit den meisten (Billig) Switches wie die oben von dir zitierten D-Links vollkommen inkomatibel.
Schlimmer noch....
Solche einfachen Single Span Switches haben ja nur einen einzigen globalen (R)STP Prozess über alle VLANs und fluten die gesamten VLANs der Cisco mit dem gleichen STP BPDU Paketen, die diese dann wieder flutet. So kommt es zu STP Mismatches die unkontrolliert je nach Root- und Backup Root Switch Konfig Ports in den Error Disable Mode bringen. Error Disable wendet der Cisco zum Eigenschutz an damit es nicht zu Loops und damit einhergehenden Floodings und Broadcast Stürmen im Netz kommt die es in den Orkus reissen.
DAS ist das Besondere auf was man zwingend in einem Netzwerk mit Cisco Catalyst IOS Switches achten muss wenn dort noch andere Netzwerk Hardware zum Einsatz kommt.
Catalyst Switches lassen sich NICHT in einem Single Span Verfahren betreiben !
Wenn sie in heterogenen Netzen arbeiten muss man immer MSTP als STP Protokoll verwenden was meist alle anderen Switches auch können.
Siehe zu dem Thema auch hier:
Spanning-Tree Modus-Migration (PVST nach MST bei Cisco)

Reine Single Spann Switches sind nicht kompatibel mit Cisco Catalysten und lassen sich in Bezug auf Spanning Tree nicht zusammen mit diesen betreiben.
Die einzige Option bei solchen Switches ist dann STP komplett zu deaktivieren und die BPDUs dann zu fluten sollten sie kein MSTP supporten.
Nicht toll und mit Gefahren behaftet aber die einzige Option wenn man die Switches nicht tauschen will, was langfristig letztlich besser wäre.
Danke aqui, wieder was gelernt face-smile
Member: aqui
aqui Mar 23, 2019 updated at 11:05:41 (UTC)
Goto Top
Immer gerne wieder aber...
Deshalb hättest du NICHT den ganzen Post überflüssigerweise nochmal zitieren müssen ! face-sad
@brammer
Mit dem voice vlan Eintrag werden zu kleine Pakete nicht mehr verworfen.
Damit sind sie dann aber NICHT mehr Standard konform für ein Ethernet Netzwerk und sollten deshalb immer explizit verworfen werden ! Besser also weglassen !
Auch trotz Voice Konfig sollte der Cisco niemals Frames forwarden die nicht dem Standard entsprechen. Tut er auch nicht, denn das ist dann kein Ethernet mehr.
Man kann davon ausgehen das der D-Link sowas grundsätzlich auch nicht kann und deshalb NICHT Standard konforme Ethernet Frames ebenfalls sofort verwirft am Port wie es eigentlich auch üblich ist und sein sollte !
Member: brammer
brammer Mar 23, 2019 at 18:32:21 (UTC)
Goto Top
Hallo,

@aqui,
Vollkommen korrekt...

Wir hatten vor 4 Jahren deswegen Probleme in mehreren Netzwerken...
Siemens hat uns geraten auf Siemens switchen zu wechseln....
Cisco hat empfohlen mit dem voice vlan zu arbeiten...

Wir verwenden weiterhin Cisco switche...

Das Siemens hier nicht Standard konform arbeitet ist Siemens egal....

Brammer
Member: aqui
aqui Mar 23, 2019 at 21:43:38 (UTC)
Goto Top
Das Siemens hier nicht Standard konform arbeitet ist Siemens egal....
Ja, ist bekannt leider und eher ein ziemliches Armutszeugnis für die Weltfirma Siemens. OK dafür können sie bessere Strom Generatoren und ICEs bauen... Netzwerk können sie definitiv nicht.
Member: maretz
maretz Mar 24, 2019 at 05:29:55 (UTC)
Goto Top
Und das die ICE's bauen können kann nur jemand sagen der im Sommer nie auf die Bahn angewiesen war ;)...

Unabhängig davon ist es aber eben egal OB das jetzt Standard ist oder nicht, ob das gut ist oder nicht -> wenn der Kram laufen muss gibt es da irgendwann eben nur die würg-arounds...
Member: elix2k
elix2k Mar 25, 2019 at 05:27:31 (UTC)
Goto Top
Vielen Dank für die zahlreichen Antworten.
Das kuriose bei der Geschichte ist, dass die D-Link Switche nie Probleme gemacht haben.
Die D-links hängen vom Anfang an bei uns im Netz. Erst kürzlich haben wir aber angefangen die Siemens dezentrale Peripherie an den Ciscos anzuschließen. Angeblich ist die gesamte Catalyst 3000er Serie Profinet IO fähig, ich habe versucht auf unseren 3750X und 3750G Switchen Profinet zu aktivieren (Leider ohne Erfolg, da die benötigten Befehle fehlen).
Member: brammer
brammer Mar 25, 2019 at 05:40:45 (UTC)
Goto Top
Hallo,

Erste Frage... welche IOS Version hast du auf den switchen?


Zweite Frage.... das hast du gelesen?

Das steht in den Artikel:

Beginning with Cisco IOS software release
12.2(52)SE, PROFINET is enabled by default on > all the base switch module and expansion-unit > Ethernet ports.

Brammer
Member: elix2k
elix2k Mar 25, 2019 at 06:15:25 (UTC)
Goto Top
Ich habe die 15.2(4) drauf. So wie ich das verstandne habe, kann man das Profinet IO auch per Port aktivieren bzw. deaktivieren.
Hab noch keine SPS angeschlossen, wollte erst schauen ob die Befehle vorhanden sind.
Member: brammer
Solution brammer Mar 25, 2019 at 07:37:57 (UTC)
Goto Top
Hallo,

@elix2k
die von dir verwendete IOS Version ist zu alt....
Updaten und dann noch mal testen.

brammer
Member: aqui
aqui Jan 20, 2023 at 10:31:30 (UTC)
Goto Top
...und wenn gefixt den Thread dann auch als erledigt schliessen!!