it-frosch
Goto Top

Datenübertragung über serielle Schnittstelle unter W10 Build 14393 zu lahm, lässt sich nicht einstellen

Guten Abend,

wir nutzen Barcodescanner die über ein Seriell - USB Adapter an die Rechner angeschlossen werden.

Damit die Daten vom Scanner schnell übertragen werden, ändere ich im Gerätemanager die Übertragungsrate des entsprechenden COM Ports von
Standard 9600 auf 128000. Anschließend ein Neustart und dann flitzten die Daten aus dem Scanner in den Rechner. So jedenfalls bisher unter W7.
Alle Änderungen führe ich als Lokaler Admin durch. face-wink

Gerade will ich einen W10 Rechner einrichten und gehe genauso vor.
Beim Übertragungstest ist die Datenübertragung aber sehr stockend.
Viel langsamer als unte W7. Erst werden 2-3 Datensätze schnell übertragen, dann dauert es viele Sekunden bevor die Übertragung weiter geht.

Hat jemand von euch da Erfahrungen, wie ich mich dem Problem nähern kann?
CPU Auslastung oder andere Punkte in der Richtung scheiden aus. Das NB macht quasi nichts.

Update 1:
Habe das jetzt, nur mit einem anderen USB-seriell Adapter unter W7 getestet.
Läuft fix, so wie erwartet.
Damit bleibt für mich der USB-Seriell Adpater der einzige Ansatz. Der Adapter, der unter W7 läuft wird unter W10 nicht erkannt.

Update 2:
Verschiedene USB Ports (NB wie auch Dockingstation) habe ich unter W10 ebenfalls geprüft.

Grüße vom it-frosch

Content-Key: 353488

Url: https://administrator.de/contentid/353488

Ausgedruckt am: 03.10.2022 um 19:10 Uhr

Mitglied: BassFishFox
Lösung BassFishFox 02.11.2017, aktualisiert am 03.11.2017 um 00:20:51 Uhr
Goto Top
Hallo,

Kannst Du einen Seriell/USB-Adapter auftreiben welcher mit einer aktuellen Version von W10 kompatibel ist?

Was sagt der Hersteller des Adapters? TreiberUpdate?

Der Adapter, der unter W7 läuft wird unter W10 nicht erkannt.

Noch nicht mal angezeigt als nicht funktionierendes Geraet im Geraetemanager? Was ist das fuer ein Chipsatz? Adapter mit FTDI-Chipsatz laufen definitiv auch unter W10 1709. Der hier ist einer davon.
https://www.amazon.de/StarTech-com-FTDI-Seriell-Adapter-Schnittstellen/d ...


Gruss
BFF
Mitglied: it-frosch
it-frosch 03.11.2017 um 08:36:48 Uhr
Goto Top
Hallo BFF,

die beiden getesteten Adapter haben einen Profilic Chipsatz.
Einer wird sauber im Gerätemanager eingebunden, trotzdem treten die oben beschriebenen Probleme auf.
Der andere wird mit gelbem Ausrufezeichen angezeigt und ich kann ihn nicht nutzen.

Laut Profilic sind bestimmte
Chipsätze (2303H, 2303HX (Rev A) und 2303X or XA) nur für W7 und nicht für W10 freigegeben.

Ich werde mir mal deinen vorgschlagenen Adapter holen und prüfen ob das dann besser geht.

Hast du ansonsten noch Denkansätze was Datenübertragung stören könnte?


PS:
Ich finde es aber schön, das MS sich den Linux Nutzern annähert. Bisher war ich da nur immer gewohnt, mich vor dem Kauf kundig zu machen, ob das Teil auch unterstützt wird. face-wink

Grüße vom it-frosch
Mitglied: BassFishFox
BassFishFox 03.11.2017 aktualisiert um 11:55:50 Uhr
Goto Top
Hallo,

Ich werde mir mal deinen vorgschlagenen Adapter holen und prüfen ob das dann besser geht.

Es werden sicherlich auch andere funktionieren, wichtig ist halt nur der Chipsatz.

Hast du ansonsten noch Denkansätze was Datenübertragung stören könnte?

Treiber vermutlich.

Irgendwo hatte ich mal gelesen, dass ein Update the USB to Serial device to a "Microsoft USB to Serial cable"
helfen soll, wenn solch ein Adapter nicht richtig will. Das geht wohl im Geraetemanager. Gebraucht haben wir es aber nicht, weil unser Kabel funktioniert.

BFF