gelöst DHCP auf 24Port managed Switch mit 5 DHCP Servern in 5 VLans

Mitglied: Giftzwerg

Giftzwerg (Level 1) - Jetzt verbinden

02.03.2020, aktualisiert 09:29 Uhr, 593 Aufrufe, 8 Kommentare

Hallo,
ich benötige Unterstützung.

Problemstellung:
Ich habe einen Netgear M4300 - 24 Port managed Switch.
An den Ports 20, 21, 22, 23, 24 sind je eine Fritz-Box angeschlossen.
Diese stellen jeweils einen eigenen DHCP zur Verfügung
(192.168.1.x ... 192.168.2.x ... 192.168.3.x ... 192.168.4.x ... 192.168.5.x)

An den Ports 1 - 19 hängen diverse Rechner und Videokonferenzsysteme.

Diese sind in 5 VLANs eingeteilt

Je nach Zuordnung sollen sich nun die Rechner/Videokenferenzsysteme eine DHCP-Adresse von der zugeordneten Fritz-Box holen.

Aktueller Stand:
So lange nur ein Rechner/Videokenferenzsystem und eine Fritz-Box angeschlossen ist (z.B. beide im VLAN 101 Ports 1 und 20) funktioniert die DHCP-Verteilung.
Kommte ein weiterer Client (ebenfalls VLAN 101) hinzu, geht das immer noch.
Wir nun eine weiter Fritz-Box an den Switch angeschlossen (z.B. an Port 21 VLAN 102) erfolgt keine Zuordung von IP-Adressen mehr.
Die Verteilung geht auch nicht mehr im VLAN 101.

Ich denke mal, ich habe eine wichtige Einstellung übersehen.
Vielen Dank schon mal vorab.
Gruß
Dieter
Mitglied: aqui
02.03.2020, aktualisiert um 09:46 Uhr
Ich denke mal, ich habe eine wichtige Einstellung übersehen.
Ja, vermutlich hast du nicht an die PVIDs gedacht. Eine typische NetGear "Krankheit".
Im Grunde ist deine Vorgehensweise richtig wenn man dein Setup jetzt so versteht, das jede der 5 FritzBoxen mit ihren PCs und Systemen dann in einen getrennten, dedizierten VLAN arbeiten soll.
Man kann hier dann nur vermuten das du einen Fehler in der VLAN Port Zuweisung bzw. dem Setzen der PVID auf dem NetGear gemacht hast. NetGear ist da etwas "speziell" denn es erzwingt immer 2 Schritte: Dem Zuweisen der Ports zu den entsprechenden VLANs und zusätzlich dem setzen der PVID auf diesen VLAN Ports. 2 Schritte also immer um den Port dann einem VLAN Untagged zuzuordnen !

Legt man am Beispiel der VLANs 101 und 102 für die FritzBoxen 1 und 2 mal zugrunde das die jeweils Untagged die Ports 1-3 und 20 (VLAN 101) und 4-6 und 21 (VLAN 102) haben, sind die ToDos die folgenden:
  • VLAN 101 einrichten
  • VLAN 102 einrichten
  • Ports 1-3 und 20 untagged (U) dem VLAN 101 zuordnen
  • Ports 4-6 und 21 untagged (U) dem VLAN 102 zuordnen
  • PVID für die Ports 1-3 und 20 auf 101 setzen
  • PVID für die Ports 4-6 und 21 auf 102 setzen
  • Das wiederholst du jetzt genau so für die Ports der VLANs 103, 104 und 105
  • Fertisch !
Damit hat dann jede FritzBox ein dediziertes VLAN und 4 dedizierte Ports pro VLAN. In den jeweiligen VLANs vergibt dann die FB ihre entsprechenden IP Adressen via DHCP.
Funktioniert fehlerlos !
Bitte warten ..
Mitglied: Giftzwerg
02.03.2020 um 09:48 Uhr
Hallo, vielen Dank für die schnelle Antwort.
So wie in Deinem Ansatz vorgeschlagen, bin ich vorgegangen.
Hatte mir die Lösung auch genau so vorgestellt.
Doch leider klappt es nicht. Das Fehlerbild kann ich mir auch nicht erklären.
Die Zuweisung der Ports und PVID ist exakt wie in Deinem Vorschlag.
Bitte warten ..
Mitglied: sabines
02.03.2020, aktualisiert um 10:06 Uhr
Moin,

warum eigentlich die 5 Boxen, willst Du das nicht den Switch erledigen lassen?

hast Du vielleicht, aus Versehen, den internen DHCP Server auf dem Switch konfiguriert oder reingrätschende ACLs?
GGfs. mal die aktuellste Firmware flashen und den Switch resetten und noch mal ganz von vorne anfangen.

https://kb.netgear.com/31026/How-to-configure-a-VLAN-on-a-NETGEAR-manage ...

Gruss
Bitte warten ..
Mitglied: aqui
02.03.2020, aktualisiert um 10:28 Uhr
Hatte mir die Lösung auch genau so vorgestellt.
Ist auch richtig so !
Habs hier eben mal mit einem NetGear GS-108T VLAN Switch nachgestellt mit 2 FritzBoxen und 2 Mikrotik Routern als FritzBox Ersatz. Also mit 4 getrennten VLANs (101-104) zu je 2 Untagged Ports (Der NG hat nur 8).
Ergebnis: Funktioniert fehlerlos und genau so wie es soll !
Fazit:
Irgendwas machst du also noch falsch in deinem Setup oder dein NetGear Switch hat einen Firmware Bug.
Hast du die Firmware des Switches auf die aktuellste Version geflasht ?!
Bitte warten ..
Mitglied: Giftzwerg
02.03.2020 um 10:32 Uhr
ok, dann also noch einma von vorne.
Werde den Switch auf Werkseinstellung zurück setzten und neu starten.
Melde mich noch mal.
Bitte warten ..
Mitglied: aqui
02.03.2020, aktualisiert um 10:35 Uhr
Werde den Switch auf Werkseinstellung zurück setzten und neu starten.
Und dabei gleich den Firmware Versionsstand checken und ggf. gleich updaten !!
12.0.9.4 ist die latest Version:
http://www.downloads.netgear.com/files/GDC/M4300/GSM_XSM4300_V12.0.9.4. ...
Bitte warten ..
Mitglied: Giftzwerg
02.03.2020 um 11:30 Uhr
ok, das war's wohl.
Habe die Firmware aktualisiert und die Konfiguration noch einmal komplett neu eingerichtet.
Problem gelöst
Danke
Gruß
Dieter
Bitte warten ..
Heiß diskutierte Inhalte
Sicherheit
Unbefugtes Öffnen zählt nicht als Einbruch
certifiedit.netInformationSicherheit19 Kommentare

Moin, wenn wir das auf die IT übertragen dürfte kaum ein Einbruch etc unter Einbruch zu definieren sein, immerhin ...

Ausbildung
MCSA Kurs Server 2016 mit VM Jobchancen
gelöst IntershipFrageAusbildung17 Kommentare

Hallo Leute, dies ist eine dringende Frage für mich, da ich gerne einen MCSA Kurs belegen möchte. Ich brauche ...

DSL, VDSL
Glasfaser Neuvertrag möglich, bei bereits vorhandenem alten Telefonvertrag im Haus?
gelöst nioletFrageDSL, VDSL15 Kommentare

Hi Könnte eigentlich im gleichen Haus ein neuer Glasfaservertrag abgeschlossen werden, sagen wir mal auf Stockwerk 0, wenn bereits ...

Exchange Server
Zustellbestätigung deaktivieren
defiant01FrageExchange Server15 Kommentare

Hallo, ich stehe vor der Aufgabe bei einem Postfach die Zustellbestätigung für eingehende Mails zu deaktivieren. Der User geht ...

Netzwerke
SonicWall VPN - Windows top - Mac flopp
MazenauerFrageNetzwerke12 Kommentare

Grüezi und hallo Vorgeschichte, das Übliche: Marketingfirma. Corona. Homeoffice. Soweit so normal, nur scheinen die iMacs irgendein Problem mit ...

Peripheriegeräte
Kaufberatung 32" Monitor mit WQHD Auflösung
gelöst GrueneSosseMitSpeckFragePeripheriegeräte11 Kommentare

Ich wollt mir einen 32" Monitor als 16:9 zulegen, 2560x1440 Pixel (WQHD). muß kein Ultrawide mit 21:9 und curved ...

Ähnliche Inhalte
Router & Routing
DHCP im VLAN und L3 Switch
gelöst WillheFrageRouter & Routing15 Kommentare

Hallo, ich bin Neuling auf dem Gebiet VLAN und die Einarbeitung in das Thema DHCP im VLAN stockt gerade ...

Switche und Hubs
Kaufempfehlung Gigabit Switch, managed
Torsten-tFrageSwitche und Hubs14 Kommentare

Hallo, ich brauche für mein Heimnetz einen neuen Switch. Z. Zt. habe ich einen unmanaged. Folgende Anforderungen: - 24 ...

TK-Netze & Geräte
Soho L3 Managed Switch
ElmaroFrageTK-Netze & Geräte3 Kommentare

Hi. Ich suche einen SoHo Layer 3 Switch, der nicht ganz so teuer ist. Brauche ca 8 Ports. Wichtig ...

Netzwerkmanagement
Suche Managed Switch für Heimnetz
raxxis990FrageNetzwerkmanagement7 Kommentare

Hallo ich bin auf der Suche nach einem Managed Switch. Er sollte 24 Port habe und für später poe ...

Netzwerke

Empfehlung neuer Switch mit multi VLAN und DHCP Unterstützung

zesam1FrageNetzwerke6 Kommentare

Hallo Leute, ich habe in einem noch kleinen Unternehmen einen TP-Link TL-ER5120 Switch. Dieser hat eine integrierte (sehr unübersichtliche ...

Switche und Hubs

Switch VLAN einrichten

gelöst TastuserFrageSwitche und Hubs8 Kommentare

Hallo, ich habe einen Switch mit VLAn-Funktion, verstehe jedoch nicht ganz wie das funktioniert. Folgende Punkte sind vorhanden: - ...

Berechtigungs- und IdentitätsmanagementBerechtigungs- und IdentitätsmanagementWebdienste und -serverWebdienste und -serverDatenbankenDatenbankenMonitoring & SupportMonitoring & SupportHybrid CloudHybrid CloudSmall Business ITSmall Business IT