metarubin
Goto Top

DOS 6.0 Soundkarte lädt nicht / Himem.sys

Hallo zusammen,

ich hab ein altes MS-DOS 6.0 auf einem eigenen Rechner installiert und Probleme mit der Soundkarte.

Glücklicherweise konnte ich noch Original DOS und Win 3.x Treiber für die Soundkarte finden und hab diese installiert. Einige Spiele und Programme erwarten EMS-Speicher. Ich hab das System einfach mit Memmaker optimiert, soweit in Ordnung aber hier hängt sich die Soundkarte auf. Ich hab ein wenig experimentiert und konnte das Problem eingrenzen:

Wird in der config.sys die Datei himem.sys geladen, hängt sich der Rechner an der Stelle in der autoexec.bat auf, an der die Soundkarte initialisiert werden soll. Deaktiviere ich himem.sys mittles REM davor, lädt der Treiber für den Sound sauber und die Karte arbeitet.

Hat irgendwer eine Idee, wie ich das zusammen unter einen Hut bekomme ?

Vielen Dank vorab.

MF

Content-Key: 29363

Url: https://administrator.de/contentid/29363

Printed on: July 20, 2024 at 19:07 o'clock

Member: stpe
stpe Mar 30, 2006 at 18:17:11 (UTC)
Goto Top
Vielleicht sind dem Treiber die 640k mit himem.sys zusammen zu eng. Versuch den mal mit "lh" zu laden.

Die ersten Zeilen in der Config.sys sollten lauten:

DEVICE=C:\WINDOWS\HIMEM.SYS
DOS=HIGH,UMB
DEVICE=C:\WINDOWS\EMM386.EXE NOEMS

Ausserdem kannst Du Speicher freischaufeln mit:

SHELL=C:\DOS\COMMAND.COM /C LH C:\DOS\COMMAND.COM /E:512 /P
(denk in der autoexec.bat an: SET COMSPEC=C:\DOS\COMMAND.COM)

Probiere ausserdem einmal, welche Schalter die Soundkartentreiber mit auf den Weg bekommen können.

Btw: um welche Soundkarte geht es denn? Früher waren die meisten Sounkarten SB16-kompatibel. Und der Treiber geht mit Sicherheit.

Gruss
Stefan

Ach, welch geniales Thema face-smile
Member: metarubin
metarubin Mar 30, 2006 at 18:35:17 (UTC)
Goto Top
also, soweit versucht, Problem nach wie vor existent.

Die Soundkarte ist von Avance Logic und hat den Chipsatz ALS4000. Originaltreiber in Verwendung. Es handelt sich um eine SB16 kompatible Karte, Standard gesetzt auf Port: 220, IRQ 5, DMA 1. Das eigene Testprogramm spielt alles korrekt ab. Da gibt es die Datei avinit.exe. Diese wird in der autoexex.bat geladen. Hab versucht mit und ohne LH zu laden, es funktioniert nur, wenn himem.sys (und dadurch zwangläufig emm386.exe) nicht geladen wird. Avconfig.exe läßt sich auch manuell ausführen und lädt den Soundtreiber, jedoch auch dann nur, wenn himem.sys inaktiv bleibt.

Das ursprüngliche Problem ist nicht der Speichermangel im konventionellen Speicher, sondern das Fehlen von EMS-Speicher für einige Anwendungen/Spiele.

Das System: ein Pentium 133Mhz mit 96 MB RAM, 1,7 GB Festplatte, MS-DOS 6.0, Windows für Worksgroups 3.11.

Gruß
MF
Member: meinereiner
meinereiner Mar 30, 2006 at 20:22:51 (UTC)
Goto Top
Hmm, wenn ich das richtig im Kopf habe geht EMS und XMS Speicher nicht.
Wenn ich mich an damals zurück erinnere, da hatte ich mehrere Konfigurationen, die ich bei Bedarf gebootet habe, um solchen Problemen aus dem Weg zu gehen.

Hier mal zwei Links mit mehr Background:
http://www.glossar.de/glossar/1frame.htm?http%3A//www.glossar.de/glossa ...

http://www.mipraso.de/enzyklopaedie/d/dos622/emm386-exe.html

Was den Treiber angeht würde ich mal einen Orginal SB16 Treiber versuchen.


Auch frage ich mich warum du DOS 6 nimmst.
DRDOS war damals um längen besser und heute gibts z.B. FreeDos: http://www.freedos.org/
Member: metarubin
metarubin Mar 31, 2006 at 03:17:20 (UTC)
Goto Top
so, nen Original SB16 Treiber hab ich versucht, haut nich hin, der kann den Port nicht ansprechen und bleibt danach hängen. Mit der Software für den SB Pro lief es schon besser, aber hier war es der DMA, der nicht wollte. Dafür bootete der Rechner mitsamt Konfiguration für den SB Pro, also er blieb trotz himem.sys nicht hängen.

Im Augenblick hab ich das System mittels memmaker auf 602 KB konventionell gebracht, inkl. CD-ROM und Maus. Der Soundtreiber würde gerade mal 2 KB brauchen, somit hätte genug Speicher und im Augenblick auch EMS.

Ich denke, das einfachste ist, ich such mir bei ebay eine AWE32 oder nen SB Pro. Dann dürfte das klappen.

Sollte es dennoch ein paar Ideen geben, werde ich dies gerne ausprobieren.

Grüße
MF

PS: DOS 6, weils hier gerade lag face-wink