Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Exchange 2010 mehrere Smarthosts nach Absender

Mitglied: Terminatorthree

Terminatorthree (Level 1) - Jetzt verbinden

27.02.2010, aktualisiert 17:59 Uhr, 13690 Aufrufe, 9 Kommentare

Hallo liebe Administrator.de Community, ich möchte in Exchange die Mails über verschiedene Smarthosts leiten, je nach Absender.

Mich quält seit einigen Tagen dieses Problem. Ich habe hier einige wenige User deren Mails sowie Kontakte und Termine auf dem Exchange verwaltet werden. Die Mails werden von Freemailern abgeholt und dann an die Postfächer zugestellt. Dies funktioniert auch. Das Problem stellt sich für mich nun beim Versenden der Mails. Die Mails müssen je nach User wieder über den Smarthost versendet werden. Wie kann ich nun erreichen das die Mails je nach Absender über bestimmte Smarthosts gesendet werden? Wie gesagt nach dem Absender nicht nach Empfängerdomain.

Es wäre super wenn ihr mir auch diesmal wieder helfen könntet.

Es kann auch zusätzliche Software eingesetzt werden, jedoch ist wie immer kein Geld vorhanden um neue Software zu kaufen also kommt nur Freeware in Frage (wenn sich das nicht mit Exchange Mitteln lösen lässt).

Mit freundlichen Grüßen

Terminatorthree
Mitglied: filippg
27.02.2010 um 22:08 Uhr
Hallo,

das ist so im Exchange nicht vorgesehen.
Der Workaround unter Ex 2003 (von dem du also schauen kannst, ob der in 2007 immer noch geht) war das Setzen von Berechtigungen auf dem Send-Connector. Lege für jeden Nutzer einen Connector an, denn nur er nutzen darf. Exchange sucht dann für jeden den geeigneten raus... Aber Freude macht man sich damit nicht.

Gruß

Filipp
Bitte warten ..
Mitglied: Terminatorthree
27.02.2010 um 22:16 Uhr
Danke die Idee hatte ich auch schon so in der Art. Aber wie setzt man denn Berechtigungen auf einen Send-Connector?
Ich habe inzwischen auch das hier noch als Tipp bekommen: http://blogs.technet.com/appssrv/archive/2009/08/26/how-to-control-rout ...
Bitte warten ..
Mitglied: Stephan.Betken
28.02.2010 um 00:51 Uhr
Hallo,

leider besteht die Möglichkeit, dies über Berechtigungen zu lösen, nicht mehr.

Terminatorthree hat aber in einem anderen Forum ein paar Lösungsvorschläge für eine Eigenbau- und eine kostenpflichtige Lösung bekommen. (siehe http://www.mcseboard.de/ms-exchange-forum-80/exchange-2010-mehrere-smar ... )

http://blogs.technet.com/appssrv/archive/2009/08/26/how-to-control-rout ...
Bitte warten ..
Mitglied: Terminatorthree
28.02.2010 um 10:25 Uhr
Hmm ok,
erstmal danke für die Info das es so nicht mehr geht. Dann brauch ich nicht mehr nach einem Berechtigungsschalter suchen.
Die Eigenbaulösung werde ich mir noch genauer ansehen (müssen). Leider startete gestern nach einem kurzen Test der Exchange Transport Dienst nicht mehr da der Assembly Path (der ja vorher importiert wurde) nicht mehr gefunden wurde. Hat jemand vielleicht eine Idee woran das liegen kann? Sobald ich zu komme werde ich auch noch ein wenig weiter probieren.

Vielen Dank bis hierhin für die Antworten
MfG Terminatorthree
Bitte warten ..
Mitglied: Stephan.Betken
28.02.2010 um 10:38 Uhr
Hi,

ich würde auch zu der bereits vorgeschlagenen Firmendomain tendieren, an die die vorhandenen E-Mail-Adressen weitergeleitet werden.
Die Alternative zur Eigenbaulösung ist für andere vielleicht auch interessant. https://solutionfinder.microsoft.com/Solutions/SolutionDetailsView.aspx? ...

Bekommst du denn eine Fehlermeldung?

Beste Grüße
Stephan
Bitte warten ..
Mitglied: Terminatorthree
28.02.2010 um 10:49 Uhr
Ja im EventViewer erhalte ich die Meldung: "AssemblyPath not found"
EDIT:
Microsoft Exchange couldn't start transport agents. The Microsoft Exchange Transport service will be stopped. Exception details: Failed to create type 'RoutingAgentOverride.SampleRoutingAgentFactory' from assembly 'E:\Share\Dlls\ClassLibrary1.dll' due to error 'Invalid agent assembly path.'. : Microsoft.Exchange.Data.ExchangeConfigurationException: Failed to create type 'RoutingAgentOverride.SampleRoutingAgentFactory' from assembly 'E:\Share\Dlls\ClassLibrary1.dll' due to error 'Invalid agent assembly path.'. ---> System.ArgumentException: Invalid agent assembly path.
--- End of inner exception stack trace ---
at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable.CreateAgentFactory(AgentInfo agentInfo)
at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable..ctor(IEnumerable agents)
at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.RuntimeSettings..ctor(MExConfiguration config, String agentGroup)
at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.MExRuntime.Initialize(String configFile, String agentGroup, Boolean isBridgeHead, String installPath)
at Microsoft.Exchange.Transport.Categorizer.MExEvents.Initialize(String configFilePath)
at Microsoft.Exchange.Transport.Components.CategorizerMExRuntimeLoader.Load()
Bitte warten ..
Mitglied: osterhase09
01.03.2010 um 16:59 Uhr
Alternativ könnte man auch einen SMTP-Relay-Server nutzen wie bspw. www.authsmtp.com
Ist aber auch nicht die eleganteste Lösung im Hinblick auf SPAM-Filter bei den Mail-Empfängern. Privat habe ich das seit etwa einem Jahr im Einsatz - es verirren sich nur recht wenige Mails in den Filtern von GMX und Co... Aber es ist definitiv nicht fehlerfrei.
Bitte warten ..
Mitglied: Stephan.Betken
01.03.2010 um 17:03 Uhr
details: Failed to create type 'RoutingAgentOverride.SampleRoutingAgentFactory' from assembly
'E:\Share\Dlls\ClassLibrary1.dll' due to error 'Invalid agent assembly path.'. :

Hört sich gerade nach dem falschen Pfad an (oder einer defekten DLL).
Bitte warten ..
Mitglied: Terminatorthree
01.03.2010 um 17:21 Uhr
Hallo ihr Lieben,
es tut mir Leid das ich mich erst jetzt wieder melden kann. Ich habe die Sache noch einmal von vorbe gemacht und nun geht es komischerweise. Woran es gelegen hat kann ich leider nict mehr nachvollziehen, der Pfad hat jedoch definitiv gestimmt. Dementsprechend markiere ich diesen Beitrag hier als gelöst, ich habe ja eine Lösung bekommen habe.

Ich danke euch allen für eure Hilfe.

MfG
Terminatorthree
Bitte warten ..
Ähnliche Inhalte
Exchange Server

Ex2016 + Hornet - Sendet über Smarthost nichts mehr

Frage von kfp000Exchange Server1 Kommentar

Hallo, folgende Problematik: - Mein Kunde hat heute eine neue feste IP bekommen (Anbieterwechsel) - Es läuft ein Exchange ...

Exchange Server

Exchange 2010 (SBS) nur noch als Smarthost nutzen?

Frage von gagaguExchange Server9 Kommentare

Hallo, wir haben einen SBS 2011 mit einem Exchange 2010 im Einsatz den wir gerade duch einen Exteren Anbieter ...

Exchange Server

Smarthost sendet nicht

gelöst Frage von zeroblue2005Exchange Server7 Kommentare

Hallo Zusammen, ist sicherlich mal wieder nur eine Kleinigkeit, aber auf meinem neu eingerichteten Exchange bekomme ich den Smarthost ...

Exchange Server

DNS und Relay-Server(SmartHost)

Frage von oceExchange Server4 Kommentare

Hallo zusammen, ich habe einen Exchange 2010 aufgesetzt der auch Intern ohne Probleme funktioniert. Ich möchte ihn jetzt von ...

Neue Wissensbeiträge
Router & Routing
Der "768k-Day" kommt
Information von LordGurke vor 9 StundenRouter & Routing2 Kommentare

Für Leute, die Router mit BGP-Fulltable betreiben vielleicht ein interessanter Hinweis: Die IPv4-Fulltable erreicht voraussichtlich innerhalb der nächsten 2-3 ...

Debian

Partition angeblich voll, dabei aber noch nicht mal zur Hälfte belegt

Anleitung von diemilz vor 12 StundenDebian8 Kommentare

Hallo zusammen, ich habe ein kleines Problem: Ich habe auf einem physischen Debian Linux Server als ZoneMinder-Server (HP ProLiant ...

Windows 7
Updategängelung auf Windows 10, die zweite
Information von Penny.Cilin vor 5 TagenWindows 72 Kommentare

Hallo, da Windows 7 im kommenden Jahr nicht mehr supportet wird, werden Nutzer von Window 7 home premium wieder ...

Internet
EU-Urheberrechtsreform: Zusammenfassung
Information von Frank vor 7 TagenInternet1 Kommentar

Auf golem.de gibt es eine Analyse von Friedhelm Greis, der das Thema EU-Urheberrechtsreform gut und strukturiert zusammenfasst. Zwar haben ...

Heiß diskutierte Inhalte
Backup
Veeam Community Edition
gelöst Frage von dgrebnerBackup21 Kommentare

Hallo Zusammen, kann jemand seine praktischen Erfahrungswerte mit der Veeam-Community Edition mit mir teilen? Es gab dazu ja schon ...

LAN, WAN, Wireless
Notebooks in Firmenwlan authentifizieren
gelöst Frage von EarthShakerLAN, WAN, Wireless17 Kommentare

Guten Tag, unsere Firma möchte gerne flächendeckend WLAN einführen und hat zu diesem Zweck einen Dienstleister beauftragt. Wir benötigen ...

Festplatten, SSD, Raid
Harddisk kaputt, was sagt mir ChrystalDiskInfo
gelöst Frage von InfoSeekerFestplatten, SSD, Raid14 Kommentare

Hallo zusammen, Mein Rechner lahmt. Ich stell mir die Frage woran es liegt und bin der Meinung es ist ...

Netzwerkmanagement
Netzwerk vorübergehend weg
gelöst Frage von ahstaxNetzwerkmanagement13 Kommentare

Hallo, folgendes Szenario stellt sich dar: Im Netzwerk mit Win7-PCs wurden Switche ausgetauscht. Grundsätzlich funktioniert alles mindestens so gut ...