telefix1
Goto Top

FreeNAS raid degraded - keine Freigaben mehr

Moin moin,

wir benutzen einen FreeNAS zur Datenspeicherung. Jeder Client hat eine Freigabe auf ein Verzeichnis und syncronisiert allabendlich,teils über LAN, teils über VPN, seine Daten. Danach läuft über LAN ein Backup.

Gestern brach das Backup nach ca. 10% plötzlich ab und die lokale Freigabe auf Verzeichnisse und zum Server war weg.

Ping auf die Server-IP: ok.
Ping auf Servernamen: ok.
Console vom NAS: funktionsfähig
Browser-GUI vom NAS: funktionsfähig

Der NAS hat 3 HD´s. ad0 ist eine Systemplatte, ad2 und ad3 bilden einen Raid1-Verbund. Status und Log zeigen an:
"Raid degraded".

Was habe ich bereits unternommen: ich habe die Raid-Platten abgehängt und entfernt. Nach einem Neustart habe ich die Platten hinzugefügt und gemounted. Wieder Neustart: die Platten sind online, der Status degraded für das Raid ist geblieben.

Den Raid-Verbund aufzulösen und neu zusammen zu setzen traue ich mir nicht, weil mich die Warnung eines kompletten Datenverlustes davon abhält.

Jetzt brauche ich Eure Hilfe.

mfg. telefix1

P.S. Anbei das Start-Log. Die SMART-Funktion ist eigentlich desabled. Warum sie als Fehler auftaucht weiss ich nicht.

Dec 23 08:34:00 lighttpd[1757]: (log.c.97) server started
Dec 23 08:34:03 login: login on ttyv0 as root
Dec 23 08:34:33 smbd[1520]: [2008/12/23 08:34:33, 0] smbd/server.c:open_sockets_smbd(527)
Dec 23 08:34:33 smbd[1520]: open_sockets_smbd: accept: Software caused connection abort
Dec 23 08:35:24 lighttpd[1757]: (connections.c.132) (warning) close: 6 Connection reset by peer
Dec 23 08:36:11 kernel: ad2: FAILURE - SMART status=51<READY,DSC,ERROR> error=4<ABORTED>
Dec 23 08:36:11 kernel: ad3: FAILURE - SMART status=51<READY,DSC,ERROR> error=4<ABORTED>
Dec 23 08:36:11 kernel: ad3: FAILURE - SMART status=51<READY,DSC,ERROR> error=4<ABORTED>
Dec 23 09:00:14 root: Error: Failed to create directory /mnt/raid1
Dec 23 09:00:14 root: Error: Failed to mount /dev/mirror/Raid1p1 using UFS
Dec 23 09:05:23 kernel: ad2: FAILURE - SMART status=51<READY,DSC,ERROR> error=4<ABORTED>
Dec 23 09:05:23 kernel: ad3: FAILURE - SMART status=51<READY,DSC,ERROR> error=4<ABORTED>
Dec 23 09:05:23 kernel: ad3: FAILURE - SMART status=51<READY,DSC,ERROR> error=4<ABORTED>

Content-Key: 104647

Url: https://administrator.de/contentid/104647

Printed on: June 22, 2024 at 19:06 o'clock

Member: Top44
Top44 Dec 23, 2008 at 09:33:21 (UTC)
Goto Top
Wenn die Dienste alle auf der ad0 liegen, solltest du dort erst einmal nachschauen, denn deine Dienste verabschieden sich nach und nach. Kann sein das mit der Systemplatte was faul ist, vielleicht nen knacks und dadurch is das Raid ( Onboard ? ) futsch.


grüße
Member: telefix1
telefix1 Dec 23, 2008 at 11:08:36 (UTC)
Goto Top
...ok., ich habe die Konfiguration gesichert, das System auf eine neue ad0 neu aufgesetzt, die Konf. zurück gespielt, die Platten eingebunden, einzeln gemounted, anschl. das Raid1als ganzes gemounted.

ES FUNKTIONIERT!

thx @all

mfg telefix1

P.S.

Das Log zeigt immer noch den SMART-Fehler:

Dec 23 11:47:41 kernel: GEOM_MIRROR: Device Raid1: rebuilding provider ad2 finished.
Dec 23 11:47:41 kernel: GEOM_MIRROR: Device Raid1: provider ad2 activated.
Dec 23 11:48:31 kernel: ad2: FAILURE - SMART status=51<READY,DSC,ERROR> error=4<ABORTED>
Dec 23 11:48:31 kernel: ad3: FAILURE - SMART status=51<READY,DSC,ERROR> error=4<ABORTED>
Dec 23 11:48:31 kernel: ad3: FAILURE - SMART status=51<READY,DSC,ERROR> error=4<ABORTED>

Ich bin sicher, dass sowohl im BIOS als auch auf dem Samba die SMART-Funktionen ausser Betrieb sind. Könnte da vielleicht noch etwas drohen???
Member: Top44
Top44 Dec 23, 2008 at 11:30:43 (UTC)
Goto Top
Frag doch einfach mal im FreeNAS Forum.
Da es deren Produkt ist werden die sicherlich mehr wissen.

grüße