telefix1
Goto Top

php4 php5 mysql crypt verschiedene Versionen?

Moin moin,
wir benutzen einen produktiven Debian etch mit php4 und mysql5 als Mailserver (fetchmail, exim4, courier, vexim, roundcube).
Ich habe jetzt einen Debian5 mit php5 neu aufgesetzt, die nötigen Programme installiert und die alten Datenbanken importiert.
Soweit sogut, alles funktioniert.

Lege ich in vexim neue Domains oder User an, werden die Zugangsdaten in die entsprechende Tabelle geschrieben.
Danach ist mit diesen neuen Zugangsdaten von vexim kein Zugang mehr möglich. Auch courier und roundcube wird mit diesen Daten kein Zugang mehr gewährt.

Ich habe daraufhin einen alten Zugang (gesichert) gelöscht und neu angelegt. Dabei ist mir aufgefallen, dass in der sql-user-Tabelle unter crypt eine völlig andere Zeichenfolge steht als erwartet, während die clear-Spalte das richtige Passwort hat. Ich habe dann händisch das alte crypt-Passwort rein geschrieben und alles war wieder gut.

Fazit für mich: php4 und php5 benutzen bei md5-crypt verschiedene Verfahren.

Irre ich mich und gibt es ein Workaround zur Lösung?

mfg telefix1

Content-Key: 111949

Url: https://administrator.de/contentid/111949

Printed on: June 22, 2024 at 19:06 o'clock

Member: wolfenstein
wolfenstein Mar 20, 2009 at 10:04:33 (UTC)
Goto Top
Wie ich weiß nicht, ab PHP5 gibt es zwar einen 2. Parameter, aber wenn der nicht eplizit auf true gesetzt wird, ändert sich das Verhalten nicht.
Member: telefix1
telefix1 Mar 20, 2009 at 11:02:37 (UTC)
Goto Top
@wolfenstein: ...meinst Du den:

  1. created by debconf
[mysqld]
old_passwords = false

?

War ich auch schon dran. Leider kein Erfolg.

Mittlerweile habe ich herausgefunden, dass die Kombination php5 und mysql5 100% funktioniert und dass es nur von vexim ausgeht.
Damit bin ich wahrscheinlich in diesem Forum verkehrt.

Sollte es trotzdem jemanden geben, der eine Lösung für dieses vexim-Problem hat, immer her damit.

mfg telefix1
Member: wolfenstein
wolfenstein Mar 20, 2009 at 13:46:23 (UTC)
Goto Top
Hi telefix1,

nee ich bin mir nicht ganz sicher aber ich glaube der heißt "raw-output" schau mal danach.
kann mich nicht mehr genau erinnern, aber ich denke der heißt so und er ist standard 'false' hab ich ja schon erwähnt .

Na wenn das an vexim liegt kann zumindest ich dir nicht wirklich helfen.
hoffe aber dennoch das ich dir irgendwie helfen konnte.

Grüße
Wolfenstein