telefix1
Goto Top

Bei Eingabe mehrere und verschieden Excel-Felder Text vergleichen und Auswertung ausgeben...

Guten Tag Allerseits,

ich lege Tabellen mit Spielansetzungen im LigaSport mit folg. Format an:

Datum | Zeit | Klasse | Location | Nummer | Team1 | Team2 | Schiedsrichter3
Datum | Zeit | Klasse | Location | Nummer | Team3 | Team4 | Schiedsrichter5
.
.
.

Schon bei der Eingabe des Schiedsrichters muss sichergestellt sein, dass er nicht angesetzt werden kann, wenn er einem Verein des Teams 1 oder 2 angehört.

Meine Idee wäre, dem Schiri in einer anderen Tabelle einen Verein zuzuordnen:

Team1 | Schiedsrichter 1
Team2 | Schiedsrichter 2
Team3 | Schiedsrichter 3
Team4 | Schiedsrichter 4
Team4.1 | Schiedsrichter 4
Team5 | Schiedsrichter 5
.
.
.

und bei der Eingabe diese Tabelle mit den Feldern für Team 1 und 2 zu vergleichen.
Sollte es eine Übereinstimmung geben, muss sofort irgendwie "Alarm" (Text) ausgelöst werden:

Datum | Zeit | Klasse | Location | Nummer | Team1 | Team2 | Schiedsrichter3 | OK
Datum | Zeit | Klasse | Location | Nummer | Team3 | Team4 | Schiedsrichter4 | NOK


Die einfache Formel "=wenn(a1=a2;"OK;"NOK")" reicht hier offenbar nicht face-sad
Zu mehr reicht es aber mit meinen spärlichen Kenntnissen nicht.
Vielleicht kann mir jemand (bastla?), mit Ideen unterstützend, unter die Arme greifen...

MfG. telefix1

Content-Key: 204096

Url: https://administrator.de/contentid/204096

Printed on: June 22, 2024 at 18:06 o'clock

Member: bastla
bastla Mar 28, 2013 updated at 13:19:20 (UTC)
Goto Top
Hallo telefix1!

Die Idee mit der Zuordnungsliste in der zweiten Tabelle ist gut; besser wäre noch die Angabe in umgekehrter Reihenfolge, da ja nach dem Schiedsrichter gesucht werden soll - dann könnte die Formel (im Beispiel für Zeile 1, lässt sich aber nach unten kopieren) zB so aussehen:
=WENN(ISTNV(SVERWEIS(H1;Tabelle2!$A:$A;1;0));"Schiri nicht in Liste";WENN(ODER(SVERWEIS(H1;Tabelle2!$A:$B;2;0)=F1;SVERWEIS(H1;Tabelle2!$A:$B;2;0)=G1);"Schiri von: " & SVERWEIS(H1;Tabelle2!$A:$B;2;0);"OK"))
Mit einer Zusatzspalte (zB Spalte T, kann auch ausgeblendet werden), in welcher das Team zum Schiedsrichter eingetragen werden könnte, würde das natürlich übersichtlicher gehen:
=WENN(ISTNV(T1);"Schiri nicht in Liste";WENN(ODER(T1=F1;T1=G1);"Schiri von: " & T1;"OK"))
und in T1 dazu:
=SVERWEIS(H1;Tabelle2!$A:$B;2;0)
Grüße
bastla