Freigabe auf Win2000 SP4 als "Nichtverbundenes Netzlaufwerk" ??

marc-1303
Goto Top
Hallo Netzwerk-Gurus

Meine Voraussetzung:
Peer-to-Peer Netzwerk, "Server" Win2000 SP4 (Keine Server-Software), Client WinXP SP2

Ich habe 6 Freigaben auf dem Datei-Server. 5 Freigaben funktionieren prima.
Eine Freigabe aber fällt immer wieder raus und erscheint dann als "Nichtverbundenes Netzlaufwerk"
im Explorer des Clients. Wenn ich das Laufwerk auf dem Client wähle habe ich trotzdem Vollzugriff.
Es bleibt aber im Explorer als nichtverbundenes Netzlaufwerk erhalten. Erst nach dem Neustart des
"Servers" bleibt das Laufwerk für ca. 1-2 Tage ganz normal als Netzlaufwerk erhalten. Dann erscheint
es wieder als nichtverbunden.

Auf dieser Freigabe sind keine speziellen Rechte gesetzt. Jeder hat Vollzugriff.

Weiss jemand Abhilfe für dieses Problem?

Content-Key: 21477

Url: https://administrator.de/contentid/21477

Ausgedruckt am: 01.07.2022 um 12:07 Uhr

Mitglied: khhess
khhess 13.12.2005 um 10:02:14 Uhr
Goto Top
Erhöhe einmal die Freigabezeit für dieses Share, dies wird in der Regestrierung gemacht.

Zum Schlüssel Hkey_Local_Machine\System\Currentcontrolset\Services\Lanmanserver\Parameters navigieren.
Den Wert "autodisconnect" auf "4294967295" (entspricht 8171 Jahre) setzen.
Mitglied: marc-1303
marc-1303 13.12.2005 um 10:18:52 Uhr
Goto Top
Hallo khhess

Ich bin kein erfahrener Registry-Surfer. Den Wert (4294967295) muss ich als Dezimal-Zahl eingeben, das isch schon richtig, oder?

Gruss
Marc
Mitglied: khhess
khhess 13.12.2005 um 10:37:26 Uhr
Goto Top
Richtig, der Wert Dezimal.

Alternativ geht auch:


Net Config Server /autodisconnect:4294967295
Mitglied: marc-1303
marc-1303 15.12.2005 um 15:12:23 Uhr
Goto Top
Hallo khhess

Ich habe den Wert erhöht und die Maschine neu gestartet.
Nach einem Tag hat sich das Laufwerk aber wieder verabschiedet.

Selbes Verhalten wie vor dem neuen Wert für autodisconnect.

Weisst Du noch mehr Tricks?

Gruss
Marc
Mitglied: khhess
khhess 15.12.2005 um 21:51:42 Uhr
Goto Top
Hast du die Befehlzeile auch auf dem "Client" und nicht auf dem "Server" ausgeführt?
Den der Client stellt die Verbindung zur Freigabe her.

Wie wäre ein Linux-Server (z.B.: Debian von der Zeitschrift ct, funktioniert gut und leicht zu administrieren. Dort wird Samba eingesetzt).
Mitglied: marc-1303
marc-1303 16.12.2005 um 07:05:17 Uhr
Goto Top
Nein, bisher habe ich den Wert nur auf dem Server eingestellt.
Werde jetzt gerade den Client umstellen und schauen ob's was bringt.

Bez. Linux läuft ein Projekt. Allerdings wird das noch ein bisschen dauern,
weil wir das Know-How nicht im Hause haben und so auf einen Externen
angewiesen sind. Wir streben eine Lösung mit Ubuntu-Linux an.
Benutzerverwaltung über LDAP mit Samba-Server.
Mitglied: marc-1303
marc-1303 05.01.2006 um 12:25:49 Uhr
Goto Top
hallo khhess

ich habe inzwischen der wert auch in der registry des clients geändert.
es tritt aber immer noch keine besserung ein.

gruss
marc
Mitglied: HuskyMcFly
HuskyMcFly 04.01.2008 um 10:58:21 Uhr
Goto Top
Versuchs mal damit:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider]
"RestoreConnection"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order]
"ProviderOrder"="Cwbnetnt,LanmanWorkstation"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\HwOrder]
"ProviderOrder"="Cwbnetnt,LanmanWorkstation"

Das Problem hatten wir früher bei uns auch...

Mache dir bitte vorher eine Sicherung der Registrykeys die hier überschrieben werden...