Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Inter VLAN Routing Frage

Mitglied: Mitsch79

Mitsch79 (Level 1) - Jetzt verbinden

15.12.2015 um 16:30 Uhr, 1350 Aufrufe, 2 Kommentare

Hallo Liebe Leute,

Ich habe ein Netzwerkseitiges Problem bei dem sich mir die Logik nicht ganz erschließt.

Folgende Situation.

2 physisch getrennte Netze sind vorhanden .

LAN1: 192.168.80.0 / 24
LAN2: 192.168.100.0 /23

1 NAS + 1 ESX Server aus dem LAN1: sind ins LAN 2 gewandert (anderer Gebäudetrakt).

Plan ist diese beiden Netze mit einem L3 Switch zu verbinden HP procurve 2920 - damit LAN 1 auf das NAS + ESX Server im LAN 2 zugreifen kann - also soll der Switch Router spielen.

1) VLAN1 mit VLAN IP: 192.168.80.35 +
VLAN2 mit VLAN IP: 192.168.100.27 sind angelegt - ip Routing am Switch aktiviert - soweit so gut.
2) das NAS hat eine neue fixe IP aus LAN2 bekommen 192.168.100.28 - GW=192.168.100.27
3) der ESX Server auf einem neuen Management Interface ebenfalls eine neue fixe ip: 192.168.100.29; GW = 192.168.100.27

Nun habe ich folgendes Problem:
Ich habe einen Testrechner aus LAN 1 mit Gateway: 192.168.80.35 versehen und kann im LAN2 die IP 192.168.100.27 (VLAN2 IP) + 192.168.100.28 (NAS) pingen - von 192.168.100.29 (ESX Server) bekomme ich keine Rückmeldung !
Wenn ich mich allerdings am besagten Switch auf ein VLAN2 Interface anhänge und mir eine IP aus dem LAN2 Netz gebe kann ich den 192.168.100.29 wie auch *27 + *28 Server problemlos pingen.


Auch kann ich aus LAN 2 über GW: 192.168.100.27 , Rechner im LAN1 pingen welche das VLAN1 GW: 192.168.80.35 benutzen .

Es geht hier dediziert darum das ich den ESX Host aus LAN 1 im LAN2 nicht erreichen kann - da die beiden anderen Schnittstellen insbesondere die 192.168.100.28 erreichbar ist, kommt mir das ganze sehr seltsam vor..

Habe ich ESX seitig evtl. vergessen etwas zu konfigurieren ? Hat jemand Erfahrung mit ESX Schnittstellen und verschiedenen VLAN´s

Bin für jeden Tipp dankbar !



Die HP Procurve 2920 Switch config sieht wie folgt aus:

*

hostname "HP-2920-48G"
module 1 type j9729a
ip routing
snmp-server community "public" unrestricted
oobm
ip address dhcp-bootp
exit
vlan 1
name "DEFAULT_VLAN"
no untagged 41-44
untagged 1-40,45-48,A1-A2,B1-B2
ip address 192.168.80.35 255.255.255.0
exit
vlan 2
name "*"
untagged 41-44
ip address 192.168.100.27 255.255.254.0
exit
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update

***
Mitglied: aqui
15.12.2015 um 17:05 Uhr
L3 Switch zu verbinden HP procurve 2920
Igitt ! HP...
also soll der Switch Router spielen.
Ein klassisches Allerweltsszenario...!
VLAN1 mit VLAN IP: 192.168.80.35 + VLAN2 mit VLAN IP: 192.168.100.27 sind angelegt
Ist IP Adress technisch nicht so besonders schön, denn Router IPs nimmt man nicht gerne "mitten" in die IP Range.
Deshalb nicht weil man so sicher Überschneidungen und damit dann ein IP Chaos verhinden kann. Am besten positionieren verantwortungsvolle Netzwerker solche IPs immer "ganz oben" oder "ganz unten". Bei einer 24 Bit Maske dann also immer die .1 und / oder die .254
Das ist aber nur ein kosmetischer Aspekt und hat mit der o.a. Problematik nichts zu tun !
von 192.168.100.29 (ESX Server) bekomme ich keine Rückmeldung !
Damit pingst du den Hypervisor selber und keine VM dadrin, richtig ?
Das der Hypervisor und das NAS von einem Client direkt im VLAN pingbar sind ist klar. Wenn das nicht gehen würde wäre grundsätzlich was falsch.
Das es das nicht ist kannst du an der Tatsache sehen das dein VLAN 1 Client fehlerlos das VLAN 2 Router Interface auf dem L3 Switch als auch das NAS pingen kann.
Wichtig ist hier immer zu wissen das die Absender IP in dieser Konstellation eine aus einem fremden Netz ist.
Hast du geprüft ob der ESXi auf solche IP Adressen antwortet ?
Wenn er eine interne Firewall hat dann wird er das nicht tun ohne das du diese anpasst ! Möglich ist auch das die Default Gateway IP des ESXi falsch ist ode rnicht konfiguriert ist. Diese muss logischerweise auch auf die VLAN 2 IP des Switches zeigen !

Du kannst ja ganz einefach einen Quercheck machen indem du einen 2ten PC oder Laptop an den Port des ESXi hängst mit seiner IP Adresse. (ESXi natürlich abziehen)
Wenn dieser Testrechner dann pingbar ist dann liegt es einzig und allein an der lokalen IP Einstellung oder Firewall des ESXi.
Zu 98% ist es nicht der Switch bzw. dessen L3 Konfiguration, denn dann wäre das NAS aus dem 2ten netz auch nicht pingbar.
Grundlagen zu dem Thema findest du hier:
https://www.administrator.de/wissen/vlan-installation-routing-pfsense-mi ...
(Den externen Router denkst du dir weg...)
Bitte warten ..
Mitglied: Mitsch79
15.12.2015, aktualisiert um 18:06 Uhr
Zitat von aqui:

Hallo @aqui Vielen Dank für die rasche Reaktion !

L3 Switch zu verbinden HP procurve 2920
Igitt ! HP...
HAHA.. wieso wusste ich dass das kommt ?
also soll der Switch Router spielen.
Ein klassisches Allerweltsszenario...!
richtig
VLAN1 mit VLAN IP: 192.168.80.35 + VLAN2 mit VLAN IP: 192.168.100.27 sind angelegt
Ist IP Adress technisch nicht so besonders schön, denn Router IPs nimmt man nicht gerne "mitten" in die IP Range.
Deshalb nicht weil man so sicher Überschneidungen und damit dann ein IP Chaos verhinden kann. Am besten positionieren verantwortungsvolle Netzwerker solche IPs immer "ganz oben" oder "ganz unten". Bei einer 24 Bit Maske dann also immer die .1 und / oder die .254
Das ist aber nur ein kosmetischer Aspekt und hat mit der o.a. Problematik nichts zu tun !
Ja ist in diesem Fall leider nicht anders möglich, ansonsten hätte ich die Bereiche anders gewählt, glaube mir.
von 192.168.100.29 (ESX Server) bekomme ich keine Rückmeldung !
Damit pingst du den Hypervisor selber und keine VM dadrin, richtig ?
richtig

Das der Hypervisor und das NAS von einem Client direkt im VLAN pingbar sind ist klar. Wenn das nicht gehen würde wäre grundsätzlich was falsch.
Das es das nicht ist kannst du an der Tatsache sehen das dein VLAN 1 Client fehlerlos das VLAN 2 Router Interface auf dem L3 Switch als auch das NAS pingen kann.
Wichtig ist hier immer zu wissen das die Absender IP in dieser Konstellation eine aus einem fremden Netz ist.
Hast du geprüft ob der ESXi auf solche IP Adressen antwortet ?
Wenn er eine interne Firewall hat dann wird er das nicht tun ohne das du diese anpasst ! Möglich ist auch das die Default Gateway IP des ESXi falsch ist ode rnicht konfiguriert ist. Diese muss logischerweise auch auf die VLAN 2 IP des Switches zeigen !

Ich habe wie gesagt mit einer LAN1 IP und entsprechender VLAN1 GW IP Einstellung versucht den esx zu pingen - ohne Erfolg, die anderen beiden VLAN2 IP´s sind ja anpingbar.
Auch hat der ESX Server auf dem Management Interface die VLAN2 IP als GW eingetragen - das passt grundsätzlich.
Ich dachte mir schon das es mit der ESX Config zu tun haben muss, allerdings habe ich den Aspekt der Firewall am esx nicht bedacht ! - danke für den Tipp ! da hast Du mir schon sehr geholfen !
Ich werde das sobald wie möglich prüfen.
Du kannst ja ganz einefach einen Quercheck machen indem du einen 2ten PC oder Laptop an den Port des ESXi hängst mit seiner IP Adresse. (ESXi natürlich abziehen)
Genau das hatte ich als nächstes Vor
Wenn dieser Testrechner dann pingbar ist dann liegt es einzig und allein an der lokalen IP Einstellung oder Firewall des ESXi.
Zu 98% ist es nicht der Switch bzw. dessen L3 Konfiguration, denn dann wäre das NAS aus dem 2ten netz auch nicht pingbar.
Grundlagen zu dem Thema findest du hier:
https://www.administrator.de/wissen/vlan-installation-routing-pfsense-mi ...
(Den externen Router denkst du dir weg...)
Bitte warten ..
Ähnliche Inhalte
Router & Routing
VLAN Routing Design
Frage von tvprog1Router & Routing6 Kommentare

Hallo, wird zwischen VLANs in großen Netzwerk Setups üblicherweise über den Core Switch geroutet, oder über eine seperate Firewall ...

Router & Routing
VLAN Routing Pfsense
gelöst Frage von jescheroRouter & Routing16 Kommentare

Hallo alle zusammen, Erstmal meine Netzwerke sind: Vlan 60 = 172.26.131.0/24 Vlan 70 = 172.27.131.0/24 Vlan 80 = 172.28.131.0/24 ...

Router & Routing
HP VLAN routing
gelöst Frage von homermgRouter & Routing5 Kommentare

Hey Leute, ich versuche gerade ein TestVLAN einszurichten auf einem HP Switch. Mein Standard VLAN auf dem gleichen Switch ...

Switche und Hubs
VLAN Gateway Routing
gelöst Frage von DerPraktikantSwitche und Hubs7 Kommentare

Hallo, und zwar habe ich mir eine Testumgebung aufgebaut : Mein Problem ist das ich über den Rechner im ...

Neue Wissensbeiträge
Sicherheits-Tools

TrendMicro Worry-Free Business Security 10.0 SP1 - Jetzt in Deutsch verfügbar! (Windows 10 1903 Support)

Tipp von TrinXx vor 1 TagSicherheits-Tools1 Kommentar

Moin! Nach wochenlangem Warten wird Trend Micro das SP1 für WFBS 10 voraussichtlich am 26.08.19 veröffentlichen. Ich habe das ...

Hyper-V
Setup VM W2016 startet nicht in Hyper-V 2016
Erfahrungsbericht von keine-ahnung vor 2 TagenHyper-V4 Kommentare

Moin, sitze gerade über meinem neuen Server und versuche, die VM auf den Host zu prügeln. Jetzt wollte ich ...

Server-Hardware

HPE Proliant ML350P Gen8 Probleme mit Zugriff auf Raid-Volumes

Erfahrungsbericht von goscho vor 2 TagenServer-Hardware1 Kommentar

Hallo Leute, das Problemgerät: HPE ML350P G8 Windows Server 2012R2 HyperV-Host 8 x 300 GB 10K SAS HDD (1 ...

Humor (lol)

"Linux und 5 Gründe Warum man kein Windows verwenden sollte sondern Ubuntu Linux"

Information von Snowbird vor 4 TagenHumor (lol)9 Kommentare

Gerade gefunden. Ja, ist etwas älter, aber irgendwie lustig?

Heiß diskutierte Inhalte
Backup
Veeam Backup Endpoint Free sichert nicht alle Dateien in AppData
gelöst Frage von speedy26gonzalesBackup12 Kommentare

Hallo, ich sollte ein paar Dateien in C:\Users\xyc\AppData\Local\Microsoft\Outlook wieder herstellen. Auf dem Benutzerkonto ist in Outlook ein IMAP Konto ...

Server
Ein Server ins Haus stellen. Was brauche ich dafür?
Frage von JoschiTomServer10 Kommentare

Hallo Community, ich spiele mit dem Gedanken eine Server mir zu holen. Was brauche ich dafür? Und wie sind ...

Windows 10
Windows 10 Backup auf Netzwerk Storage
Frage von Futschel2608Windows 1010 Kommentare

Hallo geehrte Mitstreiter Innen, Wir wollen in unserer Windows 10 Domäne den Einzelnen Usern ermöglichen ihre Desktop PC's zusichern. ...

Batch & Shell
Mittels SED Text ersetzen in Anführungszeichen
gelöst Frage von nekronBatch & Shell9 Kommentare

Moin … bin nicht wirklich der SED/regex Mensch, vielleicht kann mir jemand auf die Schnelle Helfen :) ich habe ...