Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Intranet - Apache und PhP 4 plötzlich nicht mehr erreichbar

Mitglied: StayTuned
Hallo,

wir haben auf einem PC vor 1 Jahr eine Intranetlösung für uns programmieren lassen.

Der Programmierer war ein Informatikstudent und hatte anscheinend keine Ahnung von Portabilität oder Plattformunabhängigkeit.

Jedenfalls wurde das Ding mit PHP und SQLServer (2000) realisiert.

Da der Rechner nach einer Zeit probleme machte haben wir ihn virtualisiert und einem Hardwaredefekt vorzubeugen.

Das Symthom dass er jetzt zeit stellt sich wie folgt dar.

Nach unbestimmter Zeit ist der Rechner nicht mehr im Netz erreichbar. Weder über Ping noch über http oder sonstiges. Nach neustart sind diese Dienste wieder da und lassen sich auch wie gewohnt nutzen.

die frage ist für mich, was passiert wenn er nicht mehr erreichbar ist und wie stelle ich diesen Zustand ab.

hat jemand ne idee oder Fragen???

LG

Sandro

Content-Key: 67717

Url: https://administrator.de/contentid/67717

Ausgedruckt am: 28.11.2021 um 19:11 Uhr

Mitglied: SlainteMhath
SlainteMhath 03.09.2007 um 11:24:21 Uhr
Goto Top
Spontan fallen mir dazu folgende Fragen ein:

- Werden um den Zeitpunkt des Ausfalls 'rum irgendwelche Fehlermeldung im Eventlog (oder in /var/log/messages, falls es eine Linuxkiste ist) aufgezeichnet?
- Steht was brauchbares in den apache-log files?
- hat die VM genügend RAM bzw Platz zum Swappen?
- ist auf den Virtuellen HDs der Vm noch genug Platz (TEMP Verzeichnisse!)
Mitglied: exceter
exceter 03.09.2007 um 11:24:31 Uhr
Goto Top
Mahlzeit,

Der Programmierer war ein Informatikstudent
und hatte anscheinend keine Ahnung von
Portabilität oder
Plattformunabhängigkeit.

Jo klar.. Hauptsache billig, oder? Woher soll ein Student Erfahrungen in Portabilität haben?

Da euch jetzt die virtualisierte Kiste in die Wüste geht, ist natürlich der Student schuld, nicht wahr?

Sorry, konnte mich in diesem Fall einfach nicht zurückhalten...

Gute Nacht,
Ex
Mitglied: StayTuned
StayTuned 03.09.2007 um 12:19:24 Uhr
Goto Top
@ exceter LOL bist du fertig? Danke auch für deinen absolut nutzlosen kommentar.

@ slaintemhath

ja ich hab im erg protokoll nen eintrag

Quelle: Userenv
Ereignis ID: 1000
Die Registrierungsdatei konnte nicht entfernt werden. Ihre Einstellungen werden nicht repliziert, falls Sie ein servergespeichertes Profil haben wenden sie sich an ihren administrator.

weiss nicht ob das damit zusammenhängen kann.

apachelog gibt imho nichts brauchbares her und die anderen punkte kann ich auch ausschließen.

das "wegschalten" ist auch völlig unregelmässig. mal läuft er tagelang durch. dann muss er wieder 2-3 mal gestartet werden damit er überhaupt läuft.
Mitglied: SlainteMhath
SlainteMhath 03.09.2007 um 13:08:21 Uhr
Goto Top
Also der Eintrag im Application Log hat imo nichts mit dem Systemstillstand zu tun. Im System Log steht nichts?

Wieviel RAM habt ihr denn der Kiste zugrstanden? Evtl. einfach mal bischen nach oben drehn, vielleicht wird's besser.

Windows/Apache/PHP/VMware/VMware-Tools sind auf den neuesten Stand gepatcht, ja?
Mitglied: StayTuned
StayTuned 03.09.2007 um 13:33:43 Uhr
Goto Top
im syslog ist nur ein fehler dass eine druckerwarteschlange unerwartet beendet wurde.
imho auch nichts unbedingt aufregendes. ein paar warnungen noch dass die zeit nicht synchronisiert werden konnte.

ham ihm 380 MB zugewiesen. werd mal ein wenig höher gehen aber imho muss das ausreichen.

sonst noch ideen?
Mitglied: 8644
8644 03.09.2007 um 14:03:42 Uhr
Goto Top
Hi,

naja, wenn der Rechner nicht im Netz erreichbar ist, würde ich doch hier mal ansetzen.
Netzwerkkarte, Kabel, Switch schon gecheckt?

Psycho
Mitglied: SlainteMhath
SlainteMhath 03.09.2007 um 14:06:51 Uhr
Goto Top
Oder anders gefragt:

Was taucht denn ab? die Virtuelle Maschine, oder der Host auf dem die VM läuft?
Mitglied: StayTuned
StayTuned 03.09.2007 um 16:40:55 Uhr
Goto Top
die VMWare raucht dann ab. der host hat keine Probe. ich denke das sind mitvirtualisierte Fehler in der Installation die wir da durchschleifen. die Frage ist woran sowas liegen kann und wie man das beheben kann.
Mitglied: SlainteMhath
SlainteMhath 03.09.2007 um 16:44:48 Uhr
Goto Top
Ich quote mich mal selber:
Windows/Apache/PHP/VMware/VMware-Tools sind auf den neuesten Stand gepatcht, ja?

Heiß diskutierte Beiträge
general
Sicherheit beim Online-BankingWeyershausenVor 1 TagAllgemeinSicherheitsgrundlagen19 Kommentare

Hallo, in unserer Firma verwenden wir SFirm als Online-Banking-Software. In dieser Woche hatten wir einen IT-Berater bei uns, der uns dringend folgendes Vorgehen empfahl: Wir ...

question
Reinigung der Apple Watch gelöst honeybeeVor 1 TagFrageApple6 Kommentare

Hallo, mit welchem Reinigungsmittel kann ich das Armband meiner Apple Watch schonend reinigen? Auf dem Bild seht ihr, dass es in einem guten Zustand ist. ...

question
HP Notebook startet nicht mehr gelöst ben1300Vor 1 TagFrageHardware7 Kommentare

Hallo zusammen, mein HP Notebook Modell 17-ca1300ng startet nicht mehr. Wenn ich den Power Knopf drücke, blinkt die LED neben der Ladebuchse 3x weiß. Jemand ...

question
LAN-LAN mit Dyndns?MatznoVor 1 TagFrageDNS7 Kommentare

Hallo zusammen, ich habe 3 Fritzboxen , 2 davon sind mit festen IP im LAN-LAN eingebunden (Hauptstandort und Zweigstelle). Die Dritte, welche ich jetzt verbinden ...

question
Exchange Online SMTP nach externNaibafVor 1 TagFrageExchange Server19 Kommentare

Hallo Community, ich muss aus einem Online Portal SMTP Nachrichten an Extern verschicken über einen Exchange Online. Kann mir jemand weitterhelfen das ich dafür einrichten ...

question
Medienwandler für Glasfaser gelöst Reamer76Vor 7 StundenFrageHardware9 Kommentare

Guten Tag liebe Admins, ich bräuchte mal Eure Hilfe für die Anschaffung eines Medienwandlers. Wir werden nächsten Monat freigeschaltet, Anbieter ist Wemacom. Ich habe die ...

question
Adminpasswort löschenaleks08Vor 7 StundenFrageWindows 78 Kommentare

Bei einem Kollegen hat jemand den Rechner eingerichtet und dabei ein Adminpasswort vergeben. Das Adminpasswort kennt er aber nicht und der Einrichter ist nicht mehr ...

question
BlueScreen 124 unter Win7.1MinionVor 1 TagFrageWindows 76 Kommentare

Hallo all, ich habe seit geraumer Zeit einen Rechner, der folgenden BS 124 sporadisch rausschmeisst: MB ASRock Z77 P3 und i5 3570k sind die einzigen ...