Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Intranet mit IIS 6 funkzt nicht. Fehler 400

Mitglied: JulianK

JulianK (Level 1) - Jetzt verbinden

13.01.2005, aktualisiert 11.08.2008, 12065 Aufrufe, 10 Kommentare

Folgendes Profil:

Windows 2003 Server Standard
AD, File/PrintSharing
Domäne
WinXP / MacOS X - Clients

Habe jetzt IIS 6 draufgespielt, weil ich einfaches Intranet, bestehend aus ein paar simplen .html Seiten, bereitstellen wollte.

Habe durch den Website-Assistent das alles gemacht. Ein Basisverzeichnis angezeigt, in dem paar .html Seiten drinne liegen, u.a. index.html.

Jetzt versuche ich das Intranet aufzurufen, über die IP vom Server.

Meldung: Die Seite wird nicht gefunden, Fehler 400.

Authentifizierungsmethoden: anonymer zugriff
Hosheader: Intranet


Komme nicht mehr weiter, der Dienst ist natürlich gestartet.
Mitglied: 7217
13.01.2005 um 16:59 Uhr
Was passiert, wenn du auf der Eingabeaufforderung per "telnet <deinserver> 80" auf den Server zugreifen möchtest und dort dann z.b. "GET /index.html" eingibst?

Gruß, Mupfel
Bitte warten ..
Mitglied: 7217
13.01.2005 um 17:00 Uhr
sorry, meinte "telnet deinserver 80"...
Bitte warten ..
Mitglied: JulianK
13.01.2005 um 17:07 Uhr
also kenne mich dami nicht ganz so aus. aber ich habe das telnet meinserver 80 eingegeben und dann kam "verbindung zum host verloren"
Bitte warten ..
Mitglied: 7217
13.01.2005 um 17:14 Uhr
Also nochmal langsam zum nachbauen für dich:

du setzt dich mal an den Rechner, an dem der IIS läuft und versuchst folgende Befehlssequenz:

telnet localhost 80
GET /index.html

dann postest du uns mal die kompletten Ausgaben, die das Ding bringt.

Anschließend setzt du dich an einen Rechner in deinem LAN und versuchst volgendes:

telnet ip-Adresse-des-IIS-Servers 80
GET /index.html

wobei ip-Adresse.des-IIS-Servers die IP-Adresse des Servers ist und nicht jetzt das Wort...

Auch hier postest du uns mal bitte die kompletten Ausgaben, die zu dir dann zurückkommen.

Gruß, Mupfel
Bitte warten ..
Mitglied: JulianK
13.01.2005 um 17:17 Uhr
bin am iis-rechner.

geb das zeug ein. dann ist die konsole komplett schwarz. ich sehe nicht, was ich eingebe. dann kommt irgendwann: bad request (invalid hostname) verbindung zum host verloren.

an nen anderen rechner kann ich nicht. bin remote aufm server.
Bitte warten ..
Mitglied: 7217
13.01.2005 um 17:30 Uhr
Also ist das schonmal ein Zeichen dafür, dass generell der Server schonmal auf dem Port 80 hört, aber irgendwie falsch konfiguriert ist... soweit, so gut...

Da ich mich jetzt aber mit IIS nicht auskenne, kann ich dir leider nicht weiterhelfen... wir können nur schonmal ausschließen, dass eine Firewall vorerst mal für das Problem verantwortlich ist... sondern es liegt jetzt tatsächlich an der Konfiguration des Servers... 400 hiesst übrigens soviel wie "400 Bad Request - Falsch formulierte Anfrage nicht verstanden." Aber ich vertraue dir mal, dass du das GET /index.html richtig "blind" eintippen konntest...

An sich läuft der Server ja... klingt nur irgendwie, als wäre da was grundliegendes falsch...

Gruß, Mupfel
Bitte warten ..
Mitglied: meinereiner
13.01.2005 um 17:31 Uhr
eine index.html ignoriert der IIS als Startseite, sie muss index.htm (ohne L) heissen. Oder du musst in den Eigenschaften der Webseite unter "Dokumente" die seite index.html hinzufügen.
Bitte warten ..
Mitglied: JulianK
13.01.2005 um 17:39 Uhr
auch das geht leider nicht.
Bitte warten ..
Mitglied: Maximus1
11.08.2008 um 12:24 Uhr
tschuldigung das ich hier leichenschändung begehe

ich hab hier das gleiche problem und sitze in der schule.
meine dozenten können mir da auch nicht helfen, das einzige was die mir sagen ist das ich die webseiten die ich haben möchte in die hosts datei eintragen soll.
prima, lokal bekomme ich sie, und nun?
ich will die ja nicht auf dem server haben sondern im intranet anbieten.

die anleitung hier aus dem board habe ich schon durch und das war intuitiv auch der weg den ich gegangen bin, bevor ich die anleitung gesehen hatte.
ich möchte kein asp ausliefern, nur simple htm und html seiten.
startseiten heissen index.html und sind auch in "dokumente" it angegeben.


wenn ich im browser http://server2k3/lalala/ angebe bekomme ich das bioskompendium so wie ich es haben will, aber wenn andere es so eingeben bekommen sie nichts.
pingen können sie mich und dns funktioniert auch.

systemdaten:
server 2k3
AD/DNS/DHCP/Anwendungsserver(iis 6)/RAS-VPN
2gb ram
Bitte warten ..
Mitglied: Maximus1
11.08.2008 um 15:57 Uhr
tschuldigung für das doppelposting.

ich hab nun jemanden an der hand gehabt der das erstens weiss und zweitens auch erklären kann.
ich hab mir die zusammenfasung dessen was er sagte aufgeschrieben und publiziere es mal, da ich denke das nicht nur ich damit probleme habe/hatte.


:::::ANLEITUNG:::::

Für die neue Webseite muss man im DNS eine neue primäre DNS Zone erstellen (z.b. webseite.lokal).
Darin dann einen neuen (A)-Eintrag erstellen und beim Name NUR "www" ohne "" eingeben.
Als IP die Adresse gibt man die an die an die Webseite gebunden werden soll. Wenn also der Server 2 Netzwerkkarten hat wobei eine in Richtung Clients und die andere in Richtung Inet zeigt und nur die Clients auf die Seiten zugreifen können sollen, ist die IP anzugeben die von den Clients zu erreichen ist. (siehe ipconfig)


:::::ipconfig::::::

Ethernet-Adapter ext: (extern, nicht client )

Verbindungsspezifisches DNS-Suffix: 123321
IP-Adresse. . . . . . . . . . . . : 192.168.102.116 (für öffentliche webseiten die hier)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . : 192.168.102.254

Ethernet-Adapter int: (intern, client)

Verbindungsspezifisches DNS-Suffix:321123
IP-Adresse. . . . . . . . . . . . : 192.168.20.1 (für interne Webseiten die hier)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . :

damit ist der DNS teil abgeschlossen

Im IIS die Eigenschaften der Webseite aufrufen und die "Identifikation der Webseite" (erweitert anklicken) leeren. Dort dann nur den im DNS angegebenen hostheader mit dem www aus dem (A) eintrag eingeben, in diesem fall "www.webseite.lokal" wieder ohne ""

danach sollte alles laufen


ich hoffe das ist nicht zu wirr geschrieben und hilft.


grz
Bitte warten ..
Ähnliche Inhalte
Windows 10
IIS 6 Fehlercode 0x800f0922
gelöst Frage von BadgerWindows 103 Kommentare

Hallo Leute, ich habe folgendes Problem mit (einem frisch installiertem) Win 10 1803 bei der Installation von IIS Ich ...

Windows Server

IIS Intranet Proxy-Server für Internetzugriffe Updates definieren

Frage von seadogWindows Server4 Kommentare

Liebe Mitglieder, ich habe im Netzwerk einen Proxy-Server. Betreibe einen IIS-Server fürs Intranet. Wo kann ich im IIS den ...

Informationsdienste

Kleines Intranet

Frage von MarsdolfInformationsdienste19 Kommentare

Hallo Ich habe vor eine Intranet Seite zu erstellen, die aber kaum etwas Können muss. Bei uns in den ...

Zusammenarbeit

Intranet Software

Frage von anak1mZusammenarbeit7 Kommentare

Hallo zusammen, ich bin aktuell auf der Suche nach einer geeigneten "schlanken" Intranet Software für unsere Firma. Wichtig sind ...

Neue Wissensbeiträge
Sicherheit
0-day Schwachstelle im Internet Explorer
Information von kgborn vor 7 StundenSicherheit

In Microsofts Internet Explorer gibt es eine 0-day Schwachstelle in der Scripting Engine, die faktisch alle Browser- und Windows-Versionen ...

Internet

Internet-Speedtest Automatisieren via Befehlszeile, cmd, Bash (Windows, Linux, FreeBSD, Mac)

Tipp von anteNope vor 1 TagInternet3 Kommentare

Also das hier ist irgendwie an mir vorbeigegangen. Einfacher geht es schlicht nicht mehr. Speedtest.cmd Via Aufgabenplanung stündlich oder ...

Administrator.de Feedback

Entwicklertagebuch: Codeblöcke auf unseren Seiten

Information von admtech vor 1 TagAdministrator.de Feedback4 Kommentare

Hallo Administrator User, Unsere Codeblöcke werden ab sofort anders dargestellt. Die Codeblöcke können nun direkt per Copy&Paste kopiert werden. ...

Humor (lol)
Internet - auch 2020 noch Neuland ?
Erfahrungsbericht von Henere vor 2 TagenHumor (lol)3 Kommentare

Heute eine Mail der Schule meiner Tochter bekommen. Blabla Umweltschutz bla bla siehe Anhang. Dumm nur: Da hab ich ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Werde dauernd aus dem WLAN geworfen (RouterOS)
gelöst Frage von amdkeksNetzwerkmanagement24 Kommentare

Hallo Zusammen, ich habe gestern ein update meiner Mikrotikgeräte gemacht und habe nun überall Version 6.45.5 drauf. Mikrotik Routerboard, ...

Festplatten, SSD, Raid
Größe der Partition lässt sich nicht ändern mit gparted
Frage von achkleinFestplatten, SSD, Raid17 Kommentare

Hallo, ich habe eine 480GB auf eine 1TB-SSD geklont. Jetzt möchte ich den freien Speicherplatz per gparted an die ...

Sicherheit
Wie Kann Man eine IT-Notfallhandbuch erstellen für petasan
Frage von 142658Sicherheit14 Kommentare

Hallo Leute ich muss bald meine abschlussprojekt schreiben und brauch dringend hilfe wie man ein IT-Notfallhandbuch erstellen für Petasan(eine ...

Festplatten, SSD, Raid
Wie viel Ampere braucht eine 3.5 Zoll Festplatte am SATA Stecker?
gelöst Frage von francFestplatten, SSD, Raid12 Kommentare

Hallo ich möchte gerne eine "interne" 3.5 Zoll Festplatte an USB 3.0 anschließen. Ich habe dazu diverse Stecker gefunden, ...