Keine Hardware-Virtualisierung unter Server 2008 R2 bei Desktop-Hardware

Mitglied: Seb-it

Seb-it (Level 1) - Jetzt verbinden

11.08.2011, aktualisiert 22:13 Uhr, 4763 Aufrufe, 8 Kommentare

Hallo zusammen,

ich habe vor ein paar Wochen den Windows Server 2008 R2 zum experimentieren auf Desktop-Hardware aufgesetzt (Athlon II 240e + Asus Mainboard mit 880G Chip + 4GB ECC RAM).
Ich habe diese Woche angefangen, Hyper-V zu testen und dabei ist mir aufgefallen, das die Hardware-Virtualisierung AMD-V nicht aktiv ist und hier kommt das Problem:
Anscheinend gibt es eine künstliche Beschränkung, entweder von Microsoft oder von AMD, das unter Server 2008 R2 auf Desktop-Hardware die Hardware-Virtualisierung deaktiviert.
Dies bestätigte mir auch der Asus Support: "Die unterstützung gilt aber leider nicht für Desktop Hardware. Hier ist das Betriebssystem nicht für das Mainboard vorgesehen und wird somit nicht unterstützt."
Kennt jemand vielleicht einen Trick, wie ich die Virtualisierung trotzdem aktivieren kann?

Viele Grüße,

Sebastian
Mitglied: Xboxer
11.08.2011 um 11:26 Uhr
Hi Sebastian,

hast du AMD-V den im BIOS aktiviert?

Hyper-V habe ich mehrfach schon zum testen auf Desktopkisten installiert - Keine Probleme

Gruß
Christoph
Bitte warten ..
Mitglied: ChrisIO
11.08.2011 um 11:33 Uhr
AMD-V im Bios aktivieren und dann google löchern, ob man die HW-V über die Registry aktivieren kann.
Konnte so jetzt leider keinen erfolgversprechenden Thread finden.
Das sieht wohl leider nicht so gut aus.
Bitte warten ..
Mitglied: Seb-it
11.08.2011 um 11:37 Uhr
Hallo,
ja das habe ich natürlich als erstes kontrolliert ;-) face-wink
Ich habe auch den Athlon II gegen einen Phenom II 555 C3 getauscht, brachte aber auch keine Virtualisierungsunterstützung.
Hyper-V läuft wohl, mit WinXP zum testen ist die Geschwindigkeit auch in Ordnung. Erst als ich Ubuntu installiert habe, bemerkte ich das da was nicht stimmt.
Das Tool AMD-V and Hyper-V System Compatibility Check verriet mir dann auch das mein System inkompatibel sei.
Viele Grüße,
Sebastian
Bitte warten ..
Mitglied: Philipp711
11.08.2011 um 11:37 Uhr
Hallo,

ich hatte ein ähnliches Problem mit Hyper-V und AMD-V (auch Desktop-Hardware).

Nach einiger Zeit wollte ich nämlich auch Hyper-V auf meinem neuen Srv 2008R2 testen und habe AMD-V im Nachhinein aktiviert -> Hyper-V bzw. die Installationsroutine hat das nicht wirklich erkannt, es gab eine Fehlermeldung...

Problem war anscheinend, dass der Server die Kontextumschaltung auf die Secure Virtual Machine (Ring-1; bei Intel heißt das VMX-Root) "im" Prozessor nicht mitbekommen hat.

einfachste Lösung ohne großes rumsuchen: Neuinstallaton
Bitte warten ..
Mitglied: Seb-it
11.08.2011 um 11:42 Uhr
Hi Philipp,
bei der Installation war die Virtualisierung im BIOS aktiviert. Daher bezweifle ich das es bei mir mit einer Neuinstallation getan ist.
Ich hoffe (noch) auf eine andere Lösung.
Bitte warten ..
Mitglied: Lochkartenstanzer
11.08.2011 um 11:45 Uhr
Zitat von @Seb-it:
Erst als ich Ubuntu installiert habe,

Generell ist linux unter Hyper-V (gefühlt) sehr lahm, insbesodnere an der Konsole im Hyper-V-Manager. Das ist iirc unabhängig von AMD-V. da es keine paravirtualisierten treiber von MS gibt bleibt das vermutlich so.

lks


PS. Über ssh kann man vernünftig arbeiten und die Netzwerkperformance scheint i.d.R. auch zu stimmen. Nur der Rest fühlt sich lahm an.
Bitte warten ..
Mitglied: Philipp711
11.08.2011 um 11:46 Uhr
Zitat von @Seb-it:

Ich habe diese Woche angefangen, Hyper-V zu testen und dabei ist mir aufgefallen, das die Hardware-Virtualisierung AMD-V nicht
aktiv ist und hier kommt das Problem:


Dachte du hast die AMD-V im nachhinein aktiviert, habe dich falsch verstanden.....vergiss meinen Post ;-) face-wink
Bitte warten ..
Mitglied: Seb-it
11.08.2011 um 11:53 Uhr
Kein Problem :-) face-smile
Kann wer von Euch vielleicht mal nachschauen, wenn CPU-Z auf eurem Server 2008 gestartet wird, ob da "AMD-V" bei "Instructions" auftaucht? Bei mir fehlt es nämlich.
Viele Grüße,
Bitte warten ..
Heiß diskutierte Inhalte
Microsoft
Mitteilung an alle bei Störungen in der IT
gelöst David.B2D45Vor 1 TagFrageMicrosoft31 Kommentare

Hallo Forum, ich bin auf der Suche nach einem Programm / Tool mit dem ich Text (Laufschrift) auf allen (gewünschten) PC's / Benutzer im ...

Exchange Server
Exchange Zero Day Hack - Wie entfernen?
gelöst mtaiitVor 15 StundenFrageExchange Server28 Kommentare

Hallo, bei mir hat es einige Kundenserver getroffen Weiß einer wie ich diese WebShells wieder loswerde? Das löschen der betroffenen .aspx Dateien wird wohl ...

E-Mail
Kann man mit SPF Mails für eine Domäne vollständig verbieten?
gelöst StefanKittelVor 1 TagFrageE-Mail17 Kommentare

Hallo, viele Firmen haben ja zusätzliche Domänen. Als Web- und oder Mail-weiterleitung. Es werden also niemals Emails damit gesendet werden. kann man mit einem ...

Server-Hardware
Firmware-Updates auf Servern
redhorseVor 1 TagFrageServer-Hardware8 Kommentare

Guten Morgen, die Server-Hersteller stellen bekanntlich regelmäßig Firmware- und Treiberupdates für deren Serverhardware bereit, diese können z.B. bei Dell als Dell EMC Server Update ...

Linux
Windows auf Dualbootrechner entfernen und Linux die komplette Platte zur Verfügung stellen
N8chtfalterVor 1 TagFrageLinux6 Kommentare

Hallo Linux Profis, ich habe einen Laptop auf dem ursprünglichen Windows 10 installiert war, und ist, ich habe vor einem Jahr Ubuntu testhalber als ...

Windows Server
Domänenadmin kann kein Zertifikat anfordern
noodellsVor 1 TagFrageWindows Server6 Kommentare

Hallo Zusammen, ich habe ein Problem beim Finden einer Einstellung. Zuerst einmal der Stand: Es gibt eine Windows CA und Domaincontroller und alles funktionierte ...

Router & Routing
Routing öffentliche IP-Adresse-Traffic per BGP im internal-Network
gelöst jescheroVor 1 TagFrageRouter & Routing2 Kommentare

Guten Abend alle zusammen, ich habe ein kleines Problem beim Routing in pfSense. Mein aktuelles Aufbau ist folgenden: Ich habe eine pfSense-VM und zwei ...

Exchange Server
Windows Server 2019 + Exchange Server 2019 (Probleme mit Pop3)
gelöst aristonVor 1 TagFrageExchange Server4 Kommentare

Hallo zusammen, ich habe gerade angefangen, mit dem Exchange Server 2019 in der Demoversion zu arbeiten und folge Schritt für Schritt bei der notwendigen ...