Magenta TV und Cisco IOS

Hallo und guten Tag,

seit Wochen versuche ich das Magneta TV mit einem Media Receiver MR401 und einem C896VA-K9 zum laufen zu bringen. Habe die Beiträge hier in der Community zum Thema gelesen und praktisch alles probiert.

Fehlerbild: TV Bild/Ton frieren nach ein paar Sekunden ein.

VDSL50 > Cisco > MR401 direkt auf Switchport1. Auch auf dem L3 Port versucht (Gi8) und anderen L2 Ports

getestete IOS
156-3.M6a, 157-3.M4a sowie eine 15.9x

Alles mehrfach aus/eingeschaltet, Kabel getauscht usw., Firewall komplett dektiviert/nur Routing, RPs 62.155.246.164 und 62.155.243.102 probiert. Werksreset des MR401.
Mit und ohne VLAN8 getestet. Alle weiteren Geräte aus dem Netz entfernt.

Der Internet Anschluß selbst läuft ohne Probleme, Bibel TV geht, die Megathek funktioniert ebenfalls.
Download 51/Upload 12.

Mit einer Fritzbox 7490 läuft das Magenta TV ohne Probleme an diesem Anschluß.

Hier die Konfig sowie einige CLI outputs:

!
version 15.6
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime localtime
service password-encryption
service linenumber

aaa new-model
!
aaa authentication login default local
aaa authorization network default local
!
aaa session-id common
clock timezone CET 1 0
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
clock calendar-valid
!
no ip source-route
no ip gratuitous-arps
ip options drop
!
ip dhcp bootp ignore
ip dhcp pool VLAN253-MAGENTA
network 192.168.253.0 255.255.255.0
default-router 192.168.253.254
dns-server 208.67.222.222 208.67.220.220
lease 0 6
!
ip multicast-routing
ip cef
!
spanning-tree vlan 253 priority 65535
controller VDSL 0
firmware filename flash:VA_A_39m_B_38u_24o_rc1_SDK_4.14L.04A-J.bin
!
ip tcp synwait-time 5
!
class-map type inspect match-any IPSEC-BOOT
match access-group name ACL-ZFW-ISAKMP_IPSEC
class-map type inspect match-any LAN-INET
match protocol http
match protocol https
match protocol pop3s
match protocol imaps
match protocol smtp
match protocol sip-tls
match protocol rtsp
match protocol ftp
match protocol ftps
match protocol ssh
match protocol ntp
match protocol dns
match protocol tftp
match protocol tcp
match protocol udp
match protocol icmp
class-map type inspect match-any SELF-INET
match class-map IPSEC-BOOT
match protocol tcp
match protocol udp
match protocol icmp
!
policy-map type inspect SELF-INET
class type inspect SELF-INET
inspect
class class-default
drop log
policy-map type inspect LAN-INET
class type inspect LAN-INET
inspect
class class-default
drop log
policy-map type inspect INET-SELF
class type inspect IPSEC-BOOT
pass
class class-default
drop
!
zone security INET
zone security LAN
zone-pair security INET-SELF source INET destination self
service-policy type inspect INET-SELF
zone-pair security SELF-INET source self destination INET
zone-pair security LAN-INET source LAN destination INET
service-policy type inspect LAN-INET
!
interface Ethernet0
description ### VDSL ###
no ip address
no ip route-cache
load-interval 30
!
interface Ethernet0.7
description ### VDSL DATA ###
encapsulation dot1Q 7
no ip route-cache
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Ethernet0.8
description ### VDSL Multicast Entertain ###
encapsulation dot1Q 8
ip dhcp client broadcast-flag clear
ip address dhcp
ip pim sparse-mode
zone-member security INET
no ip route-cache
ip igmp version 3
ip igmp query-interval 15
shutdown
!
interface GigabitEthernet1
description ### MAGENTA ###
switchport access vlan 253
no ip address
load-interval 30
spanning-tree portfast
!
interface Vlan253
description ### MAGENTA ###
ip address 192.168.253.254 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip pim sparse-mode
ip nat inside
ip virtual-reassembly in
zone-member security LAN
ip tcp adjust-mss 1448
ip igmp helper-address 62.155.245.147
ip igmp version 3
ip igmp explicit-tracking
ip igmp query-interval 15
load-interval 30
!
interface Dialer1
description ### Dialer to Telekom WAN ###
mtu 1492
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1488
ip pim sparse-mode
ip nat outside
ip virtual-reassembly in
zone-member security INET
encapsulation ppp
ip igmp version 3
load-interval 30
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp pap sent-username blabla@t-online.de password 7 blabla
ppp ipcp dns request
ppp ipcp mask request
ppp ipcp route default
!
ip dns server
ip pim rp-address 62.155.245.147
ip pim ssm default
ip nat inside source list ACL-NAT interface Dialer1 overload

ip access-list extended ACL-NAT
permit ip 192.168.254.0 0.0.1.255 any
permit ip 192.168.253.0 0.0.0.255 any

ip access-list extended ACL-ZFW-ISAKMP_IPSEC
permit udp any any eq isakmp
permit udp any any eq non500-isakmp
permit esp any any
permit udp any any eq bootps
permit udp any any eq bootpc
permit udp any eq bootps any
permit udp any eq bootpc any
permit ip 224.0.0.0 15.255.255.255 any
permit ip any 224.0.0.0 15.255.255.255
!


!

sh ppp all
Interface/ID OPEN+ Nego* Fail- Stage Peer Address Peer Name
------------ --------------------- -------- ---------------
Vi2 LCP+ IPCP+ CDPCP- LocalT 62.155.245.147

sh ip igmp membership
Flags: A - aggregate, T - tracked
L - Local, S - static, V - virtual, R - Reported through v3
I - v3lite, U - Urd, M - SSM (S,G) channel
1,2,3 - The version of IGMP, the group is in
Channel/Group-Flags:
/ - Filtering entry (Exclude mode (S,G), Include mode (G))
Reporter:
<mac-or-ip-address> - last reporter if group is not explicitly tracked
<n>/<m> - <n> reporter in include mode, <m> reporter in exclude

Channel/Group Reporter Uptime Exp. Flags Interface
*,224.0.1.40 0/1 00:20:45 00:39 3LAT Vl253


sh ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter Group Accounted
224.0.1.40 Vlan253 00:21:03 00:00:43 192.168.253.254


sh ip pim rp
Group: 239.255.255.250, RP: 62.155.245.147, uptime 00:02:37, expires never
Group: 224.0.1.40, RP: 62.155.245.147, uptime 00:14:14, expires never

sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.255.255.250), 00:02:08/stopped, RP 62.155.245.147, flags: SPF
Incoming interface: Dialer1, RPF nbr 62.155.245.147
Outgoing interface list: Null

(192.168.253.1, 239.255.255.250), 00:02:08/00:00:51, flags: PFT
Incoming interface: Vlan253, RPF nbr 0.0.0.0, Registering
Outgoing interface list: Null

(*, 224.0.1.40), 00:13:45/00:02:50, RP 62.155.245.147, flags: SJCL
Incoming interface: Dialer1, RPF nbr 62.155.245.147
Outgoing interface list:
Vlan253, Forward/Sparse, 00:13:45/00:02:50

sh ip pim interface stats
Interface Mpackets In Mpackets Out Octets In Octets Out
Ethernet0.8 0 0 0 0
Vlan253 4 0 616 0
Dialer1 0 0 0 0
Vi2

sh lice feature
Feature name Enforcement Evaluation Subscription Enabled RightToUse
advipservices no yes no yes yes

!


Sieht eben nach einem Multicast Problem aus, es kommt nichts am WAN an, weiß aber jetzt einfach nicht mehr weiter.

Vielleicht hat noch jemand einen Tipp, ansonsten wird wohl die Fritzbox bleiben müssen..... :-( face-sad

DANKE!

Content-Key: 614202

Url: https://administrator.de/contentid/614202

Ausgedruckt am: 22.01.2022 um 12:01 Uhr

Mitglied: aqui
Lösung aqui 19.10.2020 aktualisiert um 09:22:49 Uhr
Goto Top
Deine Konfig über das 0.8er Subinterface ist falsch. Das supportet die Telekom schon lange nicht mehr an ihren BNG Anschlüssen. Das wird vermutlich der Fehler sein und solltest du komplett aus der Konfig löschen.
Ggf. solltest du checken mit show ppp all ob deine Rendezvous Point Adresse korrekt ist.
Halte dich an die Konfig die hier im Tutorial steht:
https://administrator.de/tutorial/cisco-880-890-isr-router-konfiguration ...

Einen finalen Test machst du am besten erstmal mit VLC: https://www.videolan.org/vlc/index.de.html um die grundsätzliche IP-TV Funktion zu testen.
Die Multicast URLs der einzelnen Programme findest du als Liste hier: https://iptv.blog/artikel/multicastadressliste/
Damit solltest du alle Programme sehen können.
Sofern ein Switch dazwischen ist vergiss nicht dort die IGMP Snooping Funktion mit IGMPv3 zu aktivieren. Das macht nur Sinn wenn du überhaupt einen managebaren Switch hast.
Was hast du für ein Router Modell ? Wenn es ein 880er ist nutzt du eine alte Modem Firmware ! Die aktuellste für das 880er Modell ist die VA_B_38V_d24m.bin die Vectoring Support hat. Auch das solltest du unbedingt anpassen wenn es ein 880er ist.
https://administrator.de/content/detail.php?id=307041&token=55
Weitere kleinere Fehler:
Das Schlimmste ist das dir für die Zonenbeziehung zone-pair security SELF-INET eine Policy fehlt. Damit ist da alles geblockt was natürlich fatale Folgen hat !
Du solltest den MC Test so oder so erstmal gänzlich ohne Aktivierung ZFW machen um weitere Policy Fehler in deiner Konfig sicher auszuschliessen.
Weiter fehlt die Einschränkung des DHCP Pools im VLAN 253. Ohne das droht Adress Überschneiodung. Z.B.
ip dhcp excluded-address 192.168.253.1 192.168.253.99
ip dhcp excluded-address 192.168.253.150 192.168.253.254

Der Multicast Adressbereich 224.0.0.0 /4 muss nicht in die ZFW ACL auf den Router. Sie betrifft ja nur Traffic der auf den Router selber geht was bei MC ja nie der Fall ist. MC vom internen LAN nach außen ist eh über die match Zuweisung ja erlaubt. Das kannst (und solltest) du also entfernen.
Test in der Kombination mit einer 15.6.3M9 (deine M6a ist NICHT der latest Patch !) rennt auf einem 886va mit VLC und einem MR-400 Receiver hier vollkomen fehlerlos !
Mitglied: ip-mroute
ip-mroute 19.10.2020 um 18:27:25 Uhr
Goto Top
Hallo

schonmal vielen Dank für deine Infos, bislang läuft es leider nicht.

- DHCP Konfig und FW Konfig korrigiert

- Eth0.8 komplett gelöscht

- der MR401 hängt direkt am Router. Auch mit Switch dazwischen selber Fehler.

sh ppp all
Interface/ID OPEN+ Nego* Fail- Stage Peer Address Peer Name
------------ --------------------- -------- ---------------
Vi2 LCP+ IPCP+ CDPCP- LocalT 62.155.245.147

sh ip pim rp
Group: 224.0.1.40, RP: 62.155.245.147, uptime 00:39:53, expires never


- Cisco C896VA-K9 (revision 1.0) with 488524K/35763K bytes of memory.

- neues IOS versucht: System image file is "flash:c800-universalk9-mz.SPA.156-3.M9.bin"

- neue Firmware versucht: VDSL user config flash:VA_B_38V_d24m.bin

- FW komplett entfernt

- mit dem VCL Player tut sich auch nichts, beim öffnen von Streams kommt weder Bild noch Ton

Egal was ich bislang probiert habe, der Fehler bleibt immer genau gleich. Da hat sich nie irgendwas "ein bischen" verbessert oder so.
Mitglied: aqui
aqui 21.10.2020 aktualisiert um 12:24:25 Uhr
Goto Top
Was noch fehlerhaft ist:
Beim Dailer 1 Interface
  • MTU ist falsch
  • Die Telekom mach einzig nur PAP Authentication
  • no cdp enable fehlt. So kann jeder im Internet sehen mit welchen Endgerät du aktiv bist.
mit dem VCL Player tut sich auch nichts, beim öffnen von Streams kommt weder Bild noch Ton
Dann hast du ein generelle Problem und dein gesamtes Multicasting funktioniert nicht. Das ist eine Sache die immer wasserdicht klappen sollte.
Achtung aber: Wenn du das auf einem Laptop oder einem Rechner mit mehreren Schnittstellen machst solltest du den VLC mindestens 5 Minuten laufen lassen.
Die IGMP Joins schickt der immer nur auf dem Primär Adapter und erst viel später auf den anderen. Das ist ein lange existierender VLC Bug.
Im Zweifel einmal auf dem VLC Rechner parallel einen Wireshark laufen lassen und checken was auf den IGMP Join Request kommt.
Die Telekom selber nutzt ja ein Cisco Backbone und da ist es wasserdicht das es auch mit Cisco Routern im Access klappt. Die Praxis zeigt das ja auch.
Man kann nur vermuten das du einen falschen RP bzw. Helper konfiguriert hast. Teste sonst im Zweifel mal die im Tutorial angegebene 62.155.241.4 als RP und Helper Adresse.
Mitglied: ip-mroute
ip-mroute 22.10.2020 um 23:30:05 Uhr
Goto Top
Hi,

vielen Dank für deine Hilfe und die Tipps - es läuft jetzt mit der Konfig unten!

Zwischenzeitlich hatte ich den selben Fehler auch mit einem C866VAE-W-E-K9. Habe dann den C896 platt gemacht und mit einer minimal Konfig betankt - dann lief es. Mit den Router-Typen kann das ja nix zu tun haben. Das IOS arbeitet da gleich.

VDSL50 - C896VA-K9 mit c800-universalk9-mz.SPA.156-3.M2.bin & VA_B_38V_d24m.bin - Switch - MR401.

Die Konfig war teilweise fehlerhaft, ja. Aus meiner Sicht sind aber die einzigen möglichen Ursachen diese:
- im DHCP direkt die OPENDNS Server mitgegeben, nicht den Router der dann die Telekom DNS Server nutzt
- im DHCP keinen NTP Server mitgegeben
- im DHCP keine Domain mitgegeben
- nicht das native VLAN1 verwendet

Warum dies dann zum genannten Fehler führt kann ich nicht nachvollziehen und hab auch keinen Nerv mehr es ausgiebig zu testen :-) face-smile

!
ip dhcp excluded-address 192.168.1.1 192.168.1.99
ip dhcp excluded-address 192.168.1.120 192.168.1.254
!
ip dhcp pool VLAN1-MGMT
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
dns-server 192.168.1.254
option 42 ip 130.149.17.8
domain-name eule.home.arpa
!
ip domain name eule.home.arpa
ip multicast-routing
ip cef
!
controller VDSL 0
firmware filename flash:VA_B_38V_d24m.bin
!
class-map type inspect match-any IPSEC-BOOT
match access-group name ACL-ZFW-ISAKMP_IPSEC
class-map type inspect match-any LAN-INET
match protocol http
match protocol https
match protocol pop3s
match protocol imaps
match protocol smtp
match protocol sip-tls
match protocol rtsp
match protocol ftp
match protocol ftps
match protocol ssh
match protocol ntp
match protocol dns
match protocol tftp
match protocol tcp
match protocol udp
match protocol icmp
class-map type inspect match-any SELF-INET
match class-map IPSEC-BOOT
match protocol tcp
match protocol udp
match protocol icmp
!
policy-map type inspect SELF-INET
class type inspect SELF-INET
inspect
class class-default
drop log
policy-map type inspect LAN-INET
class type inspect LAN-INET
inspect
class class-default
drop log
policy-map type inspect INET-SELF
class type inspect IPSEC-BOOT
pass
class class-default
drop
!
zone security INET
zone security LAN
zone-pair security INET-SELF source INET destination self
service-policy type inspect INET-SELF
zone-pair security SELF-INET source self destination INET
service-policy type inspect SELF-INET
zone-pair security LAN-INET source LAN destination INET
service-policy type inspect LAN-INET
!
interface Ethernet0
no ip address
load-interval 30
!
interface Ethernet0.7
description ### VDSL WAN TELEKOM ###
encapsulation dot1Q 7
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface GigabitEthernet0
description ### TRUNK to C3560CX GE0/10 ###
switchport trunk allowed vlan 1,254,255,1002-1005
switchport mode trunk
no ip address
load-interval 30
!
interface Vlan1
description ### MGMT Interface ###
ip address 192.168.1.254 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip pim sparse-mode
ip nat inside
ip virtual-reassembly in
zone-member security LAN
ip tcp adjust-mss 1448
ip igmp helper-address 62.155.245.147
ip igmp version 3
ip igmp explicit-tracking
load-interval 30
!
interface Dialer0
description ### Dialer WAN TELEKOM ###
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1488
ip pim sparse-mode
ip nat outside
ip virtual-reassembly in
zone-member security INET
encapsulation ppp
ip igmp version 3
dialer pool 1
dialer-group 1
no keepalive
ppp authentication pap callin
ppp pap sent-username blaundblubb
ppp ipcp dns request
ppp ipcp mask request
ppp ipcp route default
no cdp enable
!
ip dns server
ip pim rp-address 62.155.245.147
ip pim ssm default
ip nat inside source list ACL-NAT interface Dialer0 overload
!
ip access-list standard ACL-NAT
permit 192.168.1.0 0.0.0.255
permit 192.168.254.0 0.0.1.255
!
ip access-list extended ACL-ZFW-ISAKMP_IPSEC
permit udp any any eq isakmp
permit udp any any eq non500-isakmp
permit esp any any
permit udp any any eq bootps
permit udp any any eq bootpc
permit udp any eq bootps any
permit udp any eq bootpc any
permit pim any any
!
ntp server 130.149.17.8 minpoll 9 source Dialer0
!
Mitglied: aqui
aqui 23.10.2020 um 12:46:57 Uhr
Goto Top
hab auch keinen Nerv mehr es ausgiebig zu testen
Glückwunsch das es rennt ! 👏
Und... "Never touch a running system " ;-) face-wink
Heiß diskutierte Beiträge
question
Welche Linux Distribution kommt ohne Schnick und ohne Schnack? gelöst StefanKittelVor 1 TagFrageLinux24 Kommentare

Hallo, ich möchte zwei neue Mini-PCs (Celeron, 2 x 1.7 GHz, 4 GB RAM, 64 GB Storage) mit Linux Desktop installieren. Darauf soll einzig Chrome ...

question
MFA mit Microsoft?cseVor 1 TagFrageWindows Userverwaltung6 Kommentare

Hi Leute, ich hoffe ihr könnt mir ein wenig helfen. Von unserer Gruppe (central IT im Ausland) verlange ich (im Zuge TISAX Audit) auf unseren ...

question
O365 Outlook + Teams sperren gelöst sraL91Vor 1 TagFrageMicrosoft Office17 Kommentare

Hallo Zusammen, wir haben in unserer Firma Office 365 ausgerollt und ich stehe nun vor folgendem Problem. Unsere Firma sind in 50 Standorte unterteilt und ...

general
Liste von URLs in wininet.dllFennek11Vor 1 TagAllgemeinInternet12 Kommentare

Hallo, die Frage ist zugleich enrsthaft und Satire: Windows enthält die Datei "c:\windows\system32\wininet.dll", die für viele Verbindungen ins Internet benötigt wird. Ein Blick in die ...

question
2 Faktor Authentifizierung generell abschaltenratzekahl1Vor 1 TagFrageGoogle Android9 Kommentare

Hallo zusammen, ich habe eine Frage: Kann ich in Google die 2 Faktor Authentifizierzung generell abschalten? Wenn ich ein Gerät als vertrauenswürdig hinzugefügt habe, ja, ...

question
Netzwerk Grafisch darstellen?FireWorldVor 21 StundenFrageInternet7 Kommentare

Hallo, ich bin der Zeit auf der Suche nach einem Programm zur Grafischen Darstellung von inbound/outbound eines Servers in einem Rechenzentrum. Hat Jemand eine idee ...

question
Cisco Switche mit Daten überflutet, daher Abstürze??? gelöst PeterGygerVor 1 TagFrageRouter & Routing6 Kommentare

Guten Morgen Ist es eine realistische Möglichkeit, dass 2022 aktuelle PC / Notebooks im Business Umfeld einen Cisco Switch 2960X mit Daten überfluten können? So ...

question
Firewall - Router - DMZmaxi1998Vor 1 TagFrageNetzwerke7 Kommentare

Hallo an alle, ich benötige eure Beratung bezüglich Hardwareauswahl von Router und Firewall bzw. grundsätzlichem Aufbau zum nachfolgenden Beispiel: Meine Ausgangslage: Firma (ca. 450 Personen) ...