winfried-hh
Goto Top

MIT AppInventor - WebApp nutzt Proxy nicht oder falsch

Hallo in die Runde!

wir haben mit dem Google/MIT AppInventor eine App erstellt, die die WebSite antolin.westermann.de aufrufen soll:

screenshot

Wir haben nun allerdings folgende Konstellation:
  • für das wLAN ist ein Proxy (Schulrouter Plus) eingetragen, dieser Proxy erfordert eine Authentifizierung
  • wenn ich mit Chrome eine WebSite aufrufe, kommt ein Dialog zur Eingabe von Benutzername und Kennwort für die Proxy-Authentifizierung
  • wenn ich die selbst erstellte App aufrufe, kommt kein Dialog
  • wenn ich Chrome einmal aufgerufen habe und mich authentifiziert habe, und dann innerhalb einer halben Stunde erneut aufrufe, muss ich mich nicht authentifizieren (das ist gewollt)
  • wenn ich aber Chrome aufrufe, mich dort authentifiziere und danach unsere App aufrufe, geht es nicht.
  • wenn ich den Proxy aus den wLAN-Einstellungen herausnehme, funktioniert die App

Die Fehlermeldung der App lautet: ERR_TUNNEL_CONNECTION_FAILED

Hat jemand eine Idee, wie wir das Problem lösen könnten? Letztlich geht es darum, ein Symbol von Antolin zu erzeugen. Es muss aber eine eigene App sein, denn der Kiosk-Modus unseres MobileDeviceManagements unterstützt nur Apps, keine Startbildschirmverknüpfungen einzelner WebSites.


Schöne Grüße von der Elbe
Winfried


P.S.: Die Option "IgnoreSslErrors" im WebViewer-Modul bringt nichts.

Content-Key: 422072

Url: https://administrator.de/contentid/422072

Printed on: June 19, 2024 at 00:06 o'clock

Member: tomolpi
tomolpi Feb 26, 2019 updated at 11:32:01 (UTC)
Goto Top
Zitat von @Winfried-HH:

Hallo in die Runde!
Hallo,
Hat jemand eine Idee, wie wir das Problem lösen könnten? Letztlich geht es darum, ein Symbol von Antolin zu erzeugen. Es muss aber eine eigene App sein, denn der Kiosk-Modus unseres MobileDeviceManagements unterstützt nur Apps, keine Startbildschirmverknüpfungen einzelner WebSites.
Hmm, das wird wohl nicht gehen. Bei Android kannst du nämlich keinen systemweiten Proxy setzen (zumindest nicht ohne root). Der gilt nur für Chrome, nicht für andere Apps. Vor dem Problem stand ich auch bei meinen Apps, schlussendlich habe ich es gelassen und User von meinen Apps mit Proxy sind halt leider raus face-confused
Auf die schnelle fällt mir da auch keine Lösung ein...
Schöne Grüße von der Elbe
Winfried
tomolpi

EDIT: https://stackoverflow.com/questions/24417242/do-android-proxy-settings-a ... hier kannst du es auch nachlesen face-wink
Member: Winfried-HH
Winfried-HH Feb 26, 2019 at 12:05:49 (UTC)
Goto Top
Zitat von @tomolpi:

Hmm, das wird wohl nicht gehen. Bei Android kannst du nämlich keinen systemweiten Proxy setzen (zumindest nicht ohne root). Der gilt nur für Chrome, nicht für andere Apps

Hm, "irgendwie" gilt der Proxy aber offenbar schon auch für meine App, denn wenn ich den Proxy aus den wLAN-Einstellungen entferne, funktioniert die App.