Mongodb 3.2 - Problem mit authentifizierung

Mitglied: Wid0kej

Wid0kej (Level 1) - Jetzt verbinden

20.02.2016, aktualisiert 16:08 Uhr, 1334 Aufrufe

Hallo,
ich habe ein großes Problem mit mongodb 3.2 auf ubuntu 14.04 und phpnongodb Treiber.

Der Server läuft, ich habe eine Datenbank erstellt und Benutzer angelegt. Dann installierte ich phpmongodb und wollte connecten.

Aber das klappt nicht, er sagt immer:


Nun soll man angeblich in der /etc/mongodb.conf die Zeile "auth=true" einfügen.

Doch sobald ich auch nur etwas in der conf Datei verändere, dann stoppt der dämon sofort. Entferne ich es, läuft der Dienst. Genauso als ich eine neue Zeile einfügen wollte "bindIp=xxx.xxx.xxx.xxx" (also die öffentliche Server ip statt 127.0.0.1). Das ging nicht, erst als ich es rückgängig machte lief es weiter. Die Datei /var/lib/mongod/mongod.lock habe ich entfernt, auch das half nicht, auch mongod --repair nicht. Ich bekomme einfach keine Verbindung.

Sicherlich mache ich etwas falsch, doch interessant war es, dass bei der Installation die /etc/mongod.conf Datei nicht erstellt worden war (habs 3x deinstalliert und neuinstalliert - immer mit gleichem Ergebnis). Ich hatte zum Glück eine sicherung dieser Datei aus einer früheren Installation und diese habe ich dann nach /etc kopiert. Nur deshalb startet mongod jetzt.

P.S.
Mit "auth=true" in der mongod.conf Datei habe ich aus der bash versucht zu connecten:



Wenn ich mich lokal auf dem server über bash verbinde erhalte ich folgende message:


Heiß diskutierte Inhalte
Off Topic
Realistische Gehaltsvorstellung für eine "IT-Allroundkraft"
gelöst JiggyLeeVor 18 StundenFrageOff Topic17 Kommentare

Hallo an alle, ich hege momentan den Wunsch mich von der alten verstaubten Behörden Bürokratie und langweiliger Aufgaben los zu lösen und in einem ...

Windows 10
Windows 10 Geschwindigkeitprobleme trotz viel mehr Gb Ram
Matthes88Vor 23 StundenFrageWindows 1036 Kommentare

Hallo ihr lieben aaaalso : Da mein neuer Arbeitsspeicher (32gb) von meiner alten Windows 7 version (max mit 8gb kompatibel) nicht angenommen wurde, habe ...

Humor (lol)
Tipp: Dinge, die man besser nicht klaut
altmetallerVor 20 StundenTippHumor (lol)10 Kommentare

Hallo, so wurde meiner Hündin z.B. heute der (eingeschaltete) GPS-Tracker mit Mobilfunkanbindung quasi "direkt vom Halsband weggefunden". Akku hatte noch 60% :-P Und ich ...

Switche und Hubs
Suche Deutsche Sprachdatei für D-Link DGS-1210-24 D1 Switch
gelöst Oggy01Vor 1 TagFrageSwitche und Hubs8 Kommentare

Hallo, ich habe einen D-Link DGS-1210-24 Vers. D1 Switch bekommen und suche für diesen eine Deutsche Sprachdatei. Die Firmware ist auf dem aktuellen Stand ...

Windows Server
GPU Passthrough HYPER-V 2019
bintesVor 1 TagFrageWindows Server8 Kommentare

Hallo, ich habe ein ein Problem mit der Bereitstellung einer Grafikkarte an eine virtuelle Maschine. Hardware: - HPE ProLiant DL380 Gen9 V4 Rack Server ...

Video & Streaming
Videoaufnahme funktioniert nur bis zum ersten Reboot (0x80040217)
IllusionFACTORYVor 1 TagFrageVideo & Streaming11 Kommentare

Ich nehme über eine Video-Software von einem USB-Hardware-Encoder Video auf. Das funktioniert exakt bis zum ersten Reboot - danach bekomme ich beim Starten der ...

Windows Server
Windows Admin Center DC
maximidVor 1 TagFrageWindows Server3 Kommentare

Hallo, ich hätte mal eine Frage zu Windows Admin Center und zwar schaue ich es mir aktuell etwas an da mir die zentrale Verwaltung ...

SAN, NAS, DAS
Synology DS213j - Volume nach HDD Austausch vergrößern
gelöst JasperBeardleyVor 1 TagFrageSAN, NAS, DAS4 Kommentare

Moin, ich hab meinem NAS zwei neue 8TB spendiert, da die 3TB Platten jetzt 6 Jahre alt sind. Da die beiden Platten im JBOD ...