Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

MS Server 2012R2 BPA DNS-Probleme

Mitglied: Valexus

Valexus (Level 2) - Jetzt verbinden

26.05.2015 um 15:23 Uhr, 5931 Aufrufe, 14 Kommentare

Hallo Admins,

vor einiger Zeit habe ich auf unseren beiden 2012R2 DCs den Best Practices Analyzer ausgeführt.
Seitdem leuchtet der halbe Servermanager rot und gibt mir 4 DNS Fehler aus:

01.
DC01 - Warnung - Der sekundäre DNS-Server 192.168.1.250 reagiert nicht auf Abfragen für Zone TrustAnchors.
02.
DC01 - Warnung - Der sekundäre DNS-Server 192.168.1.251 reagiert nicht auf Abfragen für Zone TrustAnchors.
03.
DC01 - Fehler - Keiner der für Zone TrustAnchors konfigurierten sekundären Server reagiert.
04.
DC01 - Fehler - Die Active Directory-integrierte DNS-Zone _msdcs.domain.local wurde nicht gefunden.

Es ist nur die Zone "domain.local" eingerichtet. Die Zone "TrustAnchors" und "_msdcs.domain.local" existieren bei mir beide nicht (oder werden zumindest nicht angezeigt)...

DC1 - 192.168.1.250 - alle FSMO Rollen
DC2 - 192.168.1.251

Bin leider absolut kein Windows Profi und komme auch mit den Lösungsbeschreibungen von Microsoft nicht weiter.
Wäre super, wenn mir hier jemand einen Tipp geben könnte wie ich diese Probleme beseitigen kann.

VG
Val
Mitglied: aqui
26.05.2015 um 15:34 Uhr
.local sollte man besser nie verwenden, denn das kollidiert mit mDNS im Netz das das als Standard verwendet:
http://de.wikipedia.org/wiki/Zeroconf#Multicast_DNS
Das kann also früher oder später Probleme machen. Deshalb ist es hier besser immer .lokal oder noch besser .intern zu verwenden.
Bitte warten ..
Mitglied: Valexus
26.05.2015 um 15:42 Uhr
Danke das ist mir bekannt. Ist leider vor meiner Zeit eingerichtet wurden und heute vermutlich nicht ohne erheblichen Aufwand zu ändern
Bitte warten ..
Mitglied: Pjordorf
26.05.2015 um 16:22 Uhr
Hallo,

Zitat von Valexus:
DC1 - 192.168.1.250 - alle FSMO Rollen
DC2 - 192.168.1.251
Bitte mal ein IPConfig /all von beiden hier rein stellen.
Ich nehme an der DNS (Server / Dienst) selbst läuft?
Der DC2 hat auch einen DNS am laufen?

Den Einwand bezüglich .local hast du ja vernommen, aber selbst MS macht noch immer diesen Vorschlag selbst Und wegen Zertifikate auf .local ....
https://www.networking4all.com/en/ssl+certificates/ssl+news/changes+in+i ...

Gruß,
Peter
Bitte warten ..
Mitglied: Valexus
26.05.2015 um 16:39 Uhr
Hi,

DC01:
C:\Users\Administrator>ipconfig /all

Windows-IP-Konfiguration

   Hostname  . . . . . . . . . . . . : DC01
   Primäres DNS-Suffix . . . . . . . : domain.local
   Knotentyp . . . . . . . . . . . . : Hybrid
   IP-Routing aktiviert  . . . . . . : Nein
   WINS-Proxy aktiviert  . . . . . . : Nein
   DNS-Suffixsuchliste . . . . . . . : domain.local

Ethernet-Adapter Team0:

   Verbindungsspezifisches DNS-Suffix:
   Beschreibung. . . . . . . . . . . : Microsoft Network Adapter Multiplexor Dri
ver
   Physische Adresse . . . . . . . . : 0C-C4-7A-XX-XX-XX
   DHCP aktiviert. . . . . . . . . . : Nein
   Autokonfiguration aktiviert . . . : Ja
   Verbindungslokale IPv6-Adresse  . : fe80::79ca:4497:41da:4cf6%16(Bevorzugt)
   IPv4-Adresse  . . . . . . . . . . : 192.168.1.250(Bevorzugt)
   Subnetzmaske  . . . . . . . . . . : 255.255.255.0
   Standardgateway . . . . . . . . . : 192.168.1.2
   DHCPv6-IAID . . . . . . . . . . . : 420267130
   DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-1C-A3-60-A0-0C-

   DNS-Server  . . . . . . . . . . . : 192.168.1.251
                                       127.0.0.1
   NetBIOS über TCP/IP . . . . . . . : Aktiviert

Tunneladapter isatap.{105A433B-8979-4DA5-8DA9-07FA44A415DA}:

   Medienstatus. . . . . . . . . . . : Medium getrennt
   Verbindungsspezifisches DNS-Suffix:
   Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter
   Physische Adresse . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP aktiviert. . . . . . . . . . : Nein
   Autokonfiguration aktiviert . . . : Ja
DC02:
C:\Users\Administrator.MAILINGWORK>ipconfig /all

Windows-IP-Konfiguration

   Hostname  . . . . . . . . . . . . : DC02
   Primäres DNS-Suffix . . . . . . . : domain.local
   Knotentyp . . . . . . . . . . . . : Hybrid
   IP-Routing aktiviert  . . . . . . : Nein
   WINS-Proxy aktiviert  . . . . . . : Nein
   DNS-Suffixsuchliste . . . . . . . : domain.local

Ethernet-Adapter Ethernet 3:

   Verbindungsspezifisches DNS-Suffix:
   Beschreibung. . . . . . . . . . . : Intel(R) Ethernet-Verbindun
   Physische Adresse . . . . . . . . : 44-39-C4-XX-XX-XX
   DHCP aktiviert. . . . . . . . . . : Nein
   Autokonfiguration aktiviert . . . : Ja
   Verbindungslokale IPv6-Adresse  . : fe80::90e1:7d0f:ec6:a742%12
   IPv4-Adresse  . . . . . . . . . . : 192.168.1.251(Bevorzugt)
   Subnetzmaske  . . . . . . . . . . : 255.255.255.0
   Standardgateway . . . . . . . . . : 192.168.1.2
   DHCPv6-IAID . . . . . . . . . . . : 340015556
   DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-1C-F5-E3-E2-44-

   DNS-Server  . . . . . . . . . . . : 192.168.1.250
                                       127.0.0.1
   NetBIOS über TCP/IP . . . . . . . : Aktiviert

Tunneladapter isatap.{FE54EE4A-4C62-4A00-8BCD-53E8DBD2EEEC}:

   Medienstatus. . . . . . . . . . . : Medium getrennt
   Verbindungsspezifisches DNS-Suffix:
   Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter
   Physische Adresse . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP aktiviert. . . . . . . . . . : Nein
   Autokonfiguration aktiviert . . . : Ja
Ich weis, dass die .local Domain eine absoluter Mist ist aber eine Migration kostet wieder extrem viel Zeit und Nerven für die Anwender (werd ich wohl nicht drum herum kommen...).
Umbenennen der Domain trau ich mich nicht, wenn da irgendwo Murks zurück bleibt wirds lustig.

VG
Val
Bitte warten ..
Mitglied: TomJones
26.05.2015 um 17:00 Uhr
Zitat von aqui:

.local sollte man besser nie verwenden, denn das kollidiert mit mDNS im Netz das das als Standard verwendet:
http://de.wikipedia.org/wiki/Zeroconf#Multicast_DNS
Das kann also früher oder später Probleme machen. Deshalb ist es hier besser immer .lokal oder noch besser .intern zu
verwenden.

Witzigerweise wird .local bei einem Server 2012 R2 Essentials nicht änderbar vorgegeben.
Bitte warten ..
Mitglied: Tobi1980cgn
26.05.2015 um 19:13 Uhr
Also ich sitze gerade virtuell vor 2 WinServer 2012 R2 Essentials und dies ist nicht der Std.
Ich habe keine "Domain.local" nehmen müssen. Sorry hilft nicht beim Thema.
Bitte warten ..
Mitglied: 114757
27.05.2015, aktualisiert um 09:54 Uhr
Moin,
die 127.0.0.1 jeweils als sekundären DC zu verwenden ist suboptimal und wird deswegen oft vom BPA angemeckert, trage hier die richtige IP-Adresse des Servers ein und lass den BPA nochmal laufen.
"_msdcs.domain.local" existieren bei mir beide nicht (oder werden zumindest nicht angezeigt)...
Das ist eine spezielle Subdomain der bestehenden AD Domain (Domain aufklappen!) und muss vorhanden sein, wenn nicht hats eure DNS-Serverdaten zerlegt.

Gruß jodel32
Bitte warten ..
Mitglied: Valexus
27.05.2015 um 11:10 Uhr
Moin jodel,

die 127.0.0.1 jeweils als sekundären DC zu verwenden ist suboptimal und wird deswegen oft vom BPA angemeckert, trage hier die
richtige IP-Adresse des Servers ein und lass den BPA nochmal laufen.
Die 127.0.0.1 war erst als primärer DNS eingetragen aber genau da hat der BPA gemeckert ich soll das doch als sekundären eintragen...

> "_msdcs.domain.local" existieren bei mir beide nicht (oder werden zumindest nicht angezeigt)...
Das ist eine spezielle Subdomain der bestehenden AD Domain (Domain aufklappen!) und muss vorhanden sein, wenn nicht hats eure
DNS-Serverdaten zerlegt.
Ah ok, diese ist natürlich unter der Forward-Lookupzone "domain.local" vorhanden sorry.


VG
Val
Bitte warten ..
Mitglied: 114757
27.05.2015, aktualisiert um 11:37 Uhr
Zitat von Valexus:
Die 127.0.0.1 war erst als primärer DNS eingetragen aber genau da hat der BPA gemeckert ich soll das doch als sekundären
eintragen...
Nein, ich meine das du anstatt 127.0.0.1 die richtige IP Adresse des Servers im Netzwerk einträgst und nicht die Loopbackadresse !
Bitte warten ..
Mitglied: Valexus
27.05.2015, aktualisiert um 13:55 Uhr
Mhh dann wirds aber ganz verrückt und es tauchen ca. 10 Warnungen auf:
a2d4ea4e9da5f546df703aaf3e4fb929 - Klicke auf das Bild, um es zu vergrößern

Edit: auch wenn ich es wieder zurück ändere bleiben die IPv6 Adressen Fehler bestehen.

Es ist zwar IPv6 auf dem Server aktiviert, aber nicht am Router oder sonstigen Netzwerkkomponenten...
Habe gestern Abend alle Windows Updates installiert, eventuell liegt es daran?
Bitte warten ..
Mitglied: 114757
27.05.2015, aktualisiert um 15:23 Uhr
Entweder du richtest IPv6 vollständig auf dem Server ein, mit fester IPv6 und aktivierter Abhörung des IPv6 Interfaces in den Eigenschaften der DNS MMC, oder du deaktivierst alle IPv6 Komponenten komplett.
Dein DNS scheint hier nicht richtig eingerichtet zu sein.

Poste doch mal alle Einstellungen des DNS Servers, bitte.
Bitte warten ..
Mitglied: Valexus
27.05.2015, aktualisiert um 15:35 Uhr
Lt. Microsoft soll man IPv6 ja nicht vollständig deaktivieren, deshalb hab ich dies einfach aktiv gelassen.

Unter Schnittstellen habe ich nur die IPv4 Adresse ausgewählt und die Weiterleitung auf die Stammhinweise (Scheinen die IPv6 Adressen zu sein) habe ich ebenfalls deaktiviert.

Wo wäre denn hier noch etwas einzustellen?
Bitte warten ..
Mitglied: 114757
27.05.2015, aktualisiert um 15:38 Uhr
Der BPA ist schrottig was DNS anbelangt ... man sollte nicht alles glauben was der da manchmal faselt ..
https://social.technet.microsoft.com/Forums/de-DE/289a3d1a-7c3d-4b2a-995 ...
Bitte warten ..
Mitglied: Valexus
28.05.2015 um 10:51 Uhr
Mhh na gut danke, dann werd ich das wohl ignorieren müssen...
Wenn noch jemand eine Idee hat bin ich gern dafür offen

VG
Val
Bitte warten ..
Ähnliche Inhalte
Windows Server
Problem mit Terminalserver 2012R2
gelöst Frage von huberdWindows Server6 Kommentare

Hallo, ich wende mich an dieses Forum, weil ich nicht mehr weiter komme. Wir haben drei Terminalserver 2012R2 und ...

Windows Server

MS ProjectViewer auf Terminalserver (WS 2012R2)

Frage von Neuling26Windows Server4 Kommentare

Hallo Zusammen, wir haben 2x Terminalserver (Windows Server 2012R2) am laufen und ca. 40 Benutzer. Diese melden sich unterschiedlich ...

Windows Update

WSUS Problem mit 2012R2

gelöst Frage von HenereWindows Update6 Kommentare

Hallo zusammen, ein einzelner 2012R2 macht mir Probleme beim Update über den WSUS. Die Settings sind per GPO gesetzt, ...

Windows Server

MS Terminalserver 2008R2 vs. Terminalserver 2012R2

Frage von ArtjeroWindows Server4 Kommentare

Hallo, in einer Server 2008R2/Win7 Infrastruktur suche ich nach Gründen für ein Upgrade auf 2012R2. Hierbei geht es vorerst ...

Neue Wissensbeiträge
Windows 10

Sandy-Bridge plus Nvidia plus Win10 1903 braucht Hotfix

Information von DerWoWusste vor 1 TagWindows 101 Kommentar

Es gibt ein Problem in der seltenen Konstellation Nvidia-Grafikkarte/Sandy-Bridge-CPU/Win10v1903: die von Nvidia vorgeschlagenen Treiber lassen sich nicht installieren. verlinkt ...

Off Topic
Computermuseum Stuttgart
Tipp von NixVerstehen vor 1 TagOff Topic2 Kommentare

Hallo zusammen, letzte Woche habe ich mit meinem 16-jährigen Sohn das Computermuseum Stuttgart (Uni Stuttgart) besucht, um ihm und ...

Windows 10
Windows 10: Netzwerk zeigt Fehler 0x80070035
Tipp von anteNope vor 1 TagWindows 105 Kommentare

Moin zusammen, ich hatte gerade mal wieder das Vergnügen mit dem obigen Fehler. Unter Borns Blog ist das beschreiben: ...

Windows 10

Bug: Windows 10 Enterprise LTSC erhält Funktionsupdate angeboten

Information von kgborn vor 2 TagenWindows 105 Kommentare

Der Fehler ist mittlerweile zwar korrigiert, aber ich denke, ich stelle die Info doch mal hier für Leute ein, ...

Heiß diskutierte Inhalte
DSL, VDSL
Blitzschutz für DSL-Leitung
gelöst Frage von SarekHLDSL, VDSL32 Kommentare

Hallo zusammen, nachdem ein Blitzeinschlag in der Nähe mir am Sonnabend trotz Überspannungsschutz-Steckdosenleite meinen Router gegrillt hat, habe ich ...

Server
Wie kommunizieren Server ?
gelöst Frage von A12345Server25 Kommentare

Hallo liebe Forumsgemeinde, ich bin ein absoluter Neuling und habe nicht viel Ahnung von der IT. Allerdings habe ich ...

Server
ODBC Verbindung zu MYSQL funktioniert beim Einrichten nicht
gelöst Frage von martenkServer23 Kommentare

Guten Tag, versuche gerade von meinem PC eine ODBC Testverbindung zu meinem Server (bei 1und1) aufzubauen habe dazu mysql ...

Netzwerkmanagement
Cisco - Level-One und Portbündelung bzw. Trunk
gelöst Frage von KnorkatorNetzwerkmanagement16 Kommentare

Hallo zusammen, hallo Aqui, :) Während der Umstellungsphase auf unsere neuen SG350 Switche muss ich parallel noch eine Verbindung ...