franc
Goto Top

NAS Buffalo Link Station Duo LS-WXL504 mit 1 TB RAID0 auf 3 TB RAID1 aufrüsten

Hallo
ich habe seit langem eine Buffalo Link Station Duo LS-WXL504 mit 2 x 500 GB Festplatten die zu RAID 0 zusammengeschaltet sind.
Ich will jetzt endlich aufstocken und vor allem RAID 1 einrichten!
Dazu habe ich mir 2 Festplatten zu je 3 TB (WD Blue WD30EZRZ 64MB 3.5" SATA 6Gb/s bei eb., Nr. 372849579018) gekauft.

Ich dachte, ich fahre den NAS runter, tausche die Platten und fahre wieder hoch. Geht natürlich nicht. Dann habe ich hier im Forum den Artikel gefunden:

Buffalo Linkstation Duo Pro von 1 TB auf 2 TB oder 3 TB aufrüsten

allerdings ist das bei RAID1, wo die Daten ja redundant liegen. Bei RAID0 wird mit Stripe, also sind die Daten verteilt auf beiden Platten, da dürfte es ja gleich ausfallen, wenn ich eine Platte raus ziehe, oder?

Verfahre ich da dennoch so, dass ich erst in der Weboberfläche vom Buffalo das RAID entferne per Button 'Raid wird entfernt' bei Speicher > RAID (Array 1) und dann die 2. Platte tausche, formatiere usw.?

RAID 0 und RAID 1 ist ja schon anders.
Danke für einen Tipp.

Gruß franc

Content-Key: 545837

Url: https://administrator.de/contentid/545837

Printed on: April 18, 2024 at 04:04 o'clock

Member: Pjordorf
Pjordorf Feb 11, 2020 at 12:13:17 (UTC)
Goto Top
Hallo,

Zitat von @franc:
Ich will jetzt endlich aufstocken und vor allem RAID 1 einrichten!
Mach neu komplette Sicherung, RAID 1 einrichten und sicherung zurück.Fedisch

Gruß,
Peter
Member: franc
franc Feb 11, 2020 updated at 13:30:03 (UTC)
Goto Top
Also ich habe es dann ein bisschen anders als in der oben verlinkten Anleitung gemacht und es ging sehr zügig:

  • Zuvor schon bereits alle Daten des RAID 0 gesichert auf eine ans NAS angeschlossene externe Festplatte (dauerte einen halben Tag!)
  • In der Buffalo Weboberfläche erst das RAID gelöscht mit: System > Speicher > RAID (Array 1) > 'RAID wird entfernt' (Sicherungsnr. eingeben)
  • Runterfahren (mit Schalter auf AUS)
  • Platte von Slot 2 gewechselt von alter 500 GB auf neue 3TB HDD (die HDD #1 nämlich, weil sie später auf Slot 1 gesteckt wird)
  • Hochfahren (Schalter mittig)
  • Jetzt sieht man in System > Speicher > Festplatten die neue 3TB Platte dort dann formatiert, dauert ca. 5 Minuten
  • Runterfahren
  • 3TB Platte (#1) von Slot 2 auf Slot 1 (den linken Slot) stecken (möglicherweise ist das gar nicht nötig oder aber überhaupt *der* Trick)
  • Die andere 3TB Platte (die #2) auf Slot 2 einstecken
  • Hochfahren
  • Festplatte 2 formatieren (Dauer: 5') in System > Speicher > Festplatten > [x]Festplatte 2 > 'Festplatte formatieren' (Dateisystem XFS) > Bestätigung mit den 4 Zahlen eingeben...
  • RAID 1 aus den beiden Platten erstellen: System > Speicher > RAID (Array 1) > [x]Festplatte 1, [x]Festplate 2 > raid1 > 'Raid wird erstellt' > Sicherheitsnr. eingeben
  • Nach knapp 4 Minuten war es fertig und das RAID 1 erstellt
  • Alles zurück sichern auf das neue 3 TB RAID 1

Zu bemerken ist, dass alle Einstellungen erhalten bleiben, im Ggs. zu oben verlinkter Anleitung.
Nur die Ordner müssen natürlich wieder erstellt und freigegeben werden.

Gruß franc

EDIT:

Zitat von @Pjordorf:
Mach neu komplette Sicherung, RAID 1 einrichten und sicherung zurück.Fedisch
Peter

Das geht aber nur, wenn man nicht auf einmal beide Platten tauscht, weil dann fahrt der NAS gar nicht mehr hoch, s.o.
Member: franc
franc Feb 12, 2020, updated at Feb 13, 2020 at 10:55:27 (UTC)
Goto Top
Oh, oh. Jetzt habe ich festgestellt, dass es einen Blinkcode gibt, nämlich E22, soll heißen:

Bereitstellung der Festplatte fehlgeschlagen. Formatieren Sie die Festplatte. Wenn der Fehler nach einer Formatierung und einem Neustart immer noch auftritt, dann wechseln Sie die Festplatte aus. Wenn der Fehler erneut angezeigt wird, dann wenden Sie sich an den technischen Support von Buffalo.

Der NASNavigator2 meldet:

Fehler:
E22:Fehler beim Anbringen des Datenträgers 1. (/43/11 13:43:44)
Informationen:
I17:Das RAID-Array 1 wird neu synchronisiert. (/48/11 13:48:12)

In der WEB GUI lese ich, dass das RAID (1) überprüft würde und ich noch gut 7h warten müsste (ist grad bei 55%).
Ich frage mich aber, was man beim RAID überprüfen könnte, wenn die Platte gar nicht eingehängt wäre.

Vielleicht kommt der Fehler ja durch mein Umstecken von Slot 2 auf Slot 1 der HDD#1 (s.o.)...

EDIT 2020-02-13: nachdem das RAID Reparieren fertig war (2020-02-12 ca. 18 Uhr) habe ich den NAS neu gestartet und danach war die E22 Fehlermeldung weg face-smile