Open Thin Client Splashscreen Bootvorgang Localboot

conpaw
Goto Top
Hallo Zusammen,

wir haben seit ein paar Wochen einen OpenThinClient Server und eine Hand voll Thinclients mit OTC laufen.

Im allgemeinen bin ich sehr zufrieden mit der Software nur haben wir auch die Notwendigkeit das Thinclients über ein VPN angebunden werden muss, da diese in Filialen stehen und nicht direkt in unserem Netzwerk sind.

Dafür möchte ich Localboot verwenden. Das funktioniert auch soweit, nur habe ich ein kleines Problem mit dem Bootvorgang.

Der TC ist mit Localboot installiert und auch voll funktionsfähig.
Alle Kabel sind Angeschlossen (Strom, Netzwerk, Tastatur/Maus, Monitor).
Aber wenn ich den TC dann von der Festplatte boote bekomme ich erstmal die Fehlermeldung:

Waiting for network. Thinclient offline. Please check the cable.

Und zwar mehrere (hunderte?) Male hintereinander.

Nach ca. 10-20 sek. fängt er sich dann und bootet OTC ohne Probleme.

Kann ich die Meldungen irgendwie ausblenden bzw. abschalten?
Da das personal in den Filialen schon mal wechselt, möchte ich nicht jedes mal ein Ticket kreigen wenn ein neuer Kollege den Rechner morgen hochfährt und erstmal diese Fehlermeldungen un ROT auf dem Display zu sehen sind.

Ich habe bereits versucht sie mit einem eigenen Splashscreen zu überdecken, das funktioniert leider nur bedingt, da das Bild (Firmenlogo als .ppm) nicht frühgenug geladen/angezeigt wird und auch leider nicht großgenug ist um die Bootmeldungen zu überdecken, habe es schon 3-4 mal neu erstellt und versucht es als Vollbild (Bildgröße 1280x1024 px) drüberzulegen, da kriege ich nur einen schwarzen Bildschirm und dann erscheint irgendwann der Desktop.

Wenn gewünscht kann ich auch mal Bilder machen und Anhängen.

Was kann ich noch versuchen?

EDIT: wenn ich die Clients über PXE boote und nichts auf der Platte installiere werden mir die Startmeldungen nicht angezeigt. Nur ein schwarzer hintergrund mit dem Firmenlogo und einem Ladebalken. Danach erscheint der Desktop.
Aktuell ist PXE im BIOS als Bootoption ausgeschaltet (exclude). Ohne Netzwerk fährt er aber nicht hoch.

MfG

Content-Key: 1513773768

Url: https://administrator.de/contentid/1513773768

Ausgedruckt am: 27.06.2022 um 11:06 Uhr

Mitglied: ChriBo
ChriBo 16.11.2021 um 12:32:44 Uhr
Goto Top
Hi,
wie ist die (physikalische) Konnektivität vom Thinclient mit dem Switch beim Einschalten bzw. Bootvorgang ?
ggf. Port speed anpassen oder setzen.
ggf. portfast auf dem Switchport setzen.

Gruß
CH
Mitglied: conpaw
conpaw 16.11.2021 um 14:32:05 Uhr
Goto Top
Hi,

danke für die Antwort. Die TCs sind mit einem Lankabel am Switch angebunden.

Ich bin nicht so fit in der Netzwerkkonfiguration, deswegen bin ich mir nicht ganz sicher wo ich da am dümmsten nachschaue.

Meine Idee war, dass er ewig braucht um sich mit dem Netzwerk zu verbinden oder die LAN Karte "hochzufahren/anzuschalten". Dann müsste er ja wärend des Bootvorgangs nicht erreichbar sein.

Ein Ping xxx.xxx.xxx.xxx -t geht aber die ganze Zeit durch. Müsste also die Zeit über online sein.

Meinst du das der Switch nicht hinterher kommt die Verbindung herzustellen? Oder ggf. zu schnell ist?

MfG
Mitglied: dertowa
dertowa 16.11.2021 um 22:05:51 Uhr
Goto Top
Hey,
habe die Offlinenutzung noch nicht benötigt, die Variante gibt es aber noch nicht sooo lang, kam im Laufe der Coronazeit.
Allerdings sind die Entwickler ziemlich auf Zack: https://openthinclient.com/de/info/support.html
Auch wenn du unter der Grenze von 50 Clients bist kannst du mal anrufen, die verkaufen dir dann gern ein Zeitkontingent was du mit Supportanfragen aufbrauchen kannst. :-) face-smile

Grüße