harfes
Goto Top

Outlook will auf Win-Server2019 nicht mit Exchange verbinden

Ich habe auf einem Windows Server 2019 Std ein Office 2019 Std installiert. Der Server wird als Terminalserver genutzt. Word, Excel und Co. laufen problemlos. Jetzt wollte ich in Outlook einem Nutzer sein Exchange-Postfach einrichten, aber Outlook mag nicht. Bei der Ersteinrichtung erscheint das korrekte Autodiscover-Fenster, das nach abnicken verschwindet, aber dann fragt Outlook immer wieder nach dem Kennwort. Der Exchange (2016er) ist ein HostedExchange bei einem externen Provider. Der Zugriff via OWA funktioniert einwandfrei und ebenfalls habe ich auf zwei lokalen PC's im gleichen Netzwerk das Outlook mit dem Kennwort problemlos für den Zugriff auf Exchange einrichten können. Auf dem Server konnte ich das Postfach mit IMAP ebenfalls in Outlook einrichten...es sollte aber besser via Exchange direkt sein.
Also muss es irgendwie am Server liegen (dieser hat alle aktuellen Updates bis einschliesslich 05/2024 installiert und läuft einwandfrei). Ebenfalls habe ich die Firewall am Server testweise ausgeschaltet - keine Änderung. Reparaturinstallation vom Office hat auch nicht geholfen. Als Virenschutz läuft der Defender und der meckert auch nicht. Wo könnte ich noch hinschauen?

Hartmut

Content-Key: 61317859689

Url: https://administrator.de/contentid/61317859689

Printed on: July 14, 2024 at 16:07 o'clock

Member: MysticFoxDE
MysticFoxDE Jun 15, 2024 at 07:13:38 (UTC)
Goto Top
Moin @harfes,

setz mal den folgenden Registry Key, bei einem der User auf dem TS ...

cmd, jedoch nicht explizit als Administrator starten, sondern ganz normal mit dem entsprechenden Benutzer.

reg add "HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\AutoDiscover" /t REG_DWORD /v ExcludeExplicitO365Endpoint /d 1  

Wenn das klappt, dann kannst du den oberen Reg-Key, bei den restlichen Usern z.B. auch per GPO setzen.

Gruss Alex
Member: harfes
harfes Jun 15, 2024 at 07:53:01 (UTC)
Goto Top
Hallo Alex,

das funktioniert leider auch nicht (der Key wurde korrekt beim User gesetzt...extra kontrolliert) - Outlook fragt weiterhin immer wieder nach dem Kennwort und nach dem Abbrechen kommt dann das Meldungsfenster:

outlookfehler01

Hartmut
Member: em-pie
em-pie Jun 15, 2024 at 08:35:52 (UTC)
Goto Top
Moin,

Dein Autodiscover klappt aber fehlerfrei?
Also auf was (anonymisiert) zeigt der Eintrag?
Zertifikate sind auch vorhanden und vertrauenswürdig? (Die Meldung wäre zwar eine andere, aber zur Sicherheit mal nachschauen)

Irgendwo schmeißt Outlook auch im Hintergrund Meldungen. Müsste aber selbst suchen.
Im Systray mal mit gedrückter STRG-Taste mal mit Rechtsklick auf das Outlook-Icon klicken, dann kommen zwei… drei Einträge mehr. In einem davon kann man div Tests durchlaufen lassen…
Member: harfes
harfes Jun 15, 2024 at 10:04:38 (UTC)
Goto Top
Hallo em-pie,

das mit dem Autodiscover scheint ok zu sein (es zeigt auf den korrekten HostedExchange-Server) und wenn ich beim User unter AppData/Local/Outlook schaue, gibt's da auch eine autodiscover.xml-datei, deren Inhalt bzw dessen Pfade ok aussehen (ich habe da nochmal in einem anderen Netzwerk auf einem Terminalserver nachgeschaut, dessen User auch mit dem gleichen externen Exchange arbeiten).
Bei den Zertifikaten habe ich nur gesehen, dass die üblichen Standard-Zertifikate vorhanden sind - spezielle für Outlook bzw den Provider habe ich nicht gesehen.
Da Outlook im Prinzip nicht startet, kann ich da auch leider nicht mit der Strg-Taste etwas erreichen - an der Stelle könnte auch das autodiscover explizit geprüft werden, aber da ich da nicht hinkomme... Log-Dateien habe ich nicht gesehen.

Hartmut
Member: Th0mKa
Th0mKa Jun 15, 2024 at 14:16:13 (UTC)
Goto Top
Moin,

hast du in der autodiscover.xml mal geguckt welche Protokolle der Server anbietet und dann geprüft ob der Terminalserver den Exchange mittels den dazugehörigen Ports erreichen kann? Die Meldung ist ja erstmal ziemlich eindeutig.

/Thomas
Member: harfes
harfes Jun 15, 2024 at 15:56:26 (UTC)
Goto Top
Hallo Thomas,

ja, der Exchange ist über das Protokoll (https/ssl - Port 443) problemlos erreichbar. Ich glaube mittlerweile eher, dass es an der Verschlüsselung des Kennworts liegt, denn da bleibt er ja hängen. Als Authentifizierung steht in der xml, dass Ntlm benutzt werden soll:

Type>EXHTTP</Type
Server>outlook.xx.xx.ag</Server
SSL>On</SSL
AuthPackage>Ntlm</AuthPackage

Evtl. liegt es ja daran?

Hartmut
Member: MysticFoxDE
MysticFoxDE Jun 16, 2024 at 06:28:24 (UTC)
Goto Top
Moin @harfes,

welches Authentifizierungsmethode ist den auf dem entsprechenden Exchange für Outlook Anywhere aktiviert?
oaw - authentifizierung

Wird der Datenverkehr des Terminalservers Richtung des Internets, z.B. durch eine NGFW oder ein SGW irgendwie doch anders gefiltert als der von den Clients?
Sprich, ist für den TS vielleicht die SSL/TLS-Inspection anders konfiguriert als bei den Clients?

Oder verwendest du gar kein(e) zusätzliches NGFW/SGW dazwischen?

Gruss Alex
Member: harfes
harfes Jun 16, 2024 at 08:25:39 (UTC)
Goto Top
Hallo Alex,

auf dem Exchange ist "Aushandeln" eingestellt (lt. Aussage des Providers) und für den TS gibt es keine gesonderten Einstellungen. Ebenfalls wird keine NGFW oder ein SGW eingesetzt. Der Lancom-Router hat die Firewall so eingestellt, dass die benötigten Ports nur von Innen nach Aussen frei sind - und das funktioniert im selben Netzwerk mit den Clients (getestet mit Win10 und Win11) ja auch problemlos.
Und wie bereits geschrieben: wenn ich Outlook mit IMAP und SMTP aufsetze geht's auch auf dem Server. Da Outlook beim Zugriff auf den Exchange auch die Autodiscover.xml korrekt erstellt, gehen mir langsam die Ideen aus, wo ich noch hinschauen könnte..

Hartmut
Member: Mosurama
Mosurama Jun 16, 2024 at 09:46:12 (UTC)
Goto Top
Hallo,

prüfe mal in den Kontoeinstellungen ob bei deinem Terminalserver-User der Exchange Cache Mode aktiv ist. Bei einem Anbieter von Hosted Exchange weiß ich, dass die Verbindung nur erfolgreich ist, wenn der aktiv ist.
Member: harfes
harfes Jun 16, 2024 at 12:49:16 (UTC)
Goto Top
Du hast zwar Recht mit dem Cache-Mode (das ist bei dem Provider auch so), aber soweit komme ich ja gar nicht, den Mode einzustellen. Outlook scheitert ja bereits vorher beim Kennwort und demzufolge wird der Account gar nicht erst eingerichtet...

Hartmut
Member: Mosurama
Mosurama Jun 16, 2024 at 12:57:30 (UTC)
Goto Top
Indeed, mea culpa

Auf den beiden PCs läuft die gleiche Office Version?
Member: harfes
harfes Jun 16, 2024 at 14:05:30 (UTC)
Goto Top
Ja -> Office 2019 Standard.

Hartmut
Member: support-m
support-m Jun 17, 2024 at 11:40:09 (UTC)
Goto Top
Hi,
hast du das Problem nur bei einem User oder bei allen, die auf dem TS arbeiten?

Hatte gerade heute Vormittag das Problem, dass eine info@ Mail bei einem konto auf dem TS nicht funktioniert hat (das autodiscover ist in einem Timeout gerannt), während alle anderen damit arbeiten konnten und auch ein neu erstellter User hatte keine Probleme. Handelt sich um M365.

Als Lösung hat geholfen das Windows-Profil der Person vom Terminalserver zu löschen und neu ein zu richten (System > Erweiterte Systemeinstellungen > Benutzerprofile-Einstellungen > löschen), vorher am Besten noch Lesezeichen sichern ;)

Läuft neben dem Defender noch eine andere AV Software?

MfG
Member: harfes
harfes Jun 17, 2024 at 16:19:58 (UTC)
Goto Top
Hallo support-m,

keine weitere AV-Software und gerade getestet: das Problem tritt bei jedem User auf. Interessanterweise kommt jetzt bei einem neuen User auch die Frage nach dem Autodiscover nicht mehr (und die kommt bei der Ersteinrichtung eigentlich immer bei jedem User). Die Registry habe ich schon durchsucht, aber nix gefunden, wo der Eintrag steht (es sind ein paar Standard-Einträge vorhanden, aber die sind identisch mit denen auf einem anderen 2019er-Server). Das ist alles sehr merkwürdig...ich bin für jede Idee dankbar (ok, bis auf "Server neu aufsetzen"...).

Hartmut
Member: Dani
Dani Jun 23, 2024 at 15:42:12 (UTC)
Goto Top
Moin,
Wireshark installieren, Wireshark laufen lassen und das Problem reproduzieren. Am Besten zu einer Randzeit, damit möglichst wenig Traffic erzeugt und mitgeschnitten wird.


Gruß,
Dani