sundalf
Goto Top

PfSense - WiFi AP funktioniert jedoch komme ich nicht ins Internet

Hallo,

ich habe pfSense version 2.1.2 auf einem Alix 2D13 mit einer 4GB CF Card installiert. Auf dem miniPCI Slot ist eine TP-Link TL-WN861N gesteckt, welche als WiFi Access Point konfiguriert ist. Da LAN und WLAN die IP Range 192.168.1.0/24 gemeinsam nutzen, habe ich eine Bridge eingerichtet. Der DHCP Server läuft auf dem Bridge Interface. Ich kann mich ohne Probleme mit dem WLAN verbinden und bekomme auch die IP zugewiesen, welche ich in den DHCP Static Mappings eingetragen habe, leider komme ich aber nicht ins Internet per WLAN. Per LAN ist es möglich.

Die Interfaces haben folgende IP Adressen:
LAN 192.168.1.1
WLAN 192.168.1.2
Bridge 192.168.1.3
Gateway ist für alle die LAN Interface IP 192.168.1.1

Merkwürdig ist, das ich die IPs des Bridge Interfaces nicht anpingen kann.

Hat jemand einen Tip, wo ich was vergessen habe? Gerne poste ich mehr Informationen, falls benötigt.

Danke und viele Grüße

Mario

Content-Key: 237024

Url: https://administrator.de/contentid/237024

Printed on: July 21, 2024 at 01:07 o'clock

Member: aqui
Solution aqui May 02, 2014 updated at 15:31:50 (UTC)
Goto Top
Dann funktioniert deine Bridge nicht bzw. ist nicht richtig konfiguriert !!
Du müsstest dann ja wenigstens auch Geräte im LAN anpingen können wenn die Bridge sauber funktioniert, denn WLAN und LAN sind damit transparent im gleichen IP Netz.
Das ALIX Tutorial zur WLAN Erweiterung hier im Forum hast du gelesen ??:
WLAN oder LAN Gastnetz einrichten mit einem Captive Portal (Hotspot Funktion)
Dort ist genau beschrieben wie es geht...
https://forum.pfsense.org/index.php?topic=20917.0
beschreibt es zwar für 2.0 aber bei 2.1 ists quasi identisch.
Member: SunDalf
SunDalf May 02, 2014 at 15:31:31 (UTC)
Goto Top
Ich habe den ersten Link schon mehrfach durchgelesen, fand da aber keine Lösung. Der zweite von Dir gepostete Link brachte dann die Lösung. Ich hatte das LAN und WLAN Interface in die Bridge aufgenommen und dann ein Bridge Interface angelegt und das war falsch.

Aqui, ich danke dir sehr für deine Hilfe, ich habe an dem Problem schon seit Tage gefummelt...

Viele herzlichen Dank!!!!!
Member: aqui
Solution aqui May 02, 2014 updated at 22:56:28 (UTC)
Goto Top
Es ist etwas tricky, denn du musst die IP und die Regeln auf das Bridge Interface legen.
So gehst du der Reihe nach vor:

  • 1.) WLAN Interface einrichten (+) und aktivieren im "Access Point" Mode, Regulatory Domain ETSI, Country "Germany/ETSI" und g Mode only sowie SSID anlegen. Achtung: IP Adressing bleibt auf none !

  • 2.) Du legst ein Bridge Interface an unter "Interface assign" mit Klick auf "Bridge. Hier wählst du den LAN und WLAN Port, einen Namen und klickst "Save":
abd6826e63e0d2ceeb4811317290c190
  • 3.) Jetzt fügst du das Bridge Interface wieder unter "Interface assign" den Interfaces hinzu mit Klick auf "+" rechts und klickst "Save":
c4f8fe80a42c5beb1d01690eec11fcad
  • 4.) Nun klickst du auf das Interface und "enablest" es, gibst dem einen Namen z.B. "WLAN Bridge" , stellst das IPv4 Adressing auf "Static" und vergibst im einen IP Adresse im 192.168.1er Netz z.B. 192.168.1.254 mit 24 Bit Maske und klickst Save:
0e1e27bc9199bb1685edcd1bcc35ce17
  • 5.) Achtung: Um sich jetzt nicht selbst den Ast abzusägen auf dem man sitzt MUSS man jetzt die Firewall Rules für das Bridge Interface definieren. Hier im Beispiel jetzt analog zu den Default Rules alles aus dem Bridge Netz erlauben. Muss man dann ggf. später anpassen wenn man hier Einschränkungen machen will:
7e0b5af6e55b65794bbddcc90f18f518
  • 6.) Da der DHCP Server noch auf dem LAN Interface hängt muss dieser dort deaktiviert werden (Haken entfernen) und auf dem Bridge Interface aktiviert werden:
468766ce365463f27a3f6de9edf646cb
  • 7.) Damit ist dann das IP Readressing auf das Bridge Interface abgeschlossen und man kann nun auch auf dem LAN Interface die .1 IP Adresse deaktivieren was mit einem Klick auf none im Adress Setting geschieht ! Auch hier Achtung wenn man auf "Apply Settings" geht ist die pfSense "weg" aber man eröffnet einfach eine neue Broser Session auf die 192.168.1.254 und hat sie dann wieder face-wink

  • 8.) Fertig...das wars ! Sieht man sich jetzt das Dashboard an sieht auch das aktive Bridge Interface:
ec778742022ad5107fbf8e7c8520eed1

Zugegeben nicht ganz einfach wenn man das das erste Mal macht, denn es ist nicht sofort klar das die IP Adressen am Bridge Interface nun aufgehängt werden !
In der Beziehung war der Thread hilfreich hier den damit kann man das o.a. Tutorial erweitern das nicht andere auch darüber stolpern.
Member: SunDalf
SunDalf May 02, 2014 at 22:56:17 (UTC)
Goto Top
Ich habe, nachdem es eigentlich schon bei mir lief, nun nochmal dieses Turorial hier durchgespielt und es läuft.Ich finde es auch besser, ein eigenes Bridge Interface zu erstellen, worüber der Traffic läuft, als die Bridge an das LAN Interface zu koppeln wie im o.a Tutorial.

Danke für diese, für mich, sauberere Lösung.

Hättest Du vielleicht auch noch einen Tipp für mich, warum der Traffic bei mir nicht über das openVPN Interface läuft? Ich habe dazu ein Tread eröffnet.