erikro
Goto Top

Postfix und Exchange mögen sich nicht

Moin,

da ich das Problem auf Seiten des Exchange vermute, stelle ich das mal hier ein.

Ich habe auf einer Linux-Maschine apticron und postfix unter Debian 11 installiert, um im lokalen Netz über den on-premise Exchange-Server (2019) eine Mail an mich selbst schicken zu können. Um nun postfix testen zu können, habe ich mit


eine Mail abgesetzt. Die ist nicht angekommen. Im Log des postfix steht nun:


Das heißt ja eigentlich, dass es keinen PTR-Record für den sendenden Server vorhanden ist. Aber da ist einer. Im DNS ist der Eintrag vorhanden. Wenn ich auf dem Exchange-Server das mit nslookup prüfe, bekomme ich auch das richtige Ergebnis.


Der PTR-Record ist also vorhanden und für den Exchange-Server auch sichtbar. Was könnte es noch sein, dass den Mailempfang seitens des Exchange-Servers verhindert?

Alle Systeme sind auf dem aktuellen Stand. Der Debian-Server wurde gerade frisch installiert.

Liebe Grüße

Erik

Content-Key: 4067709200

Url: https://administrator.de/contentid/4067709200

Printed on: December 4, 2022 at 20:12 o'clock

Member: Vision2015
Solution Vision2015 Sep 26, 2022 updated at 15:08:23 (UTC)
Goto Top
Moin...

der Mailserver scheint bei dir im netzwerk zu stehen!

hast du den Empfangs Connector ordentlich eingerichtet, und ip eingetragen?
hast du dort auch das den DNS Namen eingetragen?
der Exchange bekommt seine mails per SMTP?

Frank
Member: erikro
erikro Sep 26, 2022 at 15:29:59 (UTC)
Goto Top
Moin,

Zitat von @Vision2015:
hast du den Empfangs Connector ordentlich eingerichtet, und ip eingetragen?

Danke, das war's. Im Connector für nackiges SMTP war nur ein Segment des Netzes (Drucker-Netz) eingetragen, in dem die Linux-Kiste nicht drin ist. Kann das nicht in der Fehlermeldung stehen? face-wink

Liebe Grüße

Erik
Member: Cloudrakete
Cloudrakete Sep 26, 2022 at 16:49:46 (UTC)
Goto Top
Vision hat ja bereits alles relevante für dein Problem geschildert.
Aus deinen restlichen Posts entziehe, dass du Azubi oder ähnliches bist und aktuell noch lernst face-smile

Für die Zukunft: Wenn du schon Zugriff auf Quell- sowie Zielsystem hast, dann schau doch auch in beide Logs!
Scheinbar warst Du ja auch in der Lage den Connector anzupassen, dann kannst du vermutlich auch die Logs auf dem Exchange einsehen!
Vermutlich hättest Du dann dein Problem sogar selbst gelöst :p
Member: erikro
erikro Sep 27, 2022 at 08:08:20 (UTC)
Goto Top
Moin,

als erstes der seit Jahrzehnten übliche Gruß.

Zitat von @Cloudrakete:
Vision hat ja bereits alles relevante für dein Problem geschildert.

Stimmt. Und ich habe auch lieb danke gesagt.

Aus deinen restlichen Posts entziehe, dass du Azubi oder ähnliches bist und aktuell noch lernst face-smile

Aha. Wieder einer, der mich einschätzt, ohne mich zu kennen. Falsch geraten. 30 Jahre Berufserfahrung. Diese Fehleinschätzung zeigt nur eins: Arroganz ist in unserem Metier nicht angebracht, da jeder von uns seine blinden Flecken hat und täglich auf Dinge stößt, die er nicht weiß.

Für die Zukunft: Wenn du schon Zugriff auf Quell- sowie Zielsystem hast, dann schau doch auch in beide Logs!
Scheinbar warst Du ja auch in der Lage den Connector anzupassen, dann kannst du vermutlich auch die Logs auf dem Exchange einsehen!

Rate mal, was da drin steht?

Vermutlich hättest Du dann dein Problem sogar selbst gelöst :p

Vermutlich? Offenbar ja nicht. :P

Liebe Grüße

Erik

(Auch die Abschiedsformel ist laut Netiquette üblich)
Member: godlie
godlie Sep 27, 2022 at 09:02:12 (UTC)
Goto Top
Zitat von @Cloudrakete:

Vision hat ja bereits alles relevante für dein Problem geschildert.
Aus deinen restlichen Posts entziehe, dass du Azubi oder ähnliches bist und aktuell noch lernst face-smile

Für die Zukunft: Wenn du schon Zugriff auf Quell- sowie Zielsystem hast, dann schau doch auch in beide Logs!
Scheinbar warst Du ja auch in der Lage den Connector anzupassen, dann kannst du vermutlich auch die Logs auf dem Exchange einsehen!
Vermutlich hättest Du dann dein Problem sogar selbst gelöst :p

Also ich kann nur aus Erfahrung sagen, ein Exchange loggt nicht so wie ein Postfix face-smile
Member: Cloudrakete
Cloudrakete Sep 27, 2022 at 10:10:22 (UTC)
Goto Top
Zitat von @erikro:

Moin,

als erstes der seit Jahrzehnten übliche Gruß.

Zitat von @Cloudrakete:
Vision hat ja bereits alles relevante für dein Problem geschildert.

Stimmt. Und ich habe auch lieb danke gesagt.

Aus deinen restlichen Posts entziehe, dass du Azubi oder ähnliches bist und aktuell noch lernst face-smile

Aha. Wieder einer, der mich einschätzt, ohne mich zu kennen. Falsch geraten. 30 Jahre Berufserfahrung. Diese Fehleinschätzung zeigt nur eins: Arroganz ist in unserem Metier nicht angebracht, da jeder von uns seine blinden Flecken hat und täglich auf Dinge stößt, die er nicht weiß.

Für die Zukunft: Wenn du schon Zugriff auf Quell- sowie Zielsystem hast, dann schau doch auch in beide Logs!
Scheinbar warst Du ja auch in der Lage den Connector anzupassen, dann kannst du vermutlich auch die Logs auf dem Exchange einsehen!

Rate mal, was da drin steht?

Vermutlich hättest Du dann dein Problem sogar selbst gelöst :p

Vermutlich? Offenbar ja nicht. :P

Liebe Grüße

Erik

(Auch die Abschiedsformel ist laut Netiquette üblich)

Mein Fehler. Hab dich verwechselt, hab dir mal eine PN geschrieben.
Was in den Logs steht weiß ich nicht. Ist nicht mein Exchange.
Ob überhaupt was drin steht geht aus dem Startpost ja nicht hervor.
Member: Vision2015
Vision2015 Sep 27, 2022 at 13:58:36 (UTC)
Goto Top
Moin...
Zitat von @godlie:

Zitat von @Cloudrakete:

Vision hat ja bereits alles relevante für dein Problem geschildert.
Aus deinen restlichen Posts entziehe, dass du Azubi oder ähnliches bist und aktuell noch lernst face-smile

Für die Zukunft: Wenn du schon Zugriff auf Quell- sowie Zielsystem hast, dann schau doch auch in beide Logs!
Scheinbar warst Du ja auch in der Lage den Connector anzupassen, dann kannst du vermutlich auch die Logs auf dem Exchange einsehen!
Vermutlich hättest Du dann dein Problem sogar selbst gelöst :p

Also ich kann nur aus Erfahrung sagen, ein Exchange loggt nicht so wie ein Postfix face-smile
seit wann?
da halte ich locker gegen!

Frank
Member: godlie
godlie Sep 28, 2022 at 07:12:15 (UTC)
Goto Top
Ich hatte es damals nicht geschafft den Exchange in einen so ausführlichen logmode zu versetzen,
wie sich der postfix im peer_debug_level=4 verhält.